Setting tag myplc-5.0-9
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
61 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
62
63 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
64 - plc-config-tty now has a validator on booleans
65 - e.g. entering 'True' now is rejected rather than silently recording 'false'
66
67 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
68 - disable mod_wsgi
69
70 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
71 - module name changes
72 - start wsgi support
73
74 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
75 - new setting PLC_RESERVATION_GRANULARITY
76
77 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
78 - * partial-repo.sh script
79 - * preserve key along with certificates
80
81 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
82 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
83
84 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
85 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
86 - new OMF category in the config
87 - create the drl system slice
88
89 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
90 - first working version of 5.0:
91 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
92 - nodefamily is 3-fold with pldistro-fcdistro-arch
93 - new PLC_FLAVOUR config category
94 - reviewed module layout
95 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
96
97 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
98 - support for fedora 12
99 - new package myplc-config for use by sfa
100 - drupal user registration turned off
101
102 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
103 - - fix to make sure when API, BOOT, MONITOR are on the same
104 - machine as WWW that the SSL key,cert for WWW takes precedence.
105 - - Do proper setup for SSL CA certficate to be used as the server
106 - chain.
107
108 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
109 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
110
111 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
112 - depend on pcucontrol
113
114 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
115 - * validate input according to type in plc_config
116 - * added the _genicw system slice
117 - * add tag types for sites and persons
118 - * add new tags for nodes and slices for exemption from myops
119
120 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
121 - turn off drupal on a box that acts as BOOT server but not as WWW server
122 - cleanup some obsolete code for old chroot-jail packaging in the process
123 - new bootcd-kernel script for keeping bootcd variants up2date
124
125 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
126 - Make the /etc/hosts manipulation optional.
127
128 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
129 - Fix SetRole.
130
131 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
132 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
133 - into the DB.
134 - - Added the root ssh key handling support back into plc.d/ssh and the
135 - default xml file.  This should be identical to the way it was in
136 - rc12.
137 - - Added support in the db-config.d/01-init script to register the root
138 - ssh public key with the default administrator.  In this way the root
139 - ssh key will make it into the root account on the nodes by means of
140 - NodeManager's specialaccounts plugin.
141
142 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
143 - db-config ignores sliver tags
144 - sirius's db-config script renamed (was sirious)
145
146 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
147 - fix for silverauth - missing tag types now created at plc startup time
148
149 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
150 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
151
152 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
153 - companion to NM's specialaccounts plugin
154 - do not generate /etc/planetlab/root_ssh_key* anymore
155 - remove related config. variables and conf_files
156
157 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
158 - clarified description text to refer only to plcrt and not other optional
159 - packages.
160
161 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
162 - fixed a bug setting slice multiple attributes with the same tag name
163
164 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
165 - SSL setup for monitor box, and related new config variables
166 - new conf_file for /etc/planetlab/extensions
167 - various tweaks in db-config internals, about initscripts among others
168 - also more messages defined in the db
169
170 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
171 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
172
173 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
174 - bugfix in db-config, tag 4.3-19 would not fly
175
176 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
177 - Refactored db-config into snippets in db-config.d/.
178
179 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
180 - oops, tag 4.3-17 was broken and would not work
181
182 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
183 - bugfix - escape sequences inserted in xml configs
184
185 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
186 - Handle db-config.d files properly.
187
188 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
189 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
190 - than the log file
191 - - Fix db-config to be a bit more cautious when
192 - /etc/planetlab/db-config.d doesn't exist
193 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
194 - .orig files.
195 - - Refactor generic plc-config-tty code into plc_config.py.
196 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
197 - and the list of validated variables and the corresponding
198 - validator() function. This refactoring lets one reuse plc_config.py
199 - as a generic cmdline configuration tool for highly customer MyPLC
200 - like software.
201
202 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
203 - update PCU Type descriptions.
204 - updates to init scripts
205
206 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
207 - requires monitor-pcucontrol so register-wizard can work
208
209 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
210 - cleaned up plc-config-tty, no more need to configure plc-devel
211
212 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
213 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
214
215 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
216 - tighter right permissions on site_admin's authorized keys for more robustness
217
218 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
219 - fix issue in db-config that prevented correct operation
220
221 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
222 - remove support for chroot-based packaging - no crond nor syslog step anymore
223 - plc init script now named plc.init instead of former guest.init
224
225 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
226 - add Monitor to docs build
227
228 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
229 - plc_config.py and plc-config-tty: generalized to work for more diverse
230 - MyPLC configurations.
231 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
232 - deployments and increase the memory limits in php.ini
233 - plc.d/crond: add --full option to vacuumdb
234
235 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
236 - avoid generating ssl certificates for disabled services among www api boot
237
238 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
239 - cleaned up old entries in db-config
240 - mtail more robust
241
242 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
243 - php include path tweaked for plekit includes
244 - reviewed myplc (fka native) packaging dependencies
245 - renumbered 4.3
246
247 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
248 - rename myplc into myplc-chroot and myplc-native into myplc
249 - new settings (shortname & hrn_root) for local peer
250
251
252 %define module_current_branch 4.3