systemd services go in /usr/lib/systemd/system rather than /lib/<same>
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 #Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 Requires: cronie
56 # starting with f16 we depend on this new rpm
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
58 Requires: rpm-sign
59 %endif
60 # starting with f27 we depend on this new rpm
61 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
62 Requires: php-fpm
63 %endif
64
65 # planetlab stuff
66 Requires: bootmanager
67 Requires: bootcd-%{nodefamily}
68 Requires: bootcd-initscripts
69 Requires: PLCWWW
70 Requires: www-register-wizard
71 Requires: nodeconfig
72 Requires: nodeyum
73 Requires: plcapi >= 5.2
74 # this technically is a plcapi dependency but it's simpler here for chosing which
75 %if "%{distro}" == "Fedora" && %{distrorelease} >= 29
76 Requires: python2-mod_wsgi
77 %else
78 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
79 Requires: mod_wsgi
80 %else
81 Requires: mod_python
82 %endif
83 Requires: nodeimage-%{nodefamily}
84 Requires: myplc-docs
85 Requires: myplc-release
86 Requires: myplc-config
87
88 %define debug_package %{nil}
89
90 %description 
91 MyPLC is a complete PlanetLab Central (PLC) portable installation.
92 The default installation consists of a web server, an XML-RPC API
93 server, a boot server, and a database server: the core components of
94 PLC. The installation may be customized through a graphical
95 interface. All PLC services are started up and shut down through a
96 single System V init script.
97
98 ####################### myplc-config
99
100 %package config
101
102 Summary: PlanetLab Central (PLC) configuration python module
103 Group: Applications/Systems
104 Requires: python
105
106 %description config
107 This package provides the Python module to configure MyPLC.
108
109
110 %prep
111 %setup -q
112
113 %build
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 # Install configuration scripts
119 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
120 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
121 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
122
123 echo "* Installing scripts in /usr/bin"
124 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
125 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
126 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
127 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
128
129 # Install initscript 
130 echo "* Installing plc initscript"
131 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
132 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
133
134 # Install initscripts
135 echo "* Installing plc.d initscripts"
136 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
137 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
138
139 # Install db-config.d files
140 echo "* Installing db-config.d files"
141 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
142 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
143 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
144
145 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
146 echo "* Installing scripts in /etc/support-scripts"
147 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
148 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
149 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
150
151 # copy initscripts to etc/plc_sliceinitscripts
152 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
153 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
154 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
155
156 # Install configuration file
157 echo "* myplc: Installing configuration file"
158 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
159 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
160     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
161 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
162
163 echo "* Installing bashrc convenience"
164 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
165
166 # yumgroups.xml and yum repo : let noderepo handle that
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %pre
172 if [ -x %{_sysconfdir}/init.d/plc ] ; then
173     %{_sysconfdir}/init.d/plc stop
174 fi
175
176 # Old versions of myplc used to ship with a bootstrapped database and
177 # /etc/planetlab directory. Including generated files in the manifest
178 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
179 # names from one RPM build to another, it would be rpmsaved and thus
180 # effectively deleted. Now we do not include these files in the
181 # manifest. However, to avoid deleting these files in the process of
182 # upgrading from one of these old versions of myplc, we must back up
183 # the database and /etc/planetlab and restore them after the old
184 # version has been uninstalled in %triggerpostun (also in %post, in
185 # case we are force upgrading to the same version).
186 #
187 # This code can be removed once all myplc-0.4-1 installations have
188 # been upgraded to at least myplc-0.4-2.
189
190 # 0 = install, 1 = upgrade
191 if [ $1 -gt 0 ] ; then
192     for dir in /var/lib/pgsql/data /etc/planetlab ; do
193         if [ -d $dir ] ; then
194             echo "Preserving $dir"
195             mkdir -p $dir.rpmsave
196             tar -C $dir -cpf - . | \
197                tar -C $dir.rpmsave -xpf -
198
199             # Except for the default configuration file and DTD, which
200             # really should be considered for upgrade.
201             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
202         fi
203     done
204 fi
205
206 %post
207 if [ -x /sbin/chkconfig ] ; then
208     /sbin/chkconfig --add plc
209     /sbin/chkconfig plc on
210 fi
211
212 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
213 systemctl enable php-fpm
214 systemctl start  php-fpm
215 %endif
216
217 %triggerpostun -- %{name}
218 # 0 = erase, 1 = upgrade
219 if [ $1 -gt 0 ] ; then
220     for dir in /var/lib/pgsql/data /etc/planetlab ; do
221         if [ -d $dir.rpmsave -a -d $dir ] ; then
222             echo "Merging $dir"
223             if tar -C $dir.rpmsave -cpf - . | \
224                tar -C $dir -xpf - ; then
225                 rm -rf $dir.rpmsave
226             fi
227         fi
228     done
229 fi    
230
231 %preun
232 # 0 = erase, 1 = upgrade
233 if [ $1 -eq 0 ] ; then
234     %{_sysconfdir}/init.d/plc stop
235     if [ -x /sbin/chkconfig ] ; then
236         /sbin/chkconfig plc off
237         /sbin/chkconfig --del plc
238     fi
239 fi
240
241 %files
242 %defattr(-,root,root,-)
243 # Host startup script and configuration file
244 /etc/init.d/plc
245 /etc/plc.d
246 /etc/planetlab
247 /etc/plc_sliceinitscripts
248 /etc/support-scripts
249 /usr/share/myplc/bashrc
250 # keep a detailed list, to avoid duplicate of plc-config,
251 # that belongs to the myplc-config rpm
252 /usr/bin/plc-config-tty
253 /usr/bin/db-config
254 /usr/bin/dns-config
255 /usr/bin/refresh-peer.py*
256 /usr/bin/mtail.py*
257 /usr/bin/mtail
258 /usr/bin/plc-map.py*
259 /usr/bin/plc-kml.py*
260 /usr/bin/clean-empty-dirs.py*
261 /usr/bin/plc-check-ssl-peering.py*
262 /usr/bin/plc-orphan-accounts.py*
263 /usr/bin/spot-aliens.py*
264 /usr/bin/check-hrns.py*
265 /usr/bin/check-vsys-defaults.py*
266 /usr/bin/spot-dup-accounts.sh
267 /usr/lib/systemd/system/plc.service
268
269 %files config
270 %defattr(-,root,root,-)
271 /usr/bin/plc-config
272 %{python_sitearch}/plc_config.py*
273
274
275 %changelog
276 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
277 - takes care of creating plcapi log file
278
279 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
280 - tweaked renew_reminder for federation
281
282 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
283 - tweaks in check-hrns.py
284 - do not require PyXML any more
285
286 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
287 - review check-hrns for plcapi-5.3
288 - add PLC_HRN_ROOT in usual plc-config-tty's settings
289
290 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
291 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
292 - add an rpm-sign dependency on feedora>=16
293
294 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
295 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
296
297 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
298 - plc.d/gpg now does not rm /dev/random but preserves it
299 - this is because libvirt won't let us run mknod
300
301 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
302 - fix typo in check-hrns - used to print 'host' while dealing with persons
303
304 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
305 - supports httpd config for either mod_python (preferred) or mod_wsgi
306 - requires mod_wsgi on f18 only, otherwise mod_python
307 - supports httpd config for apache 2.4 (f18)
308 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
309
310 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
311 - bugfix in check-vsys-defaults.py
312
313 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
314 - define open_basedir in php.ini to stop confidentiality leak
315 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
316 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
317 - new utilities check-hrns.py and check-vsys-defaults.py
318
319 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
320 - set TimeoutSec to 300 in plc.service
321 - remove ref to deprecated svn $URL$ in db-config usage
322
323 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
324 - expose mtail.py as simply mtail
325
326 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
327 - plc-kml.py now has support for nodegroups
328
329 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
330 - use nodeimage package instead of deprecated bootstrapfs
331 - has systemd-friendly startup script
332 - plc_reload moved to functions/ - no more service plc reload
333 - no svn keywords anymore
334
335 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
336 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
337
338 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
339 - new settings for myslice (comon&tophat) and monitor (db)
340 - removed mentions of chroot in description
341 - can redo myplc-docs on broken f12-latex
342 - set short_open_tag in php.ini
343 - fixes in gen-sites-xml (is that still used ?)
344 - partial-repo.sh has moved to 'build' where it more belongs
345 - tweaks in convenience tool 'mtail'
346
347 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
348 - fixed changelog, no change from 5.0-16
349
350 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
351 - requires ed for the plc.d/packages step
352 - sirius initscript to handle stop and restart
353
354 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
355 - ignore steps in db-config.d if they have a '.' or '~' in their name
356
357 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
358 - can redo myplc-docs without the doc for monitor
359
360 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
361 - no semantic change - just fixed specfile for git URL
362
363 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
364 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
365
366 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
367 - add missing files to rpm package
368
369 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
370 - mtail.py -s for SFA
371 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
372
373 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
374 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
375
376 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
377 - plc-config-tty now has a validator on booleans
378 - e.g. entering 'True' now is rejected rather than silently recording 'false'
379
380 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
381 - disable mod_wsgi
382
383 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
384 - module name changes
385 - start wsgi support
386
387 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
388 - new setting PLC_RESERVATION_GRANULARITY
389
390 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
391 - * partial-repo.sh script
392 - * preserve key along with certificates
393
394 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
395 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
396
397 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
398 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
399 - new OMF category in the config
400 - create the drl system slice
401
402 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
403 - first working version of 5.0:
404 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
405 - nodefamily is 3-fold with pldistro-fcdistro-arch
406 - new PLC_FLAVOUR config category
407 - reviewed module layout
408 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
409
410 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
411 - support for fedora 12
412 - new package myplc-config for use by sfa
413 - drupal user registration turned off
414
415 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
416 - - fix to make sure when API, BOOT, MONITOR are on the same
417 - machine as WWW that the SSL key,cert for WWW takes precedence.
418 - - Do proper setup for SSL CA certficate to be used as the server
419 - chain.
420
421 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
422 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
423
424 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
425 - depend on pcucontrol
426
427 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
428 - * validate input according to type in plc_config
429 - * added the _genicw system slice
430 - * add tag types for sites and persons
431 - * add new tags for nodes and slices for exemption from myops
432
433 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
434 - turn off drupal on a box that acts as BOOT server but not as WWW server
435 - cleanup some obsolete code for old chroot-jail packaging in the process
436 - new bootcd-kernel script for keeping bootcd variants up2date
437
438 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
439 - Make the /etc/hosts manipulation optional.
440
441 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
442 - Fix SetRole.
443
444 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
445 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
446 - into the DB.
447 - - Added the root ssh key handling support back into plc.d/ssh and the
448 - default xml file.  This should be identical to the way it was in
449 - rc12.
450 - - Added support in the db-config.d/01-init script to register the root
451 - ssh public key with the default administrator.  In this way the root
452 - ssh key will make it into the root account on the nodes by means of
453 - NodeManager's specialaccounts plugin.
454
455 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
456 - db-config ignores sliver tags
457 - sirius's db-config script renamed (was sirious)
458
459 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
460 - fix for silverauth - missing tag types now created at plc startup time
461
462 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
463 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
464
465 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
466 - companion to NM's specialaccounts plugin
467 - do not generate /etc/planetlab/root_ssh_key* anymore
468 - remove related config. variables and conf_files
469
470 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
471 - clarified description text to refer only to plcrt and not other optional
472 - packages.
473
474 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
475 - fixed a bug setting slice multiple attributes with the same tag name
476
477 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
478 - SSL setup for monitor box, and related new config variables
479 - new conf_file for /etc/planetlab/extensions
480 - various tweaks in db-config internals, about initscripts among others
481 - also more messages defined in the db
482
483 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
484 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
485
486 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
487 - bugfix in db-config, tag 4.3-19 would not fly
488
489 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
490 - Refactored db-config into snippets in db-config.d/.
491
492 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
493 - oops, tag 4.3-17 was broken and would not work
494
495 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
496 - bugfix - escape sequences inserted in xml configs
497
498 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
499 - Handle db-config.d files properly.
500
501 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
502 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
503 - than the log file
504 - - Fix db-config to be a bit more cautious when
505 - /etc/planetlab/db-config.d doesn''t exist
506 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
507 - .orig files.
508 - - Refactor generic plc-config-tty code into plc_config.py.
509 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
510 - and the list of validated variables and the corresponding
511 - validator() function. This refactoring lets one reuse plc_config.py
512 - as a generic cmdline configuration tool for highly customer MyPLC
513 - like software.
514
515 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
516 - update PCU Type descriptions.
517 - updates to init scripts
518
519 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
520 - requires monitor-pcucontrol so register-wizard can work
521
522 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
523 - cleaned up plc-config-tty, no more need to configure plc-devel
524
525 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
526 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
527
528 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
529 - fix issue in db-config that prevented correct operation
530
531 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
532 - remove support for chroot-based packaging - no crond nor syslog step anymore
533 - plc init script now named plc.init instead of former guest.init
534
535 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
536 - add Monitor to docs build
537
538 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
539 - plc_config.py and plc-config-tty: generalized to work for more diverse
540 - MyPLC configurations.
541 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
542 - deployments and increase the memory limits in php.ini
543 - plc.d/crond: add --full option to vacuumdb
544
545 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
546 - avoid generating ssl certificates for disabled services among www api boot
547
548 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
549 - cleaned up old entries in db-config
550 - mtail more robust
551
552 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
553 - php include path tweaked for plekit includes
554 - reviewed myplc (fka native) packaging dependencies
555 - renumbered 4.3
556
557 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
558 - rename myplc into myplc-chroot and myplc-native into myplc
559 - new settings (shortname & hrn_root) for local peer
560
561 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
562 - First iteration of new data model
563 - Bunch of various fixes
564
565 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
566 - Removed proper ops from planetflow slice.
567
568 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
569 - myplc-native requires myplc-docs
570 - fixed doc build by locating locally installed DTDs at build-time
571
572 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
573 - turn myplc-docs off for now
574
575 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
576 - figures in doc package
577
578 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
579 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
580 - chroot packaging does not have docs anymore
581 - 'cvs' and 'dev' not required from myplc-native anymore
582 - cosmetic change in kml output
583
584 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
585 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
586 - gethostbyname uses python rather than perl (hope this shrinks deps) 
587 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
588 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
589 - make sync now works towards vserver-based myplc only 
590
591 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
592
593 - added vsys 'pfmount' script to the default netflow slice attributes.
594
595
596 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
597 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
598 - to new bootcd packaging
599
600 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
601 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
602
603 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
604 - packaging of mplc-release in myplc-native
605 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
606 - resolv file in /etc/resolv.conf, not plc_resolv.conf
607 - improved sirius script
608 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
609 - expires more properly set 
610
611 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
612
613
614 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
615 - renew_reminder script moved to support-scripts/
616 - gen-aliases script added in support-scripts/
617 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
618 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
619 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
620 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
621 - new setting 'Mom list address' for sending emails to a separate destination
622 - starts rsyslogd/syslogd as appropriate
623 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
624 - convenience generation of yum.conf in resulting image based on build/mirroring
625
626 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
627 - refresh-peer.py removed (duplicate with PLCAPI)
628 - plc.d/ scripts cleaned up
629 - sirius initscript updated
630 - slice auto renewal fixed
631
632 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
633 - initial build.
634
635 %define module_current_branch 4.3