remove requirements for a serverside-only build
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 7.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23
24 ####################### myplc - mostly a meta-package
25 Summary: PlanetLab Central (PLC) Portable Installation
26 Group: Applications/Systems
27
28 # planetlab stuff
29 Requires: myplc-docs
30 Requires: myplc-release
31 Requires: myplc-core
32 Requires: createrepo
33 ## serverside only
34 #Requires: bootmanager
35 #Requires: bootcd-%{nodefamily}
36 #Requires: bootcd-initscripts
37 #Requires: nodeimage-%{nodefamily}
38 #Requires: nodeconfig
39 #Requires: nodeyum
40 Requires: www-register-wizard
41
42
43 # starting with f16 we depend on this new rpm
44 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
45 Requires: rpm-sign
46 %endif
47
48
49 %description
50 MyPLC is a complete PlanetLab Central (PLC) portable installation.
51 The default installation consists of a web server, an XML-RPC API
52 server, a boot server, and a database server: the core components of
53 PLC. The installation may be customized through a graphical
54 interface. All PLC services are started up and shut down through a
55 single System V init script.
56
57
58 ####################### myplc-core
59 # Warning: it appears that Requires should come here
60 # BEFORE the %description thingy
61
62 %package core
63
64 Summary: core contents of myplc with API + db + www UI
65
66 # as much as possible, requires should have gone
67 # with the individual packages, but well
68 Requires: myplc-config
69 Requires: plcapi
70 Requires: plewww
71
72 # this technically is a plcapi dependency
73 # but it's simpler here for chosing which
74 Requires: python3-mod_wsgi
75
76 # this technically is a plewww dependency
77 # starting with f27 we depend on this new rpm
78 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
79 Requires: php-fpm
80 %endif
81
82 Requires: redhat-lsb
83 Requires: bzip2
84 Requires: tar
85 Requires: less
86 Requires: sendmail
87 Requires: sendmail-cf
88 Requires: openssl
89 Requires: expect
90 Requires: php-pgsql
91 Requires: curl
92 Requires: rsync
93 Requires: python3-devel
94 Requires: dnf
95 #Requires: PyXML
96 Requires: cpio
97 Requires: wget
98 Requires: php
99 Requires: openssh
100 Requires: dnsmasq
101 Requires: diffutils
102 Requires: gzip
103 Requires: vim-minimal
104 Requires: findutils
105 Requires: xmlsec1
106 Requires: xmlsec1-openssl
107 Requires: ed
108 Requires: cronie
109
110
111 %description core
112 The core of myplc is about its API + database + web interface.
113 Installing this will not require any node-oriented
114 package, like bootcd, nodeimage, or bootmanager.
115
116 ####################### myplc-config
117
118 %package config
119
120 Summary: PlanetLab Central (PLC) configuration python module
121 Group: Applications/Systems
122 Requires: python3
123
124 %description config
125 This package provides the Python module to configure MyPLC.
126
127
128
129 %prep
130 %setup -q
131
132 %build
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 # Install configuration scripts
138 echo "* Installing plc_config.py in %{python3_sitelib}"
139 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}/plc_config.py
140
141 echo "* Installing scripts in /usr/bin"
142 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
143 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
144 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
145 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
146
147 # Install initscript
148 echo "* Installing plc initscript"
149 install -D -m 755 systemd/plc-ctl ${RPM_BUILD_ROOT}/usr/bin/plc-ctl
150 install -D -m 644 systemd/plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
151
152 # Install initscripts
153 echo "* Installing plc.d initscripts"
154 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
155 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
156
157 # Install db-config.d files
158 echo "* Installing db-config.d files"
159 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
160 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
161 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
162
163 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
164 echo "* Installing scripts in /etc/support-scripts"
165 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
166 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
167 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
168
169 # copy initscripts to etc/plc_sliceinitscripts
170 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
171 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
172 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
173
174 # Install configuration file
175 echo "* myplc: Installing configuration file"
176 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
177 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
178     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
179 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
180
181 echo "* Installing bashrc convenience"
182 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
183
184 # yumgroups.xml and yum repo : let noderepo handle that
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %pre
190 if [ -x %{_sysconfdir}/init.d/plc ] ; then
191     %{_sysconfdir}/init.d/plc stop
192 fi
193
194 # Old versions of myplc used to ship with a bootstrapped database and
195 # /etc/planetlab directory. Including generated files in the manifest
196 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
197 # names from one RPM build to another, it would be rpmsaved and thus
198 # effectively deleted. Now we do not include these files in the
199 # manifest. However, to avoid deleting these files in the process of
200 # upgrading from one of these old versions of myplc, we must back up
201 # the database and /etc/planetlab and restore them after the old
202 # version has been uninstalled in %triggerpostun (also in %post, in
203 # case we are force upgrading to the same version).
204 #
205 # This code can be removed once all myplc-0.4-1 installations have
206 # been upgraded to at least myplc-0.4-2.
207
208 # 0 = install, 1 = upgrade
209 if [ $1 -gt 0 ] ; then
210     for dir in /var/lib/pgsql/data /etc/planetlab ; do
211         if [ -d $dir ] ; then
212             echo "Preserving $dir"
213             mkdir -p $dir.rpmsave
214             tar -C $dir -cpf - . | \
215                tar -C $dir.rpmsave -xpf -
216
217             # Except for the default configuration file and DTD, which
218             # really should be considered for upgrade.
219             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
220         fi
221     done
222 fi
223
224 %post
225 systemctl enable plc
226
227 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
228 systemctl enable php-fpm
229 systemctl start  php-fpm
230 %endif
231
232 %triggerpostun -- %{name}
233 # 0 = erase, 1 = upgrade
234 if [ $1 -gt 0 ] ; then
235     for dir in /var/lib/pgsql/data /etc/planetlab ; do
236         if [ -d $dir.rpmsave -a -d $dir ] ; then
237             echo "Merging $dir"
238             if tar -C $dir.rpmsave -cpf - . | \
239                tar -C $dir -xpf - ; then
240                 rm -rf $dir.rpmsave
241             fi
242         fi
243     done
244 fi
245
246 %preun
247 # 0 = erase, 1 = upgrade
248 if [ $1 -eq 0 ] ; then
249     %{_sysconfdir}/init.d/plc stop
250     systemctl disable plc
251 fi
252
253
254 %files
255 /usr/share/myplc/bashrc
256
257 %files core
258 %defattr(-,root,root,-)
259 /usr/lib/systemd/system/plc.service
260 /usr/bin/plc-ctl
261 /etc/plc.d
262 /etc/planetlab
263 /etc/plc_sliceinitscripts
264 /etc/support-scripts
265 # keep a detailed list, to avoid duplicate of plc-config,
266 # that belongs to the myplc-config rpm
267 /usr/bin/plc-config-tty
268 /usr/bin/db-config
269 /usr/bin/dns-config
270 /usr/bin/refresh-peer.py*
271 /usr/bin/mtail.py*
272 /usr/bin/mtail
273 /usr/bin/plc-map.py*
274 /usr/bin/plc-kml.py*
275 /usr/bin/clean-empty-dirs.py*
276 /usr/bin/plc-check-ssl-peering.py*
277 /usr/bin/plc-orphan-accounts.py*
278 /usr/bin/spot-aliens.py*
279 /usr/bin/check-hrns.py*
280 /usr/bin/check-vsys-defaults.py*
281 /usr/bin/spot-dup-accounts.sh
282
283
284 %files config
285 %defattr(-,root,root,-)
286 /usr/bin/plc-config
287 %{python3_sitelib}/plc_config.py*
288 %exclude %{python3_sitelib}/__pycache__/*.pyc
289
290 %changelog
291 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
292 - suitable for python3 on both f27 and f29
293
294 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
295 - takes care of creating plcapi log file
296
297 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
298 - tweaked renew_reminder for federation
299
300 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
301 - tweaks in check-hrns.py
302 - do not require PyXML any more
303
304 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
305 - review check-hrns for plcapi-5.3
306 - add PLC_HRN_ROOT in usual plc-config-tty's settings
307
308 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
309 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
310 - add an rpm-sign dependency on feedora>=16
311
312 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
313 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
314
315 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
316 - plc.d/gpg now does not rm /dev/random but preserves it
317 - this is because libvirt won't let us run mknod
318
319 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
320 - fix typo in check-hrns - used to print 'host' while dealing with persons
321
322 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
323 - supports httpd config for either mod_python (preferred) or mod_wsgi
324 - requires mod_wsgi on f18 only, otherwise mod_python
325 - supports httpd config for apache 2.4 (f18)
326 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
327
328 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
329 - bugfix in check-vsys-defaults.py
330
331 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
332 - define open_basedir in php.ini to stop confidentiality leak
333 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
334 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
335 - new utilities check-hrns.py and check-vsys-defaults.py
336
337 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
338 - set TimeoutSec to 300 in plc.service
339 - remove ref to deprecated svn $URL$ in db-config usage
340
341 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
342 - expose mtail.py as simply mtail
343
344 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
345 - plc-kml.py now has support for nodegroups
346
347 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
348 - use nodeimage package instead of deprecated bootstrapfs
349 - has systemd-friendly startup script
350 - plc_reload moved to functions/ - no more service plc reload
351 - no svn keywords anymore
352
353 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
354 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
355
356 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
357 - new settings for myslice (comon&tophat) and monitor (db)
358 - removed mentions of chroot in description
359 - can redo myplc-docs on broken f12-latex
360 - set short_open_tag in php.ini
361 - fixes in gen-sites-xml (is that still used ?)
362 - partial-repo.sh has moved to 'build' where it more belongs
363 - tweaks in convenience tool 'mtail'
364
365 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
366 - fixed changelog, no change from 5.0-16
367
368 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
369 - requires ed for the plc.d/packages step
370 - sirius initscript to handle stop and restart
371
372 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
373 - ignore steps in db-config.d if they have a '.' or '~' in their name
374
375 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
376 - can redo myplc-docs without the doc for monitor
377
378 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
379 - no semantic change - just fixed specfile for git URL
380
381 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
382 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
383
384 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
385 - add missing files to rpm package
386
387 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
388 - mtail.py -s for SFA
389 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
390
391 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
392 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
393
394 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
395 - plc-config-tty now has a validator on booleans
396 - e.g. entering 'True' now is rejected rather than silently recording 'false'
397
398 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
399 - disable mod_wsgi
400
401 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
402 - module name changes
403 - start wsgi support
404
405 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
406 - new setting PLC_RESERVATION_GRANULARITY
407
408 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
409 - * partial-repo.sh script
410 - * preserve key along with certificates
411
412 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
413 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
414
415 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
416 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
417 - new OMF category in the config
418 - create the drl system slice
419
420 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
421 - first working version of 5.0:
422 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
423 - nodefamily is 3-fold with pldistro-fcdistro-arch
424 - new PLC_FLAVOUR config category
425 - reviewed module layout
426 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
427
428 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
429 - support for fedora 12
430 - new package myplc-config for use by sfa
431 - drupal user registration turned off
432
433 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
434 - - fix to make sure when API, BOOT, MONITOR are on the same
435 - machine as WWW that the SSL key,cert for WWW takes precedence.
436 - - Do proper setup for SSL CA certficate to be used as the server
437 - chain.
438
439 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
440 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
441
442 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
443 - depend on pcucontrol
444
445 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
446 - * validate input according to type in plc_config
447 - * added the _genicw system slice
448 - * add tag types for sites and persons
449 - * add new tags for nodes and slices for exemption from myops
450
451 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
452 - turn off drupal on a box that acts as BOOT server but not as WWW server
453 - cleanup some obsolete code for old chroot-jail packaging in the process
454 - new bootcd-kernel script for keeping bootcd variants up2date
455
456 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
457 - Make the /etc/hosts manipulation optional.
458
459 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
460 - Fix SetRole.
461
462 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
463 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
464 - into the DB.
465 - - Added the root ssh key handling support back into plc.d/ssh and the
466 - default xml file.  This should be identical to the way it was in
467 - rc12.
468 - - Added support in the db-config.d/01-init script to register the root
469 - ssh public key with the default administrator.  In this way the root
470 - ssh key will make it into the root account on the nodes by means of
471 - NodeManager's specialaccounts plugin.
472
473 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
474 - db-config ignores sliver tags
475 - sirius's db-config script renamed (was sirious)
476
477 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
478 - fix for silverauth - missing tag types now created at plc startup time
479
480 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
481 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
482
483 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
484 - companion to NM's specialaccounts plugin
485 - do not generate /etc/planetlab/root_ssh_key* anymore
486 - remove related config. variables and conf_files
487
488 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
489 - clarified description text to refer only to plcrt and not other optional
490 - packages.
491
492 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
493 - fixed a bug setting slice multiple attributes with the same tag name
494
495 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
496 - SSL setup for monitor box, and related new config variables
497 - new conf_file for /etc/planetlab/extensions
498 - various tweaks in db-config internals, about initscripts among others
499 - also more messages defined in the db
500
501 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
502 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
503
504 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
505 - bugfix in db-config, tag 4.3-19 would not fly
506
507 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
508 - Refactored db-config into snippets in db-config.d/.
509
510 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
511 - oops, tag 4.3-17 was broken and would not work
512
513 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
514 - bugfix - escape sequences inserted in xml configs
515
516 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
517 - Handle db-config.d files properly.
518
519 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
520 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
521 - than the log file
522 - - Fix db-config to be a bit more cautious when
523 - /etc/planetlab/db-config.d doesn''t exist
524 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
525 - .orig files.
526 - - Refactor generic plc-config-tty code into plc_config.py.
527 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
528 - and the list of validated variables and the corresponding
529 - validator() function. This refactoring lets one reuse plc_config.py
530 - as a generic cmdline configuration tool for highly customer MyPLC
531 - like software.
532
533 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
534 - update PCU Type descriptions.
535 - updates to init scripts
536
537 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
538 - requires monitor-pcucontrol so register-wizard can work
539
540 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
541 - cleaned up plc-config-tty, no more need to configure plc-devel
542
543 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
544 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
545
546 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
547 - fix issue in db-config that prevented correct operation
548
549 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
550 - remove support for chroot-based packaging - no crond nor syslog step anymore
551 - plc init script now named plc.init instead of former guest.init
552
553 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
554 - add Monitor to docs build
555
556 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
557 - plc_config.py and plc-config-tty: generalized to work for more diverse
558 - MyPLC configurations.
559 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
560 - deployments and increase the memory limits in php.ini
561 - plc.d/crond: add --full option to vacuumdb
562
563 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
564 - avoid generating ssl certificates for disabled services among www api boot
565
566 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
567 - cleaned up old entries in db-config
568 - mtail more robust
569
570 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
571 - php include path tweaked for plekit includes
572 - reviewed myplc (fka native) packaging dependencies
573 - renumbered 4.3
574
575 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
576 - rename myplc into myplc-chroot and myplc-native into myplc
577 - new settings (shortname & hrn_root) for local peer
578
579 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
580 - First iteration of new data model
581 - Bunch of various fixes
582
583 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
584 - Removed proper ops from planetflow slice.
585
586 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
587 - myplc-native requires myplc-docs
588 - fixed doc build by locating locally installed DTDs at build-time
589
590 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
591 - turn myplc-docs off for now
592
593 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
594 - figures in doc package
595
596 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
597 - no more doc packaged outside of myplc-docs - doc/ cleaned up
598 - chroot packaging does not have docs anymore
599 - 'cvs' and 'dev' not required from myplc-native anymore
600 - cosmetic change in kml output
601
602 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
603 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
604 - gethostbyname uses python rather than perl (hope this shrinks deps)
605 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
606 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
607 - make sync now works towards vserver-based myplc only
608
609 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
610 -
611 - added vsys 'pfmount' script to the default netflow slice attributes.
612 -
613
614 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
615 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
616 - to new bootcd packaging
617
618 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
619 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
620
621 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
622 - packaging of mplc-release in myplc-native
623 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
624 - resolv file in /etc/resolv.conf, not plc_resolv.conf
625 - improved sirius script
626 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
627 - expires more properly set
628
629 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
630 -
631
632 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
633 - renew_reminder script moved to support-scripts/
634 - gen-aliases script added in support-scripts/
635 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
636 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
637 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
638 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
639 - new setting 'Mom list address' for sending emails to a separate destination
640 - starts rsyslogd/syslogd as appropriate
641 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
642 - convenience generation of yum.conf in resulting image based on build/mirroring
643
644 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
645 - refresh-peer.py removed (duplicate with PLCAPI)
646 - plc.d/ scripts cleaned up
647 - sirius initscript updated
648 - slice auto renewal fixed
649
650 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
651 - initial build.
652
653 %define module_current_branch 4.3