workaround for dealing with /dev/random /dev/urandom in a libvirt environment that...
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.2
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
56 Requires: cronie
57 %else
58 Requires: vixie-cron
59 %endif
60 # planetlab stuff
61 Requires: bootmanager
62 Requires: bootcd-%{nodefamily}
63 Requires: bootcd-initscripts
64 Requires: PLCWWW
65 Requires: www-register-wizard
66 Requires: nodeconfig
67 Requires: nodeyum
68 Requires: plcapi >= 5.2
69 # this technically is a plcapi dependency but it's simpler here for chosing which
70 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
71 Requires: mod_wsgi
72 %else
73 Requires: mod_python
74 %endif
75 Requires: nodeimage-%{nodefamily}
76 Requires: myplc-docs
77 Requires: myplc-release
78 Requires: myplc-config
79
80 %define debug_package %{nil}
81
82 %description 
83 MyPLC is a complete PlanetLab Central (PLC) portable installation.
84 The default installation consists of a web server, an XML-RPC API
85 server, a boot server, and a database server: the core components of
86 PLC. The installation may be customized through a graphical
87 interface. All PLC services are started up and shut down through a
88 single System V init script.
89
90 ####################### myplc-config
91
92 %package config
93
94 Summary: PlanetLab Central (PLC) configuration python module
95 Group: Applications/Systems
96 Requires: python
97
98 %description config
99 This package provides the Python module to configure MyPLC.
100
101
102 %prep
103 %setup -q
104
105 %build
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 # Install configuration scripts
111 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
112 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
113 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
114
115 echo "* Installing scripts in /usr/bin"
116 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
117 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
118 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
119 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
120
121 # Install initscript 
122 echo "* Installing plc initscript"
123 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
124 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
125
126 # Install initscripts
127 echo "* Installing plc.d initscripts"
128 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
129 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
130
131 # Install db-config.d files
132 echo "* Installing db-config.d files"
133 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
134 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
136
137 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
138 echo "* Installing scripts in /etc/support-scripts"
139 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
140 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
141 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
142
143 # copy initscripts to etc/plc_sliceinitscripts
144 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
145 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
146 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
147
148 # Install configuration file
149 echo "* myplc: Installing configuration file"
150 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
151 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
152     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
153 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
154
155 echo "* Installing bashrc convenience"
156 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
157
158 # yumgroups.xml and yum repo : let noderepo handle that
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %pre
164 if [ -x %{_sysconfdir}/init.d/plc ] ; then
165     %{_sysconfdir}/init.d/plc stop
166 fi
167
168 # Old versions of myplc used to ship with a bootstrapped database and
169 # /etc/planetlab directory. Including generated files in the manifest
170 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
171 # names from one RPM build to another, it would be rpmsaved and thus
172 # effectively deleted. Now we do not include these files in the
173 # manifest. However, to avoid deleting these files in the process of
174 # upgrading from one of these old versions of myplc, we must back up
175 # the database and /etc/planetlab and restore them after the old
176 # version has been uninstalled in %triggerpostun (also in %post, in
177 # case we are force upgrading to the same version).
178 #
179 # This code can be removed once all myplc-0.4-1 installations have
180 # been upgraded to at least myplc-0.4-2.
181
182 # 0 = install, 1 = upgrade
183 if [ $1 -gt 0 ] ; then
184     for dir in /var/lib/pgsql/data /etc/planetlab ; do
185         if [ -d $dir ] ; then
186             echo "Preserving $dir"
187             mkdir -p $dir.rpmsave
188             tar -C $dir -cpf - . | \
189                tar -C $dir.rpmsave -xpf -
190
191             # Except for the default configuration file and DTD, which
192             # really should be considered for upgrade.
193             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
194         fi
195     done
196 fi
197
198 %post
199 if [ -x /sbin/chkconfig ] ; then
200     /sbin/chkconfig --add plc
201     /sbin/chkconfig plc on
202 fi
203
204 %triggerpostun -- %{name}
205 # 0 = erase, 1 = upgrade
206 if [ $1 -gt 0 ] ; then
207     for dir in /var/lib/pgsql/data /etc/planetlab ; do
208         if [ -d $dir.rpmsave -a -d $dir ] ; then
209             echo "Merging $dir"
210             if tar -C $dir.rpmsave -cpf - . | \
211                tar -C $dir -xpf - ; then
212                 rm -rf $dir.rpmsave
213             fi
214         fi
215     done
216 fi    
217
218 %preun
219 # 0 = erase, 1 = upgrade
220 if [ $1 -eq 0 ] ; then
221     %{_sysconfdir}/init.d/plc stop
222     if [ -x /sbin/chkconfig ] ; then
223         /sbin/chkconfig plc off
224         /sbin/chkconfig --del plc
225     fi
226 fi
227
228 %files
229 %defattr(-,root,root,-)
230 # Host startup script and configuration file
231 /etc/init.d/plc
232 /etc/plc.d
233 /etc/planetlab
234 /etc/plc_sliceinitscripts
235 /etc/support-scripts
236 /usr/share/myplc/bashrc
237 # keep a detailed list, to avoid duplicate of plc-config,
238 # that belongs to the myplc-config rpm
239 /usr/bin/plc-config-tty
240 /usr/bin/db-config
241 /usr/bin/dns-config
242 /usr/bin/refresh-peer.py*
243 /usr/bin/mtail.py*
244 /usr/bin/mtail
245 /usr/bin/plc-map.py*
246 /usr/bin/plc-kml.py*
247 /usr/bin/clean-empty-dirs.py*
248 /usr/bin/plc-check-ssl-peering.py*
249 /usr/bin/plc-orphan-accounts.py*
250 /usr/bin/spot-aliens.py*
251 /usr/bin/check-hrns.py*
252 /usr/bin/check-vsys-defaults.py*
253 /usr/bin/spot-dup-accounts.sh
254 /lib/systemd/system/plc.service
255
256 %files config
257 %defattr(-,root,root,-)
258 /usr/bin/plc-config
259 %{python_sitearch}/plc_config.py*
260
261
262 %changelog
263 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
264 - supports httpd config for either mod_python (preferred) or mod_wsgi
265 - requires mod_wsgi on f18 only, otherwise mod_python
266 - supports httpd config for apache 2.4 (f18)
267 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
268
269 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
270 - bugfix in check-vsys-defaults.py
271
272 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
273 - define open_basedir in php.ini to stop confidentiality leak
274 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
275 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
276 - new utilities check-hrns.py and check-vsys-defaults.py
277
278 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
279 - set TimeoutSec to 300 in plc.service
280 - remove ref to deprecated svn $URL$ in db-config usage
281
282 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
283 - expose mtail.py as simply mtail
284
285 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
286 - plc-kml.py now has support for nodegroups
287
288 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
289 - use nodeimage package instead of deprecated bootstrapfs
290 - has systemd-friendly startup script
291 - plc_reload moved to functions/ - no more service plc reload
292 - no svn keywords anymore
293
294 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
295 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
296
297 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
298 - new settings for myslice (comon&tophat) and monitor (db)
299 - removed mentions of chroot in description
300 - can redo myplc-docs on broken f12-latex
301 - set short_open_tag in php.ini
302 - fixes in gen-sites-xml (is that still used ?)
303 - partial-repo.sh has moved to 'build' where it more belongs
304 - tweaks in convenience tool 'mtail'
305
306 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
307 - fixed changelog, no change from 5.0-16
308
309 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
310 - requires ed for the plc.d/packages step
311 - sirius initscript to handle stop and restart
312
313 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
314 - ignore steps in db-config.d if they have a '.' or '~' in their name
315
316 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
317 - can redo myplc-docs without the doc for monitor
318
319 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
320 - no semantic change - just fixed specfile for git URL
321
322 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
323 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
324
325 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
326 - add missing files to rpm package
327
328 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
329 - mtail.py -s for SFA
330 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
331
332 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
333 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
334
335 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
336 - plc-config-tty now has a validator on booleans
337 - e.g. entering 'True' now is rejected rather than silently recording 'false'
338
339 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
340 - disable mod_wsgi
341
342 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
343 - module name changes
344 - start wsgi support
345
346 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
347 - new setting PLC_RESERVATION_GRANULARITY
348
349 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
350 - * partial-repo.sh script
351 - * preserve key along with certificates
352
353 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
354 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
355
356 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
357 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
358 - new OMF category in the config
359 - create the drl system slice
360
361 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
362 - first working version of 5.0:
363 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
364 - nodefamily is 3-fold with pldistro-fcdistro-arch
365 - new PLC_FLAVOUR config category
366 - reviewed module layout
367 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
368
369 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
370 - support for fedora 12
371 - new package myplc-config for use by sfa
372 - drupal user registration turned off
373
374 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
375 - - fix to make sure when API, BOOT, MONITOR are on the same
376 - machine as WWW that the SSL key,cert for WWW takes precedence.
377 - - Do proper setup for SSL CA certficate to be used as the server
378 - chain.
379
380 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
381 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
382
383 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
384 - depend on pcucontrol
385
386 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
387 - * validate input according to type in plc_config
388 - * added the _genicw system slice
389 - * add tag types for sites and persons
390 - * add new tags for nodes and slices for exemption from myops
391
392 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
393 - turn off drupal on a box that acts as BOOT server but not as WWW server
394 - cleanup some obsolete code for old chroot-jail packaging in the process
395 - new bootcd-kernel script for keeping bootcd variants up2date
396
397 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
398 - Make the /etc/hosts manipulation optional.
399
400 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
401 - Fix SetRole.
402
403 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
404 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
405 - into the DB.
406 - - Added the root ssh key handling support back into plc.d/ssh and the
407 - default xml file.  This should be identical to the way it was in
408 - rc12.
409 - - Added support in the db-config.d/01-init script to register the root
410 - ssh public key with the default administrator.  In this way the root
411 - ssh key will make it into the root account on the nodes by means of
412 - NodeManager's specialaccounts plugin.
413
414 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
415 - db-config ignores sliver tags
416 - sirius's db-config script renamed (was sirious)
417
418 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
419 - fix for silverauth - missing tag types now created at plc startup time
420
421 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
422 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
423
424 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
425 - companion to NM's specialaccounts plugin
426 - do not generate /etc/planetlab/root_ssh_key* anymore
427 - remove related config. variables and conf_files
428
429 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
430 - clarified description text to refer only to plcrt and not other optional
431 - packages.
432
433 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
434 - fixed a bug setting slice multiple attributes with the same tag name
435
436 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
437 - SSL setup for monitor box, and related new config variables
438 - new conf_file for /etc/planetlab/extensions
439 - various tweaks in db-config internals, about initscripts among others
440 - also more messages defined in the db
441
442 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
443 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
444
445 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
446 - bugfix in db-config, tag 4.3-19 would not fly
447
448 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
449 - Refactored db-config into snippets in db-config.d/.
450
451 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
452 - oops, tag 4.3-17 was broken and would not work
453
454 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
455 - bugfix - escape sequences inserted in xml configs
456
457 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
458 - Handle db-config.d files properly.
459
460 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
461 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
462 - than the log file
463 - - Fix db-config to be a bit more cautious when
464 - /etc/planetlab/db-config.d doesn''t exist
465 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
466 - .orig files.
467 - - Refactor generic plc-config-tty code into plc_config.py.
468 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
469 - and the list of validated variables and the corresponding
470 - validator() function. This refactoring lets one reuse plc_config.py
471 - as a generic cmdline configuration tool for highly customer MyPLC
472 - like software.
473
474 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
475 - update PCU Type descriptions.
476 - updates to init scripts
477
478 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
479 - requires monitor-pcucontrol so register-wizard can work
480
481 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
482 - cleaned up plc-config-tty, no more need to configure plc-devel
483
484 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
485 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
486
487 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
488 - fix issue in db-config that prevented correct operation
489
490 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
491 - remove support for chroot-based packaging - no crond nor syslog step anymore
492 - plc init script now named plc.init instead of former guest.init
493
494 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
495 - add Monitor to docs build
496
497 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
498 - plc_config.py and plc-config-tty: generalized to work for more diverse
499 - MyPLC configurations.
500 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
501 - deployments and increase the memory limits in php.ini
502 - plc.d/crond: add --full option to vacuumdb
503
504 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
505 - avoid generating ssl certificates for disabled services among www api boot
506
507 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
508 - cleaned up old entries in db-config
509 - mtail more robust
510
511 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
512 - php include path tweaked for plekit includes
513 - reviewed myplc (fka native) packaging dependencies
514 - renumbered 4.3
515
516 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
517 - rename myplc into myplc-chroot and myplc-native into myplc
518 - new settings (shortname & hrn_root) for local peer
519
520 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
521 - First iteration of new data model
522 - Bunch of various fixes
523
524 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
525 - Removed proper ops from planetflow slice.
526
527 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
528 - myplc-native requires myplc-docs
529 - fixed doc build by locating locally installed DTDs at build-time
530
531 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
532 - turn myplc-docs off for now
533
534 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
535 - figures in doc package
536
537 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
538 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
539 - chroot packaging does not have docs anymore
540 - 'cvs' and 'dev' not required from myplc-native anymore
541 - cosmetic change in kml output
542
543 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
544 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
545 - gethostbyname uses python rather than perl (hope this shrinks deps) 
546 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
547 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
548 - make sync now works towards vserver-based myplc only 
549
550 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
551
552 - added vsys 'pfmount' script to the default netflow slice attributes.
553
554
555 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
556 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
557 - to new bootcd packaging
558
559 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
560 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
561
562 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
563 - packaging of mplc-release in myplc-native
564 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
565 - resolv file in /etc/resolv.conf, not plc_resolv.conf
566 - improved sirius script
567 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
568 - expires more properly set 
569
570 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
571
572
573 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
574 - renew_reminder script moved to support-scripts/
575 - gen-aliases script added in support-scripts/
576 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
577 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
578 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
579 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
580 - new setting 'Mom list address' for sending emails to a separate destination
581 - starts rsyslogd/syslogd as appropriate
582 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
583 - convenience generation of yum.conf in resulting image based on build/mirroring
584
585 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
586 - refresh-peer.py removed (duplicate with PLCAPI)
587 - plc.d/ scripts cleaned up
588 - sirius initscript updated
589 - slice auto renewal fixed
590
591 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
592 - initial build.
593
594 %define module_current_branch 4.3