Setting tag myplc-5.3-5
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23
24 ####################### myplc - mostly a meta-package
25 Summary: PlanetLab Central (PLC) Portable Installation
26 Group: Applications/Systems
27
28 # planetlab stuff
29 Requires: myplc-docs
30 Requires: myplc-release
31 Requires: myplc-core
32 Requires: createrepo
33 Requires: bootmanager
34 Requires: bootcd-%{nodefamily}
35 Requires: bootcd-initscripts
36 Requires: nodeimage-%{nodefamily}
37 Requires: nodeconfig
38 Requires: nodeyum
39 Requires: www-register-wizard
40
41
42 # starting with f16 we depend on this new rpm
43 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
44 Requires: rpm-sign
45 %endif
46
47
48 %description
49 MyPLC is a complete PlanetLab Central (PLC) portable installation.
50 The default installation consists of a web server, an XML-RPC API
51 server, a boot server, and a database server: the core components of
52 PLC. The installation may be customized through a graphical
53 interface. All PLC services are started up and shut down through a
54 single System V init script.
55
56
57 ####################### myplc-core
58 # Warning: it appears that Requires should come here
59 # BEFORE the %description thingy
60
61 %package core
62
63 Summary: core contents of myplc with API + db + www UI
64
65 # as much as possible, requires should have gone
66 # with the individual packages, but well
67 Requires: myplc-config
68 Requires: plcapi
69 Requires: plewww
70
71 # this technically is a plcapi dependency
72 # but it's simpler here for chosing which
73 %if "%{distro}" == "Fedora" && %{distrorelease} >= 29
74 Requires: python2-mod_wsgi
75 %else
76 Requires: mod_wsgi
77 %endif
78
79 # this technically is a plewww dependency
80 # starting with f27 we depend on this new rpm
81 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
82 Requires: php-fpm
83 %endif
84
85 Requires: redhat-lsb
86 Requires: bzip2
87 Requires: tar
88 Requires: less
89 Requires: sendmail
90 Requires: sendmail-cf
91 Requires: openssl
92 Requires: expect
93 Requires: php-pgsql
94 Requires: curl
95 Requires: rsync
96 Requires: python-devel
97 Requires: dnf
98 #Requires: PyXML
99 Requires: cpio
100 Requires: wget
101 Requires: php
102 Requires: openssh
103 Requires: dnsmasq
104 Requires: diffutils
105 Requires: gzip
106 Requires: vim-minimal
107 Requires: findutils
108 Requires: xmlsec1
109 Requires: xmlsec1-openssl
110 Requires: ed
111 Requires: cronie
112
113
114 %description core
115 The core of myplc is about its API + database + web interface.
116 Installing this will not require any node-oriented
117 package, like bootcd, nodeimage, or bootmanager.
118
119 ####################### myplc-config
120
121 %package config
122
123 Summary: PlanetLab Central (PLC) configuration python module
124 Group: Applications/Systems
125 Requires: python
126
127 %description config
128 This package provides the Python module to configure MyPLC.
129
130
131
132 %prep
133 %setup -q
134
135 %build
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 # Install configuration scripts
141 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
142 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
143 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
144
145 echo "* Installing scripts in /usr/bin"
146 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
147 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
148 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
149 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
150
151 # Install initscript
152 echo "* Installing plc initscript"
153 install -D -m 755 systemd/plc-ctl ${RPM_BUILD_ROOT}/usr/bin/plc-ctl
154 install -D -m 644 systemd/plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
155
156 # Install initscripts
157 echo "* Installing plc.d initscripts"
158 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
159 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
160
161 # Install db-config.d files
162 echo "* Installing db-config.d files"
163 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
164 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
165 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
166
167 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
168 echo "* Installing scripts in /etc/support-scripts"
169 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
170 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
171 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
172
173 # copy initscripts to etc/plc_sliceinitscripts
174 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
175 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
176 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
177
178 # Install configuration file
179 echo "* myplc: Installing configuration file"
180 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
181 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
182     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
183 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
184
185 echo "* Installing bashrc convenience"
186 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
187
188 # yumgroups.xml and yum repo : let noderepo handle that
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %pre
194 if [ -x %{_sysconfdir}/init.d/plc ] ; then
195     %{_sysconfdir}/init.d/plc stop
196 fi
197
198 # Old versions of myplc used to ship with a bootstrapped database and
199 # /etc/planetlab directory. Including generated files in the manifest
200 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
201 # names from one RPM build to another, it would be rpmsaved and thus
202 # effectively deleted. Now we do not include these files in the
203 # manifest. However, to avoid deleting these files in the process of
204 # upgrading from one of these old versions of myplc, we must back up
205 # the database and /etc/planetlab and restore them after the old
206 # version has been uninstalled in %triggerpostun (also in %post, in
207 # case we are force upgrading to the same version).
208 #
209 # This code can be removed once all myplc-0.4-1 installations have
210 # been upgraded to at least myplc-0.4-2.
211
212 # 0 = install, 1 = upgrade
213 if [ $1 -gt 0 ] ; then
214     for dir in /var/lib/pgsql/data /etc/planetlab ; do
215         if [ -d $dir ] ; then
216             echo "Preserving $dir"
217             mkdir -p $dir.rpmsave
218             tar -C $dir -cpf - . | \
219                tar -C $dir.rpmsave -xpf -
220
221             # Except for the default configuration file and DTD, which
222             # really should be considered for upgrade.
223             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
224         fi
225     done
226 fi
227
228 %post
229 systemctl enable plc
230
231 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
232 systemctl enable php-fpm
233 systemctl start  php-fpm
234 %endif
235
236 %triggerpostun -- %{name}
237 # 0 = erase, 1 = upgrade
238 if [ $1 -gt 0 ] ; then
239     for dir in /var/lib/pgsql/data /etc/planetlab ; do
240         if [ -d $dir.rpmsave -a -d $dir ] ; then
241             echo "Merging $dir"
242             if tar -C $dir.rpmsave -cpf - . | \
243                tar -C $dir -xpf - ; then
244                 rm -rf $dir.rpmsave
245             fi
246         fi
247     done
248 fi
249
250 %preun
251 # 0 = erase, 1 = upgrade
252 if [ $1 -eq 0 ] ; then
253     %{_sysconfdir}/init.d/plc stop
254     systemctl disable plc
255 fi
256
257
258 %files
259 /usr/share/myplc/bashrc
260
261 %files core
262 %defattr(-,root,root,-)
263 /usr/lib/systemd/system/plc.service
264 /usr/bin/plc-ctl
265 /etc/plc.d
266 /etc/planetlab
267 /etc/plc_sliceinitscripts
268 /etc/support-scripts
269 # keep a detailed list, to avoid duplicate of plc-config,
270 # that belongs to the myplc-config rpm
271 /usr/bin/plc-config-tty
272 /usr/bin/db-config
273 /usr/bin/dns-config
274 /usr/bin/refresh-peer.py*
275 /usr/bin/mtail.py*
276 /usr/bin/mtail
277 /usr/bin/plc-map.py*
278 /usr/bin/plc-kml.py*
279 /usr/bin/clean-empty-dirs.py*
280 /usr/bin/plc-check-ssl-peering.py*
281 /usr/bin/plc-orphan-accounts.py*
282 /usr/bin/spot-aliens.py*
283 /usr/bin/check-hrns.py*
284 /usr/bin/check-vsys-defaults.py*
285 /usr/bin/spot-dup-accounts.sh
286
287
288 %files config
289 %defattr(-,root,root,-)
290 /usr/bin/plc-config
291 %{python_sitearch}/plc_config.py*
292
293
294 %changelog
295 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-5.3-5
296 - last version suitable for f27/f29 with python2
297 - packaging is split up, one more rpm named 'myplc-core' is produced,
298 - that covers the infrastructure side only (without bootcds and nodeimages and all node-oriented material)
299 - no more init file, one systemd service only, that leverages new /usr/bin/plc-ctl
300 - more robust config for httpd and php-fpm and php
301
302 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
303 - takes care of creating plcapi log file
304
305 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
306 - tweaked renew_reminder for federation
307
308 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
309 - tweaks in check-hrns.py
310 - do not require PyXML any more
311
312 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
313 - review check-hrns for plcapi-5.3
314 - add PLC_HRN_ROOT in usual plc-config-tty's settings
315
316 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
317 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
318 - add an rpm-sign dependency on feedora>=16
319
320 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
321 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
322
323 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
324 - plc.d/gpg now does not rm /dev/random but preserves it
325 - this is because libvirt won't let us run mknod
326
327 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
328 - fix typo in check-hrns - used to print 'host' while dealing with persons
329
330 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
331 - supports httpd config for either mod_python (preferred) or mod_wsgi
332 - requires mod_wsgi on f18 only, otherwise mod_python
333 - supports httpd config for apache 2.4 (f18)
334 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
335
336 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
337 - bugfix in check-vsys-defaults.py
338
339 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
340 - define open_basedir in php.ini to stop confidentiality leak
341 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
342 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
343 - new utilities check-hrns.py and check-vsys-defaults.py
344
345 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
346 - set TimeoutSec to 300 in plc.service
347 - remove ref to deprecated svn $URL$ in db-config usage
348
349 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
350 - expose mtail.py as simply mtail
351
352 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
353 - plc-kml.py now has support for nodegroups
354
355 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
356 - use nodeimage package instead of deprecated bootstrapfs
357 - has systemd-friendly startup script
358 - plc_reload moved to functions/ - no more service plc reload
359 - no svn keywords anymore
360
361 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
362 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
363
364 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
365 - new settings for myslice (comon&tophat) and monitor (db)
366 - removed mentions of chroot in description
367 - can redo myplc-docs on broken f12-latex
368 - set short_open_tag in php.ini
369 - fixes in gen-sites-xml (is that still used ?)
370 - partial-repo.sh has moved to 'build' where it more belongs
371 - tweaks in convenience tool 'mtail'
372
373 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
374 - fixed changelog, no change from 5.0-16
375
376 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
377 - requires ed for the plc.d/packages step
378 - sirius initscript to handle stop and restart
379
380 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
381 - ignore steps in db-config.d if they have a '.' or '~' in their name
382
383 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
384 - can redo myplc-docs without the doc for monitor
385
386 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
387 - no semantic change - just fixed specfile for git URL
388
389 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
390 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
391
392 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
393 - add missing files to rpm package
394
395 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
396 - mtail.py -s for SFA
397 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
398
399 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
400 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
401
402 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
403 - plc-config-tty now has a validator on booleans
404 - e.g. entering 'True' now is rejected rather than silently recording 'false'
405
406 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
407 - disable mod_wsgi
408
409 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
410 - module name changes
411 - start wsgi support
412
413 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
414 - new setting PLC_RESERVATION_GRANULARITY
415
416 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
417 - * partial-repo.sh script
418 - * preserve key along with certificates
419
420 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
421 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
422
423 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
424 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
425 - new OMF category in the config
426 - create the drl system slice
427
428 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
429 - first working version of 5.0:
430 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
431 - nodefamily is 3-fold with pldistro-fcdistro-arch
432 - new PLC_FLAVOUR config category
433 - reviewed module layout
434 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
435
436 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
437 - support for fedora 12
438 - new package myplc-config for use by sfa
439 - drupal user registration turned off
440
441 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
442 - - fix to make sure when API, BOOT, MONITOR are on the same
443 - machine as WWW that the SSL key,cert for WWW takes precedence.
444 - - Do proper setup for SSL CA certficate to be used as the server
445 - chain.
446
447 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
448 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
449
450 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
451 - depend on pcucontrol
452
453 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
454 - * validate input according to type in plc_config
455 - * added the _genicw system slice
456 - * add tag types for sites and persons
457 - * add new tags for nodes and slices for exemption from myops
458
459 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
460 - turn off drupal on a box that acts as BOOT server but not as WWW server
461 - cleanup some obsolete code for old chroot-jail packaging in the process
462 - new bootcd-kernel script for keeping bootcd variants up2date
463
464 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
465 - Make the /etc/hosts manipulation optional.
466
467 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
468 - Fix SetRole.
469
470 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
471 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
472 - into the DB.
473 - - Added the root ssh key handling support back into plc.d/ssh and the
474 - default xml file.  This should be identical to the way it was in
475 - rc12.
476 - - Added support in the db-config.d/01-init script to register the root
477 - ssh public key with the default administrator.  In this way the root
478 - ssh key will make it into the root account on the nodes by means of
479 - NodeManager's specialaccounts plugin.
480
481 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
482 - db-config ignores sliver tags
483 - sirius's db-config script renamed (was sirious)
484
485 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
486 - fix for silverauth - missing tag types now created at plc startup time
487
488 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
489 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
490
491 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
492 - companion to NM's specialaccounts plugin
493 - do not generate /etc/planetlab/root_ssh_key* anymore
494 - remove related config. variables and conf_files
495
496 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
497 - clarified description text to refer only to plcrt and not other optional
498 - packages.
499
500 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
501 - fixed a bug setting slice multiple attributes with the same tag name
502
503 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
504 - SSL setup for monitor box, and related new config variables
505 - new conf_file for /etc/planetlab/extensions
506 - various tweaks in db-config internals, about initscripts among others
507 - also more messages defined in the db
508
509 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
510 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
511
512 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
513 - bugfix in db-config, tag 4.3-19 would not fly
514
515 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
516 - Refactored db-config into snippets in db-config.d/.
517
518 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
519 - oops, tag 4.3-17 was broken and would not work
520
521 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
522 - bugfix - escape sequences inserted in xml configs
523
524 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
525 - Handle db-config.d files properly.
526
527 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
528 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
529 - than the log file
530 - - Fix db-config to be a bit more cautious when
531 - /etc/planetlab/db-config.d doesn''t exist
532 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
533 - .orig files.
534 - - Refactor generic plc-config-tty code into plc_config.py.
535 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
536 - and the list of validated variables and the corresponding
537 - validator() function. This refactoring lets one reuse plc_config.py
538 - as a generic cmdline configuration tool for highly customer MyPLC
539 - like software.
540
541 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
542 - update PCU Type descriptions.
543 - updates to init scripts
544
545 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
546 - requires monitor-pcucontrol so register-wizard can work
547
548 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
549 - cleaned up plc-config-tty, no more need to configure plc-devel
550
551 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
552 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
553
554 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
555 - fix issue in db-config that prevented correct operation
556
557 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
558 - remove support for chroot-based packaging - no crond nor syslog step anymore
559 - plc init script now named plc.init instead of former guest.init
560
561 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
562 - add Monitor to docs build
563
564 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
565 - plc_config.py and plc-config-tty: generalized to work for more diverse
566 - MyPLC configurations.
567 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
568 - deployments and increase the memory limits in php.ini
569 - plc.d/crond: add --full option to vacuumdb
570
571 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
572 - avoid generating ssl certificates for disabled services among www api boot
573
574 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
575 - cleaned up old entries in db-config
576 - mtail more robust
577
578 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
579 - php include path tweaked for plekit includes
580 - reviewed myplc (fka native) packaging dependencies
581 - renumbered 4.3
582
583 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
584 - rename myplc into myplc-chroot and myplc-native into myplc
585 - new settings (shortname & hrn_root) for local peer
586
587 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
588 - First iteration of new data model
589 - Bunch of various fixes
590
591 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
592 - Removed proper ops from planetflow slice.
593
594 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
595 - myplc-native requires myplc-docs
596 - fixed doc build by locating locally installed DTDs at build-time
597
598 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
599 - turn myplc-docs off for now
600
601 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
602 - figures in doc package
603
604 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
605 - no more doc packaged outside of myplc-docs - doc/ cleaned up
606 - chroot packaging does not have docs anymore
607 - 'cvs' and 'dev' not required from myplc-native anymore
608 - cosmetic change in kml output
609
610 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
611 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
612 - gethostbyname uses python rather than perl (hope this shrinks deps)
613 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
614 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
615 - make sync now works towards vserver-based myplc only
616
617 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
618 -
619 - added vsys 'pfmount' script to the default netflow slice attributes.
620 -
621
622 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
623 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
624 - to new bootcd packaging
625
626 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
627 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
628
629 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
630 - packaging of mplc-release in myplc-native
631 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
632 - resolv file in /etc/resolv.conf, not plc_resolv.conf
633 - improved sirius script
634 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
635 - expires more properly set
636
637 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
638 -
639
640 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
641 - renew_reminder script moved to support-scripts/
642 - gen-aliases script added in support-scripts/
643 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
644 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
645 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
646 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
647 - new setting 'Mom list address' for sending emails to a separate destination
648 - starts rsyslogd/syslogd as appropriate
649 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
650 - convenience generation of yum.conf in resulting image based on build/mirroring
651
652 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
653 - refresh-peer.py removed (duplicate with PLCAPI)
654 - plc.d/ scripts cleaned up
655 - sirius initscript updated
656 - slice auto renewal fixed
657
658 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
659 - initial build.
660
661 %define module_current_branch 4.3