fixes to the service file; + former stub /etc/init.d/plc becomes /usr/bin/plc-ctl
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 #Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 Requires: cronie
56 # starting with f16 we depend on this new rpm
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
58 Requires: rpm-sign
59 %endif
60 # starting with f27 we depend on this new rpm
61 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
62 Requires: php-fpm
63 %endif
64
65 # planetlab stuff
66 Requires: bootmanager
67 Requires: bootcd-%{nodefamily}
68 Requires: bootcd-initscripts
69 Requires: PLCWWW
70 Requires: www-register-wizard
71 Requires: nodeconfig
72 Requires: nodeyum
73 Requires: plcapi >= 5.2
74 # this technically is a plcapi dependency but it's simpler here for chosing which
75 %if "%{distro}" == "Fedora" && %{distrorelease} >= 29
76 Requires: python2-mod_wsgi
77 %else
78 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
79 Requires: mod_wsgi
80 %else
81 Requires: mod_python
82 %endif
83 %endif
84 Requires: nodeimage-%{nodefamily}
85 Requires: myplc-docs
86 Requires: myplc-release
87 Requires: myplc-config
88
89 %define debug_package %{nil}
90
91 %description
92 MyPLC is a complete PlanetLab Central (PLC) portable installation.
93 The default installation consists of a web server, an XML-RPC API
94 server, a boot server, and a database server: the core components of
95 PLC. The installation may be customized through a graphical
96 interface. All PLC services are started up and shut down through a
97 single System V init script.
98
99 ####################### myplc-config
100
101 %package config
102
103 Summary: PlanetLab Central (PLC) configuration python module
104 Group: Applications/Systems
105 Requires: python
106
107 %description config
108 This package provides the Python module to configure MyPLC.
109
110
111 %prep
112 %setup -q
113
114 %build
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 # Install configuration scripts
120 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
121 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
122 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
123
124 echo "* Installing scripts in /usr/bin"
125 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
126 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
127 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
128 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
129
130 # Install initscript
131 echo "* Installing plc initscript"
132 install -D -m 755 systemd/plc-ctl ${RPM_BUILD_ROOT}/usr/bin/plc-ctl
133 install -D -m 644 systemd/plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
134
135 # Install initscripts
136 echo "* Installing plc.d initscripts"
137 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
138 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
139
140 # Install db-config.d files
141 echo "* Installing db-config.d files"
142 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
143 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
144 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
145
146 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
147 echo "* Installing scripts in /etc/support-scripts"
148 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
149 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
150 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
151
152 # copy initscripts to etc/plc_sliceinitscripts
153 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
154 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
155 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
156
157 # Install configuration file
158 echo "* myplc: Installing configuration file"
159 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
160 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
161     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
162 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
163
164 echo "* Installing bashrc convenience"
165 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
166
167 # yumgroups.xml and yum repo : let noderepo handle that
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %pre
173 if [ -x %{_sysconfdir}/init.d/plc ] ; then
174     %{_sysconfdir}/init.d/plc stop
175 fi
176
177 # Old versions of myplc used to ship with a bootstrapped database and
178 # /etc/planetlab directory. Including generated files in the manifest
179 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
180 # names from one RPM build to another, it would be rpmsaved and thus
181 # effectively deleted. Now we do not include these files in the
182 # manifest. However, to avoid deleting these files in the process of
183 # upgrading from one of these old versions of myplc, we must back up
184 # the database and /etc/planetlab and restore them after the old
185 # version has been uninstalled in %triggerpostun (also in %post, in
186 # case we are force upgrading to the same version).
187 #
188 # This code can be removed once all myplc-0.4-1 installations have
189 # been upgraded to at least myplc-0.4-2.
190
191 # 0 = install, 1 = upgrade
192 if [ $1 -gt 0 ] ; then
193     for dir in /var/lib/pgsql/data /etc/planetlab ; do
194         if [ -d $dir ] ; then
195             echo "Preserving $dir"
196             mkdir -p $dir.rpmsave
197             tar -C $dir -cpf - . | \
198                tar -C $dir.rpmsave -xpf -
199
200             # Except for the default configuration file and DTD, which
201             # really should be considered for upgrade.
202             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
203         fi
204     done
205 fi
206
207 %post
208 if [ -x /sbin/chkconfig ] ; then
209     /sbin/chkconfig --add plc
210     /sbin/chkconfig plc on
211 fi
212
213 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
214 systemctl enable php-fpm
215 systemctl start  php-fpm
216 %endif
217
218 %triggerpostun -- %{name}
219 # 0 = erase, 1 = upgrade
220 if [ $1 -gt 0 ] ; then
221     for dir in /var/lib/pgsql/data /etc/planetlab ; do
222         if [ -d $dir.rpmsave -a -d $dir ] ; then
223             echo "Merging $dir"
224             if tar -C $dir.rpmsave -cpf - . | \
225                tar -C $dir -xpf - ; then
226                 rm -rf $dir.rpmsave
227             fi
228         fi
229     done
230 fi
231
232 %preun
233 # 0 = erase, 1 = upgrade
234 if [ $1 -eq 0 ] ; then
235     %{_sysconfdir}/init.d/plc stop
236     if [ -x /sbin/chkconfig ] ; then
237         /sbin/chkconfig plc off
238         /sbin/chkconfig --del plc
239     fi
240 fi
241
242 %files
243 %defattr(-,root,root,-)
244 # Host startup script and configuration file
245 /usr/bin/plc-ctl
246 /etc/plc.d
247 /etc/planetlab
248 /etc/plc_sliceinitscripts
249 /etc/support-scripts
250 /usr/share/myplc/bashrc
251 # keep a detailed list, to avoid duplicate of plc-config,
252 # that belongs to the myplc-config rpm
253 /usr/bin/plc-config-tty
254 /usr/bin/db-config
255 /usr/bin/dns-config
256 /usr/bin/refresh-peer.py*
257 /usr/bin/mtail.py*
258 /usr/bin/mtail
259 /usr/bin/plc-map.py*
260 /usr/bin/plc-kml.py*
261 /usr/bin/clean-empty-dirs.py*
262 /usr/bin/plc-check-ssl-peering.py*
263 /usr/bin/plc-orphan-accounts.py*
264 /usr/bin/spot-aliens.py*
265 /usr/bin/check-hrns.py*
266 /usr/bin/check-vsys-defaults.py*
267 /usr/bin/spot-dup-accounts.sh
268 /usr/lib/systemd/system/plc.service
269
270 %files config
271 %defattr(-,root,root,-)
272 /usr/bin/plc-config
273 %{python_sitearch}/plc_config.py*
274
275
276 %changelog
277 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
278 - takes care of creating plcapi log file
279
280 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
281 - tweaked renew_reminder for federation
282
283 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
284 - tweaks in check-hrns.py
285 - do not require PyXML any more
286
287 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
288 - review check-hrns for plcapi-5.3
289 - add PLC_HRN_ROOT in usual plc-config-tty's settings
290
291 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
292 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
293 - add an rpm-sign dependency on feedora>=16
294
295 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
296 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
297
298 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
299 - plc.d/gpg now does not rm /dev/random but preserves it
300 - this is because libvirt won't let us run mknod
301
302 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
303 - fix typo in check-hrns - used to print 'host' while dealing with persons
304
305 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
306 - supports httpd config for either mod_python (preferred) or mod_wsgi
307 - requires mod_wsgi on f18 only, otherwise mod_python
308 - supports httpd config for apache 2.4 (f18)
309 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
310
311 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
312 - bugfix in check-vsys-defaults.py
313
314 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
315 - define open_basedir in php.ini to stop confidentiality leak
316 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
317 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
318 - new utilities check-hrns.py and check-vsys-defaults.py
319
320 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
321 - set TimeoutSec to 300 in plc.service
322 - remove ref to deprecated svn $URL$ in db-config usage
323
324 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
325 - expose mtail.py as simply mtail
326
327 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
328 - plc-kml.py now has support for nodegroups
329
330 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
331 - use nodeimage package instead of deprecated bootstrapfs
332 - has systemd-friendly startup script
333 - plc_reload moved to functions/ - no more service plc reload
334 - no svn keywords anymore
335
336 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
337 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
338
339 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
340 - new settings for myslice (comon&tophat) and monitor (db)
341 - removed mentions of chroot in description
342 - can redo myplc-docs on broken f12-latex
343 - set short_open_tag in php.ini
344 - fixes in gen-sites-xml (is that still used ?)
345 - partial-repo.sh has moved to 'build' where it more belongs
346 - tweaks in convenience tool 'mtail'
347
348 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
349 - fixed changelog, no change from 5.0-16
350
351 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
352 - requires ed for the plc.d/packages step
353 - sirius initscript to handle stop and restart
354
355 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
356 - ignore steps in db-config.d if they have a '.' or '~' in their name
357
358 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
359 - can redo myplc-docs without the doc for monitor
360
361 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
362 - no semantic change - just fixed specfile for git URL
363
364 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
365 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
366
367 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
368 - add missing files to rpm package
369
370 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
371 - mtail.py -s for SFA
372 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
373
374 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
375 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
376
377 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
378 - plc-config-tty now has a validator on booleans
379 - e.g. entering 'True' now is rejected rather than silently recording 'false'
380
381 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
382 - disable mod_wsgi
383
384 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
385 - module name changes
386 - start wsgi support
387
388 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
389 - new setting PLC_RESERVATION_GRANULARITY
390
391 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
392 - * partial-repo.sh script
393 - * preserve key along with certificates
394
395 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
396 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
397
398 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
399 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
400 - new OMF category in the config
401 - create the drl system slice
402
403 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
404 - first working version of 5.0:
405 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
406 - nodefamily is 3-fold with pldistro-fcdistro-arch
407 - new PLC_FLAVOUR config category
408 - reviewed module layout
409 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
410
411 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
412 - support for fedora 12
413 - new package myplc-config for use by sfa
414 - drupal user registration turned off
415
416 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
417 - - fix to make sure when API, BOOT, MONITOR are on the same
418 - machine as WWW that the SSL key,cert for WWW takes precedence.
419 - - Do proper setup for SSL CA certficate to be used as the server
420 - chain.
421
422 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
423 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
424
425 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
426 - depend on pcucontrol
427
428 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
429 - * validate input according to type in plc_config
430 - * added the _genicw system slice
431 - * add tag types for sites and persons
432 - * add new tags for nodes and slices for exemption from myops
433
434 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
435 - turn off drupal on a box that acts as BOOT server but not as WWW server
436 - cleanup some obsolete code for old chroot-jail packaging in the process
437 - new bootcd-kernel script for keeping bootcd variants up2date
438
439 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
440 - Make the /etc/hosts manipulation optional.
441
442 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
443 - Fix SetRole.
444
445 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
446 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
447 - into the DB.
448 - - Added the root ssh key handling support back into plc.d/ssh and the
449 - default xml file.  This should be identical to the way it was in
450 - rc12.
451 - - Added support in the db-config.d/01-init script to register the root
452 - ssh public key with the default administrator.  In this way the root
453 - ssh key will make it into the root account on the nodes by means of
454 - NodeManager's specialaccounts plugin.
455
456 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
457 - db-config ignores sliver tags
458 - sirius's db-config script renamed (was sirious)
459
460 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
461 - fix for silverauth - missing tag types now created at plc startup time
462
463 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
464 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
465
466 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
467 - companion to NM's specialaccounts plugin
468 - do not generate /etc/planetlab/root_ssh_key* anymore
469 - remove related config. variables and conf_files
470
471 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
472 - clarified description text to refer only to plcrt and not other optional
473 - packages.
474
475 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
476 - fixed a bug setting slice multiple attributes with the same tag name
477
478 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
479 - SSL setup for monitor box, and related new config variables
480 - new conf_file for /etc/planetlab/extensions
481 - various tweaks in db-config internals, about initscripts among others
482 - also more messages defined in the db
483
484 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
485 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
486
487 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
488 - bugfix in db-config, tag 4.3-19 would not fly
489
490 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
491 - Refactored db-config into snippets in db-config.d/.
492
493 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
494 - oops, tag 4.3-17 was broken and would not work
495
496 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
497 - bugfix - escape sequences inserted in xml configs
498
499 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
500 - Handle db-config.d files properly.
501
502 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
503 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
504 - than the log file
505 - - Fix db-config to be a bit more cautious when
506 - /etc/planetlab/db-config.d doesn''t exist
507 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
508 - .orig files.
509 - - Refactor generic plc-config-tty code into plc_config.py.
510 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
511 - and the list of validated variables and the corresponding
512 - validator() function. This refactoring lets one reuse plc_config.py
513 - as a generic cmdline configuration tool for highly customer MyPLC
514 - like software.
515
516 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
517 - update PCU Type descriptions.
518 - updates to init scripts
519
520 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
521 - requires monitor-pcucontrol so register-wizard can work
522
523 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
524 - cleaned up plc-config-tty, no more need to configure plc-devel
525
526 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
527 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
528
529 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
530 - fix issue in db-config that prevented correct operation
531
532 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
533 - remove support for chroot-based packaging - no crond nor syslog step anymore
534 - plc init script now named plc.init instead of former guest.init
535
536 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
537 - add Monitor to docs build
538
539 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
540 - plc_config.py and plc-config-tty: generalized to work for more diverse
541 - MyPLC configurations.
542 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
543 - deployments and increase the memory limits in php.ini
544 - plc.d/crond: add --full option to vacuumdb
545
546 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
547 - avoid generating ssl certificates for disabled services among www api boot
548
549 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
550 - cleaned up old entries in db-config
551 - mtail more robust
552
553 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
554 - php include path tweaked for plekit includes
555 - reviewed myplc (fka native) packaging dependencies
556 - renumbered 4.3
557
558 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
559 - rename myplc into myplc-chroot and myplc-native into myplc
560 - new settings (shortname & hrn_root) for local peer
561
562 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
563 - First iteration of new data model
564 - Bunch of various fixes
565
566 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
567 - Removed proper ops from planetflow slice.
568
569 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
570 - myplc-native requires myplc-docs
571 - fixed doc build by locating locally installed DTDs at build-time
572
573 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
574 - turn myplc-docs off for now
575
576 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
577 - figures in doc package
578
579 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
580 - no more doc packaged outside of myplc-docs - doc/ cleaned up
581 - chroot packaging does not have docs anymore
582 - 'cvs' and 'dev' not required from myplc-native anymore
583 - cosmetic change in kml output
584
585 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
586 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
587 - gethostbyname uses python rather than perl (hope this shrinks deps)
588 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
589 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
590 - make sync now works towards vserver-based myplc only
591
592 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
593 -
594 - added vsys 'pfmount' script to the default netflow slice attributes.
595 -
596
597 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
598 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
599 - to new bootcd packaging
600
601 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
602 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
603
604 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
605 - packaging of mplc-release in myplc-native
606 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
607 - resolv file in /etc/resolv.conf, not plc_resolv.conf
608 - improved sirius script
609 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
610 - expires more properly set
611
612 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
613 -
614
615 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
616 - renew_reminder script moved to support-scripts/
617 - gen-aliases script added in support-scripts/
618 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
619 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
620 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
621 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
622 - new setting 'Mom list address' for sending emails to a separate destination
623 - starts rsyslogd/syslogd as appropriate
624 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
625 - convenience generation of yum.conf in resulting image based on build/mirroring
626
627 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
628 - refresh-peer.py removed (duplicate with PLCAPI)
629 - plc.d/ scripts cleaned up
630 - sirius initscript updated
631 - slice auto renewal fixed
632
633 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
634 - initial build.
635
636 %define module_current_branch 4.3