Setting tag myplc-5.2-5
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.2
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 Requires: cronie
56 # starting with f16 we depend on this new rpm
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
58 Requires: rpm-sign
59 %endif
60
61 # planetlab stuff
62 Requires: bootmanager
63 Requires: bootcd-%{nodefamily}
64 Requires: bootcd-initscripts
65 Requires: PLCWWW
66 Requires: www-register-wizard
67 Requires: nodeconfig
68 Requires: nodeyum
69 Requires: plcapi >= 5.2
70 # this technically is a plcapi dependency but it's simpler here for chosing which
71 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
72 Requires: mod_wsgi
73 %else
74 Requires: mod_python
75 %endif
76 Requires: nodeimage-%{nodefamily}
77 Requires: myplc-docs
78 Requires: myplc-release
79 Requires: myplc-config
80
81 %define debug_package %{nil}
82
83 %description 
84 MyPLC is a complete PlanetLab Central (PLC) portable installation.
85 The default installation consists of a web server, an XML-RPC API
86 server, a boot server, and a database server: the core components of
87 PLC. The installation may be customized through a graphical
88 interface. All PLC services are started up and shut down through a
89 single System V init script.
90
91 ####################### myplc-config
92
93 %package config
94
95 Summary: PlanetLab Central (PLC) configuration python module
96 Group: Applications/Systems
97 Requires: python
98
99 %description config
100 This package provides the Python module to configure MyPLC.
101
102
103 %prep
104 %setup -q
105
106 %build
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 # Install configuration scripts
112 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
113 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
114 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
115
116 echo "* Installing scripts in /usr/bin"
117 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
118 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
119 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
120 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
121
122 # Install initscript 
123 echo "* Installing plc initscript"
124 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
125 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
126
127 # Install initscripts
128 echo "* Installing plc.d initscripts"
129 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
130 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
131
132 # Install db-config.d files
133 echo "* Installing db-config.d files"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
136 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
137
138 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
139 echo "* Installing scripts in /etc/support-scripts"
140 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
141 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
142 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
143
144 # copy initscripts to etc/plc_sliceinitscripts
145 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
146 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
147 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
148
149 # Install configuration file
150 echo "* myplc: Installing configuration file"
151 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
152 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
153     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
154 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
155
156 echo "* Installing bashrc convenience"
157 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
158
159 # yumgroups.xml and yum repo : let noderepo handle that
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %pre
165 if [ -x %{_sysconfdir}/init.d/plc ] ; then
166     %{_sysconfdir}/init.d/plc stop
167 fi
168
169 # Old versions of myplc used to ship with a bootstrapped database and
170 # /etc/planetlab directory. Including generated files in the manifest
171 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
172 # names from one RPM build to another, it would be rpmsaved and thus
173 # effectively deleted. Now we do not include these files in the
174 # manifest. However, to avoid deleting these files in the process of
175 # upgrading from one of these old versions of myplc, we must back up
176 # the database and /etc/planetlab and restore them after the old
177 # version has been uninstalled in %triggerpostun (also in %post, in
178 # case we are force upgrading to the same version).
179 #
180 # This code can be removed once all myplc-0.4-1 installations have
181 # been upgraded to at least myplc-0.4-2.
182
183 # 0 = install, 1 = upgrade
184 if [ $1 -gt 0 ] ; then
185     for dir in /var/lib/pgsql/data /etc/planetlab ; do
186         if [ -d $dir ] ; then
187             echo "Preserving $dir"
188             mkdir -p $dir.rpmsave
189             tar -C $dir -cpf - . | \
190                tar -C $dir.rpmsave -xpf -
191
192             # Except for the default configuration file and DTD, which
193             # really should be considered for upgrade.
194             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
195         fi
196     done
197 fi
198
199 %post
200 if [ -x /sbin/chkconfig ] ; then
201     /sbin/chkconfig --add plc
202     /sbin/chkconfig plc on
203 fi
204
205 %triggerpostun -- %{name}
206 # 0 = erase, 1 = upgrade
207 if [ $1 -gt 0 ] ; then
208     for dir in /var/lib/pgsql/data /etc/planetlab ; do
209         if [ -d $dir.rpmsave -a -d $dir ] ; then
210             echo "Merging $dir"
211             if tar -C $dir.rpmsave -cpf - . | \
212                tar -C $dir -xpf - ; then
213                 rm -rf $dir.rpmsave
214             fi
215         fi
216     done
217 fi    
218
219 %preun
220 # 0 = erase, 1 = upgrade
221 if [ $1 -eq 0 ] ; then
222     %{_sysconfdir}/init.d/plc stop
223     if [ -x /sbin/chkconfig ] ; then
224         /sbin/chkconfig plc off
225         /sbin/chkconfig --del plc
226     fi
227 fi
228
229 %files
230 %defattr(-,root,root,-)
231 # Host startup script and configuration file
232 /etc/init.d/plc
233 /etc/plc.d
234 /etc/planetlab
235 /etc/plc_sliceinitscripts
236 /etc/support-scripts
237 /usr/share/myplc/bashrc
238 # keep a detailed list, to avoid duplicate of plc-config,
239 # that belongs to the myplc-config rpm
240 /usr/bin/plc-config-tty
241 /usr/bin/db-config
242 /usr/bin/dns-config
243 /usr/bin/refresh-peer.py*
244 /usr/bin/mtail.py*
245 /usr/bin/mtail
246 /usr/bin/plc-map.py*
247 /usr/bin/plc-kml.py*
248 /usr/bin/clean-empty-dirs.py*
249 /usr/bin/plc-check-ssl-peering.py*
250 /usr/bin/plc-orphan-accounts.py*
251 /usr/bin/spot-aliens.py*
252 /usr/bin/check-hrns.py*
253 /usr/bin/check-vsys-defaults.py*
254 /usr/bin/spot-dup-accounts.sh
255 /lib/systemd/system/plc.service
256
257 %files config
258 %defattr(-,root,root,-)
259 /usr/bin/plc-config
260 %{python_sitearch}/plc_config.py*
261
262
263 %changelog
264 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
265 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
266 - add an rpm-sign dependency on feedora>=16
267
268 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
269 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
270
271 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
272 - plc.d/gpg now does not rm /dev/random but preserves it
273 - this is because libvirt won't let us run mknod
274
275 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
276 - fix typo in check-hrns - used to print 'host' while dealing with persons
277
278 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
279 - supports httpd config for either mod_python (preferred) or mod_wsgi
280 - requires mod_wsgi on f18 only, otherwise mod_python
281 - supports httpd config for apache 2.4 (f18)
282 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
283
284 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
285 - bugfix in check-vsys-defaults.py
286
287 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
288 - define open_basedir in php.ini to stop confidentiality leak
289 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
290 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
291 - new utilities check-hrns.py and check-vsys-defaults.py
292
293 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
294 - set TimeoutSec to 300 in plc.service
295 - remove ref to deprecated svn $URL$ in db-config usage
296
297 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
298 - expose mtail.py as simply mtail
299
300 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
301 - plc-kml.py now has support for nodegroups
302
303 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
304 - use nodeimage package instead of deprecated bootstrapfs
305 - has systemd-friendly startup script
306 - plc_reload moved to functions/ - no more service plc reload
307 - no svn keywords anymore
308
309 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
310 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
311
312 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
313 - new settings for myslice (comon&tophat) and monitor (db)
314 - removed mentions of chroot in description
315 - can redo myplc-docs on broken f12-latex
316 - set short_open_tag in php.ini
317 - fixes in gen-sites-xml (is that still used ?)
318 - partial-repo.sh has moved to 'build' where it more belongs
319 - tweaks in convenience tool 'mtail'
320
321 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
322 - fixed changelog, no change from 5.0-16
323
324 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
325 - requires ed for the plc.d/packages step
326 - sirius initscript to handle stop and restart
327
328 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
329 - ignore steps in db-config.d if they have a '.' or '~' in their name
330
331 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
332 - can redo myplc-docs without the doc for monitor
333
334 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
335 - no semantic change - just fixed specfile for git URL
336
337 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
338 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
339
340 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
341 - add missing files to rpm package
342
343 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
344 - mtail.py -s for SFA
345 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
346
347 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
348 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
349
350 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
351 - plc-config-tty now has a validator on booleans
352 - e.g. entering 'True' now is rejected rather than silently recording 'false'
353
354 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
355 - disable mod_wsgi
356
357 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
358 - module name changes
359 - start wsgi support
360
361 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
362 - new setting PLC_RESERVATION_GRANULARITY
363
364 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
365 - * partial-repo.sh script
366 - * preserve key along with certificates
367
368 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
369 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
370
371 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
372 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
373 - new OMF category in the config
374 - create the drl system slice
375
376 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
377 - first working version of 5.0:
378 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
379 - nodefamily is 3-fold with pldistro-fcdistro-arch
380 - new PLC_FLAVOUR config category
381 - reviewed module layout
382 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
383
384 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
385 - support for fedora 12
386 - new package myplc-config for use by sfa
387 - drupal user registration turned off
388
389 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
390 - - fix to make sure when API, BOOT, MONITOR are on the same
391 - machine as WWW that the SSL key,cert for WWW takes precedence.
392 - - Do proper setup for SSL CA certficate to be used as the server
393 - chain.
394
395 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
396 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
397
398 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
399 - depend on pcucontrol
400
401 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
402 - * validate input according to type in plc_config
403 - * added the _genicw system slice
404 - * add tag types for sites and persons
405 - * add new tags for nodes and slices for exemption from myops
406
407 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
408 - turn off drupal on a box that acts as BOOT server but not as WWW server
409 - cleanup some obsolete code for old chroot-jail packaging in the process
410 - new bootcd-kernel script for keeping bootcd variants up2date
411
412 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
413 - Make the /etc/hosts manipulation optional.
414
415 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
416 - Fix SetRole.
417
418 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
419 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
420 - into the DB.
421 - - Added the root ssh key handling support back into plc.d/ssh and the
422 - default xml file.  This should be identical to the way it was in
423 - rc12.
424 - - Added support in the db-config.d/01-init script to register the root
425 - ssh public key with the default administrator.  In this way the root
426 - ssh key will make it into the root account on the nodes by means of
427 - NodeManager's specialaccounts plugin.
428
429 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
430 - db-config ignores sliver tags
431 - sirius's db-config script renamed (was sirious)
432
433 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
434 - fix for silverauth - missing tag types now created at plc startup time
435
436 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
437 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
438
439 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
440 - companion to NM's specialaccounts plugin
441 - do not generate /etc/planetlab/root_ssh_key* anymore
442 - remove related config. variables and conf_files
443
444 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
445 - clarified description text to refer only to plcrt and not other optional
446 - packages.
447
448 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
449 - fixed a bug setting slice multiple attributes with the same tag name
450
451 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
452 - SSL setup for monitor box, and related new config variables
453 - new conf_file for /etc/planetlab/extensions
454 - various tweaks in db-config internals, about initscripts among others
455 - also more messages defined in the db
456
457 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
458 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
459
460 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
461 - bugfix in db-config, tag 4.3-19 would not fly
462
463 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
464 - Refactored db-config into snippets in db-config.d/.
465
466 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
467 - oops, tag 4.3-17 was broken and would not work
468
469 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
470 - bugfix - escape sequences inserted in xml configs
471
472 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
473 - Handle db-config.d files properly.
474
475 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
476 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
477 - than the log file
478 - - Fix db-config to be a bit more cautious when
479 - /etc/planetlab/db-config.d doesn''t exist
480 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
481 - .orig files.
482 - - Refactor generic plc-config-tty code into plc_config.py.
483 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
484 - and the list of validated variables and the corresponding
485 - validator() function. This refactoring lets one reuse plc_config.py
486 - as a generic cmdline configuration tool for highly customer MyPLC
487 - like software.
488
489 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
490 - update PCU Type descriptions.
491 - updates to init scripts
492
493 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
494 - requires monitor-pcucontrol so register-wizard can work
495
496 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
497 - cleaned up plc-config-tty, no more need to configure plc-devel
498
499 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
500 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
501
502 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
503 - fix issue in db-config that prevented correct operation
504
505 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
506 - remove support for chroot-based packaging - no crond nor syslog step anymore
507 - plc init script now named plc.init instead of former guest.init
508
509 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
510 - add Monitor to docs build
511
512 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
513 - plc_config.py and plc-config-tty: generalized to work for more diverse
514 - MyPLC configurations.
515 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
516 - deployments and increase the memory limits in php.ini
517 - plc.d/crond: add --full option to vacuumdb
518
519 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
520 - avoid generating ssl certificates for disabled services among www api boot
521
522 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
523 - cleaned up old entries in db-config
524 - mtail more robust
525
526 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
527 - php include path tweaked for plekit includes
528 - reviewed myplc (fka native) packaging dependencies
529 - renumbered 4.3
530
531 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
532 - rename myplc into myplc-chroot and myplc-native into myplc
533 - new settings (shortname & hrn_root) for local peer
534
535 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
536 - First iteration of new data model
537 - Bunch of various fixes
538
539 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
540 - Removed proper ops from planetflow slice.
541
542 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
543 - myplc-native requires myplc-docs
544 - fixed doc build by locating locally installed DTDs at build-time
545
546 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
547 - turn myplc-docs off for now
548
549 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
550 - figures in doc package
551
552 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
553 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
554 - chroot packaging does not have docs anymore
555 - 'cvs' and 'dev' not required from myplc-native anymore
556 - cosmetic change in kml output
557
558 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
559 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
560 - gethostbyname uses python rather than perl (hope this shrinks deps) 
561 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
562 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
563 - make sync now works towards vserver-based myplc only 
564
565 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
566
567 - added vsys 'pfmount' script to the default netflow slice attributes.
568
569
570 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
571 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
572 - to new bootcd packaging
573
574 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
575 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
576
577 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
578 - packaging of mplc-release in myplc-native
579 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
580 - resolv file in /etc/resolv.conf, not plc_resolv.conf
581 - improved sirius script
582 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
583 - expires more properly set 
584
585 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
586
587
588 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
589 - renew_reminder script moved to support-scripts/
590 - gen-aliases script added in support-scripts/
591 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
592 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
593 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
594 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
595 - new setting 'Mom list address' for sending emails to a separate destination
596 - starts rsyslogd/syslogd as appropriate
597 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
598 - convenience generation of yum.conf in resulting image based on build/mirroring
599
600 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
601 - refresh-peer.py removed (duplicate with PLCAPI)
602 - plc.d/ scripts cleaned up
603 - sirius initscript updated
604 - slice auto renewal fixed
605
606 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
607 - initial build.
608
609 %define module_current_branch 4.3