Merge branch '4.3' of git.verivue.com:/git/planetlab/myplc into origin-4.3
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 49
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: PLCWWW
67 Requires: nodeconfig
68 Requires: PLCAPI
69 Requires: pcucontrol
70 Requires: bootstrapfs-%{pldistro}-%{_arch}
71 Requires: myplc-docs
72 Requires: myplc-release
73 Requires: myplc-config
74
75 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
76 %if "%{pldistro}" == "onelab"
77 Requires: dummynet_image
78 %endif
79
80 %define debug_package %{nil}
81
82 %description
83 MyPLC is a complete PlanetLab Central (PLC) portable installation
84 contained within a chroot jail. The default installation consists of a
85 web server, an XML-RPC API server, a boot server, and a database
86 server: the core components of PLC. The installation may be customized
87 through a graphical interface. All PLC services are started up and
88 shut down through a single System V init script installed in the host
89 system.
90
91 ####################### myplc-config
92
93 %package config
94
95 Summary: PlanetLab Central (PLC) configuration python module
96 Group: Applications/Systems
97 Requires: python
98
99 %description config
100 This package provides the Python module to configure MyPLC.
101
102
103 %prep
104 %setup -q
105
106 %build
107
108 %install
109 [ -d MyPLC] || ln -s myplc MyPLC
110 pushd MyPLC
111 rm -rf $RPM_BUILD_ROOT
112 ./build.sh %{pldistro} $RPM_BUILD_ROOT
113 popd
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 # If run under sudo
119 if [ -n "$SUDO_USER" ] ; then
120     # Allow user to delete the build directory
121     chown -h -R $SUDO_USER .
122     # Some temporary cdroot files like /var/empty/sshd and
123     # /usr/bin/sudo get created with non-readable permissions.
124     find . -not -perm +0600 -exec chmod u+rw {} \;
125     # Allow user to delete the built RPM(s)
126     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
127 fi
128
129 %pre
130 if [ -x %{_sysconfdir}/init.d/plc ] ; then
131     %{_sysconfdir}/init.d/plc stop
132 fi
133
134 # Old versions of myplc used to ship with a bootstrapped database and
135 # /etc/planetlab directory. Including generated files in the manifest
136 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
137 # names from one RPM build to another, it would be rpmsaved and thus
138 # effectively deleted. Now we do not include these files in the
139 # manifest. However, to avoid deleting these files in the process of
140 # upgrading from one of these old versions of myplc, we must back up
141 # the database and /etc/planetlab and restore them after the old
142 # version has been uninstalled in %triggerpostun (also in %post, in
143 # case we are force upgrading to the same version).
144 #
145 # This code can be removed once all myplc-0.4-1 installations have
146 # been upgraded to at least myplc-0.4-2.
147
148 # 0 = install, 1 = upgrade
149 if [ $1 -gt 0 ] ; then
150     for dir in /var/lib/pgsql/data /etc/planetlab ; do
151         if [ -d $dir ] ; then
152             echo "Preserving $dir"
153             mkdir -p $dir.rpmsave
154             tar -C $dir -cpf - . | \
155                tar -C $dir.rpmsave -xpf -
156
157             # Except for the default configuration file and DTD, which
158             # really should be considered for upgrade.
159             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
160         fi
161     done
162 fi
163
164 %post
165 if [ -x /sbin/chkconfig ] ; then
166     /sbin/chkconfig --add plc
167     /sbin/chkconfig plc on
168 fi
169
170 %triggerpostun -- %{name}
171 # 0 = erase, 1 = upgrade
172 if [ $1 -gt 0 ] ; then
173     for dir in /var/lib/pgsql/data /etc/planetlab ; do
174         if [ -d $dir.rpmsave -a -d $dir ] ; then
175             echo "Merging $dir"
176             if tar -C $dir.rpmsave -cpf - . | \
177                tar -C $dir -xpf - ; then
178                 rm -rf $dir.rpmsave
179             fi
180         fi
181     done
182 fi    
183
184 %preun
185 # 0 = erase, 1 = upgrade
186 if [ $1 -eq 0 ] ; then
187     %{_sysconfdir}/init.d/plc stop
188     if [ -x /sbin/chkconfig ] ; then
189         /sbin/chkconfig plc off
190         /sbin/chkconfig --del plc
191     fi
192 fi
193
194 %files
195 %defattr(-,root,root,-)
196 # Host startup script and configuration file
197 /etc/init.d/plc
198 /etc/plc.d
199 /etc/planetlab
200 /etc/plc_sliceinitscripts/sirius
201 /etc/support-scripts/gen_aliases.py*
202 /etc/support-scripts/renew_reminder.py*
203 /etc/support-scripts/renew_reminder_logrotate
204 /usr/bin/plc-config-tty
205 /usr/bin/db-config
206 /usr/bin/dns-config
207 /usr/bin/plc-map.py*
208 /usr/bin/plc-kml.py*
209 /usr/bin/refresh-peer.py*
210 /usr/bin/clean-empty-dirs.py*
211 /usr/bin/mtail.py*
212 /usr/bin/plc-check-ssl-peering.py*
213 /usr/bin/plc-orphan-accounts.py*
214 /usr/share/myplc/bashrc
215
216 %files config
217 %defattr(-,root,root,-)
218 /usr/bin/plc-config
219 %{python_sitearch}/plc_config.py*
220
221
222 %changelog
223 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
224 - Remove Monitor references from spec file
225
226 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
227 - Introduce staticroute tagtype
228
229 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
230 - attempt to fix small glitches
231
232 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
233 - enable short_open_tag for backward compatibility
234
235 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
236 - Cherry-pick PHP5 timezone fix form master
237
238 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
239 - pick the greatest version as a kernel
240
241 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
242 - handle directory name changes for myplc-docs package as well
243
244 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
245 - handle directory name changes
246
247 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
248 - Use correct resolv.conf file.
249
250 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
251 - Make dnsmasq usable.
252
253 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
254 - Allow dnsmasq configuration to be extended.
255
256 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
257 - Add DRL slice.
258 - Generalize bootcd-kernel.
259
260 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
261 - support for fedora 12
262 - new package myplc-config for use by sfa
263 - drupal user registration turned off
264
265 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
266 - - fix to make sure when API, BOOT, MONITOR are on the same
267 - machine as WWW that the SSL key,cert for WWW takes precedence.
268 - - Do proper setup for SSL CA certficate to be used as the server
269 - chain.
270
271 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
272 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
273
274 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
275 - depend on pcucontrol
276
277 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
278 - * validate input according to type in plc_config
279 - * added the _genicw system slice
280 - * add tag types for sites and persons
281 - * add new tags for nodes and slices for exemption from myops
282
283 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
284 - turn off drupal on a box that acts as BOOT server but not as WWW server
285 - cleanup some obsolete code for old chroot-jail packaging in the process
286 - new bootcd-kernel script for keeping bootcd variants up2date
287
288 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
289 - Make the /etc/hosts manipulation optional.
290
291 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
292 - Fix SetRole.
293
294 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
295 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
296 - into the DB.
297 - - Added the root ssh key handling support back into plc.d/ssh and the
298 - default xml file.  This should be identical to the way it was in
299 - rc12.
300 - - Added support in the db-config.d/01-init script to register the root
301 - ssh public key with the default administrator.  In this way the root
302 - ssh key will make it into the root account on the nodes by means of
303 - NodeManager's specialaccounts plugin.
304
305 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
306 - db-config ignores sliver tags
307 - sirius's db-config script renamed (was sirious)
308
309 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
310 - fix for silverauth - missing tag types now created at plc startup time
311
312 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
313 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
314
315 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
316 - companion to NM's specialaccounts plugin
317 - do not generate /etc/planetlab/root_ssh_key* anymore
318 - remove related config. variables and conf_files
319
320 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
321 - clarified description text to refer only to plcrt and not other optional
322 - packages.
323
324 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
325 - fixed a bug setting slice multiple attributes with the same tag name
326
327 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
328 - SSL setup for monitor box, and related new config variables
329 - new conf_file for /etc/planetlab/extensions
330 - various tweaks in db-config internals, about initscripts among others
331 - also more messages defined in the db
332
333 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
334 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
335
336 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
337 - bugfix in db-config, tag 4.3-19 would not fly
338
339 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
340 - Refactored db-config into snippets in db-config.d/.
341
342 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
343 - oops, tag 4.3-17 was broken and would not work
344
345 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
346 - bugfix - escape sequences inserted in xml configs
347
348 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
349 - Handle db-config.d files properly.
350
351 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
352 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
353 - than the log file
354 - - Fix db-config to be a bit more cautious when
355 - /etc/planetlab/db-config.d doesn't exist
356 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
357 - .orig files.
358 - - Refactor generic plc-config-tty code into plc_config.py.
359 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
360 - and the list of validated variables and the corresponding
361 - validator() function. This refactoring lets one reuse plc_config.py
362 - as a generic cmdline configuration tool for highly customer MyPLC
363 - like software.
364
365 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
366 - update PCU Type descriptions.
367 - updates to init scripts
368
369 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
370 - requires monitor-pcucontrol so register-wizard can work
371
372 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
373 - cleaned up plc-config-tty, no more need to configure plc-devel
374
375 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
376 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
377
378 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
379 - fix issue in db-config that prevented correct operation
380
381 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
382 - remove support for chroot-based packaging - no crond nor syslog step anymore
383 - plc init script now named plc.init instead of former guest.init
384
385 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
386 - add Monitor to docs build
387
388 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
389 - plc_config.py and plc-config-tty: generalized to work for more diverse
390 - MyPLC configurations.
391 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
392 - deployments and increase the memory limits in php.ini
393 - plc.d/crond: add --full option to vacuumdb
394
395 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
396 - avoid generating ssl certificates for disabled services among www api boot
397
398 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
399 - cleaned up old entries in db-config
400 - mtail more robust
401
402 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
403 - php include path tweaked for plekit includes
404 - reviewed myplc (fka native) packaging dependencies
405 - renumbered 4.3
406
407 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
408 - rename myplc into myplc-chroot and myplc-native into myplc
409 - new settings (shortname & hrn_root) for local peer
410
411 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
412 - First iteration of new data model
413 - Bunch of various fixes
414
415 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
416 - Removed proper ops from planetflow slice.
417
418 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
419 - myplc-native requires myplc-docs
420 - fixed doc build by locating locally installed DTDs at build-time
421
422 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
423 - turn myplc-docs off for now
424
425 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
426 - figures in doc package
427
428 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
429 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
430 - chroot packaging does not have docs anymore
431 - 'cvs' and 'dev' not required from myplc-native anymore
432 - cosmetic change in kml output
433
434 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
435 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
436 - gethostbyname uses python rather than perl (hope this shrinks deps) 
437 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
438 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
439 - make sync now works towards vserver-based myplc only 
440
441 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
442
443 - added vsys 'pfmount' script to the default netflow slice attributes.
444
445
446 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
447 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
448 - to new bootcd packaging
449
450 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
451 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
452
453 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
454 - packaging of mplc-release in myplc-native
455 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
456 - resolv file in /etc/resolv.conf, not plc_resolv.conf
457 - improved sirius script
458 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
459 - expires more properly set 
460
461 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
462
463
464 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
465 - renew_reminder script moved to support-scripts/
466 - gen-aliases script added in support-scripts/
467 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
468 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
469 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
470 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
471 - new setting 'Mom list address' for sending emails to a separate destination
472 - starts rsyslogd/syslogd as appropriate
473 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
474 - convenience generation of yum.conf in resulting image based on build/mirroring
475
476 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
477 - refresh-peer.py removed (duplicate with PLCAPI)
478 - plc.d/ scripts cleaned up
479 - sirius initscript updated
480 - slice auto renewal fixed
481
482 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
483 - initial build.
484
485 %define module_current_branch 4.2