Merge remote branch 'origin/4.3' into 4.3
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 48
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: redhat-lsb
34 Requires: bzip2
35 Requires: tar 
36 Requires: less
37 Requires: sendmail
38 Requires: sendmail-cf
39 Requires: openssl
40 Requires: expect
41 Requires: php-pgsql
42 Requires: curl
43 Requires: rsync
44 Requires: python-devel
45 Requires: yum
46 Requires: PyXML
47 Requires: createrepo
48 Requires: cpio
49 Requires: wget
50 Requires: php
51 Requires: openssh
52 Requires: dnsmasq
53 Requires: diffutils
54 Requires: gzip
55 Requires: vim-minimal
56 Requires: findutils
57 Requires: xmlsec1
58 Requires: xmlsec1-openssl
59 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
60 Requires: cronie
61 %else
62 Requires: vixie-cron
63 %endif
64 # planetlab stuff
65 Requires: bootmanager
66 Requires: bootcd-%{pldistro}-%{_arch}
67 Requires: PLCWWW
68 Requires: www-register-wizard
69 Requires: nodeconfig
70 Requires: PLCAPI
71 Requires: pcucontrol
72 Requires: bootstrapfs-%{pldistro}-%{_arch}
73 Requires: myplc-docs
74 Requires: myplc-release
75 Requires: myplc-config
76
77 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
78 %if "%{pldistro}" == "onelab"
79 Requires: dummynet_image
80 %endif
81
82 %define debug_package %{nil}
83
84 %description
85 MyPLC is a complete PlanetLab Central (PLC) portable installation
86 contained within a chroot jail. The default installation consists of a
87 web server, an XML-RPC API server, a boot server, and a database
88 server: the core components of PLC. The installation may be customized
89 through a graphical interface. All PLC services are started up and
90 shut down through a single System V init script installed in the host
91 system.
92
93 ####################### myplc-config
94
95 %package config
96
97 Summary: PlanetLab Central (PLC) configuration python module
98 Group: Applications/Systems
99 Requires: python
100
101 %description config
102 This package provides the Python module to configure MyPLC.
103
104
105 %prep
106 %setup -q
107
108 %build
109
110 %install
111 [ -d MyPLC] || ln -s myplc MyPLC
112 pushd MyPLC
113 rm -rf $RPM_BUILD_ROOT
114 ./build.sh %{pldistro} $RPM_BUILD_ROOT
115 popd
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 # If run under sudo
121 if [ -n "$SUDO_USER" ] ; then
122     # Allow user to delete the build directory
123     chown -h -R $SUDO_USER .
124     # Some temporary cdroot files like /var/empty/sshd and
125     # /usr/bin/sudo get created with non-readable permissions.
126     find . -not -perm +0600 -exec chmod u+rw {} \;
127     # Allow user to delete the built RPM(s)
128     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
129 fi
130
131 %pre
132 if [ -x %{_sysconfdir}/init.d/plc ] ; then
133     %{_sysconfdir}/init.d/plc stop
134 fi
135
136 # Old versions of myplc used to ship with a bootstrapped database and
137 # /etc/planetlab directory. Including generated files in the manifest
138 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
139 # names from one RPM build to another, it would be rpmsaved and thus
140 # effectively deleted. Now we do not include these files in the
141 # manifest. However, to avoid deleting these files in the process of
142 # upgrading from one of these old versions of myplc, we must back up
143 # the database and /etc/planetlab and restore them after the old
144 # version has been uninstalled in %triggerpostun (also in %post, in
145 # case we are force upgrading to the same version).
146 #
147 # This code can be removed once all myplc-0.4-1 installations have
148 # been upgraded to at least myplc-0.4-2.
149
150 # 0 = install, 1 = upgrade
151 if [ $1 -gt 0 ] ; then
152     for dir in /var/lib/pgsql/data /etc/planetlab ; do
153         if [ -d $dir ] ; then
154             echo "Preserving $dir"
155             mkdir -p $dir.rpmsave
156             tar -C $dir -cpf - . | \
157                tar -C $dir.rpmsave -xpf -
158
159             # Except for the default configuration file and DTD, which
160             # really should be considered for upgrade.
161             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
162         fi
163     done
164 fi
165
166 %post
167 if [ -x /sbin/chkconfig ] ; then
168     /sbin/chkconfig --add plc
169     /sbin/chkconfig plc on
170 fi
171
172 %triggerpostun -- %{name}
173 # 0 = erase, 1 = upgrade
174 if [ $1 -gt 0 ] ; then
175     for dir in /var/lib/pgsql/data /etc/planetlab ; do
176         if [ -d $dir.rpmsave -a -d $dir ] ; then
177             echo "Merging $dir"
178             if tar -C $dir.rpmsave -cpf - . | \
179                tar -C $dir -xpf - ; then
180                 rm -rf $dir.rpmsave
181             fi
182         fi
183     done
184 fi    
185
186 %preun
187 # 0 = erase, 1 = upgrade
188 if [ $1 -eq 0 ] ; then
189     %{_sysconfdir}/init.d/plc stop
190     if [ -x /sbin/chkconfig ] ; then
191         /sbin/chkconfig plc off
192         /sbin/chkconfig --del plc
193     fi
194 fi
195
196 %files
197 %defattr(-,root,root,-)
198 # Host startup script and configuration file
199 /etc/init.d/plc
200 /etc/plc.d
201 /etc/planetlab
202 /etc/plc_sliceinitscripts/sirius
203 /etc/support-scripts/gen_aliases.py*
204 /etc/support-scripts/renew_reminder.py*
205 /etc/support-scripts/renew_reminder_logrotate
206 /usr/bin/plc-config-tty
207 /usr/bin/db-config
208 /usr/bin/dns-config
209 /usr/bin/plc-map.py*
210 /usr/bin/plc-kml.py*
211 /usr/bin/refresh-peer.py*
212 /usr/bin/clean-empty-dirs.py*
213 /usr/bin/mtail.py*
214 /usr/bin/plc-check-ssl-peering.py*
215 /usr/bin/plc-orphan-accounts.py*
216 /usr/share/myplc/bashrc
217
218 %files config
219 %defattr(-,root,root,-)
220 /usr/bin/plc-config
221 %{python_sitearch}/plc_config.py*
222
223
224 %changelog
225 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
226 - Introduce staticroute tagtype
227
228 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
229 - attempt to fix small glitches
230
231 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
232 - enable short_open_tag for backward compatibility
233
234 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
235 - Cherry-pick PHP5 timezone fix form master
236
237 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
238 - pick the greatest version as a kernel
239
240 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
241 - handle directory name changes for myplc-docs package as well
242
243 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
244 - handle directory name changes
245
246 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
247 - Use correct resolv.conf file.
248
249 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
250 - Make dnsmasq usable.
251
252 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
253 - Allow dnsmasq configuration to be extended.
254
255 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
256 - Add DRL slice.
257 - Generalize bootcd-kernel.
258
259 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
260 - support for fedora 12
261 - new package myplc-config for use by sfa
262 - drupal user registration turned off
263
264 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
265 - - fix to make sure when API, BOOT, MONITOR are on the same
266 - machine as WWW that the SSL key,cert for WWW takes precedence.
267 - - Do proper setup for SSL CA certficate to be used as the server
268 - chain.
269
270 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
271 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
272
273 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
274 - depend on pcucontrol
275
276 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
277 - * validate input according to type in plc_config
278 - * added the _genicw system slice
279 - * add tag types for sites and persons
280 - * add new tags for nodes and slices for exemption from myops
281
282 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
283 - turn off drupal on a box that acts as BOOT server but not as WWW server
284 - cleanup some obsolete code for old chroot-jail packaging in the process
285 - new bootcd-kernel script for keeping bootcd variants up2date
286
287 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
288 - Make the /etc/hosts manipulation optional.
289
290 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
291 - Fix SetRole.
292
293 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
294 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
295 - into the DB.
296 - - Added the root ssh key handling support back into plc.d/ssh and the
297 - default xml file.  This should be identical to the way it was in
298 - rc12.
299 - - Added support in the db-config.d/01-init script to register the root
300 - ssh public key with the default administrator.  In this way the root
301 - ssh key will make it into the root account on the nodes by means of
302 - NodeManager's specialaccounts plugin.
303
304 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
305 - db-config ignores sliver tags
306 - sirius's db-config script renamed (was sirious)
307
308 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
309 - fix for silverauth - missing tag types now created at plc startup time
310
311 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
312 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
313
314 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
315 - companion to NM's specialaccounts plugin
316 - do not generate /etc/planetlab/root_ssh_key* anymore
317 - remove related config. variables and conf_files
318
319 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
320 - clarified description text to refer only to plcrt and not other optional
321 - packages.
322
323 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
324 - fixed a bug setting slice multiple attributes with the same tag name
325
326 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
327 - SSL setup for monitor box, and related new config variables
328 - new conf_file for /etc/planetlab/extensions
329 - various tweaks in db-config internals, about initscripts among others
330 - also more messages defined in the db
331
332 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
333 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
334
335 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
336 - bugfix in db-config, tag 4.3-19 would not fly
337
338 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
339 - Refactored db-config into snippets in db-config.d/.
340
341 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
342 - oops, tag 4.3-17 was broken and would not work
343
344 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
345 - bugfix - escape sequences inserted in xml configs
346
347 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
348 - Handle db-config.d files properly.
349
350 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
351 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
352 - than the log file
353 - - Fix db-config to be a bit more cautious when
354 - /etc/planetlab/db-config.d doesn't exist
355 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
356 - .orig files.
357 - - Refactor generic plc-config-tty code into plc_config.py.
358 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
359 - and the list of validated variables and the corresponding
360 - validator() function. This refactoring lets one reuse plc_config.py
361 - as a generic cmdline configuration tool for highly customer MyPLC
362 - like software.
363
364 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
365 - update PCU Type descriptions.
366 - updates to init scripts
367
368 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
369 - requires monitor-pcucontrol so register-wizard can work
370
371 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
372 - cleaned up plc-config-tty, no more need to configure plc-devel
373
374 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
375 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
376
377 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
378 - fix issue in db-config that prevented correct operation
379
380 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
381 - remove support for chroot-based packaging - no crond nor syslog step anymore
382 - plc init script now named plc.init instead of former guest.init
383
384 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
385 - add Monitor to docs build
386
387 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
388 - plc_config.py and plc-config-tty: generalized to work for more diverse
389 - MyPLC configurations.
390 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
391 - deployments and increase the memory limits in php.ini
392 - plc.d/crond: add --full option to vacuumdb
393
394 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
395 - avoid generating ssl certificates for disabled services among www api boot
396
397 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
398 - cleaned up old entries in db-config
399 - mtail more robust
400
401 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
402 - php include path tweaked for plekit includes
403 - reviewed myplc (fka native) packaging dependencies
404 - renumbered 4.3
405
406 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
407 - rename myplc into myplc-chroot and myplc-native into myplc
408 - new settings (shortname & hrn_root) for local peer
409
410 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
411 - First iteration of new data model
412 - Bunch of various fixes
413
414 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
415 - Removed proper ops from planetflow slice.
416
417 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
418 - myplc-native requires myplc-docs
419 - fixed doc build by locating locally installed DTDs at build-time
420
421 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
422 - turn myplc-docs off for now
423
424 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
425 - figures in doc package
426
427 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
428 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
429 - chroot packaging does not have docs anymore
430 - 'cvs' and 'dev' not required from myplc-native anymore
431 - cosmetic change in kml output
432
433 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
434 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
435 - gethostbyname uses python rather than perl (hope this shrinks deps) 
436 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
437 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
438 - make sync now works towards vserver-based myplc only 
439
440 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
441
442 - added vsys 'pfmount' script to the default netflow slice attributes.
443
444
445 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
446 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
447 - to new bootcd packaging
448
449 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
450 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
451
452 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
453 - packaging of mplc-release in myplc-native
454 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
455 - resolv file in /etc/resolv.conf, not plc_resolv.conf
456 - improved sirius script
457 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
458 - expires more properly set 
459
460 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
461
462
463 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
464 - renew_reminder script moved to support-scripts/
465 - gen-aliases script added in support-scripts/
466 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
467 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
468 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
469 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
470 - new setting 'Mom list address' for sending emails to a separate destination
471 - starts rsyslogd/syslogd as appropriate
472 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
473 - convenience generation of yum.conf in resulting image based on build/mirroring
474
475 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
476 - refresh-peer.py removed (duplicate with PLCAPI)
477 - plc.d/ scripts cleaned up
478 - sirius initscript updated
479 - slice auto renewal fixed
480
481 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
482 - initial build.
483
484 %define module_current_branch 4.2