Setting tag myplc-5.3-4
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 #Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 Requires: cronie
56 # starting with f16 we depend on this new rpm
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
58 Requires: rpm-sign
59 %endif
60
61 # planetlab stuff
62 Requires: bootmanager
63 Requires: bootcd-%{nodefamily}
64 Requires: bootcd-initscripts
65 Requires: PLCWWW
66 Requires: www-register-wizard
67 Requires: nodeconfig
68 Requires: nodeyum
69 Requires: plcapi >= 5.2
70 # this technically is a plcapi dependency but it's simpler here for chosing which
71 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
72 Requires: mod_wsgi
73 %else
74 Requires: mod_python
75 %endif
76 Requires: nodeimage-%{nodefamily}
77 Requires: myplc-docs
78 Requires: myplc-release
79 Requires: myplc-config
80
81 %define debug_package %{nil}
82
83 %description 
84 MyPLC is a complete PlanetLab Central (PLC) portable installation.
85 The default installation consists of a web server, an XML-RPC API
86 server, a boot server, and a database server: the core components of
87 PLC. The installation may be customized through a graphical
88 interface. All PLC services are started up and shut down through a
89 single System V init script.
90
91 ####################### myplc-config
92
93 %package config
94
95 Summary: PlanetLab Central (PLC) configuration python module
96 Group: Applications/Systems
97 Requires: python
98
99 %description config
100 This package provides the Python module to configure MyPLC.
101
102
103 %prep
104 %setup -q
105
106 %build
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 # Install configuration scripts
112 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
113 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
114 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
115
116 echo "* Installing scripts in /usr/bin"
117 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
118 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
119 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
120 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
121
122 # Install initscript 
123 echo "* Installing plc initscript"
124 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
125 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
126
127 # Install initscripts
128 echo "* Installing plc.d initscripts"
129 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
130 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
131
132 # Install db-config.d files
133 echo "* Installing db-config.d files"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
136 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
137
138 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
139 echo "* Installing scripts in /etc/support-scripts"
140 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
141 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
142 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
143
144 # copy initscripts to etc/plc_sliceinitscripts
145 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
146 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
147 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
148
149 # Install configuration file
150 echo "* myplc: Installing configuration file"
151 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
152 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
153     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
154 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
155
156 echo "* Installing bashrc convenience"
157 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
158
159 # yumgroups.xml and yum repo : let noderepo handle that
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %pre
165 if [ -x %{_sysconfdir}/init.d/plc ] ; then
166     %{_sysconfdir}/init.d/plc stop
167 fi
168
169 # Old versions of myplc used to ship with a bootstrapped database and
170 # /etc/planetlab directory. Including generated files in the manifest
171 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
172 # names from one RPM build to another, it would be rpmsaved and thus
173 # effectively deleted. Now we do not include these files in the
174 # manifest. However, to avoid deleting these files in the process of
175 # upgrading from one of these old versions of myplc, we must back up
176 # the database and /etc/planetlab and restore them after the old
177 # version has been uninstalled in %triggerpostun (also in %post, in
178 # case we are force upgrading to the same version).
179 #
180 # This code can be removed once all myplc-0.4-1 installations have
181 # been upgraded to at least myplc-0.4-2.
182
183 # 0 = install, 1 = upgrade
184 if [ $1 -gt 0 ] ; then
185     for dir in /var/lib/pgsql/data /etc/planetlab ; do
186         if [ -d $dir ] ; then
187             echo "Preserving $dir"
188             mkdir -p $dir.rpmsave
189             tar -C $dir -cpf - . | \
190                tar -C $dir.rpmsave -xpf -
191
192             # Except for the default configuration file and DTD, which
193             # really should be considered for upgrade.
194             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
195         fi
196     done
197 fi
198
199 %post
200 if [ -x /sbin/chkconfig ] ; then
201     /sbin/chkconfig --add plc
202     /sbin/chkconfig plc on
203 fi
204
205 %triggerpostun -- %{name}
206 # 0 = erase, 1 = upgrade
207 if [ $1 -gt 0 ] ; then
208     for dir in /var/lib/pgsql/data /etc/planetlab ; do
209         if [ -d $dir.rpmsave -a -d $dir ] ; then
210             echo "Merging $dir"
211             if tar -C $dir.rpmsave -cpf - . | \
212                tar -C $dir -xpf - ; then
213                 rm -rf $dir.rpmsave
214             fi
215         fi
216     done
217 fi    
218
219 %preun
220 # 0 = erase, 1 = upgrade
221 if [ $1 -eq 0 ] ; then
222     %{_sysconfdir}/init.d/plc stop
223     if [ -x /sbin/chkconfig ] ; then
224         /sbin/chkconfig plc off
225         /sbin/chkconfig --del plc
226     fi
227 fi
228
229 %files
230 %defattr(-,root,root,-)
231 # Host startup script and configuration file
232 /etc/init.d/plc
233 /etc/plc.d
234 /etc/planetlab
235 /etc/plc_sliceinitscripts
236 /etc/support-scripts
237 /usr/share/myplc/bashrc
238 # keep a detailed list, to avoid duplicate of plc-config,
239 # that belongs to the myplc-config rpm
240 /usr/bin/plc-config-tty
241 /usr/bin/db-config
242 /usr/bin/dns-config
243 /usr/bin/refresh-peer.py*
244 /usr/bin/mtail.py*
245 /usr/bin/mtail
246 /usr/bin/plc-map.py*
247 /usr/bin/plc-kml.py*
248 /usr/bin/clean-empty-dirs.py*
249 /usr/bin/plc-check-ssl-peering.py*
250 /usr/bin/plc-orphan-accounts.py*
251 /usr/bin/spot-aliens.py*
252 /usr/bin/check-hrns.py*
253 /usr/bin/check-vsys-defaults.py*
254 /usr/bin/spot-dup-accounts.sh
255 /lib/systemd/system/plc.service
256
257 %files config
258 %defattr(-,root,root,-)
259 /usr/bin/plc-config
260 %{python_sitearch}/plc_config.py*
261
262
263 %changelog
264 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
265 - takes care of creating plcapi log file
266
267 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
268 - tweaked renew_reminder for federation
269
270 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
271 - tweaks in check-hrns.py
272 - do not require PyXML any more
273
274 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
275 - review check-hrns for plcapi-5.3
276 - add PLC_HRN_ROOT in usual plc-config-tty's settings
277
278 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
279 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
280 - add an rpm-sign dependency on feedora>=16
281
282 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
283 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
284
285 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
286 - plc.d/gpg now does not rm /dev/random but preserves it
287 - this is because libvirt won't let us run mknod
288
289 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
290 - fix typo in check-hrns - used to print 'host' while dealing with persons
291
292 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
293 - supports httpd config for either mod_python (preferred) or mod_wsgi
294 - requires mod_wsgi on f18 only, otherwise mod_python
295 - supports httpd config for apache 2.4 (f18)
296 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
297
298 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
299 - bugfix in check-vsys-defaults.py
300
301 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
302 - define open_basedir in php.ini to stop confidentiality leak
303 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
304 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
305 - new utilities check-hrns.py and check-vsys-defaults.py
306
307 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
308 - set TimeoutSec to 300 in plc.service
309 - remove ref to deprecated svn $URL$ in db-config usage
310
311 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
312 - expose mtail.py as simply mtail
313
314 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
315 - plc-kml.py now has support for nodegroups
316
317 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
318 - use nodeimage package instead of deprecated bootstrapfs
319 - has systemd-friendly startup script
320 - plc_reload moved to functions/ - no more service plc reload
321 - no svn keywords anymore
322
323 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
324 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
325
326 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
327 - new settings for myslice (comon&tophat) and monitor (db)
328 - removed mentions of chroot in description
329 - can redo myplc-docs on broken f12-latex
330 - set short_open_tag in php.ini
331 - fixes in gen-sites-xml (is that still used ?)
332 - partial-repo.sh has moved to 'build' where it more belongs
333 - tweaks in convenience tool 'mtail'
334
335 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
336 - fixed changelog, no change from 5.0-16
337
338 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
339 - requires ed for the plc.d/packages step
340 - sirius initscript to handle stop and restart
341
342 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
343 - ignore steps in db-config.d if they have a '.' or '~' in their name
344
345 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
346 - can redo myplc-docs without the doc for monitor
347
348 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
349 - no semantic change - just fixed specfile for git URL
350
351 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
352 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
353
354 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
355 - add missing files to rpm package
356
357 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
358 - mtail.py -s for SFA
359 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
360
361 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
362 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
363
364 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
365 - plc-config-tty now has a validator on booleans
366 - e.g. entering 'True' now is rejected rather than silently recording 'false'
367
368 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
369 - disable mod_wsgi
370
371 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
372 - module name changes
373 - start wsgi support
374
375 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
376 - new setting PLC_RESERVATION_GRANULARITY
377
378 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
379 - * partial-repo.sh script
380 - * preserve key along with certificates
381
382 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
383 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
384
385 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
386 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
387 - new OMF category in the config
388 - create the drl system slice
389
390 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
391 - first working version of 5.0:
392 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
393 - nodefamily is 3-fold with pldistro-fcdistro-arch
394 - new PLC_FLAVOUR config category
395 - reviewed module layout
396 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
397
398 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
399 - support for fedora 12
400 - new package myplc-config for use by sfa
401 - drupal user registration turned off
402
403 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
404 - - fix to make sure when API, BOOT, MONITOR are on the same
405 - machine as WWW that the SSL key,cert for WWW takes precedence.
406 - - Do proper setup for SSL CA certficate to be used as the server
407 - chain.
408
409 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
410 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
411
412 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
413 - depend on pcucontrol
414
415 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
416 - * validate input according to type in plc_config
417 - * added the _genicw system slice
418 - * add tag types for sites and persons
419 - * add new tags for nodes and slices for exemption from myops
420
421 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
422 - turn off drupal on a box that acts as BOOT server but not as WWW server
423 - cleanup some obsolete code for old chroot-jail packaging in the process
424 - new bootcd-kernel script for keeping bootcd variants up2date
425
426 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
427 - Make the /etc/hosts manipulation optional.
428
429 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
430 - Fix SetRole.
431
432 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
433 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
434 - into the DB.
435 - - Added the root ssh key handling support back into plc.d/ssh and the
436 - default xml file.  This should be identical to the way it was in
437 - rc12.
438 - - Added support in the db-config.d/01-init script to register the root
439 - ssh public key with the default administrator.  In this way the root
440 - ssh key will make it into the root account on the nodes by means of
441 - NodeManager's specialaccounts plugin.
442
443 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
444 - db-config ignores sliver tags
445 - sirius's db-config script renamed (was sirious)
446
447 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
448 - fix for silverauth - missing tag types now created at plc startup time
449
450 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
451 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
452
453 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
454 - companion to NM's specialaccounts plugin
455 - do not generate /etc/planetlab/root_ssh_key* anymore
456 - remove related config. variables and conf_files
457
458 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
459 - clarified description text to refer only to plcrt and not other optional
460 - packages.
461
462 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
463 - fixed a bug setting slice multiple attributes with the same tag name
464
465 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
466 - SSL setup for monitor box, and related new config variables
467 - new conf_file for /etc/planetlab/extensions
468 - various tweaks in db-config internals, about initscripts among others
469 - also more messages defined in the db
470
471 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
472 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
473
474 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
475 - bugfix in db-config, tag 4.3-19 would not fly
476
477 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
478 - Refactored db-config into snippets in db-config.d/.
479
480 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
481 - oops, tag 4.3-17 was broken and would not work
482
483 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
484 - bugfix - escape sequences inserted in xml configs
485
486 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
487 - Handle db-config.d files properly.
488
489 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
490 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
491 - than the log file
492 - - Fix db-config to be a bit more cautious when
493 - /etc/planetlab/db-config.d doesn''t exist
494 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
495 - .orig files.
496 - - Refactor generic plc-config-tty code into plc_config.py.
497 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
498 - and the list of validated variables and the corresponding
499 - validator() function. This refactoring lets one reuse plc_config.py
500 - as a generic cmdline configuration tool for highly customer MyPLC
501 - like software.
502
503 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
504 - update PCU Type descriptions.
505 - updates to init scripts
506
507 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
508 - requires monitor-pcucontrol so register-wizard can work
509
510 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
511 - cleaned up plc-config-tty, no more need to configure plc-devel
512
513 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
514 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
515
516 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
517 - fix issue in db-config that prevented correct operation
518
519 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
520 - remove support for chroot-based packaging - no crond nor syslog step anymore
521 - plc init script now named plc.init instead of former guest.init
522
523 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
524 - add Monitor to docs build
525
526 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
527 - plc_config.py and plc-config-tty: generalized to work for more diverse
528 - MyPLC configurations.
529 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
530 - deployments and increase the memory limits in php.ini
531 - plc.d/crond: add --full option to vacuumdb
532
533 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
534 - avoid generating ssl certificates for disabled services among www api boot
535
536 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
537 - cleaned up old entries in db-config
538 - mtail more robust
539
540 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
541 - php include path tweaked for plekit includes
542 - reviewed myplc (fka native) packaging dependencies
543 - renumbered 4.3
544
545 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
546 - rename myplc into myplc-chroot and myplc-native into myplc
547 - new settings (shortname & hrn_root) for local peer
548
549 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
550 - First iteration of new data model
551 - Bunch of various fixes
552
553 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
554 - Removed proper ops from planetflow slice.
555
556 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
557 - myplc-native requires myplc-docs
558 - fixed doc build by locating locally installed DTDs at build-time
559
560 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
561 - turn myplc-docs off for now
562
563 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
564 - figures in doc package
565
566 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
567 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
568 - chroot packaging does not have docs anymore
569 - 'cvs' and 'dev' not required from myplc-native anymore
570 - cosmetic change in kml output
571
572 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
573 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
574 - gethostbyname uses python rather than perl (hope this shrinks deps) 
575 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
576 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
577 - make sync now works towards vserver-based myplc only 
578
579 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
580
581 - added vsys 'pfmount' script to the default netflow slice attributes.
582
583
584 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
585 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
586 - to new bootcd packaging
587
588 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
589 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
590
591 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
592 - packaging of mplc-release in myplc-native
593 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
594 - resolv file in /etc/resolv.conf, not plc_resolv.conf
595 - improved sirius script
596 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
597 - expires more properly set 
598
599 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
600
601
602 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
603 - renew_reminder script moved to support-scripts/
604 - gen-aliases script added in support-scripts/
605 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
606 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
607 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
608 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
609 - new setting 'Mom list address' for sending emails to a separate destination
610 - starts rsyslogd/syslogd as appropriate
611 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
612 - convenience generation of yum.conf in resulting image based on build/mirroring
613
614 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
615 - refresh-peer.py removed (duplicate with PLCAPI)
616 - plc.d/ scripts cleaned up
617 - sirius initscript updated
618 - slice auto renewal fixed
619
620 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
621 - initial build.
622
623 %define module_current_branch 4.3