catch up with code running at PLE for nicer layout
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
56 Requires: cronie
57 %else
58 Requires: vixie-cron
59 %endif
60 # planetlab stuff
61 Requires: bootmanager
62 Requires: bootcd-%{nodefamily}
63 Requires: bootcd-initscripts
64 Requires: PLCWWW
65 Requires: www-register-wizard
66 Requires: nodeconfig
67 Requires: nodeyum
68 Requires: PLCAPI
69 Requires: nodeimage-%{nodefamily}
70 Requires: myplc-docs
71 Requires: myplc-release
72 Requires: myplc-config
73
74 %define debug_package %{nil}
75
76 %description 
77 MyPLC is a complete PlanetLab Central (PLC) portable installation.
78 The default installation consists of a web server, an XML-RPC API
79 server, a boot server, and a database server: the core components of
80 PLC. The installation may be customized through a graphical
81 interface. All PLC services are started up and shut down through a
82 single System V init script.
83
84 ####################### myplc-config
85
86 %package config
87
88 Summary: PlanetLab Central (PLC) configuration python module
89 Group: Applications/Systems
90 Requires: python
91
92 %description config
93 This package provides the Python module to configure MyPLC.
94
95
96 %prep
97 %setup -q
98
99 %build
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 # Install configuration scripts
105 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
106 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
107 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
108
109 echo "* Installing scripts in /usr/bin"
110 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
111 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
112 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
113
114 # Install initscript 
115 echo "* Installing plc initscript"
116 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
117 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
118
119 # Install initscripts
120 echo "* Installing plc.d initscripts"
121 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
122 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
123
124 # Install db-config.d files
125 echo "* Installing db-config.d files"
126 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
127 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
128 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
129
130 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
131 echo "* Installing scripts in /etc/support-scripts"
132 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
133 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
134 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
135
136 # copy initscripts to etc/plc_sliceinitscripts
137 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
138 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
139 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
140
141 # Install configuration file
142 echo "* myplc: Installing configuration file"
143 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
144 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
145     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
146 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
147
148 echo "* Installing bashrc convenience"
149 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
150
151 # yumgroups.xml and yum repo : let noderepo handle that
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %pre
157 if [ -x %{_sysconfdir}/init.d/plc ] ; then
158     %{_sysconfdir}/init.d/plc stop
159 fi
160
161 # Old versions of myplc used to ship with a bootstrapped database and
162 # /etc/planetlab directory. Including generated files in the manifest
163 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
164 # names from one RPM build to another, it would be rpmsaved and thus
165 # effectively deleted. Now we do not include these files in the
166 # manifest. However, to avoid deleting these files in the process of
167 # upgrading from one of these old versions of myplc, we must back up
168 # the database and /etc/planetlab and restore them after the old
169 # version has been uninstalled in %triggerpostun (also in %post, in
170 # case we are force upgrading to the same version).
171 #
172 # This code can be removed once all myplc-0.4-1 installations have
173 # been upgraded to at least myplc-0.4-2.
174
175 # 0 = install, 1 = upgrade
176 if [ $1 -gt 0 ] ; then
177     for dir in /var/lib/pgsql/data /etc/planetlab ; do
178         if [ -d $dir ] ; then
179             echo "Preserving $dir"
180             mkdir -p $dir.rpmsave
181             tar -C $dir -cpf - . | \
182                tar -C $dir.rpmsave -xpf -
183
184             # Except for the default configuration file and DTD, which
185             # really should be considered for upgrade.
186             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
187         fi
188     done
189 fi
190
191 %post
192 if [ -x /sbin/chkconfig ] ; then
193     /sbin/chkconfig --add plc
194     /sbin/chkconfig plc on
195 fi
196
197 %triggerpostun -- %{name}
198 # 0 = erase, 1 = upgrade
199 if [ $1 -gt 0 ] ; then
200     for dir in /var/lib/pgsql/data /etc/planetlab ; do
201         if [ -d $dir.rpmsave -a -d $dir ] ; then
202             echo "Merging $dir"
203             if tar -C $dir.rpmsave -cpf - . | \
204                tar -C $dir -xpf - ; then
205                 rm -rf $dir.rpmsave
206             fi
207         fi
208     done
209 fi    
210
211 %preun
212 # 0 = erase, 1 = upgrade
213 if [ $1 -eq 0 ] ; then
214     %{_sysconfdir}/init.d/plc stop
215     if [ -x /sbin/chkconfig ] ; then
216         /sbin/chkconfig plc off
217         /sbin/chkconfig --del plc
218     fi
219 fi
220
221 %files
222 %defattr(-,root,root,-)
223 # Host startup script and configuration file
224 /etc/init.d/plc
225 /etc/plc.d
226 /etc/planetlab
227 /etc/plc_sliceinitscripts
228 /etc/support-scripts
229 /usr/share/myplc/bashrc
230 # keep a detailed list, to avoid duplicate of plc-config,
231 # that belongs to the myplc-config rpm
232 /usr/bin/plc-config-tty
233 /usr/bin/db-config
234 /usr/bin/dns-config
235 /usr/bin/refresh-peer.py*
236 /usr/bin/mtail.py*
237 /usr/bin/plc-map.py*
238 /usr/bin/plc-kml.py*
239 /usr/bin/clean-empty-dirs.py*
240 /usr/bin/plc-check-ssl-peering.py*
241 /usr/bin/plc-orphan-accounts.py*
242 /usr/bin/spot-aliens.py*
243 /usr/bin/spot-dup-accounts.sh
244 /lib/systemd/system/plc.service
245
246 %files config
247 %defattr(-,root,root,-)
248 /usr/bin/plc-config
249 %{python_sitearch}/plc_config.py*
250
251
252 %changelog
253 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
254 - use nodeimage package instead of deprecated bootstrapfs
255 - has systemd-friendly startup script
256 - plc_reload moved to functions/ - no more service plc reload
257 - no svn keywords anymore
258
259 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
260 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
261
262 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
263 - new settings for myslice (comon&tophat) and monitor (db)
264 - removed mentions of chroot in description
265 - can redo myplc-docs on broken f12-latex
266 - set short_open_tag in php.ini
267 - fixes in gen-sites-xml (is that still used ?)
268 - partial-repo.sh has moved to 'build' where it more belongs
269 - tweaks in convenience tool 'mtail'
270
271 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
272 - fixed changelog, no change from 5.0-16
273
274 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
275 - requires ed for the plc.d/packages step
276 - sirius initscript to handle stop and restart
277
278 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
279 - ignore steps in db-config.d if they have a '.' or '~' in their name
280
281 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
282 - can redo myplc-docs without the doc for monitor
283
284 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
285 - no semantic change - just fixed specfile for git URL
286
287 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
288 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
289
290 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
291 - add missing files to rpm package
292
293 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
294 - mtail.py -s for SFA
295 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
296
297 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
298 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
299
300 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
301 - plc-config-tty now has a validator on booleans
302 - e.g. entering 'True' now is rejected rather than silently recording 'false'
303
304 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
305 - disable mod_wsgi
306
307 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
308 - module name changes
309 - start wsgi support
310
311 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
312 - new setting PLC_RESERVATION_GRANULARITY
313
314 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
315 - * partial-repo.sh script
316 - * preserve key along with certificates
317
318 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
319 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
320
321 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
322 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
323 - new OMF category in the config
324 - create the drl system slice
325
326 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
327 - first working version of 5.0:
328 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
329 - nodefamily is 3-fold with pldistro-fcdistro-arch
330 - new PLC_FLAVOUR config category
331 - reviewed module layout
332 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
333
334 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
335 - support for fedora 12
336 - new package myplc-config for use by sfa
337 - drupal user registration turned off
338
339 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
340 - - fix to make sure when API, BOOT, MONITOR are on the same
341 - machine as WWW that the SSL key,cert for WWW takes precedence.
342 - - Do proper setup for SSL CA certficate to be used as the server
343 - chain.
344
345 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
346 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
347
348 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
349 - depend on pcucontrol
350
351 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
352 - * validate input according to type in plc_config
353 - * added the _genicw system slice
354 - * add tag types for sites and persons
355 - * add new tags for nodes and slices for exemption from myops
356
357 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
358 - turn off drupal on a box that acts as BOOT server but not as WWW server
359 - cleanup some obsolete code for old chroot-jail packaging in the process
360 - new bootcd-kernel script for keeping bootcd variants up2date
361
362 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
363 - Make the /etc/hosts manipulation optional.
364
365 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
366 - Fix SetRole.
367
368 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
369 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
370 - into the DB.
371 - - Added the root ssh key handling support back into plc.d/ssh and the
372 - default xml file.  This should be identical to the way it was in
373 - rc12.
374 - - Added support in the db-config.d/01-init script to register the root
375 - ssh public key with the default administrator.  In this way the root
376 - ssh key will make it into the root account on the nodes by means of
377 - NodeManager's specialaccounts plugin.
378
379 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
380 - db-config ignores sliver tags
381 - sirius's db-config script renamed (was sirious)
382
383 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
384 - fix for silverauth - missing tag types now created at plc startup time
385
386 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
387 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
388
389 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
390 - companion to NM's specialaccounts plugin
391 - do not generate /etc/planetlab/root_ssh_key* anymore
392 - remove related config. variables and conf_files
393
394 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
395 - clarified description text to refer only to plcrt and not other optional
396 - packages.
397
398 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
399 - fixed a bug setting slice multiple attributes with the same tag name
400
401 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
402 - SSL setup for monitor box, and related new config variables
403 - new conf_file for /etc/planetlab/extensions
404 - various tweaks in db-config internals, about initscripts among others
405 - also more messages defined in the db
406
407 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
408 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
409
410 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
411 - bugfix in db-config, tag 4.3-19 would not fly
412
413 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
414 - Refactored db-config into snippets in db-config.d/.
415
416 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
417 - oops, tag 4.3-17 was broken and would not work
418
419 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
420 - bugfix - escape sequences inserted in xml configs
421
422 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
423 - Handle db-config.d files properly.
424
425 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
426 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
427 - than the log file
428 - - Fix db-config to be a bit more cautious when
429 - /etc/planetlab/db-config.d doesn''t exist
430 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
431 - .orig files.
432 - - Refactor generic plc-config-tty code into plc_config.py.
433 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
434 - and the list of validated variables and the corresponding
435 - validator() function. This refactoring lets one reuse plc_config.py
436 - as a generic cmdline configuration tool for highly customer MyPLC
437 - like software.
438
439 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
440 - update PCU Type descriptions.
441 - updates to init scripts
442
443 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
444 - requires monitor-pcucontrol so register-wizard can work
445
446 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
447 - cleaned up plc-config-tty, no more need to configure plc-devel
448
449 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
450 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
451
452 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
453 - fix issue in db-config that prevented correct operation
454
455 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
456 - remove support for chroot-based packaging - no crond nor syslog step anymore
457 - plc init script now named plc.init instead of former guest.init
458
459 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
460 - add Monitor to docs build
461
462 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
463 - plc_config.py and plc-config-tty: generalized to work for more diverse
464 - MyPLC configurations.
465 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
466 - deployments and increase the memory limits in php.ini
467 - plc.d/crond: add --full option to vacuumdb
468
469 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
470 - avoid generating ssl certificates for disabled services among www api boot
471
472 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
473 - cleaned up old entries in db-config
474 - mtail more robust
475
476 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
477 - php include path tweaked for plekit includes
478 - reviewed myplc (fka native) packaging dependencies
479 - renumbered 4.3
480
481 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
482 - rename myplc into myplc-chroot and myplc-native into myplc
483 - new settings (shortname & hrn_root) for local peer
484
485 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
486 - First iteration of new data model
487 - Bunch of various fixes
488
489 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
490 - Removed proper ops from planetflow slice.
491
492 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
493 - myplc-native requires myplc-docs
494 - fixed doc build by locating locally installed DTDs at build-time
495
496 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
497 - turn myplc-docs off for now
498
499 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
500 - figures in doc package
501
502 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
503 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
504 - chroot packaging does not have docs anymore
505 - 'cvs' and 'dev' not required from myplc-native anymore
506 - cosmetic change in kml output
507
508 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
509 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
510 - gethostbyname uses python rather than perl (hope this shrinks deps) 
511 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
512 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
513 - make sync now works towards vserver-based myplc only 
514
515 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
516
517 - added vsys 'pfmount' script to the default netflow slice attributes.
518
519
520 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
521 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
522 - to new bootcd packaging
523
524 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
525 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
526
527 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
528 - packaging of mplc-release in myplc-native
529 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
530 - resolv file in /etc/resolv.conf, not plc_resolv.conf
531 - improved sirius script
532 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
533 - expires more properly set 
534
535 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
536
537
538 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
539 - renew_reminder script moved to support-scripts/
540 - gen-aliases script added in support-scripts/
541 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
542 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
543 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
544 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
545 - new setting 'Mom list address' for sending emails to a separate destination
546 - starts rsyslogd/syslogd as appropriate
547 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
548 - convenience generation of yum.conf in resulting image based on build/mirroring
549
550 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
551 - refresh-peer.py removed (duplicate with PLCAPI)
552 - plc.d/ scripts cleaned up
553 - sirius initscript updated
554 - slice auto renewal fixed
555
556 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
557 - initial build.
558
559 %define module_current_branch 4.3