bump major to 5.2
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.2
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
56 Requires: cronie
57 %else
58 Requires: vixie-cron
59 %endif
60 # planetlab stuff
61 Requires: bootmanager
62 Requires: bootcd-%{nodefamily}
63 Requires: bootcd-initscripts
64 Requires: PLCWWW
65 Requires: www-register-wizard
66 Requires: nodeconfig
67 Requires: nodeyum
68 Requires: plcapi >= 5.2
69 # this technically is a plcapi dependency but it's simpler here for chosing which
70 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
71 Requires: mod_wsgi
72 %else
73 Requires: mod_python
74 %endif
75 Requires: nodeimage-%{nodefamily}
76 Requires: myplc-docs
77 Requires: myplc-release
78 Requires: myplc-config
79
80 %define debug_package %{nil}
81
82 %description 
83 MyPLC is a complete PlanetLab Central (PLC) portable installation.
84 The default installation consists of a web server, an XML-RPC API
85 server, a boot server, and a database server: the core components of
86 PLC. The installation may be customized through a graphical
87 interface. All PLC services are started up and shut down through a
88 single System V init script.
89
90 ####################### myplc-config
91
92 %package config
93
94 Summary: PlanetLab Central (PLC) configuration python module
95 Group: Applications/Systems
96 Requires: python
97
98 %description config
99 This package provides the Python module to configure MyPLC.
100
101
102 %prep
103 %setup -q
104
105 %build
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 # Install configuration scripts
111 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
112 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
113 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
114
115 echo "* Installing scripts in /usr/bin"
116 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
117 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
118 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
119 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
120
121 # Install initscript 
122 echo "* Installing plc initscript"
123 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
124 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
125
126 # Install initscripts
127 echo "* Installing plc.d initscripts"
128 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
129 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
130
131 # Install db-config.d files
132 echo "* Installing db-config.d files"
133 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
134 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
136
137 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
138 echo "* Installing scripts in /etc/support-scripts"
139 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
140 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
141 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
142
143 # copy initscripts to etc/plc_sliceinitscripts
144 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
145 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
146 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
147
148 # Install configuration file
149 echo "* myplc: Installing configuration file"
150 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
151 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
152     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
153 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
154
155 echo "* Installing bashrc convenience"
156 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
157
158 # yumgroups.xml and yum repo : let noderepo handle that
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %pre
164 if [ -x %{_sysconfdir}/init.d/plc ] ; then
165     %{_sysconfdir}/init.d/plc stop
166 fi
167
168 # Old versions of myplc used to ship with a bootstrapped database and
169 # /etc/planetlab directory. Including generated files in the manifest
170 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
171 # names from one RPM build to another, it would be rpmsaved and thus
172 # effectively deleted. Now we do not include these files in the
173 # manifest. However, to avoid deleting these files in the process of
174 # upgrading from one of these old versions of myplc, we must back up
175 # the database and /etc/planetlab and restore them after the old
176 # version has been uninstalled in %triggerpostun (also in %post, in
177 # case we are force upgrading to the same version).
178 #
179 # This code can be removed once all myplc-0.4-1 installations have
180 # been upgraded to at least myplc-0.4-2.
181
182 # 0 = install, 1 = upgrade
183 if [ $1 -gt 0 ] ; then
184     for dir in /var/lib/pgsql/data /etc/planetlab ; do
185         if [ -d $dir ] ; then
186             echo "Preserving $dir"
187             mkdir -p $dir.rpmsave
188             tar -C $dir -cpf - . | \
189                tar -C $dir.rpmsave -xpf -
190
191             # Except for the default configuration file and DTD, which
192             # really should be considered for upgrade.
193             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
194         fi
195     done
196 fi
197
198 %post
199 if [ -x /sbin/chkconfig ] ; then
200     /sbin/chkconfig --add plc
201     /sbin/chkconfig plc on
202 fi
203
204 %triggerpostun -- %{name}
205 # 0 = erase, 1 = upgrade
206 if [ $1 -gt 0 ] ; then
207     for dir in /var/lib/pgsql/data /etc/planetlab ; do
208         if [ -d $dir.rpmsave -a -d $dir ] ; then
209             echo "Merging $dir"
210             if tar -C $dir.rpmsave -cpf - . | \
211                tar -C $dir -xpf - ; then
212                 rm -rf $dir.rpmsave
213             fi
214         fi
215     done
216 fi    
217
218 %preun
219 # 0 = erase, 1 = upgrade
220 if [ $1 -eq 0 ] ; then
221     %{_sysconfdir}/init.d/plc stop
222     if [ -x /sbin/chkconfig ] ; then
223         /sbin/chkconfig plc off
224         /sbin/chkconfig --del plc
225     fi
226 fi
227
228 %files
229 %defattr(-,root,root,-)
230 # Host startup script and configuration file
231 /etc/init.d/plc
232 /etc/plc.d
233 /etc/planetlab
234 /etc/plc_sliceinitscripts
235 /etc/support-scripts
236 /usr/share/myplc/bashrc
237 # keep a detailed list, to avoid duplicate of plc-config,
238 # that belongs to the myplc-config rpm
239 /usr/bin/plc-config-tty
240 /usr/bin/db-config
241 /usr/bin/dns-config
242 /usr/bin/refresh-peer.py*
243 /usr/bin/mtail.py*
244 /usr/bin/mtail
245 /usr/bin/plc-map.py*
246 /usr/bin/plc-kml.py*
247 /usr/bin/clean-empty-dirs.py*
248 /usr/bin/plc-check-ssl-peering.py*
249 /usr/bin/plc-orphan-accounts.py*
250 /usr/bin/spot-aliens.py*
251 /usr/bin/check-hrns.py*
252 /usr/bin/check-vsys-defaults.py*
253 /usr/bin/spot-dup-accounts.sh
254 /lib/systemd/system/plc.service
255
256 %files config
257 %defattr(-,root,root,-)
258 /usr/bin/plc-config
259 %{python_sitearch}/plc_config.py*
260
261
262 %changelog
263 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
264 - bugfix in check-vsys-defaults.py
265
266 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
267 - define open_basedir in php.ini to stop confidentiality leak
268 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
269 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
270 - new utilities check-hrns.py and check-vsys-defaults.py
271
272 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
273 - set TimeoutSec to 300 in plc.service
274 - remove ref to deprecated svn $URL$ in db-config usage
275
276 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
277 - expose mtail.py as simply mtail
278
279 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
280 - plc-kml.py now has support for nodegroups
281
282 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
283 - use nodeimage package instead of deprecated bootstrapfs
284 - has systemd-friendly startup script
285 - plc_reload moved to functions/ - no more service plc reload
286 - no svn keywords anymore
287
288 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
289 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
290
291 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
292 - new settings for myslice (comon&tophat) and monitor (db)
293 - removed mentions of chroot in description
294 - can redo myplc-docs on broken f12-latex
295 - set short_open_tag in php.ini
296 - fixes in gen-sites-xml (is that still used ?)
297 - partial-repo.sh has moved to 'build' where it more belongs
298 - tweaks in convenience tool 'mtail'
299
300 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
301 - fixed changelog, no change from 5.0-16
302
303 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
304 - requires ed for the plc.d/packages step
305 - sirius initscript to handle stop and restart
306
307 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
308 - ignore steps in db-config.d if they have a '.' or '~' in their name
309
310 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
311 - can redo myplc-docs without the doc for monitor
312
313 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
314 - no semantic change - just fixed specfile for git URL
315
316 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
317 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
318
319 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
320 - add missing files to rpm package
321
322 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
323 - mtail.py -s for SFA
324 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
325
326 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
327 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
328
329 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
330 - plc-config-tty now has a validator on booleans
331 - e.g. entering 'True' now is rejected rather than silently recording 'false'
332
333 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
334 - disable mod_wsgi
335
336 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
337 - module name changes
338 - start wsgi support
339
340 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
341 - new setting PLC_RESERVATION_GRANULARITY
342
343 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
344 - * partial-repo.sh script
345 - * preserve key along with certificates
346
347 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
348 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
349
350 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
351 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
352 - new OMF category in the config
353 - create the drl system slice
354
355 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
356 - first working version of 5.0:
357 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
358 - nodefamily is 3-fold with pldistro-fcdistro-arch
359 - new PLC_FLAVOUR config category
360 - reviewed module layout
361 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
362
363 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
364 - support for fedora 12
365 - new package myplc-config for use by sfa
366 - drupal user registration turned off
367
368 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
369 - - fix to make sure when API, BOOT, MONITOR are on the same
370 - machine as WWW that the SSL key,cert for WWW takes precedence.
371 - - Do proper setup for SSL CA certficate to be used as the server
372 - chain.
373
374 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
375 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
376
377 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
378 - depend on pcucontrol
379
380 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
381 - * validate input according to type in plc_config
382 - * added the _genicw system slice
383 - * add tag types for sites and persons
384 - * add new tags for nodes and slices for exemption from myops
385
386 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
387 - turn off drupal on a box that acts as BOOT server but not as WWW server
388 - cleanup some obsolete code for old chroot-jail packaging in the process
389 - new bootcd-kernel script for keeping bootcd variants up2date
390
391 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
392 - Make the /etc/hosts manipulation optional.
393
394 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
395 - Fix SetRole.
396
397 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
398 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
399 - into the DB.
400 - - Added the root ssh key handling support back into plc.d/ssh and the
401 - default xml file.  This should be identical to the way it was in
402 - rc12.
403 - - Added support in the db-config.d/01-init script to register the root
404 - ssh public key with the default administrator.  In this way the root
405 - ssh key will make it into the root account on the nodes by means of
406 - NodeManager's specialaccounts plugin.
407
408 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
409 - db-config ignores sliver tags
410 - sirius's db-config script renamed (was sirious)
411
412 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
413 - fix for silverauth - missing tag types now created at plc startup time
414
415 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
416 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
417
418 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
419 - companion to NM's specialaccounts plugin
420 - do not generate /etc/planetlab/root_ssh_key* anymore
421 - remove related config. variables and conf_files
422
423 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
424 - clarified description text to refer only to plcrt and not other optional
425 - packages.
426
427 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
428 - fixed a bug setting slice multiple attributes with the same tag name
429
430 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
431 - SSL setup for monitor box, and related new config variables
432 - new conf_file for /etc/planetlab/extensions
433 - various tweaks in db-config internals, about initscripts among others
434 - also more messages defined in the db
435
436 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
437 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
438
439 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
440 - bugfix in db-config, tag 4.3-19 would not fly
441
442 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
443 - Refactored db-config into snippets in db-config.d/.
444
445 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
446 - oops, tag 4.3-17 was broken and would not work
447
448 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
449 - bugfix - escape sequences inserted in xml configs
450
451 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
452 - Handle db-config.d files properly.
453
454 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
455 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
456 - than the log file
457 - - Fix db-config to be a bit more cautious when
458 - /etc/planetlab/db-config.d doesn''t exist
459 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
460 - .orig files.
461 - - Refactor generic plc-config-tty code into plc_config.py.
462 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
463 - and the list of validated variables and the corresponding
464 - validator() function. This refactoring lets one reuse plc_config.py
465 - as a generic cmdline configuration tool for highly customer MyPLC
466 - like software.
467
468 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
469 - update PCU Type descriptions.
470 - updates to init scripts
471
472 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
473 - requires monitor-pcucontrol so register-wizard can work
474
475 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
476 - cleaned up plc-config-tty, no more need to configure plc-devel
477
478 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
479 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
480
481 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
482 - fix issue in db-config that prevented correct operation
483
484 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
485 - remove support for chroot-based packaging - no crond nor syslog step anymore
486 - plc init script now named plc.init instead of former guest.init
487
488 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
489 - add Monitor to docs build
490
491 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
492 - plc_config.py and plc-config-tty: generalized to work for more diverse
493 - MyPLC configurations.
494 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
495 - deployments and increase the memory limits in php.ini
496 - plc.d/crond: add --full option to vacuumdb
497
498 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
499 - avoid generating ssl certificates for disabled services among www api boot
500
501 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
502 - cleaned up old entries in db-config
503 - mtail more robust
504
505 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
506 - php include path tweaked for plekit includes
507 - reviewed myplc (fka native) packaging dependencies
508 - renumbered 4.3
509
510 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
511 - rename myplc into myplc-chroot and myplc-native into myplc
512 - new settings (shortname & hrn_root) for local peer
513
514 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
515 - First iteration of new data model
516 - Bunch of various fixes
517
518 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
519 - Removed proper ops from planetflow slice.
520
521 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
522 - myplc-native requires myplc-docs
523 - fixed doc build by locating locally installed DTDs at build-time
524
525 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
526 - turn myplc-docs off for now
527
528 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
529 - figures in doc package
530
531 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
532 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
533 - chroot packaging does not have docs anymore
534 - 'cvs' and 'dev' not required from myplc-native anymore
535 - cosmetic change in kml output
536
537 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
538 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
539 - gethostbyname uses python rather than perl (hope this shrinks deps) 
540 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
541 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
542 - make sync now works towards vserver-based myplc only 
543
544 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
545
546 - added vsys 'pfmount' script to the default netflow slice attributes.
547
548
549 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
550 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
551 - to new bootcd packaging
552
553 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
554 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
555
556 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
557 - packaging of mplc-release in myplc-native
558 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
559 - resolv file in /etc/resolv.conf, not plc_resolv.conf
560 - improved sirius script
561 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
562 - expires more properly set 
563
564 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
565
566
567 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
568 - renew_reminder script moved to support-scripts/
569 - gen-aliases script added in support-scripts/
570 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
571 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
572 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
573 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
574 - new setting 'Mom list address' for sending emails to a separate destination
575 - starts rsyslogd/syslogd as appropriate
576 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
577 - convenience generation of yum.conf in resulting image based on build/mirroring
578
579 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
580 - refresh-peer.py removed (duplicate with PLCAPI)
581 - plc.d/ scripts cleaned up
582 - sirius initscript updated
583 - slice auto renewal fixed
584
585 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
586 - initial build.
587
588 %define module_current_branch 4.3