explicitly enable and start php-fpm when the rpm is found
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 #Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 Requires: cronie
56 # starting with f16 we depend on this new rpm
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
58 Requires: rpm-sign
59 %endif
60
61 # planetlab stuff
62 Requires: bootmanager
63 Requires: bootcd-%{nodefamily}
64 Requires: bootcd-initscripts
65 Requires: PLCWWW
66 Requires: www-register-wizard
67 Requires: nodeconfig
68 Requires: nodeyum
69 Requires: plcapi >= 5.2
70 # this technically is a plcapi dependency but it's simpler here for chosing which
71 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
72 Requires: mod_wsgi
73 %else
74 Requires: mod_python
75 %endif
76 Requires: nodeimage-%{nodefamily}
77 Requires: myplc-docs
78 Requires: myplc-release
79 Requires: myplc-config
80
81 %define debug_package %{nil}
82
83 %description 
84 MyPLC is a complete PlanetLab Central (PLC) portable installation.
85 The default installation consists of a web server, an XML-RPC API
86 server, a boot server, and a database server: the core components of
87 PLC. The installation may be customized through a graphical
88 interface. All PLC services are started up and shut down through a
89 single System V init script.
90
91 ####################### myplc-config
92
93 %package config
94
95 Summary: PlanetLab Central (PLC) configuration python module
96 Group: Applications/Systems
97 Requires: python
98
99 %description config
100 This package provides the Python module to configure MyPLC.
101
102
103 %prep
104 %setup -q
105
106 %build
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 # Install configuration scripts
112 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
113 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
114 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
115
116 echo "* Installing scripts in /usr/bin"
117 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
118 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
119 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
120 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
121
122 # Install initscript 
123 echo "* Installing plc initscript"
124 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
125 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
126
127 # Install initscripts
128 echo "* Installing plc.d initscripts"
129 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
130 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
131
132 # Install db-config.d files
133 echo "* Installing db-config.d files"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
136 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
137
138 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
139 echo "* Installing scripts in /etc/support-scripts"
140 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
141 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
142 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
143
144 # copy initscripts to etc/plc_sliceinitscripts
145 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
146 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
147 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
148
149 # Install configuration file
150 echo "* myplc: Installing configuration file"
151 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
152 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
153     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
154 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
155
156 echo "* Installing bashrc convenience"
157 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
158
159 # yumgroups.xml and yum repo : let noderepo handle that
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %pre
165 if [ -x %{_sysconfdir}/init.d/plc ] ; then
166     %{_sysconfdir}/init.d/plc stop
167 fi
168
169 # Old versions of myplc used to ship with a bootstrapped database and
170 # /etc/planetlab directory. Including generated files in the manifest
171 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
172 # names from one RPM build to another, it would be rpmsaved and thus
173 # effectively deleted. Now we do not include these files in the
174 # manifest. However, to avoid deleting these files in the process of
175 # upgrading from one of these old versions of myplc, we must back up
176 # the database and /etc/planetlab and restore them after the old
177 # version has been uninstalled in %triggerpostun (also in %post, in
178 # case we are force upgrading to the same version).
179 #
180 # This code can be removed once all myplc-0.4-1 installations have
181 # been upgraded to at least myplc-0.4-2.
182
183 # 0 = install, 1 = upgrade
184 if [ $1 -gt 0 ] ; then
185     for dir in /var/lib/pgsql/data /etc/planetlab ; do
186         if [ -d $dir ] ; then
187             echo "Preserving $dir"
188             mkdir -p $dir.rpmsave
189             tar -C $dir -cpf - . | \
190                tar -C $dir.rpmsave -xpf -
191
192             # Except for the default configuration file and DTD, which
193             # really should be considered for upgrade.
194             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
195         fi
196     done
197 fi
198
199 %post
200 if [ -x /sbin/chkconfig ] ; then
201     /sbin/chkconfig --add plc
202     /sbin/chkconfig plc on
203 fi
204 rpm -q php-fpm >& /dev/null && { systemctl enable php-fpm; systemctl start php-fpm; }
205
206 %triggerpostun -- %{name}
207 # 0 = erase, 1 = upgrade
208 if [ $1 -gt 0 ] ; then
209     for dir in /var/lib/pgsql/data /etc/planetlab ; do
210         if [ -d $dir.rpmsave -a -d $dir ] ; then
211             echo "Merging $dir"
212             if tar -C $dir.rpmsave -cpf - . | \
213                tar -C $dir -xpf - ; then
214                 rm -rf $dir.rpmsave
215             fi
216         fi
217     done
218 fi    
219
220 %preun
221 # 0 = erase, 1 = upgrade
222 if [ $1 -eq 0 ] ; then
223     %{_sysconfdir}/init.d/plc stop
224     if [ -x /sbin/chkconfig ] ; then
225         /sbin/chkconfig plc off
226         /sbin/chkconfig --del plc
227     fi
228 fi
229
230 %files
231 %defattr(-,root,root,-)
232 # Host startup script and configuration file
233 /etc/init.d/plc
234 /etc/plc.d
235 /etc/planetlab
236 /etc/plc_sliceinitscripts
237 /etc/support-scripts
238 /usr/share/myplc/bashrc
239 # keep a detailed list, to avoid duplicate of plc-config,
240 # that belongs to the myplc-config rpm
241 /usr/bin/plc-config-tty
242 /usr/bin/db-config
243 /usr/bin/dns-config
244 /usr/bin/refresh-peer.py*
245 /usr/bin/mtail.py*
246 /usr/bin/mtail
247 /usr/bin/plc-map.py*
248 /usr/bin/plc-kml.py*
249 /usr/bin/clean-empty-dirs.py*
250 /usr/bin/plc-check-ssl-peering.py*
251 /usr/bin/plc-orphan-accounts.py*
252 /usr/bin/spot-aliens.py*
253 /usr/bin/check-hrns.py*
254 /usr/bin/check-vsys-defaults.py*
255 /usr/bin/spot-dup-accounts.sh
256 /lib/systemd/system/plc.service
257
258 %files config
259 %defattr(-,root,root,-)
260 /usr/bin/plc-config
261 %{python_sitearch}/plc_config.py*
262
263
264 %changelog
265 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
266 - takes care of creating plcapi log file
267
268 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
269 - tweaked renew_reminder for federation
270
271 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
272 - tweaks in check-hrns.py
273 - do not require PyXML any more
274
275 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
276 - review check-hrns for plcapi-5.3
277 - add PLC_HRN_ROOT in usual plc-config-tty's settings
278
279 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
280 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
281 - add an rpm-sign dependency on feedora>=16
282
283 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
284 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
285
286 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
287 - plc.d/gpg now does not rm /dev/random but preserves it
288 - this is because libvirt won't let us run mknod
289
290 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
291 - fix typo in check-hrns - used to print 'host' while dealing with persons
292
293 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
294 - supports httpd config for either mod_python (preferred) or mod_wsgi
295 - requires mod_wsgi on f18 only, otherwise mod_python
296 - supports httpd config for apache 2.4 (f18)
297 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
298
299 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
300 - bugfix in check-vsys-defaults.py
301
302 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
303 - define open_basedir in php.ini to stop confidentiality leak
304 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
305 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
306 - new utilities check-hrns.py and check-vsys-defaults.py
307
308 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
309 - set TimeoutSec to 300 in plc.service
310 - remove ref to deprecated svn $URL$ in db-config usage
311
312 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
313 - expose mtail.py as simply mtail
314
315 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
316 - plc-kml.py now has support for nodegroups
317
318 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
319 - use nodeimage package instead of deprecated bootstrapfs
320 - has systemd-friendly startup script
321 - plc_reload moved to functions/ - no more service plc reload
322 - no svn keywords anymore
323
324 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
325 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
326
327 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
328 - new settings for myslice (comon&tophat) and monitor (db)
329 - removed mentions of chroot in description
330 - can redo myplc-docs on broken f12-latex
331 - set short_open_tag in php.ini
332 - fixes in gen-sites-xml (is that still used ?)
333 - partial-repo.sh has moved to 'build' where it more belongs
334 - tweaks in convenience tool 'mtail'
335
336 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
337 - fixed changelog, no change from 5.0-16
338
339 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
340 - requires ed for the plc.d/packages step
341 - sirius initscript to handle stop and restart
342
343 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
344 - ignore steps in db-config.d if they have a '.' or '~' in their name
345
346 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
347 - can redo myplc-docs without the doc for monitor
348
349 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
350 - no semantic change - just fixed specfile for git URL
351
352 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
353 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
354
355 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
356 - add missing files to rpm package
357
358 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
359 - mtail.py -s for SFA
360 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
361
362 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
363 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
364
365 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
366 - plc-config-tty now has a validator on booleans
367 - e.g. entering 'True' now is rejected rather than silently recording 'false'
368
369 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
370 - disable mod_wsgi
371
372 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
373 - module name changes
374 - start wsgi support
375
376 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
377 - new setting PLC_RESERVATION_GRANULARITY
378
379 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
380 - * partial-repo.sh script
381 - * preserve key along with certificates
382
383 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
384 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
385
386 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
387 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
388 - new OMF category in the config
389 - create the drl system slice
390
391 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
392 - first working version of 5.0:
393 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
394 - nodefamily is 3-fold with pldistro-fcdistro-arch
395 - new PLC_FLAVOUR config category
396 - reviewed module layout
397 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
398
399 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
400 - support for fedora 12
401 - new package myplc-config for use by sfa
402 - drupal user registration turned off
403
404 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
405 - - fix to make sure when API, BOOT, MONITOR are on the same
406 - machine as WWW that the SSL key,cert for WWW takes precedence.
407 - - Do proper setup for SSL CA certficate to be used as the server
408 - chain.
409
410 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
411 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
412
413 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
414 - depend on pcucontrol
415
416 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
417 - * validate input according to type in plc_config
418 - * added the _genicw system slice
419 - * add tag types for sites and persons
420 - * add new tags for nodes and slices for exemption from myops
421
422 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
423 - turn off drupal on a box that acts as BOOT server but not as WWW server
424 - cleanup some obsolete code for old chroot-jail packaging in the process
425 - new bootcd-kernel script for keeping bootcd variants up2date
426
427 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
428 - Make the /etc/hosts manipulation optional.
429
430 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
431 - Fix SetRole.
432
433 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
434 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
435 - into the DB.
436 - - Added the root ssh key handling support back into plc.d/ssh and the
437 - default xml file.  This should be identical to the way it was in
438 - rc12.
439 - - Added support in the db-config.d/01-init script to register the root
440 - ssh public key with the default administrator.  In this way the root
441 - ssh key will make it into the root account on the nodes by means of
442 - NodeManager's specialaccounts plugin.
443
444 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
445 - db-config ignores sliver tags
446 - sirius's db-config script renamed (was sirious)
447
448 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
449 - fix for silverauth - missing tag types now created at plc startup time
450
451 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
452 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
453
454 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
455 - companion to NM's specialaccounts plugin
456 - do not generate /etc/planetlab/root_ssh_key* anymore
457 - remove related config. variables and conf_files
458
459 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
460 - clarified description text to refer only to plcrt and not other optional
461 - packages.
462
463 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
464 - fixed a bug setting slice multiple attributes with the same tag name
465
466 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
467 - SSL setup for monitor box, and related new config variables
468 - new conf_file for /etc/planetlab/extensions
469 - various tweaks in db-config internals, about initscripts among others
470 - also more messages defined in the db
471
472 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
473 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
474
475 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
476 - bugfix in db-config, tag 4.3-19 would not fly
477
478 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
479 - Refactored db-config into snippets in db-config.d/.
480
481 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
482 - oops, tag 4.3-17 was broken and would not work
483
484 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
485 - bugfix - escape sequences inserted in xml configs
486
487 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
488 - Handle db-config.d files properly.
489
490 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
491 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
492 - than the log file
493 - - Fix db-config to be a bit more cautious when
494 - /etc/planetlab/db-config.d doesn''t exist
495 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
496 - .orig files.
497 - - Refactor generic plc-config-tty code into plc_config.py.
498 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
499 - and the list of validated variables and the corresponding
500 - validator() function. This refactoring lets one reuse plc_config.py
501 - as a generic cmdline configuration tool for highly customer MyPLC
502 - like software.
503
504 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
505 - update PCU Type descriptions.
506 - updates to init scripts
507
508 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
509 - requires monitor-pcucontrol so register-wizard can work
510
511 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
512 - cleaned up plc-config-tty, no more need to configure plc-devel
513
514 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
515 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
516
517 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
518 - fix issue in db-config that prevented correct operation
519
520 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
521 - remove support for chroot-based packaging - no crond nor syslog step anymore
522 - plc init script now named plc.init instead of former guest.init
523
524 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
525 - add Monitor to docs build
526
527 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
528 - plc_config.py and plc-config-tty: generalized to work for more diverse
529 - MyPLC configurations.
530 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
531 - deployments and increase the memory limits in php.ini
532 - plc.d/crond: add --full option to vacuumdb
533
534 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
535 - avoid generating ssl certificates for disabled services among www api boot
536
537 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
538 - cleaned up old entries in db-config
539 - mtail more robust
540
541 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
542 - php include path tweaked for plekit includes
543 - reviewed myplc (fka native) packaging dependencies
544 - renumbered 4.3
545
546 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
547 - rename myplc into myplc-chroot and myplc-native into myplc
548 - new settings (shortname & hrn_root) for local peer
549
550 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
551 - First iteration of new data model
552 - Bunch of various fixes
553
554 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
555 - Removed proper ops from planetflow slice.
556
557 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
558 - myplc-native requires myplc-docs
559 - fixed doc build by locating locally installed DTDs at build-time
560
561 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
562 - turn myplc-docs off for now
563
564 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
565 - figures in doc package
566
567 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
568 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
569 - chroot packaging does not have docs anymore
570 - 'cvs' and 'dev' not required from myplc-native anymore
571 - cosmetic change in kml output
572
573 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
574 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
575 - gethostbyname uses python rather than perl (hope this shrinks deps) 
576 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
577 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
578 - make sync now works towards vserver-based myplc only 
579
580 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
581
582 - added vsys 'pfmount' script to the default netflow slice attributes.
583
584
585 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
586 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
587 - to new bootcd packaging
588
589 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
590 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
591
592 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
593 - packaging of mplc-release in myplc-native
594 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
595 - resolv file in /etc/resolv.conf, not plc_resolv.conf
596 - improved sirius script
597 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
598 - expires more properly set 
599
600 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
601
602
603 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
604 - renew_reminder script moved to support-scripts/
605 - gen-aliases script added in support-scripts/
606 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
607 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
608 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
609 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
610 - new setting 'Mom list address' for sending emails to a separate destination
611 - starts rsyslogd/syslogd as appropriate
612 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
613 - convenience generation of yum.conf in resulting image based on build/mirroring
614
615 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
616 - refresh-peer.py removed (duplicate with PLCAPI)
617 - plc.d/ scripts cleaned up
618 - sirius initscript updated
619 - slice auto renewal fixed
620
621 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
622 - initial build.
623
624 %define module_current_branch 4.3