Setting tag myplc-4.3-47
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 47
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: PLCWWW
67 Requires: www-register-wizard
68 Requires: nodeconfig
69 Requires: PLCAPI
70 Requires: pcucontrol
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
77 %if "%{pldistro}" == "onelab"
78 Requires: dummynet_image
79 %endif
80
81 %define debug_package %{nil}
82
83 %description
84 MyPLC is a complete PlanetLab Central (PLC) portable installation
85 contained within a chroot jail. The default installation consists of a
86 web server, an XML-RPC API server, a boot server, and a database
87 server: the core components of PLC. The installation may be customized
88 through a graphical interface. All PLC services are started up and
89 shut down through a single System V init script installed in the host
90 system.
91
92 ####################### myplc-config
93
94 %package config
95
96 Summary: PlanetLab Central (PLC) configuration python module
97 Group: Applications/Systems
98 Requires: python
99
100 %description config
101 This package provides the Python module to configure MyPLC.
102
103
104 %prep
105 %setup -q
106
107 %build
108
109 %install
110 [ -d MyPLC] || ln -s myplc MyPLC
111 pushd MyPLC
112 rm -rf $RPM_BUILD_ROOT
113 ./build.sh %{pldistro} $RPM_BUILD_ROOT
114 popd
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 # If run under sudo
120 if [ -n "$SUDO_USER" ] ; then
121     # Allow user to delete the build directory
122     chown -h -R $SUDO_USER .
123     # Some temporary cdroot files like /var/empty/sshd and
124     # /usr/bin/sudo get created with non-readable permissions.
125     find . -not -perm +0600 -exec chmod u+rw {} \;
126     # Allow user to delete the built RPM(s)
127     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
128 fi
129
130 %pre
131 if [ -x %{_sysconfdir}/init.d/plc ] ; then
132     %{_sysconfdir}/init.d/plc stop
133 fi
134
135 # Old versions of myplc used to ship with a bootstrapped database and
136 # /etc/planetlab directory. Including generated files in the manifest
137 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
138 # names from one RPM build to another, it would be rpmsaved and thus
139 # effectively deleted. Now we do not include these files in the
140 # manifest. However, to avoid deleting these files in the process of
141 # upgrading from one of these old versions of myplc, we must back up
142 # the database and /etc/planetlab and restore them after the old
143 # version has been uninstalled in %triggerpostun (also in %post, in
144 # case we are force upgrading to the same version).
145 #
146 # This code can be removed once all myplc-0.4-1 installations have
147 # been upgraded to at least myplc-0.4-2.
148
149 # 0 = install, 1 = upgrade
150 if [ $1 -gt 0 ] ; then
151     for dir in /var/lib/pgsql/data /etc/planetlab ; do
152         if [ -d $dir ] ; then
153             echo "Preserving $dir"
154             mkdir -p $dir.rpmsave
155             tar -C $dir -cpf - . | \
156                tar -C $dir.rpmsave -xpf -
157
158             # Except for the default configuration file and DTD, which
159             # really should be considered for upgrade.
160             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
161         fi
162     done
163 fi
164
165 %post
166 if [ -x /sbin/chkconfig ] ; then
167     /sbin/chkconfig --add plc
168     /sbin/chkconfig plc on
169 fi
170
171 %triggerpostun -- %{name}
172 # 0 = erase, 1 = upgrade
173 if [ $1 -gt 0 ] ; then
174     for dir in /var/lib/pgsql/data /etc/planetlab ; do
175         if [ -d $dir.rpmsave -a -d $dir ] ; then
176             echo "Merging $dir"
177             if tar -C $dir.rpmsave -cpf - . | \
178                tar -C $dir -xpf - ; then
179                 rm -rf $dir.rpmsave
180             fi
181         fi
182     done
183 fi    
184
185 %preun
186 # 0 = erase, 1 = upgrade
187 if [ $1 -eq 0 ] ; then
188     %{_sysconfdir}/init.d/plc stop
189     if [ -x /sbin/chkconfig ] ; then
190         /sbin/chkconfig plc off
191         /sbin/chkconfig --del plc
192     fi
193 fi
194
195 %files
196 %defattr(-,root,root,-)
197 # Host startup script and configuration file
198 /etc/init.d/plc
199 /etc/plc.d
200 /etc/planetlab
201 /etc/plc_sliceinitscripts/sirius
202 /etc/support-scripts/gen_aliases.py*
203 /etc/support-scripts/renew_reminder.py*
204 /etc/support-scripts/renew_reminder_logrotate
205 /usr/bin/plc-config-tty
206 /usr/bin/db-config
207 /usr/bin/dns-config
208 /usr/bin/plc-map.py*
209 /usr/bin/plc-kml.py*
210 /usr/bin/refresh-peer.py*
211 /usr/bin/clean-empty-dirs.py*
212 /usr/bin/mtail.py*
213 /usr/bin/plc-check-ssl-peering.py*
214 /usr/bin/plc-orphan-accounts.py*
215 /usr/share/myplc/bashrc
216
217 %files config
218 %defattr(-,root,root,-)
219 /usr/bin/plc-config
220 %{python_sitearch}/plc_config.py*
221
222
223 %changelog
224 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
225 - attempt to fix small glitches
226
227 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
228 - enable short_open_tag for backward compatibility
229
230 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
231 - Cherry-pick PHP5 timezone fix form master
232
233 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
234 - pick the greatest version as a kernel
235
236 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
237 - handle directory name changes for myplc-docs package as well
238
239 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
240 - handle directory name changes
241
242 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
243 - Use correct resolv.conf file.
244
245 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
246 - Make dnsmasq usable.
247
248 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
249 - Allow dnsmasq configuration to be extended.
250
251 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
252 - Add DRL slice.
253 - Generalize bootcd-kernel.
254
255 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
256 - support for fedora 12
257 - new package myplc-config for use by sfa
258 - drupal user registration turned off
259
260 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
261 - - fix to make sure when API, BOOT, MONITOR are on the same
262 - machine as WWW that the SSL key,cert for WWW takes precedence.
263 - - Do proper setup for SSL CA certficate to be used as the server
264 - chain.
265
266 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
267 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
268
269 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
270 - depend on pcucontrol
271
272 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
273 - * validate input according to type in plc_config
274 - * added the _genicw system slice
275 - * add tag types for sites and persons
276 - * add new tags for nodes and slices for exemption from myops
277
278 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
279 - turn off drupal on a box that acts as BOOT server but not as WWW server
280 - cleanup some obsolete code for old chroot-jail packaging in the process
281 - new bootcd-kernel script for keeping bootcd variants up2date
282
283 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
284 - Make the /etc/hosts manipulation optional.
285
286 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
287 - Fix SetRole.
288
289 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
290 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
291 - into the DB.
292 - - Added the root ssh key handling support back into plc.d/ssh and the
293 - default xml file.  This should be identical to the way it was in
294 - rc12.
295 - - Added support in the db-config.d/01-init script to register the root
296 - ssh public key with the default administrator.  In this way the root
297 - ssh key will make it into the root account on the nodes by means of
298 - NodeManager's specialaccounts plugin.
299
300 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
301 - db-config ignores sliver tags
302 - sirius's db-config script renamed (was sirious)
303
304 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
305 - fix for silverauth - missing tag types now created at plc startup time
306
307 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
308 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
309
310 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
311 - companion to NM's specialaccounts plugin
312 - do not generate /etc/planetlab/root_ssh_key* anymore
313 - remove related config. variables and conf_files
314
315 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
316 - clarified description text to refer only to plcrt and not other optional
317 - packages.
318
319 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
320 - fixed a bug setting slice multiple attributes with the same tag name
321
322 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
323 - SSL setup for monitor box, and related new config variables
324 - new conf_file for /etc/planetlab/extensions
325 - various tweaks in db-config internals, about initscripts among others
326 - also more messages defined in the db
327
328 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
329 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
330
331 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
332 - bugfix in db-config, tag 4.3-19 would not fly
333
334 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
335 - Refactored db-config into snippets in db-config.d/.
336
337 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
338 - oops, tag 4.3-17 was broken and would not work
339
340 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
341 - bugfix - escape sequences inserted in xml configs
342
343 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
344 - Handle db-config.d files properly.
345
346 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
347 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
348 - than the log file
349 - - Fix db-config to be a bit more cautious when
350 - /etc/planetlab/db-config.d doesn't exist
351 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
352 - .orig files.
353 - - Refactor generic plc-config-tty code into plc_config.py.
354 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
355 - and the list of validated variables and the corresponding
356 - validator() function. This refactoring lets one reuse plc_config.py
357 - as a generic cmdline configuration tool for highly customer MyPLC
358 - like software.
359
360 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
361 - update PCU Type descriptions.
362 - updates to init scripts
363
364 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
365 - requires monitor-pcucontrol so register-wizard can work
366
367 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
368 - cleaned up plc-config-tty, no more need to configure plc-devel
369
370 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
371 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
372
373 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
374 - fix issue in db-config that prevented correct operation
375
376 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
377 - remove support for chroot-based packaging - no crond nor syslog step anymore
378 - plc init script now named plc.init instead of former guest.init
379
380 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
381 - add Monitor to docs build
382
383 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
384 - plc_config.py and plc-config-tty: generalized to work for more diverse
385 - MyPLC configurations.
386 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
387 - deployments and increase the memory limits in php.ini
388 - plc.d/crond: add --full option to vacuumdb
389
390 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
391 - avoid generating ssl certificates for disabled services among www api boot
392
393 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
394 - cleaned up old entries in db-config
395 - mtail more robust
396
397 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
398 - php include path tweaked for plekit includes
399 - reviewed myplc (fka native) packaging dependencies
400 - renumbered 4.3
401
402 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
403 - rename myplc into myplc-chroot and myplc-native into myplc
404 - new settings (shortname & hrn_root) for local peer
405
406 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
407 - First iteration of new data model
408 - Bunch of various fixes
409
410 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
411 - Removed proper ops from planetflow slice.
412
413 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
414 - myplc-native requires myplc-docs
415 - fixed doc build by locating locally installed DTDs at build-time
416
417 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
418 - turn myplc-docs off for now
419
420 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
421 - figures in doc package
422
423 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
424 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
425 - chroot packaging does not have docs anymore
426 - 'cvs' and 'dev' not required from myplc-native anymore
427 - cosmetic change in kml output
428
429 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
430 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
431 - gethostbyname uses python rather than perl (hope this shrinks deps) 
432 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
433 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
434 - make sync now works towards vserver-based myplc only 
435
436 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
437
438 - added vsys 'pfmount' script to the default netflow slice attributes.
439
440
441 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
442 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
443 - to new bootcd packaging
444
445 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
446 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
447
448 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
449 - packaging of mplc-release in myplc-native
450 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
451 - resolv file in /etc/resolv.conf, not plc_resolv.conf
452 - improved sirius script
453 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
454 - expires more properly set 
455
456 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
457
458
459 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
460 - renew_reminder script moved to support-scripts/
461 - gen-aliases script added in support-scripts/
462 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
463 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
464 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
465 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
466 - new setting 'Mom list address' for sending emails to a separate destination
467 - starts rsyslogd/syslogd as appropriate
468 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
469 - convenience generation of yum.conf in resulting image based on build/mirroring
470
471 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
472 - refresh-peer.py removed (duplicate with PLCAPI)
473 - plc.d/ scripts cleaned up
474 - sirius initscript updated
475 - slice auto renewal fixed
476
477 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
478 - initial build.
479
480 %define module_current_branch 4.2