Setting tag myplc-4.3-40
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 40
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: PLCWWW
67 Requires: www-register-wizard
68 Requires: nodeconfig
69 Requires: PLCAPI
70 Requires: pcucontrol
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
77 %if "%{pldistro}" == "onelab"
78 Requires: dummynet_image
79 %endif
80
81 %define debug_package %{nil}
82
83 %description
84 MyPLC is a complete PlanetLab Central (PLC) portable installation
85 contained within a chroot jail. The default installation consists of a
86 web server, an XML-RPC API server, a boot server, and a database
87 server: the core components of PLC. The installation may be customized
88 through a graphical interface. All PLC services are started up and
89 shut down through a single System V init script installed in the host
90 system.
91
92 ####################### myplc-config
93
94 %package config
95
96 Summary: PlanetLab Central (PLC) configuration python module
97 Group: Applications/Systems
98 Requires: python
99
100 %description config
101 This package provides the Python module to configure MyPLC.
102
103
104 %prep
105 %setup -q
106
107 %build
108
109 %install
110 pushd MyPLC
111 rm -rf $RPM_BUILD_ROOT
112 ./build.sh %{pldistro} $RPM_BUILD_ROOT
113 popd
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 # If run under sudo
119 if [ -n "$SUDO_USER" ] ; then
120     # Allow user to delete the build directory
121     chown -h -R $SUDO_USER .
122     # Some temporary cdroot files like /var/empty/sshd and
123     # /usr/bin/sudo get created with non-readable permissions.
124     find . -not -perm +0600 -exec chmod u+rw {} \;
125     # Allow user to delete the built RPM(s)
126     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
127 fi
128
129 %pre
130 if [ -x %{_sysconfdir}/init.d/plc ] ; then
131     %{_sysconfdir}/init.d/plc stop
132 fi
133
134 # Old versions of myplc used to ship with a bootstrapped database and
135 # /etc/planetlab directory. Including generated files in the manifest
136 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
137 # names from one RPM build to another, it would be rpmsaved and thus
138 # effectively deleted. Now we do not include these files in the
139 # manifest. However, to avoid deleting these files in the process of
140 # upgrading from one of these old versions of myplc, we must back up
141 # the database and /etc/planetlab and restore them after the old
142 # version has been uninstalled in %triggerpostun (also in %post, in
143 # case we are force upgrading to the same version).
144 #
145 # This code can be removed once all myplc-0.4-1 installations have
146 # been upgraded to at least myplc-0.4-2.
147
148 # 0 = install, 1 = upgrade
149 if [ $1 -gt 0 ] ; then
150     for dir in /var/lib/pgsql/data /etc/planetlab ; do
151         if [ -d $dir ] ; then
152             echo "Preserving $dir"
153             mkdir -p $dir.rpmsave
154             tar -C $dir -cpf - . | \
155                tar -C $dir.rpmsave -xpf -
156
157             # Except for the default configuration file and DTD, which
158             # really should be considered for upgrade.
159             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
160         fi
161     done
162 fi
163
164 %post
165 if [ -x /sbin/chkconfig ] ; then
166     /sbin/chkconfig --add plc
167     /sbin/chkconfig plc on
168 fi
169
170 %triggerpostun -- %{name}
171 # 0 = erase, 1 = upgrade
172 if [ $1 -gt 0 ] ; then
173     for dir in /var/lib/pgsql/data /etc/planetlab ; do
174         if [ -d $dir.rpmsave -a -d $dir ] ; then
175             echo "Merging $dir"
176             if tar -C $dir.rpmsave -cpf - . | \
177                tar -C $dir -xpf - ; then
178                 rm -rf $dir.rpmsave
179             fi
180         fi
181     done
182 fi    
183
184 %preun
185 # 0 = erase, 1 = upgrade
186 if [ $1 -eq 0 ] ; then
187     %{_sysconfdir}/init.d/plc stop
188     if [ -x /sbin/chkconfig ] ; then
189         /sbin/chkconfig plc off
190         /sbin/chkconfig --del plc
191     fi
192 fi
193
194 %files
195 %defattr(-,root,root,-)
196 # Host startup script and configuration file
197 /etc/init.d/plc
198 /etc/plc.d
199 /etc/planetlab
200 /etc/plc_sliceinitscripts/sirius
201 /etc/support-scripts/gen_aliases.py*
202 /etc/support-scripts/renew_reminder.py*
203 /etc/support-scripts/renew_reminder_logrotate
204 /usr/bin/plc-config-tty
205 /usr/bin/db-config
206 /usr/bin/dns-config
207 /usr/bin/plc-map.py*
208 /usr/bin/plc-kml.py*
209 /usr/bin/refresh-peer.py*
210 /usr/bin/clean-empty-dirs.py*
211 /usr/bin/mtail.py*
212 /usr/bin/plc-check-ssl-peering.py*
213 /usr/bin/plc-orphan-accounts.py*
214 /usr/share/myplc/bashrc
215
216 %files config
217 %defattr(-,root,root,-)
218 /usr/bin/plc-config
219 %{python_sitearch}/plc_config.py*
220
221
222 %changelog
223 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
224 - Make dnsmasq usable.
225
226 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
227 - Allow dnsmasq configuration to be extended.
228
229 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
230 - Add DRL slice.
231 - Generalize bootcd-kernel.
232
233 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
234 - support for fedora 12
235 - new package myplc-config for use by sfa
236 - drupal user registration turned off
237
238 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
239 - - fix to make sure when API, BOOT, MONITOR are on the same
240 - machine as WWW that the SSL key,cert for WWW takes precedence.
241 - - Do proper setup for SSL CA certficate to be used as the server
242 - chain.
243
244 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
245 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
246
247 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
248 - depend on pcucontrol
249
250 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
251 - * validate input according to type in plc_config
252 - * added the _genicw system slice
253 - * add tag types for sites and persons
254 - * add new tags for nodes and slices for exemption from myops
255
256 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
257 - turn off drupal on a box that acts as BOOT server but not as WWW server
258 - cleanup some obsolete code for old chroot-jail packaging in the process
259 - new bootcd-kernel script for keeping bootcd variants up2date
260
261 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
262 - Make the /etc/hosts manipulation optional.
263
264 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
265 - Fix SetRole.
266
267 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
268 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
269 - into the DB.
270 - - Added the root ssh key handling support back into plc.d/ssh and the
271 - default xml file.  This should be identical to the way it was in
272 - rc12.
273 - - Added support in the db-config.d/01-init script to register the root
274 - ssh public key with the default administrator.  In this way the root
275 - ssh key will make it into the root account on the nodes by means of
276 - NodeManager's specialaccounts plugin.
277
278 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
279 - db-config ignores sliver tags
280 - sirius's db-config script renamed (was sirious)
281
282 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
283 - fix for silverauth - missing tag types now created at plc startup time
284
285 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
286 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
287
288 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
289 - companion to NM's specialaccounts plugin
290 - do not generate /etc/planetlab/root_ssh_key* anymore
291 - remove related config. variables and conf_files
292
293 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
294 - clarified description text to refer only to plcrt and not other optional
295 - packages.
296
297 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
298 - fixed a bug setting slice multiple attributes with the same tag name
299
300 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
301 - SSL setup for monitor box, and related new config variables
302 - new conf_file for /etc/planetlab/extensions
303 - various tweaks in db-config internals, about initscripts among others
304 - also more messages defined in the db
305
306 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
307 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
308
309 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
310 - bugfix in db-config, tag 4.3-19 would not fly
311
312 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
313 - Refactored db-config into snippets in db-config.d/.
314
315 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
316 - oops, tag 4.3-17 was broken and would not work
317
318 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
319 - bugfix - escape sequences inserted in xml configs
320
321 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
322 - Handle db-config.d files properly.
323
324 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
325 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
326 - than the log file
327 - - Fix db-config to be a bit more cautious when
328 - /etc/planetlab/db-config.d doesn't exist
329 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
330 - .orig files.
331 - - Refactor generic plc-config-tty code into plc_config.py.
332 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
333 - and the list of validated variables and the corresponding
334 - validator() function. This refactoring lets one reuse plc_config.py
335 - as a generic cmdline configuration tool for highly customer MyPLC
336 - like software.
337
338 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
339 - update PCU Type descriptions.
340 - updates to init scripts
341
342 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
343 - requires monitor-pcucontrol so register-wizard can work
344
345 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
346 - cleaned up plc-config-tty, no more need to configure plc-devel
347
348 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
349 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
350
351 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
352 - fix issue in db-config that prevented correct operation
353
354 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
355 - remove support for chroot-based packaging - no crond nor syslog step anymore
356 - plc init script now named plc.init instead of former guest.init
357
358 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
359 - add Monitor to docs build
360
361 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
362 - plc_config.py and plc-config-tty: generalized to work for more diverse
363 - MyPLC configurations.
364 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
365 - deployments and increase the memory limits in php.ini
366 - plc.d/crond: add --full option to vacuumdb
367
368 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
369 - avoid generating ssl certificates for disabled services among www api boot
370
371 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
372 - cleaned up old entries in db-config
373 - mtail more robust
374
375 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
376 - php include path tweaked for plekit includes
377 - reviewed myplc (fka native) packaging dependencies
378 - renumbered 4.3
379
380 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
381 - rename myplc into myplc-chroot and myplc-native into myplc
382 - new settings (shortname & hrn_root) for local peer
383
384 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
385 - First iteration of new data model
386 - Bunch of various fixes
387
388 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
389 - Removed proper ops from planetflow slice.
390
391 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
392 - myplc-native requires myplc-docs
393 - fixed doc build by locating locally installed DTDs at build-time
394
395 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
396 - turn myplc-docs off for now
397
398 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
399 - figures in doc package
400
401 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
402 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
403 - chroot packaging does not have docs anymore
404 - 'cvs' and 'dev' not required from myplc-native anymore
405 - cosmetic change in kml output
406
407 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
408 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
409 - gethostbyname uses python rather than perl (hope this shrinks deps) 
410 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
411 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
412 - make sync now works towards vserver-based myplc only 
413
414 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
415
416 - added vsys 'pfmount' script to the default netflow slice attributes.
417
418
419 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
420 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
421 - to new bootcd packaging
422
423 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
424 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
425
426 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
427 - packaging of mplc-release in myplc-native
428 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
429 - resolv file in /etc/resolv.conf, not plc_resolv.conf
430 - improved sirius script
431 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
432 - expires more properly set 
433
434 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
435
436
437 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
438 - renew_reminder script moved to support-scripts/
439 - gen-aliases script added in support-scripts/
440 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
441 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
442 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
443 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
444 - new setting 'Mom list address' for sending emails to a separate destination
445 - starts rsyslogd/syslogd as appropriate
446 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
447 - convenience generation of yum.conf in resulting image based on build/mirroring
448
449 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
450 - refresh-peer.py removed (duplicate with PLCAPI)
451 - plc.d/ scripts cleaned up
452 - sirius initscript updated
453 - slice auto renewal fixed
454
455 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
456 - initial build.
457
458 %define module_current_branch 4.2