cleanup myplc
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 37
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: bootcd-initscripts
67 Requires: PLCWWW
68 Requires: www-register-wizard
69 Requires: nodeconfig
70 Requires: PLCAPI
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 %define debug_package %{nil}
77
78 %description
79 MyPLC is a complete PlanetLab Central (PLC) portable installation
80 contained within a chroot jail. The default installation consists of a
81 web server, an XML-RPC API server, a boot server, and a database
82 server: the core components of PLC. The installation may be customized
83 through a graphical interface. All PLC services are started up and
84 shut down through a single System V init script installed in the host
85 system.
86
87 ####################### myplc-config
88
89 %package config
90
91 Summary: PlanetLab Central (PLC) configuration python module
92 Group: Applications/Systems
93 Requires: python
94
95 %description config
96 This package provides the Python module to configure MyPLC.
97
98
99 %prep
100 %setup -q
101
102 %build
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 # Install configuration scripts
108 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
109 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
110 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
111
112 echo "* Installing scripts in /usr/bin"
113 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
114 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
115 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
116
117 # Install initscript 
118 echo "* Installing plc initscript"
119 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
120
121 # Install initscripts
122 echo "* Installing plc.d initscripts"
123 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
124 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
125
126 # Install db-config.d files
127 echo "* Installing db-config.d files"
128 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
129 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
130 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
131
132 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
133 echo "* Installing scripts in /etc/support-scripts"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
135 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
136 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
137
138 # copy initscripts to etc/plc_sliceinitscripts
139 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
140 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
141 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
142
143 # Install configuration file
144 echo "* myplc: Installing configuration file"
145 install -D -m 444 default_config.xml ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
146 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
147
148 echo "* Installing bashrc convenience"
149 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
150
151 # yumgroups.xml and yum repo : let noderepo handle that
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %pre
157 if [ -x %{_sysconfdir}/init.d/plc ] ; then
158     %{_sysconfdir}/init.d/plc stop
159 fi
160
161 # Old versions of myplc used to ship with a bootstrapped database and
162 # /etc/planetlab directory. Including generated files in the manifest
163 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
164 # names from one RPM build to another, it would be rpmsaved and thus
165 # effectively deleted. Now we do not include these files in the
166 # manifest. However, to avoid deleting these files in the process of
167 # upgrading from one of these old versions of myplc, we must back up
168 # the database and /etc/planetlab and restore them after the old
169 # version has been uninstalled in %triggerpostun (also in %post, in
170 # case we are force upgrading to the same version).
171 #
172 # This code can be removed once all myplc-0.4-1 installations have
173 # been upgraded to at least myplc-0.4-2.
174
175 # 0 = install, 1 = upgrade
176 if [ $1 -gt 0 ] ; then
177     for dir in /var/lib/pgsql/data /etc/planetlab ; do
178         if [ -d $dir ] ; then
179             echo "Preserving $dir"
180             mkdir -p $dir.rpmsave
181             tar -C $dir -cpf - . | \
182                tar -C $dir.rpmsave -xpf -
183
184             # Except for the default configuration file and DTD, which
185             # really should be considered for upgrade.
186             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
187         fi
188     done
189 fi
190
191 %post
192 if [ -x /sbin/chkconfig ] ; then
193     /sbin/chkconfig --add plc
194     /sbin/chkconfig plc on
195 fi
196
197 %triggerpostun -- %{name}
198 # 0 = erase, 1 = upgrade
199 if [ $1 -gt 0 ] ; then
200     for dir in /var/lib/pgsql/data /etc/planetlab ; do
201         if [ -d $dir.rpmsave -a -d $dir ] ; then
202             echo "Merging $dir"
203             if tar -C $dir.rpmsave -cpf - . | \
204                tar -C $dir -xpf - ; then
205                 rm -rf $dir.rpmsave
206             fi
207         fi
208     done
209 fi    
210
211 %preun
212 # 0 = erase, 1 = upgrade
213 if [ $1 -eq 0 ] ; then
214     %{_sysconfdir}/init.d/plc stop
215     if [ -x /sbin/chkconfig ] ; then
216         /sbin/chkconfig plc off
217         /sbin/chkconfig --del plc
218     fi
219 fi
220
221 %files
222 %defattr(-,root,root,-)
223 # Host startup script and configuration file
224 /etc/init.d/plc
225 /etc/plc.d
226 /etc/planetlab
227 /etc/plc_sliceinitscripts
228 /etc/support-scripts
229 /usr/bin/
230 /usr/share/myplc/bashrc
231
232 %files config
233 %defattr(-,root,root,-)
234 /usr/bin/plc-config
235 %{python_sitearch}/plc_config.py*
236
237
238 %changelog
239 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
240 - support for fedora 12
241 - new package myplc-config for use by sfa
242 - drupal user registration turned off
243
244 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
245 - - fix to make sure when API, BOOT, MONITOR are on the same
246 - machine as WWW that the SSL key,cert for WWW takes precedence.
247 - - Do proper setup for SSL CA certficate to be used as the server
248 - chain.
249
250 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
251 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
252
253 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
254 - depend on pcucontrol
255
256 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
257 - * validate input according to type in plc_config
258 - * added the _genicw system slice
259 - * add tag types for sites and persons
260 - * add new tags for nodes and slices for exemption from myops
261
262 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
263 - turn off drupal on a box that acts as BOOT server but not as WWW server
264 - cleanup some obsolete code for old chroot-jail packaging in the process
265 - new bootcd-kernel script for keeping bootcd variants up2date
266
267 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
268 - Make the /etc/hosts manipulation optional.
269
270 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
271 - Fix SetRole.
272
273 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
274 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
275 - into the DB.
276 - - Added the root ssh key handling support back into plc.d/ssh and the
277 - default xml file.  This should be identical to the way it was in
278 - rc12.
279 - - Added support in the db-config.d/01-init script to register the root
280 - ssh public key with the default administrator.  In this way the root
281 - ssh key will make it into the root account on the nodes by means of
282 - NodeManager's specialaccounts plugin.
283
284 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
285 - db-config ignores sliver tags
286 - sirius's db-config script renamed (was sirious)
287
288 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
289 - fix for silverauth - missing tag types now created at plc startup time
290
291 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
292 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
293
294 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
295 - companion to NM's specialaccounts plugin
296 - do not generate /etc/planetlab/root_ssh_key* anymore
297 - remove related config. variables and conf_files
298
299 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
300 - clarified description text to refer only to plcrt and not other optional
301 - packages.
302
303 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
304 - fixed a bug setting slice multiple attributes with the same tag name
305
306 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
307 - SSL setup for monitor box, and related new config variables
308 - new conf_file for /etc/planetlab/extensions
309 - various tweaks in db-config internals, about initscripts among others
310 - also more messages defined in the db
311
312 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
313 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
314
315 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
316 - bugfix in db-config, tag 4.3-19 would not fly
317
318 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
319 - Refactored db-config into snippets in db-config.d/.
320
321 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
322 - oops, tag 4.3-17 was broken and would not work
323
324 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
325 - bugfix - escape sequences inserted in xml configs
326
327 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
328 - Handle db-config.d files properly.
329
330 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
331 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
332 - than the log file
333 - - Fix db-config to be a bit more cautious when
334 - /etc/planetlab/db-config.d doesn''t exist
335 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
336 - .orig files.
337 - - Refactor generic plc-config-tty code into plc_config.py.
338 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
339 - and the list of validated variables and the corresponding
340 - validator() function. This refactoring lets one reuse plc_config.py
341 - as a generic cmdline configuration tool for highly customer MyPLC
342 - like software.
343
344 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
345 - update PCU Type descriptions.
346 - updates to init scripts
347
348 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
349 - requires monitor-pcucontrol so register-wizard can work
350
351 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
352 - cleaned up plc-config-tty, no more need to configure plc-devel
353
354 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
355 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
356
357 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
358 - fix issue in db-config that prevented correct operation
359
360 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
361 - remove support for chroot-based packaging - no crond nor syslog step anymore
362 - plc init script now named plc.init instead of former guest.init
363
364 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
365 - add Monitor to docs build
366
367 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
368 - plc_config.py and plc-config-tty: generalized to work for more diverse
369 - MyPLC configurations.
370 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
371 - deployments and increase the memory limits in php.ini
372 - plc.d/crond: add --full option to vacuumdb
373
374 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
375 - avoid generating ssl certificates for disabled services among www api boot
376
377 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
378 - cleaned up old entries in db-config
379 - mtail more robust
380
381 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
382 - php include path tweaked for plekit includes
383 - reviewed myplc (fka native) packaging dependencies
384 - renumbered 4.3
385
386 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
387 - rename myplc into myplc-chroot and myplc-native into myplc
388 - new settings (shortname & hrn_root) for local peer
389
390 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
391 - First iteration of new data model
392 - Bunch of various fixes
393
394 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
395 - Removed proper ops from planetflow slice.
396
397 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
398 - myplc-native requires myplc-docs
399 - fixed doc build by locating locally installed DTDs at build-time
400
401 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
402 - turn myplc-docs off for now
403
404 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
405 - figures in doc package
406
407 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
408 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
409 - chroot packaging does not have docs anymore
410 - 'cvs' and 'dev' not required from myplc-native anymore
411 - cosmetic change in kml output
412
413 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
414 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
415 - gethostbyname uses python rather than perl (hope this shrinks deps) 
416 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
417 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
418 - make sync now works towards vserver-based myplc only 
419
420 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
421
422 - added vsys 'pfmount' script to the default netflow slice attributes.
423
424
425 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
426 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
427 - to new bootcd packaging
428
429 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
430 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
431
432 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
433 - packaging of mplc-release in myplc-native
434 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
435 - resolv file in /etc/resolv.conf, not plc_resolv.conf
436 - improved sirius script
437 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
438 - expires more properly set 
439
440 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
441
442
443 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
444 - renew_reminder script moved to support-scripts/
445 - gen-aliases script added in support-scripts/
446 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
447 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
448 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
449 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
450 - new setting 'Mom list address' for sending emails to a separate destination
451 - starts rsyslogd/syslogd as appropriate
452 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
453 - convenience generation of yum.conf in resulting image based on build/mirroring
454
455 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
456 - refresh-peer.py removed (duplicate with PLCAPI)
457 - plc.d/ scripts cleaned up
458 - sirius initscript updated
459 - slice auto renewal fixed
460
461 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
462 - initial build.
463
464 %define module_current_branch 4.2