- merge revision 1.25
[myplc.git] / myplc.spec
1 Vendor: PlanetLab
2 Packager: PlanetLab Central <support@planet-lab.org>
3 Distribution: PlanetLab 4.0
4 URL: http://cvs.planet-lab.org/cvs/myplc
5
6 Summary: PlanetLab Central (PLC) Portable Installation
7 Name: myplc
8 Version: 0.4
9 Release: 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 License: PlanetLab
11 Group: Applications/Systems
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15 %define debug_package %{nil}
16
17 %description
18 MyPLC is a complete PlanetLab Central (PLC) portable installation
19 contained within a chroot jail. The default installation consists of a
20 web server, an XML-RPC API server, a boot server, and a database
21 server: the core components of PLC. The installation may be customized
22 through a graphical interface. All PLC services are started up and
23 shut down through a single System V init script installed in the host
24 system.
25
26 %package devel
27 Summary: PlanetLab Central (PLC) Development Environment
28 Group: Development/Tools
29 AutoReqProv: no
30
31 %description devel
32 This package install a complete PlanetLab development environment
33 contained within a chroot jail. The default installation consists of a
34 local CVS repository bootstrapped with a snapshot of all PlanetLab
35 source code, and all the tools necessary to compile it.
36
37 %prep
38 %setup -q
39
40 %build
41 pushd myplc
42 ./build_devel.sh %{?cvstag:-t %{cvstag}}
43 ./build.sh %{?cvstag:-t %{cvstag}}
44 popd
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 pushd myplc
50
51 #
52 # myplc
53 #
54
55 # Install host startup script and configuration file
56 install -D -m 755 host.init $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/plc
57 install -D -m 644 plc.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/plc
58
59 # Create convenient symlink
60 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}
61 ln -sf /plc/data/etc/planetlab $RPM_BUILD_ROOT/%{_sysconfdir}/planetlab
62
63 # Install root filesystem
64 install -d -m 755 $RPM_BUILD_ROOT/plc/root
65 install -D -m 644 root.img $RPM_BUILD_ROOT/plc/root.img
66
67 # Install data directory
68 find data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
69
70 #
71 # myplc-devel
72 #
73
74 # Install host startup script and configuration file
75 install -D -m 755 host.init $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/plc-devel
76 install -D -m 644 plc-devel.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/plc-devel
77
78 # Install root filesystem
79 install -d -m 755 $RPM_BUILD_ROOT/plc/devel/root
80 install -D -m 644 devel/root.img $RPM_BUILD_ROOT/plc/devel/root.img
81
82 # Install data directory
83 find devel/data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
84
85 # Make sure /cvs is never upgraded once installed by giving it a
86 # unique name. A hard-linked copy is made in %post.
87 mv $RPM_BUILD_ROOT/plc/devel/data/{cvs,cvs-%{version}-%{release}}
88
89 popd
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 # If run under sudo
95 if [ -n "$SUDO_USER" ] ; then
96     # Allow user to delete the build directory
97     chown -R $SUDO_USER .
98     # Some temporary cdroot files like /var/empty/sshd and
99     # /usr/bin/sudo get created with non-readable permissions.
100     find . -not -perm +0600 -exec chmod u+rw {} \;
101     # Allow user to delete the built RPM(s)
102     chown -R $SUDO_USER %{_rpmdir}/%{_arch}
103 fi
104
105 %pre
106 if [ -x %{_sysconfdir}/init.d/plc ] ; then
107     %{_sysconfdir}/init.d/plc stop
108 fi
109
110 # Old versions of myplc used to ship with a bootstrapped database and
111 # /etc/planetlab directory. Including generated files in the manifest
112 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
113 # names from one RPM build to another, it would be rpmsaved and thus
114 # effectively deleted. Now we do not include these files in the
115 # manifest. However, to avoid deleting these files in the process of
116 # upgrading from one of these old versions of myplc, we must back up
117 # the database and /etc/planetlab and restore them after the old
118 # version has been uninstalled in %triggerpostun (also in %post, in
119 # case we are force upgrading to the same version).
120 #
121 # This code can be removed once all myplc-0.4-1 installations have
122 # been upgraded to at least myplc-0.4-2.
123
124 # 0 = install, 1 = upgrade
125 if [ $1 -gt 0 ] ; then
126     for dir in /var/lib/pgsql/data /etc/planetlab ; do
127         if [ -d /plc/data/$dir -a ! -d /plc/data/$dir.rpmsave ] ; then
128             echo "Preserving /plc/data/$dir"
129             cp -ra /plc/data/$dir{,.rpmsave}
130         fi
131     done
132 fi
133
134 %post
135 if [ -x /sbin/chkconfig ] ; then
136     /sbin/chkconfig --add plc
137     /sbin/chkconfig plc on
138 fi
139
140 for dir in /var/lib/pgsql/data /etc/planetlab ; do
141     if [ -d /plc/data/$dir.rpmsave -a -d /plc/data/$dir ] ; then
142         echo "Merging /plc/data/$dir"
143         if tar -C /plc/data/$dir.rpmsave -cpf - . | \
144             tar -C /plc/data/$dir -xpf - ; then
145             rm -rf /plc/data/$dir.rpmsave
146         fi
147     fi
148 done
149
150 # Force a regeneration to take into account new variables
151 touch /plc/data/etc/planetlab/default_config.xml
152
153 %triggerpostun -- %{name}
154 # 0 = erase, 1 = upgrade
155 if [ $1 -gt 0 ] ; then
156     for dir in /var/lib/pgsql/data /etc/planetlab ; do
157         if [ -d /plc/data/$dir.rpmsave -a -d /plc/data/$dir ] ; then
158             echo "Merging /plc/data/$dir"
159             if tar -C /plc/data/$dir.rpmsave -cpf - . | \
160                tar -C /plc/data/$dir -xpf - ; then
161                 rm -rf /plc/data/$dir.rpmsave
162             fi
163         fi
164     done
165 fi    
166
167 %preun
168 # 0 = erase, 1 = upgrade
169 if [ $1 -eq 0 ] ; then
170     %{_sysconfdir}/init.d/plc stop
171     if [ -x /sbin/chkconfig ] ; then
172         /sbin/chkconfig plc off
173         /sbin/chkconfig --del plc
174     fi
175 fi
176
177 %pre devel
178 if [ -x %{_sysconfdir}/init.d/plc-devel ] ; then
179     %{_sysconfdir}/init.d/plc-devel stop
180 fi
181
182 %post devel
183 if [ -x /sbin/chkconfig ] ; then
184     /sbin/chkconfig --add plc-devel
185     /sbin/chkconfig plc-devel on
186 fi
187
188 # If /cvs does not already exist, make a hard-linked copy of this
189 # version's /cvs repository.
190 if [ ! -d /plc/devel/data/cvs ] ; then
191     cp -rl /plc/devel/data/{cvs-%{version}-%{release},cvs}
192 fi
193
194 %preun devel
195 # 0 = erase, 1 = upgrade
196 if [ $1 -eq 0 ] ; then
197     %{_sysconfdir}/init.d/plc-devel stop
198     if [ -x /sbin/chkconfig ] ; then
199         /sbin/chkconfig plc-devel off
200         /sbin/chkconfig --del plc-devel
201     fi
202 fi
203
204 %files
205 %defattr(-,root,root,-)
206 # Host startup script and configuration file
207 %{_sysconfdir}/init.d/plc
208 %{_sysconfdir}/sysconfig/plc
209
210 # Symlink to /etc/planetlab within data directory
211 %{_sysconfdir}/planetlab
212
213 # Root filesystem
214 /plc/root.img
215 /plc/root
216
217 # Data directory
218 %dir /plc/data
219 %config(noreplace) /plc/data/*
220
221 %files devel
222 %defattr(-,root,root,-)
223 # Host startup script and configuration file
224 %{_sysconfdir}/init.d/plc-devel
225 %{_sysconfdir}/sysconfig/plc-devel
226
227 # Root filesystem
228 /plc/devel/root.img
229 /plc/devel/root
230
231 # Data directory
232 %dir /plc/devel/data
233 %config(noreplace) /plc/devel/data/*
234
235 %changelog
236 * Thu Jul 13 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-2, 0.5-2
237 - MyPLC 0.4 RC2.
238 - Fix many spec files (License replaces Copyright).
239 - Fix kernel build under gcc32 (module verification bug).
240 - Fix vnet build under gcc32
241 - Fix PlanetFlow. MySQL RPM postinstall script no longer starts the
242   server. Also, get hostnames list from PLC_WWW_HOST, not
243   www.planet-lab.org.
244 - Fix pl_mom/bwmon to use cached values if NM is unresponsive
245 - Fix pl_mom/swapmon reset logic to avoid endless loops
246 - Remove ksymoops, add kernel-smp to standard PlanetLab package group
247 - Add kernel-smp boot support to bootmanager
248 - Add badblock search support to bootmanager
249 - Build development environment (myplc-devel). Add support for
250   building myplc itself inside myplc-devel.
251 - Move step-specific initialization to appropriate plc.d scripts
252 - Fix postgresql startup failure when bootstrapping
253 - Allow CA to be configured for each SSL certificate set. Stop doing
254   root CA stuff, this is outside the scope of MyPLC. MyPLC now only
255   generates self-signed certificates, but supports replacement of the
256   self-signed certificates with real certifcates signed by another CA,
257   as long as the CA is specified.
258 - Self-sign the MA/SA SSL certificate (and by extension, the MA/SA API
259   certificate).
260 - pl_mom: Workarounds for when NM queries time out.
261 - plc_api: Honor PLC_MAIL_ENABLED.
262
263 * Wed Jul  6 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-1, 0.5-1
264 - First stable release of MyPLC 0.4 RC1.
265
266 * Wed Apr  5 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.2-1
267 - Basic functionality complete. Consolidate into a single package
268   installed in /plc.
269
270 * Fri Mar 17 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.1-1
271 - Initial build.
272