remove the postinstall and compute python site-packages path to install python module...
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 36
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: vixie-cron
45 Requires: yum
46 Requires: PyXML
47 Requires: createrepo
48 Requires: cpio
49 Requires: wget
50 Requires: php
51 Requires: openssh
52 Requires: dnsmasq
53 Requires: diffutils
54 Requires: gzip
55 Requires: vim-minimal
56 Requires: findutils
57 Requires: xmlsec1
58 Requires: xmlsec1-openssl
59 # planetlab stuff
60 Requires: bootmanager
61 Requires: bootcd-%{pldistro}-%{_arch}
62 Requires: PLCWWW
63 Requires: www-register-wizard
64 Requires: nodeconfig
65 Requires: PLCAPI
66 Requires: pcucontrol
67 Requires: bootstrapfs-%{pldistro}-%{_arch}
68 Requires: myplc-docs
69 Requires: myplc-release
70 Requires: myplc-config
71
72 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
73 %if "%{pldistro}" == "onelab"
74 Requires: dummynet_image
75 %endif
76
77 %define debug_package %{nil}
78
79 %description
80 MyPLC is a complete PlanetLab Central (PLC) portable installation
81 contained within a chroot jail. The default installation consists of a
82 web server, an XML-RPC API server, a boot server, and a database
83 server: the core components of PLC. The installation may be customized
84 through a graphical interface. All PLC services are started up and
85 shut down through a single System V init script installed in the host
86 system.
87
88 ####################### myplc-config
89
90 %package config
91
92 Summary: PlanetLab Central (PLC) configuration python module
93 Group: Applications/Systems
94 Requires: python
95
96 %description config
97 This package provides the Python module to configure MyPLC.
98
99
100 %prep
101 %setup -q
102
103 %build
104
105 %install
106 pushd MyPLC
107 rm -rf $RPM_BUILD_ROOT
108 ./build.sh %{pldistro} $RPM_BUILD_ROOT
109 popd
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 # If run under sudo
115 if [ -n "$SUDO_USER" ] ; then
116     # Allow user to delete the build directory
117     chown -h -R $SUDO_USER .
118     # Some temporary cdroot files like /var/empty/sshd and
119     # /usr/bin/sudo get created with non-readable permissions.
120     find . -not -perm +0600 -exec chmod u+rw {} \;
121     # Allow user to delete the built RPM(s)
122     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
123 fi
124
125 %pre
126 if [ -x %{_sysconfdir}/init.d/plc ] ; then
127     %{_sysconfdir}/init.d/plc stop
128 fi
129
130 # Old versions of myplc used to ship with a bootstrapped database and
131 # /etc/planetlab directory. Including generated files in the manifest
132 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
133 # names from one RPM build to another, it would be rpmsaved and thus
134 # effectively deleted. Now we do not include these files in the
135 # manifest. However, to avoid deleting these files in the process of
136 # upgrading from one of these old versions of myplc, we must back up
137 # the database and /etc/planetlab and restore them after the old
138 # version has been uninstalled in %triggerpostun (also in %post, in
139 # case we are force upgrading to the same version).
140 #
141 # This code can be removed once all myplc-0.4-1 installations have
142 # been upgraded to at least myplc-0.4-2.
143
144 # 0 = install, 1 = upgrade
145 if [ $1 -gt 0 ] ; then
146     for dir in /var/lib/pgsql/data /etc/planetlab ; do
147         if [ -d $dir ] ; then
148             echo "Preserving $dir"
149             mkdir -p $dir.rpmsave
150             tar -C $dir -cpf - . | \
151                tar -C $dir.rpmsave -xpf -
152
153             # Except for the default configuration file and DTD, which
154             # really should be considered for upgrade.
155             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
156         fi
157     done
158 fi
159
160 %post
161 if [ -x /sbin/chkconfig ] ; then
162     /sbin/chkconfig --add plc
163     /sbin/chkconfig plc on
164 fi
165
166 %triggerpostun -- %{name}
167 # 0 = erase, 1 = upgrade
168 if [ $1 -gt 0 ] ; then
169     for dir in /var/lib/pgsql/data /etc/planetlab ; do
170         if [ -d $dir.rpmsave -a -d $dir ] ; then
171             echo "Merging $dir"
172             if tar -C $dir.rpmsave -cpf - . | \
173                tar -C $dir -xpf - ; then
174                 rm -rf $dir.rpmsave
175             fi
176         fi
177     done
178 fi    
179
180 %preun
181 # 0 = erase, 1 = upgrade
182 if [ $1 -eq 0 ] ; then
183     %{_sysconfdir}/init.d/plc stop
184     if [ -x /sbin/chkconfig ] ; then
185         /sbin/chkconfig plc off
186         /sbin/chkconfig --del plc
187     fi
188 fi
189
190 %files
191 %defattr(-,root,root,-)
192 # Host startup script and configuration file
193 /etc/init.d/plc
194 /etc/plc.d
195 /etc/planetlab
196 /etc/plc_sliceinitscripts/sirius
197 /etc/support-scripts/gen_aliases.py*
198 /etc/support-scripts/renew_reminder.py*
199 /etc/support-scripts/renew_reminder_logrotate
200 /usr/bin/plc-config-tty
201 /usr/bin/db-config
202 /usr/bin/dns-config
203 /usr/bin/plc-map.py*
204 /usr/bin/plc-kml.py*
205 /usr/bin/refresh-peer.py*
206 /usr/bin/clean-empty-dirs.py*
207 /usr/bin/mtail.py*
208 /usr/bin/plc-check-ssl-peering.py*
209 /usr/bin/plc-orphan-accounts.py*
210 /usr/share/myplc/bashrc
211
212 %files config
213 %defattr(-,root,root,-)
214 /usr/bin/plc-config
215 %{python_sitearch}/plc_config.py*
216
217
218 %changelog
219 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
220 - - fix to make sure when API, BOOT, MONITOR are on the same
221 - machine as WWW that the SSL key,cert for WWW takes precedence.
222 - - Do proper setup for SSL CA certficate to be used as the server
223 - chain.
224
225 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
226 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
227
228 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
229 - depend on pcucontrol
230
231 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
232 - * validate input according to type in plc_config
233 - * added the _genicw system slice
234 - * add tag types for sites and persons
235 - * add new tags for nodes and slices for exemption from myops
236
237 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
238 - turn off drupal on a box that acts as BOOT server but not as WWW server
239 - cleanup some obsolete code for old chroot-jail packaging in the process
240 - new bootcd-kernel script for keeping bootcd variants up2date
241
242 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
243 - Make the /etc/hosts manipulation optional.
244
245 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
246 - Fix SetRole.
247
248 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
249 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
250 - into the DB.
251 - - Added the root ssh key handling support back into plc.d/ssh and the
252 - default xml file.  This should be identical to the way it was in
253 - rc12.
254 - - Added support in the db-config.d/01-init script to register the root
255 - ssh public key with the default administrator.  In this way the root
256 - ssh key will make it into the root account on the nodes by means of
257 - NodeManager's specialaccounts plugin.
258
259 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
260 - db-config ignores sliver tags
261 - sirius's db-config script renamed (was sirious)
262
263 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
264 - fix for silverauth - missing tag types now created at plc startup time
265
266 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
267 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
268
269 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
270 - companion to NM's specialaccounts plugin
271 - do not generate /etc/planetlab/root_ssh_key* anymore
272 - remove related config. variables and conf_files
273
274 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
275 - clarified description text to refer only to plcrt and not other optional
276 - packages.
277
278 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
279 - fixed a bug setting slice multiple attributes with the same tag name
280
281 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
282 - SSL setup for monitor box, and related new config variables
283 - new conf_file for /etc/planetlab/extensions
284 - various tweaks in db-config internals, about initscripts among others
285 - also more messages defined in the db
286
287 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
288 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
289
290 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
291 - bugfix in db-config, tag 4.3-19 would not fly
292
293 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
294 - Refactored db-config into snippets in db-config.d/.
295
296 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
297 - oops, tag 4.3-17 was broken and would not work
298
299 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
300 - bugfix - escape sequences inserted in xml configs
301
302 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
303 - Handle db-config.d files properly.
304
305 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
306 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
307 - than the log file
308 - - Fix db-config to be a bit more cautious when
309 - /etc/planetlab/db-config.d doesn't exist
310 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
311 - .orig files.
312 - - Refactor generic plc-config-tty code into plc_config.py.
313 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
314 - and the list of validated variables and the corresponding
315 - validator() function. This refactoring lets one reuse plc_config.py
316 - as a generic cmdline configuration tool for highly customer MyPLC
317 - like software.
318
319 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
320 - update PCU Type descriptions.
321 - updates to init scripts
322
323 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
324 - requires monitor-pcucontrol so register-wizard can work
325
326 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
327 - cleaned up plc-config-tty, no more need to configure plc-devel
328
329 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
330 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
331
332 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
333 - fix issue in db-config that prevented correct operation
334
335 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
336 - remove support for chroot-based packaging - no crond nor syslog step anymore
337 - plc init script now named plc.init instead of former guest.init
338
339 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
340 - add Monitor to docs build
341
342 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
343 - plc_config.py and plc-config-tty: generalized to work for more diverse
344 - MyPLC configurations.
345 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
346 - deployments and increase the memory limits in php.ini
347 - plc.d/crond: add --full option to vacuumdb
348
349 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
350 - avoid generating ssl certificates for disabled services among www api boot
351
352 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
353 - cleaned up old entries in db-config
354 - mtail more robust
355
356 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
357 - php include path tweaked for plekit includes
358 - reviewed myplc (fka native) packaging dependencies
359 - renumbered 4.3
360
361 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
362 - rename myplc into myplc-chroot and myplc-native into myplc
363 - new settings (shortname & hrn_root) for local peer
364
365 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
366 - First iteration of new data model
367 - Bunch of various fixes
368
369 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
370 - Removed proper ops from planetflow slice.
371
372 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
373 - myplc-native requires myplc-docs
374 - fixed doc build by locating locally installed DTDs at build-time
375
376 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
377 - turn myplc-docs off for now
378
379 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
380 - figures in doc package
381
382 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
383 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
384 - chroot packaging does not have docs anymore
385 - 'cvs' and 'dev' not required from myplc-native anymore
386 - cosmetic change in kml output
387
388 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
389 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
390 - gethostbyname uses python rather than perl (hope this shrinks deps) 
391 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
392 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
393 - make sync now works towards vserver-based myplc only 
394
395 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
396
397 - added vsys 'pfmount' script to the default netflow slice attributes.
398
399
400 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
401 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
402 - to new bootcd packaging
403
404 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
405 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
406
407 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
408 - packaging of mplc-release in myplc-native
409 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
410 - resolv file in /etc/resolv.conf, not plc_resolv.conf
411 - improved sirius script
412 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
413 - expires more properly set 
414
415 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
416
417
418 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
419 - renew_reminder script moved to support-scripts/
420 - gen-aliases script added in support-scripts/
421 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
422 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
423 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
424 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
425 - new setting 'Mom list address' for sending emails to a separate destination
426 - starts rsyslogd/syslogd as appropriate
427 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
428 - convenience generation of yum.conf in resulting image based on build/mirroring
429
430 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
431 - refresh-peer.py removed (duplicate with PLCAPI)
432 - plc.d/ scripts cleaned up
433 - sirius initscript updated
434 - slice auto renewal fixed
435
436 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
437 - initial build.
438
439 %define module_current_branch 4.2