Setting tag MyPLC-4.3-37
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 37
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: PLCWWW
67 Requires: www-register-wizard
68 Requires: nodeconfig
69 Requires: PLCAPI
70 Requires: pcucontrol
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
77 %if "%{pldistro}" == "onelab"
78 Requires: dummynet_image
79 %endif
80
81 %define debug_package %{nil}
82
83 %description
84 MyPLC is a complete PlanetLab Central (PLC) portable installation
85 contained within a chroot jail. The default installation consists of a
86 web server, an XML-RPC API server, a boot server, and a database
87 server: the core components of PLC. The installation may be customized
88 through a graphical interface. All PLC services are started up and
89 shut down through a single System V init script installed in the host
90 system.
91
92 ####################### myplc-config
93
94 %package config
95
96 Summary: PlanetLab Central (PLC) configuration python module
97 Group: Applications/Systems
98 Requires: python
99
100 %description config
101 This package provides the Python module to configure MyPLC.
102
103
104 %prep
105 %setup -q
106
107 %build
108
109 %install
110 pushd MyPLC
111 rm -rf $RPM_BUILD_ROOT
112 ./build.sh %{pldistro} $RPM_BUILD_ROOT
113 popd
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 # If run under sudo
119 if [ -n "$SUDO_USER" ] ; then
120     # Allow user to delete the build directory
121     chown -h -R $SUDO_USER .
122     # Some temporary cdroot files like /var/empty/sshd and
123     # /usr/bin/sudo get created with non-readable permissions.
124     find . -not -perm +0600 -exec chmod u+rw {} \;
125     # Allow user to delete the built RPM(s)
126     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
127 fi
128
129 %pre
130 if [ -x %{_sysconfdir}/init.d/plc ] ; then
131     %{_sysconfdir}/init.d/plc stop
132 fi
133
134 # Old versions of myplc used to ship with a bootstrapped database and
135 # /etc/planetlab directory. Including generated files in the manifest
136 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
137 # names from one RPM build to another, it would be rpmsaved and thus
138 # effectively deleted. Now we do not include these files in the
139 # manifest. However, to avoid deleting these files in the process of
140 # upgrading from one of these old versions of myplc, we must back up
141 # the database and /etc/planetlab and restore them after the old
142 # version has been uninstalled in %triggerpostun (also in %post, in
143 # case we are force upgrading to the same version).
144 #
145 # This code can be removed once all myplc-0.4-1 installations have
146 # been upgraded to at least myplc-0.4-2.
147
148 # 0 = install, 1 = upgrade
149 if [ $1 -gt 0 ] ; then
150     for dir in /var/lib/pgsql/data /etc/planetlab ; do
151         if [ -d $dir ] ; then
152             echo "Preserving $dir"
153             mkdir -p $dir.rpmsave
154             tar -C $dir -cpf - . | \
155                tar -C $dir.rpmsave -xpf -
156
157             # Except for the default configuration file and DTD, which
158             # really should be considered for upgrade.
159             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
160         fi
161     done
162 fi
163
164 %post
165 if [ -x /sbin/chkconfig ] ; then
166     /sbin/chkconfig --add plc
167     /sbin/chkconfig plc on
168 fi
169
170 %triggerpostun -- %{name}
171 # 0 = erase, 1 = upgrade
172 if [ $1 -gt 0 ] ; then
173     for dir in /var/lib/pgsql/data /etc/planetlab ; do
174         if [ -d $dir.rpmsave -a -d $dir ] ; then
175             echo "Merging $dir"
176             if tar -C $dir.rpmsave -cpf - . | \
177                tar -C $dir -xpf - ; then
178                 rm -rf $dir.rpmsave
179             fi
180         fi
181     done
182 fi    
183
184 %preun
185 # 0 = erase, 1 = upgrade
186 if [ $1 -eq 0 ] ; then
187     %{_sysconfdir}/init.d/plc stop
188     if [ -x /sbin/chkconfig ] ; then
189         /sbin/chkconfig plc off
190         /sbin/chkconfig --del plc
191     fi
192 fi
193
194 %files
195 %defattr(-,root,root,-)
196 # Host startup script and configuration file
197 /etc/init.d/plc
198 /etc/plc.d
199 /etc/planetlab
200 /etc/plc_sliceinitscripts/sirius
201 /etc/support-scripts/gen_aliases.py*
202 /etc/support-scripts/renew_reminder.py*
203 /etc/support-scripts/renew_reminder_logrotate
204 /usr/bin/plc-config-tty
205 /usr/bin/db-config
206 /usr/bin/dns-config
207 /usr/bin/plc-map.py*
208 /usr/bin/plc-kml.py*
209 /usr/bin/refresh-peer.py*
210 /usr/bin/clean-empty-dirs.py*
211 /usr/bin/mtail.py*
212 /usr/bin/plc-check-ssl-peering.py*
213 /usr/bin/plc-orphan-accounts.py*
214 /usr/share/myplc/bashrc
215
216 %files config
217 %defattr(-,root,root,-)
218 /usr/bin/plc-config
219 %{python_sitearch}/plc_config.py*
220
221
222 %changelog
223 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
224 - support for fedora 12
225 - new package myplc-config for use by sfa
226 - drupal user registration turned off
227
228 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
229 - - fix to make sure when API, BOOT, MONITOR are on the same
230 - machine as WWW that the SSL key,cert for WWW takes precedence.
231 - - Do proper setup for SSL CA certficate to be used as the server
232 - chain.
233
234 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
235 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
236
237 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
238 - depend on pcucontrol
239
240 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
241 - * validate input according to type in plc_config
242 - * added the _genicw system slice
243 - * add tag types for sites and persons
244 - * add new tags for nodes and slices for exemption from myops
245
246 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
247 - turn off drupal on a box that acts as BOOT server but not as WWW server
248 - cleanup some obsolete code for old chroot-jail packaging in the process
249 - new bootcd-kernel script for keeping bootcd variants up2date
250
251 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
252 - Make the /etc/hosts manipulation optional.
253
254 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
255 - Fix SetRole.
256
257 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
258 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
259 - into the DB.
260 - - Added the root ssh key handling support back into plc.d/ssh and the
261 - default xml file.  This should be identical to the way it was in
262 - rc12.
263 - - Added support in the db-config.d/01-init script to register the root
264 - ssh public key with the default administrator.  In this way the root
265 - ssh key will make it into the root account on the nodes by means of
266 - NodeManager's specialaccounts plugin.
267
268 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
269 - db-config ignores sliver tags
270 - sirius's db-config script renamed (was sirious)
271
272 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
273 - fix for silverauth - missing tag types now created at plc startup time
274
275 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
276 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
277
278 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
279 - companion to NM's specialaccounts plugin
280 - do not generate /etc/planetlab/root_ssh_key* anymore
281 - remove related config. variables and conf_files
282
283 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
284 - clarified description text to refer only to plcrt and not other optional
285 - packages.
286
287 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
288 - fixed a bug setting slice multiple attributes with the same tag name
289
290 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
291 - SSL setup for monitor box, and related new config variables
292 - new conf_file for /etc/planetlab/extensions
293 - various tweaks in db-config internals, about initscripts among others
294 - also more messages defined in the db
295
296 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
297 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
298
299 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
300 - bugfix in db-config, tag 4.3-19 would not fly
301
302 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
303 - Refactored db-config into snippets in db-config.d/.
304
305 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
306 - oops, tag 4.3-17 was broken and would not work
307
308 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
309 - bugfix - escape sequences inserted in xml configs
310
311 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
312 - Handle db-config.d files properly.
313
314 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
315 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
316 - than the log file
317 - - Fix db-config to be a bit more cautious when
318 - /etc/planetlab/db-config.d doesn't exist
319 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
320 - .orig files.
321 - - Refactor generic plc-config-tty code into plc_config.py.
322 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
323 - and the list of validated variables and the corresponding
324 - validator() function. This refactoring lets one reuse plc_config.py
325 - as a generic cmdline configuration tool for highly customer MyPLC
326 - like software.
327
328 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
329 - update PCU Type descriptions.
330 - updates to init scripts
331
332 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
333 - requires monitor-pcucontrol so register-wizard can work
334
335 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
336 - cleaned up plc-config-tty, no more need to configure plc-devel
337
338 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
339 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
340
341 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
342 - fix issue in db-config that prevented correct operation
343
344 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
345 - remove support for chroot-based packaging - no crond nor syslog step anymore
346 - plc init script now named plc.init instead of former guest.init
347
348 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
349 - add Monitor to docs build
350
351 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
352 - plc_config.py and plc-config-tty: generalized to work for more diverse
353 - MyPLC configurations.
354 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
355 - deployments and increase the memory limits in php.ini
356 - plc.d/crond: add --full option to vacuumdb
357
358 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
359 - avoid generating ssl certificates for disabled services among www api boot
360
361 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
362 - cleaned up old entries in db-config
363 - mtail more robust
364
365 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
366 - php include path tweaked for plekit includes
367 - reviewed myplc (fka native) packaging dependencies
368 - renumbered 4.3
369
370 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
371 - rename myplc into myplc-chroot and myplc-native into myplc
372 - new settings (shortname & hrn_root) for local peer
373
374 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
375 - First iteration of new data model
376 - Bunch of various fixes
377
378 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
379 - Removed proper ops from planetflow slice.
380
381 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
382 - myplc-native requires myplc-docs
383 - fixed doc build by locating locally installed DTDs at build-time
384
385 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
386 - turn myplc-docs off for now
387
388 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
389 - figures in doc package
390
391 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
392 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
393 - chroot packaging does not have docs anymore
394 - 'cvs' and 'dev' not required from myplc-native anymore
395 - cosmetic change in kml output
396
397 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
398 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
399 - gethostbyname uses python rather than perl (hope this shrinks deps) 
400 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
401 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
402 - make sync now works towards vserver-based myplc only 
403
404 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
405
406 - added vsys 'pfmount' script to the default netflow slice attributes.
407
408
409 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
410 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
411 - to new bootcd packaging
412
413 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
414 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
415
416 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
417 - packaging of mplc-release in myplc-native
418 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
419 - resolv file in /etc/resolv.conf, not plc_resolv.conf
420 - improved sirius script
421 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
422 - expires more properly set 
423
424 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
425
426
427 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
428 - renew_reminder script moved to support-scripts/
429 - gen-aliases script added in support-scripts/
430 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
431 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
432 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
433 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
434 - new setting 'Mom list address' for sending emails to a separate destination
435 - starts rsyslogd/syslogd as appropriate
436 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
437 - convenience generation of yum.conf in resulting image based on build/mirroring
438
439 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
440 - refresh-peer.py removed (duplicate with PLCAPI)
441 - plc.d/ scripts cleaned up
442 - sirius initscript updated
443 - slice auto renewal fixed
444
445 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
446 - initial build.
447
448 %define module_current_branch 4.2