fix spec
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23
24 ####################### myplc - mostly a meta-package
25 Summary: PlanetLab Central (PLC) Portable Installation
26 Group: Applications/Systems
27
28 # planetlab stuff
29 Requires: bootmanager
30 Requires: bootcd-%{nodefamily}
31 Requires: bootcd-initscripts
32 Requires: www-register-wizard
33 Requires: nodeconfig
34 Requires: nodeyum
35 Requires: nodeimage-%{nodefamily}
36 Requires: myplc-docs
37 Requires: myplc-release
38 Requires: myplc-core
39 Requires: createrepo
40
41
42 # starting with f16 we depend on this new rpm
43 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
44 Requires: rpm-sign
45 %endif
46
47
48 %define debug_package %{nil}
49
50 %description
51 MyPLC is a complete PlanetLab Central (PLC) portable installation.
52 The default installation consists of a web server, an XML-RPC API
53 server, a boot server, and a database server: the core components of
54 PLC. The installation may be customized through a graphical
55 interface. All PLC services are started up and shut down through a
56 single System V init script.
57
58
59 ####################### myplc-core
60
61 %package core
62
63 Summary: core contents of myplc with API + db + www UI
64
65 %description core
66 The core of myplc is about its API + database + web interface.
67 Installing this will not require any node-oriented
68 package, like bootcd, nodeimage, or bootmanager.
69
70 # as much as possible, requires should go in the subpackages specfile
71 Requires: myplc-config
72 Requires: plcapi
73 Requires: plewww
74
75 # this technically is a plcapi dependency
76 # but it's simpler here for chosing which
77 %if "%{distro}" == "Fedora" && %{distrorelease} >= 29
78 Requires: python2-mod_wsgi
79 %else
80 Requires: mod_wsgi
81 %endif
82
83 # this technically is a plewww dependency
84 # starting with f27 we depend on this new rpm
85 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
86 Requires: php-fpm
87 %endif
88
89 Requires: redhat-lsb
90 Requires: bzip2
91 Requires: tar
92 Requires: less
93 Requires: sendmail
94 Requires: sendmail-cf
95 Requires: openssl
96 Requires: expect
97 Requires: php-pgsql
98 Requires: curl
99 Requires: rsync
100 Requires: python-devel
101 Requires: dnf
102 #Requires: PyXML
103 Requires: cpio
104 Requires: wget
105 Requires: php
106 Requires: openssh
107 Requires: dnsmasq
108 Requires: diffutils
109 Requires: gzip
110 Requires: vim-minimal
111 Requires: findutils
112 Requires: xmlsec1
113 Requires: xmlsec1-openssl
114 Requires: ed
115 Requires: cronie
116
117
118 ####################### myplc-config
119
120 %package config
121
122 Summary: PlanetLab Central (PLC) configuration python module
123 Group: Applications/Systems
124 Requires: python
125
126 %description config
127 This package provides the Python module to configure MyPLC.
128
129
130 %prep
131 %setup -q
132
133 %build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 # Install configuration scripts
139 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
140 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
141 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
142
143 echo "* Installing scripts in /usr/bin"
144 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
145 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
146 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
147 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
148
149 # Install initscript
150 echo "* Installing plc initscript"
151 install -D -m 755 systemd/plc-ctl ${RPM_BUILD_ROOT}/usr/bin/plc-ctl
152 install -D -m 644 systemd/plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
153
154 # Install initscripts
155 echo "* Installing plc.d initscripts"
156 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
157 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
158
159 # Install db-config.d files
160 echo "* Installing db-config.d files"
161 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
162 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
163 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
164
165 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
166 echo "* Installing scripts in /etc/support-scripts"
167 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
168 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
169 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
170
171 # copy initscripts to etc/plc_sliceinitscripts
172 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
173 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
174 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
175
176 # Install configuration file
177 echo "* myplc: Installing configuration file"
178 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
179 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
180     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
181 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
182
183 echo "* Installing bashrc convenience"
184 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
185
186 # yumgroups.xml and yum repo : let noderepo handle that
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %pre
192 if [ -x %{_sysconfdir}/init.d/plc ] ; then
193     %{_sysconfdir}/init.d/plc stop
194 fi
195
196 # Old versions of myplc used to ship with a bootstrapped database and
197 # /etc/planetlab directory. Including generated files in the manifest
198 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
199 # names from one RPM build to another, it would be rpmsaved and thus
200 # effectively deleted. Now we do not include these files in the
201 # manifest. However, to avoid deleting these files in the process of
202 # upgrading from one of these old versions of myplc, we must back up
203 # the database and /etc/planetlab and restore them after the old
204 # version has been uninstalled in %triggerpostun (also in %post, in
205 # case we are force upgrading to the same version).
206 #
207 # This code can be removed once all myplc-0.4-1 installations have
208 # been upgraded to at least myplc-0.4-2.
209
210 # 0 = install, 1 = upgrade
211 if [ $1 -gt 0 ] ; then
212     for dir in /var/lib/pgsql/data /etc/planetlab ; do
213         if [ -d $dir ] ; then
214             echo "Preserving $dir"
215             mkdir -p $dir.rpmsave
216             tar -C $dir -cpf - . | \
217                tar -C $dir.rpmsave -xpf -
218
219             # Except for the default configuration file and DTD, which
220             # really should be considered for upgrade.
221             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
222         fi
223     done
224 fi
225
226 %post
227 systemctl enable plc
228
229 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
230 systemctl enable php-fpm
231 systemctl start  php-fpm
232 %endif
233
234 %triggerpostun -- %{name}
235 # 0 = erase, 1 = upgrade
236 if [ $1 -gt 0 ] ; then
237     for dir in /var/lib/pgsql/data /etc/planetlab ; do
238         if [ -d $dir.rpmsave -a -d $dir ] ; then
239             echo "Merging $dir"
240             if tar -C $dir.rpmsave -cpf - . | \
241                tar -C $dir -xpf - ; then
242                 rm -rf $dir.rpmsave
243             fi
244         fi
245     done
246 fi
247
248 %preun
249 # 0 = erase, 1 = upgrade
250 if [ $1 -eq 0 ] ; then
251     %{_sysconfdir}/init.d/plc stop
252     systemctl disable plc
253 fi
254
255
256 %files
257 /usr/share/myplc/bashrc
258
259 %files core
260 %defattr(-,root,root,-)
261 /usr/lib/systemd/system/plc.service
262 /usr/bin/plc-ctl
263 /etc/plc.d
264 /etc/planetlab
265 /etc/plc_sliceinitscripts
266 /etc/support-scripts
267 # keep a detailed list, to avoid duplicate of plc-config,
268 # that belongs to the myplc-config rpm
269 /usr/bin/plc-config-tty
270 /usr/bin/db-config
271 /usr/bin/dns-config
272 /usr/bin/refresh-peer.py*
273 /usr/bin/mtail.py*
274 /usr/bin/mtail
275 /usr/bin/plc-map.py*
276 /usr/bin/plc-kml.py*
277 /usr/bin/clean-empty-dirs.py*
278 /usr/bin/plc-check-ssl-peering.py*
279 /usr/bin/plc-orphan-accounts.py*
280 /usr/bin/spot-aliens.py*
281 /usr/bin/check-hrns.py*
282 /usr/bin/check-vsys-defaults.py*
283 /usr/bin/spot-dup-accounts.sh
284
285
286 %files config
287 %defattr(-,root,root,-)
288 /usr/bin/plc-config
289 %{python_sitearch}/plc_config.py*
290
291
292 %changelog
293 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
294 - takes care of creating plcapi log file
295
296 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
297 - tweaked renew_reminder for federation
298
299 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
300 - tweaks in check-hrns.py
301 - do not require PyXML any more
302
303 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
304 - review check-hrns for plcapi-5.3
305 - add PLC_HRN_ROOT in usual plc-config-tty's settings
306
307 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
308 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
309 - add an rpm-sign dependency on feedora>=16
310
311 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
312 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
313
314 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
315 - plc.d/gpg now does not rm /dev/random but preserves it
316 - this is because libvirt won't let us run mknod
317
318 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
319 - fix typo in check-hrns - used to print 'host' while dealing with persons
320
321 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
322 - supports httpd config for either mod_python (preferred) or mod_wsgi
323 - requires mod_wsgi on f18 only, otherwise mod_python
324 - supports httpd config for apache 2.4 (f18)
325 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
326
327 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
328 - bugfix in check-vsys-defaults.py
329
330 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
331 - define open_basedir in php.ini to stop confidentiality leak
332 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
333 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
334 - new utilities check-hrns.py and check-vsys-defaults.py
335
336 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
337 - set TimeoutSec to 300 in plc.service
338 - remove ref to deprecated svn $URL$ in db-config usage
339
340 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
341 - expose mtail.py as simply mtail
342
343 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
344 - plc-kml.py now has support for nodegroups
345
346 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
347 - use nodeimage package instead of deprecated bootstrapfs
348 - has systemd-friendly startup script
349 - plc_reload moved to functions/ - no more service plc reload
350 - no svn keywords anymore
351
352 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
353 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
354
355 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
356 - new settings for myslice (comon&tophat) and monitor (db)
357 - removed mentions of chroot in description
358 - can redo myplc-docs on broken f12-latex
359 - set short_open_tag in php.ini
360 - fixes in gen-sites-xml (is that still used ?)
361 - partial-repo.sh has moved to 'build' where it more belongs
362 - tweaks in convenience tool 'mtail'
363
364 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
365 - fixed changelog, no change from 5.0-16
366
367 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
368 - requires ed for the plc.d/packages step
369 - sirius initscript to handle stop and restart
370
371 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
372 - ignore steps in db-config.d if they have a '.' or '~' in their name
373
374 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
375 - can redo myplc-docs without the doc for monitor
376
377 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
378 - no semantic change - just fixed specfile for git URL
379
380 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
381 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
382
383 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
384 - add missing files to rpm package
385
386 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
387 - mtail.py -s for SFA
388 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
389
390 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
391 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
392
393 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
394 - plc-config-tty now has a validator on booleans
395 - e.g. entering 'True' now is rejected rather than silently recording 'false'
396
397 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
398 - disable mod_wsgi
399
400 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
401 - module name changes
402 - start wsgi support
403
404 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
405 - new setting PLC_RESERVATION_GRANULARITY
406
407 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
408 - * partial-repo.sh script
409 - * preserve key along with certificates
410
411 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
412 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
413
414 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
415 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
416 - new OMF category in the config
417 - create the drl system slice
418
419 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
420 - first working version of 5.0:
421 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
422 - nodefamily is 3-fold with pldistro-fcdistro-arch
423 - new PLC_FLAVOUR config category
424 - reviewed module layout
425 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
426
427 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
428 - support for fedora 12
429 - new package myplc-config for use by sfa
430 - drupal user registration turned off
431
432 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
433 - - fix to make sure when API, BOOT, MONITOR are on the same
434 - machine as WWW that the SSL key,cert for WWW takes precedence.
435 - - Do proper setup for SSL CA certficate to be used as the server
436 - chain.
437
438 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
439 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
440
441 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
442 - depend on pcucontrol
443
444 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
445 - * validate input according to type in plc_config
446 - * added the _genicw system slice
447 - * add tag types for sites and persons
448 - * add new tags for nodes and slices for exemption from myops
449
450 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
451 - turn off drupal on a box that acts as BOOT server but not as WWW server
452 - cleanup some obsolete code for old chroot-jail packaging in the process
453 - new bootcd-kernel script for keeping bootcd variants up2date
454
455 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
456 - Make the /etc/hosts manipulation optional.
457
458 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
459 - Fix SetRole.
460
461 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
462 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
463 - into the DB.
464 - - Added the root ssh key handling support back into plc.d/ssh and the
465 - default xml file.  This should be identical to the way it was in
466 - rc12.
467 - - Added support in the db-config.d/01-init script to register the root
468 - ssh public key with the default administrator.  In this way the root
469 - ssh key will make it into the root account on the nodes by means of
470 - NodeManager's specialaccounts plugin.
471
472 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
473 - db-config ignores sliver tags
474 - sirius's db-config script renamed (was sirious)
475
476 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
477 - fix for silverauth - missing tag types now created at plc startup time
478
479 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
480 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
481
482 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
483 - companion to NM's specialaccounts plugin
484 - do not generate /etc/planetlab/root_ssh_key* anymore
485 - remove related config. variables and conf_files
486
487 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
488 - clarified description text to refer only to plcrt and not other optional
489 - packages.
490
491 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
492 - fixed a bug setting slice multiple attributes with the same tag name
493
494 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
495 - SSL setup for monitor box, and related new config variables
496 - new conf_file for /etc/planetlab/extensions
497 - various tweaks in db-config internals, about initscripts among others
498 - also more messages defined in the db
499
500 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
501 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
502
503 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
504 - bugfix in db-config, tag 4.3-19 would not fly
505
506 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
507 - Refactored db-config into snippets in db-config.d/.
508
509 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
510 - oops, tag 4.3-17 was broken and would not work
511
512 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
513 - bugfix - escape sequences inserted in xml configs
514
515 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
516 - Handle db-config.d files properly.
517
518 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
519 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
520 - than the log file
521 - - Fix db-config to be a bit more cautious when
522 - /etc/planetlab/db-config.d doesn''t exist
523 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
524 - .orig files.
525 - - Refactor generic plc-config-tty code into plc_config.py.
526 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
527 - and the list of validated variables and the corresponding
528 - validator() function. This refactoring lets one reuse plc_config.py
529 - as a generic cmdline configuration tool for highly customer MyPLC
530 - like software.
531
532 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
533 - update PCU Type descriptions.
534 - updates to init scripts
535
536 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
537 - requires monitor-pcucontrol so register-wizard can work
538
539 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
540 - cleaned up plc-config-tty, no more need to configure plc-devel
541
542 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
543 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
544
545 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
546 - fix issue in db-config that prevented correct operation
547
548 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
549 - remove support for chroot-based packaging - no crond nor syslog step anymore
550 - plc init script now named plc.init instead of former guest.init
551
552 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
553 - add Monitor to docs build
554
555 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
556 - plc_config.py and plc-config-tty: generalized to work for more diverse
557 - MyPLC configurations.
558 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
559 - deployments and increase the memory limits in php.ini
560 - plc.d/crond: add --full option to vacuumdb
561
562 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
563 - avoid generating ssl certificates for disabled services among www api boot
564
565 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
566 - cleaned up old entries in db-config
567 - mtail more robust
568
569 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
570 - php include path tweaked for plekit includes
571 - reviewed myplc (fka native) packaging dependencies
572 - renumbered 4.3
573
574 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
575 - rename myplc into myplc-chroot and myplc-native into myplc
576 - new settings (shortname & hrn_root) for local peer
577
578 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
579 - First iteration of new data model
580 - Bunch of various fixes
581
582 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
583 - Removed proper ops from planetflow slice.
584
585 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
586 - myplc-native requires myplc-docs
587 - fixed doc build by locating locally installed DTDs at build-time
588
589 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
590 - turn myplc-docs off for now
591
592 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
593 - figures in doc package
594
595 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
596 - no more doc packaged outside of myplc-docs - doc/ cleaned up
597 - chroot packaging does not have docs anymore
598 - 'cvs' and 'dev' not required from myplc-native anymore
599 - cosmetic change in kml output
600
601 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
602 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
603 - gethostbyname uses python rather than perl (hope this shrinks deps)
604 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
605 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
606 - make sync now works towards vserver-based myplc only
607
608 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
609 -
610 - added vsys 'pfmount' script to the default netflow slice attributes.
611 -
612
613 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
614 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
615 - to new bootcd packaging
616
617 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
618 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
619
620 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
621 - packaging of mplc-release in myplc-native
622 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
623 - resolv file in /etc/resolv.conf, not plc_resolv.conf
624 - improved sirius script
625 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
626 - expires more properly set
627
628 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
629 -
630
631 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
632 - renew_reminder script moved to support-scripts/
633 - gen-aliases script added in support-scripts/
634 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
635 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
636 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
637 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
638 - new setting 'Mom list address' for sending emails to a separate destination
639 - starts rsyslogd/syslogd as appropriate
640 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
641 - convenience generation of yum.conf in resulting image based on build/mirroring
642
643 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
644 - refresh-peer.py removed (duplicate with PLCAPI)
645 - plc.d/ scripts cleaned up
646 - sirius initscript updated
647 - slice auto renewal fixed
648
649 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
650 - initial build.
651
652 %define module_current_branch 4.3