Merge commit 'origin/master'
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.0
3 %define taglevel 16
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: bzip2
29 Requires: tar 
30 Requires: less
31 Requires: sendmail
32 Requires: sendmail-cf
33 Requires: openssl
34 Requires: expect
35 Requires: php-pgsql
36 Requires: curl
37 Requires: rsync
38 Requires: python-devel
39 Requires: yum
40 Requires: PyXML
41 Requires: createrepo
42 Requires: cpio
43 Requires: wget
44 Requires: php
45 Requires: openssh
46 Requires: dnsmasq
47 Requires: diffutils
48 Requires: gzip
49 Requires: vim-minimal
50 Requires: findutils
51 Requires: xmlsec1
52 Requires: xmlsec1-openssl
53 Requires: ed
54 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
55 Requires: cronie
56 %else
57 Requires: vixie-cron
58 %endif
59 # planetlab stuff
60 Requires: bootmanager
61 Requires: bootcd-%{nodefamily}
62 Requires: bootcd-initscripts
63 Requires: PLCWWW
64 Requires: www-register-wizard
65 Requires: nodeconfig
66 Requires: nodeyum
67 Requires: PLCAPI
68 Requires: bootstrapfs-%{nodefamily}
69 Requires: myplc-docs
70 Requires: myplc-release
71 Requires: myplc-config
72
73 %define debug_package %{nil}
74
75 %description
76 MyPLC is a complete PlanetLab Central (PLC) portable installation
77 contained within a chroot jail. The default installation consists of a
78 web server, an XML-RPC API server, a boot server, and a database
79 server: the core components of PLC. The installation may be customized
80 through a graphical interface. All PLC services are started up and
81 shut down through a single System V init script installed in the host
82 system.
83
84 ####################### myplc-config
85
86 %package config
87
88 Summary: PlanetLab Central (PLC) configuration python module
89 Group: Applications/Systems
90 Requires: python
91
92 %description config
93 This package provides the Python module to configure MyPLC.
94
95
96 %prep
97 %setup -q
98
99 %build
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 # Install configuration scripts
105 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
106 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
107 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
108
109 echo "* Installing scripts in /usr/bin"
110 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
111 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
112 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
113
114 # Install initscript 
115 echo "* Installing plc initscript"
116 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
117
118 # Install initscripts
119 echo "* Installing plc.d initscripts"
120 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
121 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
122
123 # Install db-config.d files
124 echo "* Installing db-config.d files"
125 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
126 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
127 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
128
129 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
130 echo "* Installing scripts in /etc/support-scripts"
131 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
132 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
133 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
134
135 # copy initscripts to etc/plc_sliceinitscripts
136 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
137 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
138 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
139
140 # Install configuration file
141 echo "* myplc: Installing configuration file"
142 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
143 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
144     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
145 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
146
147 echo "* Installing bashrc convenience"
148 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
149
150 # yumgroups.xml and yum repo : let noderepo handle that
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %pre
156 if [ -x %{_sysconfdir}/init.d/plc ] ; then
157     %{_sysconfdir}/init.d/plc stop
158 fi
159
160 # Old versions of myplc used to ship with a bootstrapped database and
161 # /etc/planetlab directory. Including generated files in the manifest
162 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
163 # names from one RPM build to another, it would be rpmsaved and thus
164 # effectively deleted. Now we do not include these files in the
165 # manifest. However, to avoid deleting these files in the process of
166 # upgrading from one of these old versions of myplc, we must back up
167 # the database and /etc/planetlab and restore them after the old
168 # version has been uninstalled in %triggerpostun (also in %post, in
169 # case we are force upgrading to the same version).
170 #
171 # This code can be removed once all myplc-0.4-1 installations have
172 # been upgraded to at least myplc-0.4-2.
173
174 # 0 = install, 1 = upgrade
175 if [ $1 -gt 0 ] ; then
176     for dir in /var/lib/pgsql/data /etc/planetlab ; do
177         if [ -d $dir ] ; then
178             echo "Preserving $dir"
179             mkdir -p $dir.rpmsave
180             tar -C $dir -cpf - . | \
181                tar -C $dir.rpmsave -xpf -
182
183             # Except for the default configuration file and DTD, which
184             # really should be considered for upgrade.
185             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
186         fi
187     done
188 fi
189
190 %post
191 if [ -x /sbin/chkconfig ] ; then
192     /sbin/chkconfig --add plc
193     /sbin/chkconfig plc on
194 fi
195
196 %triggerpostun -- %{name}
197 # 0 = erase, 1 = upgrade
198 if [ $1 -gt 0 ] ; then
199     for dir in /var/lib/pgsql/data /etc/planetlab ; do
200         if [ -d $dir.rpmsave -a -d $dir ] ; then
201             echo "Merging $dir"
202             if tar -C $dir.rpmsave -cpf - . | \
203                tar -C $dir -xpf - ; then
204                 rm -rf $dir.rpmsave
205             fi
206         fi
207     done
208 fi    
209
210 %preun
211 # 0 = erase, 1 = upgrade
212 if [ $1 -eq 0 ] ; then
213     %{_sysconfdir}/init.d/plc stop
214     if [ -x /sbin/chkconfig ] ; then
215         /sbin/chkconfig plc off
216         /sbin/chkconfig --del plc
217     fi
218 fi
219
220 %files
221 %defattr(-,root,root,-)
222 # Host startup script and configuration file
223 /etc/init.d/plc
224 /etc/plc.d
225 /etc/planetlab
226 /etc/plc_sliceinitscripts
227 /etc/support-scripts
228 /usr/share/myplc/bashrc
229 # keep a detailed list, to avoid duplicate of plc-config,
230 # that belongs to the myplc-config rpm
231 /usr/bin/plc-config-tty
232 /usr/bin/db-config
233 /usr/bin/dns-config
234 /usr/bin/refresh-peer.py*
235 /usr/bin/partial-repo.sh
236 /usr/bin/mtail.py*
237 /usr/bin/plc-map.py*
238 /usr/bin/plc-kml.py*
239 /usr/bin/clean-empty-dirs.py*
240 /usr/bin/plc-check-ssl-peering.py*
241 /usr/bin/plc-orphan-accounts.py*
242 /usr/bin/spot-aliens.py*
243 /usr/bin/spot-dup-accounts.sh
244
245 %files config
246 %defattr(-,root,root,-)
247 /usr/bin/plc-config
248 %{python_sitearch}/plc_config.py*
249
250
251 %changelog
252 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
253 - requires ed for the plc.d/packages step
254 - new initscript_body slice tag
255 - sirius initscript to handle stop and restart
256
257 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
258 - ignore steps in db-config.d if they have a '.' or '~' in their name
259
260 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
261 - can redo myplc-docs without the doc for monitor
262
263 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
264 - no semantic change - just fixed specfile for git URL
265
266 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
267 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
268
269 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
270 - add missing files to rpm package
271
272 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
273 - mtail.py -s for SFA
274 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
275
276 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
277 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
278
279 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
280 - plc-config-tty now has a validator on booleans
281 - e.g. entering 'True' now is rejected rather than silently recording 'false'
282
283 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
284 - disable mod_wsgi
285
286 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
287 - module name changes
288 - start wsgi support
289
290 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
291 - new setting PLC_RESERVATION_GRANULARITY
292
293 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
294 - * partial-repo.sh script
295 - * preserve key along with certificates
296
297 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
298 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
299
300 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
301 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
302 - new OMF category in the config
303 - create the drl system slice
304
305 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
306 - first working version of 5.0:
307 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
308 - nodefamily is 3-fold with pldistro-fcdistro-arch
309 - new PLC_FLAVOUR config category
310 - reviewed module layout
311 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
312
313 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
314 - support for fedora 12
315 - new package myplc-config for use by sfa
316 - drupal user registration turned off
317
318 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
319 - - fix to make sure when API, BOOT, MONITOR are on the same
320 - machine as WWW that the SSL key,cert for WWW takes precedence.
321 - - Do proper setup for SSL CA certficate to be used as the server
322 - chain.
323
324 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
325 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
326
327 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
328 - depend on pcucontrol
329
330 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
331 - * validate input according to type in plc_config
332 - * added the _genicw system slice
333 - * add tag types for sites and persons
334 - * add new tags for nodes and slices for exemption from myops
335
336 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
337 - turn off drupal on a box that acts as BOOT server but not as WWW server
338 - cleanup some obsolete code for old chroot-jail packaging in the process
339 - new bootcd-kernel script for keeping bootcd variants up2date
340
341 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
342 - Make the /etc/hosts manipulation optional.
343
344 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
345 - Fix SetRole.
346
347 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
348 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
349 - into the DB.
350 - - Added the root ssh key handling support back into plc.d/ssh and the
351 - default xml file.  This should be identical to the way it was in
352 - rc12.
353 - - Added support in the db-config.d/01-init script to register the root
354 - ssh public key with the default administrator.  In this way the root
355 - ssh key will make it into the root account on the nodes by means of
356 - NodeManager's specialaccounts plugin.
357
358 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
359 - db-config ignores sliver tags
360 - sirius's db-config script renamed (was sirious)
361
362 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
363 - fix for silverauth - missing tag types now created at plc startup time
364
365 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
366 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
367
368 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
369 - companion to NM's specialaccounts plugin
370 - do not generate /etc/planetlab/root_ssh_key* anymore
371 - remove related config. variables and conf_files
372
373 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
374 - clarified description text to refer only to plcrt and not other optional
375 - packages.
376
377 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
378 - fixed a bug setting slice multiple attributes with the same tag name
379
380 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
381 - SSL setup for monitor box, and related new config variables
382 - new conf_file for /etc/planetlab/extensions
383 - various tweaks in db-config internals, about initscripts among others
384 - also more messages defined in the db
385
386 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
387 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
388
389 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
390 - bugfix in db-config, tag 4.3-19 would not fly
391
392 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
393 - Refactored db-config into snippets in db-config.d/.
394
395 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
396 - oops, tag 4.3-17 was broken and would not work
397
398 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
399 - bugfix - escape sequences inserted in xml configs
400
401 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
402 - Handle db-config.d files properly.
403
404 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
405 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
406 - than the log file
407 - - Fix db-config to be a bit more cautious when
408 - /etc/planetlab/db-config.d doesn''t exist
409 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
410 - .orig files.
411 - - Refactor generic plc-config-tty code into plc_config.py.
412 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
413 - and the list of validated variables and the corresponding
414 - validator() function. This refactoring lets one reuse plc_config.py
415 - as a generic cmdline configuration tool for highly customer MyPLC
416 - like software.
417
418 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
419 - update PCU Type descriptions.
420 - updates to init scripts
421
422 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
423 - requires monitor-pcucontrol so register-wizard can work
424
425 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
426 - cleaned up plc-config-tty, no more need to configure plc-devel
427
428 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
429 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
430
431 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
432 - fix issue in db-config that prevented correct operation
433
434 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
435 - remove support for chroot-based packaging - no crond nor syslog step anymore
436 - plc init script now named plc.init instead of former guest.init
437
438 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
439 - add Monitor to docs build
440
441 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
442 - plc_config.py and plc-config-tty: generalized to work for more diverse
443 - MyPLC configurations.
444 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
445 - deployments and increase the memory limits in php.ini
446 - plc.d/crond: add --full option to vacuumdb
447
448 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
449 - avoid generating ssl certificates for disabled services among www api boot
450
451 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
452 - cleaned up old entries in db-config
453 - mtail more robust
454
455 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
456 - php include path tweaked for plekit includes
457 - reviewed myplc (fka native) packaging dependencies
458 - renumbered 4.3
459
460 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
461 - rename myplc into myplc-chroot and myplc-native into myplc
462 - new settings (shortname & hrn_root) for local peer
463
464 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
465 - First iteration of new data model
466 - Bunch of various fixes
467
468 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
469 - Removed proper ops from planetflow slice.
470
471 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
472 - myplc-native requires myplc-docs
473 - fixed doc build by locating locally installed DTDs at build-time
474
475 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
476 - turn myplc-docs off for now
477
478 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
479 - figures in doc package
480
481 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
482 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
483 - chroot packaging does not have docs anymore
484 - 'cvs' and 'dev' not required from myplc-native anymore
485 - cosmetic change in kml output
486
487 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
488 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
489 - gethostbyname uses python rather than perl (hope this shrinks deps) 
490 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
491 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
492 - make sync now works towards vserver-based myplc only 
493
494 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
495
496 - added vsys 'pfmount' script to the default netflow slice attributes.
497
498
499 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
500 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
501 - to new bootcd packaging
502
503 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
504 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
505
506 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
507 - packaging of mplc-release in myplc-native
508 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
509 - resolv file in /etc/resolv.conf, not plc_resolv.conf
510 - improved sirius script
511 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
512 - expires more properly set 
513
514 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
515
516
517 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
518 - renew_reminder script moved to support-scripts/
519 - gen-aliases script added in support-scripts/
520 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
521 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
522 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
523 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
524 - new setting 'Mom list address' for sending emails to a separate destination
525 - starts rsyslogd/syslogd as appropriate
526 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
527 - convenience generation of yum.conf in resulting image based on build/mirroring
528
529 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
530 - refresh-peer.py removed (duplicate with PLCAPI)
531 - plc.d/ scripts cleaned up
532 - sirius initscript updated
533 - slice auto renewal fixed
534
535 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
536 - initial build.
537
538 %define module_current_branch 4.3