Setting tag myplc-5.0-15
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.0
3 %define taglevel 15
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: bzip2
29 Requires: tar 
30 Requires: less
31 Requires: sendmail
32 Requires: sendmail-cf
33 Requires: openssl
34 Requires: expect
35 Requires: php-pgsql
36 Requires: curl
37 Requires: rsync
38 Requires: python-devel
39 Requires: yum
40 Requires: PyXML
41 Requires: createrepo
42 Requires: cpio
43 Requires: wget
44 Requires: php
45 Requires: openssh
46 Requires: dnsmasq
47 Requires: diffutils
48 Requires: gzip
49 Requires: vim-minimal
50 Requires: findutils
51 Requires: xmlsec1
52 Requires: xmlsec1-openssl
53 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
54 Requires: cronie
55 %else
56 Requires: vixie-cron
57 %endif
58 # planetlab stuff
59 Requires: bootmanager
60 Requires: bootcd-%{nodefamily}
61 Requires: bootcd-initscripts
62 Requires: PLCWWW
63 Requires: www-register-wizard
64 Requires: nodeconfig
65 Requires: nodeyum
66 Requires: PLCAPI
67 Requires: bootstrapfs-%{nodefamily}
68 Requires: myplc-docs
69 Requires: myplc-release
70 Requires: myplc-config
71
72 %define debug_package %{nil}
73
74 %description
75 MyPLC is a complete PlanetLab Central (PLC) portable installation
76 contained within a chroot jail. The default installation consists of a
77 web server, an XML-RPC API server, a boot server, and a database
78 server: the core components of PLC. The installation may be customized
79 through a graphical interface. All PLC services are started up and
80 shut down through a single System V init script installed in the host
81 system.
82
83 ####################### myplc-config
84
85 %package config
86
87 Summary: PlanetLab Central (PLC) configuration python module
88 Group: Applications/Systems
89 Requires: python
90
91 %description config
92 This package provides the Python module to configure MyPLC.
93
94
95 %prep
96 %setup -q
97
98 %build
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 # Install configuration scripts
104 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
105 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
106 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
107
108 echo "* Installing scripts in /usr/bin"
109 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
110 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
111 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
112
113 # Install initscript 
114 echo "* Installing plc initscript"
115 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
116
117 # Install initscripts
118 echo "* Installing plc.d initscripts"
119 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
120 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
121
122 # Install db-config.d files
123 echo "* Installing db-config.d files"
124 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
125 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
126 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
127
128 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
129 echo "* Installing scripts in /etc/support-scripts"
130 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
131 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
132 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
133
134 # copy initscripts to etc/plc_sliceinitscripts
135 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
136 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
137 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
138
139 # Install configuration file
140 echo "* myplc: Installing configuration file"
141 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
142 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
143     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
144 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
145
146 echo "* Installing bashrc convenience"
147 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
148
149 # yumgroups.xml and yum repo : let noderepo handle that
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %pre
155 if [ -x %{_sysconfdir}/init.d/plc ] ; then
156     %{_sysconfdir}/init.d/plc stop
157 fi
158
159 # Old versions of myplc used to ship with a bootstrapped database and
160 # /etc/planetlab directory. Including generated files in the manifest
161 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
162 # names from one RPM build to another, it would be rpmsaved and thus
163 # effectively deleted. Now we do not include these files in the
164 # manifest. However, to avoid deleting these files in the process of
165 # upgrading from one of these old versions of myplc, we must back up
166 # the database and /etc/planetlab and restore them after the old
167 # version has been uninstalled in %triggerpostun (also in %post, in
168 # case we are force upgrading to the same version).
169 #
170 # This code can be removed once all myplc-0.4-1 installations have
171 # been upgraded to at least myplc-0.4-2.
172
173 # 0 = install, 1 = upgrade
174 if [ $1 -gt 0 ] ; then
175     for dir in /var/lib/pgsql/data /etc/planetlab ; do
176         if [ -d $dir ] ; then
177             echo "Preserving $dir"
178             mkdir -p $dir.rpmsave
179             tar -C $dir -cpf - . | \
180                tar -C $dir.rpmsave -xpf -
181
182             # Except for the default configuration file and DTD, which
183             # really should be considered for upgrade.
184             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
185         fi
186     done
187 fi
188
189 %post
190 if [ -x /sbin/chkconfig ] ; then
191     /sbin/chkconfig --add plc
192     /sbin/chkconfig plc on
193 fi
194
195 %triggerpostun -- %{name}
196 # 0 = erase, 1 = upgrade
197 if [ $1 -gt 0 ] ; then
198     for dir in /var/lib/pgsql/data /etc/planetlab ; do
199         if [ -d $dir.rpmsave -a -d $dir ] ; then
200             echo "Merging $dir"
201             if tar -C $dir.rpmsave -cpf - . | \
202                tar -C $dir -xpf - ; then
203                 rm -rf $dir.rpmsave
204             fi
205         fi
206     done
207 fi    
208
209 %preun
210 # 0 = erase, 1 = upgrade
211 if [ $1 -eq 0 ] ; then
212     %{_sysconfdir}/init.d/plc stop
213     if [ -x /sbin/chkconfig ] ; then
214         /sbin/chkconfig plc off
215         /sbin/chkconfig --del plc
216     fi
217 fi
218
219 %files
220 %defattr(-,root,root,-)
221 # Host startup script and configuration file
222 /etc/init.d/plc
223 /etc/plc.d
224 /etc/planetlab
225 /etc/plc_sliceinitscripts
226 /etc/support-scripts
227 /usr/share/myplc/bashrc
228 # keep a detailed list, to avoid duplicate of plc-config,
229 # that belongs to the myplc-config rpm
230 /usr/bin/plc-config-tty
231 /usr/bin/db-config
232 /usr/bin/dns-config
233 /usr/bin/refresh-peer.py*
234 /usr/bin/partial-repo.sh
235 /usr/bin/mtail.py*
236 /usr/bin/plc-map.py*
237 /usr/bin/plc-kml.py*
238 /usr/bin/clean-empty-dirs.py*
239 /usr/bin/plc-check-ssl-peering.py*
240 /usr/bin/plc-orphan-accounts.py*
241 /usr/bin/spot-aliens.py*
242 /usr/bin/spot-dup-accounts.sh
243
244 %files config
245 %defattr(-,root,root,-)
246 /usr/bin/plc-config
247 %{python_sitearch}/plc_config.py*
248
249
250 %changelog
251 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
252 - ignore steps in db-config.d if they have a '.' or '~' in their name
253
254 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
255 - can redo myplc-docs without the doc for monitor
256
257 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
258 - no semantic change - just fixed specfile for git URL
259
260 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
261 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
262
263 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
264 - add missing files to rpm package
265
266 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
267 - mtail.py -s for SFA
268 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
269
270 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
271 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
272
273 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
274 - plc-config-tty now has a validator on booleans
275 - e.g. entering 'True' now is rejected rather than silently recording 'false'
276
277 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
278 - disable mod_wsgi
279
280 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
281 - module name changes
282 - start wsgi support
283
284 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
285 - new setting PLC_RESERVATION_GRANULARITY
286
287 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
288 - * partial-repo.sh script
289 - * preserve key along with certificates
290
291 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
292 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
293
294 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
295 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
296 - new OMF category in the config
297 - create the drl system slice
298
299 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
300 - first working version of 5.0:
301 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
302 - nodefamily is 3-fold with pldistro-fcdistro-arch
303 - new PLC_FLAVOUR config category
304 - reviewed module layout
305 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
306
307 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
308 - support for fedora 12
309 - new package myplc-config for use by sfa
310 - drupal user registration turned off
311
312 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
313 - - fix to make sure when API, BOOT, MONITOR are on the same
314 - machine as WWW that the SSL key,cert for WWW takes precedence.
315 - - Do proper setup for SSL CA certficate to be used as the server
316 - chain.
317
318 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
319 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
320
321 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
322 - depend on pcucontrol
323
324 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
325 - * validate input according to type in plc_config
326 - * added the _genicw system slice
327 - * add tag types for sites and persons
328 - * add new tags for nodes and slices for exemption from myops
329
330 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
331 - turn off drupal on a box that acts as BOOT server but not as WWW server
332 - cleanup some obsolete code for old chroot-jail packaging in the process
333 - new bootcd-kernel script for keeping bootcd variants up2date
334
335 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
336 - Make the /etc/hosts manipulation optional.
337
338 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
339 - Fix SetRole.
340
341 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
342 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
343 - into the DB.
344 - - Added the root ssh key handling support back into plc.d/ssh and the
345 - default xml file.  This should be identical to the way it was in
346 - rc12.
347 - - Added support in the db-config.d/01-init script to register the root
348 - ssh public key with the default administrator.  In this way the root
349 - ssh key will make it into the root account on the nodes by means of
350 - NodeManager's specialaccounts plugin.
351
352 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
353 - db-config ignores sliver tags
354 - sirius's db-config script renamed (was sirious)
355
356 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
357 - fix for silverauth - missing tag types now created at plc startup time
358
359 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
360 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
361
362 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
363 - companion to NM's specialaccounts plugin
364 - do not generate /etc/planetlab/root_ssh_key* anymore
365 - remove related config. variables and conf_files
366
367 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
368 - clarified description text to refer only to plcrt and not other optional
369 - packages.
370
371 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
372 - fixed a bug setting slice multiple attributes with the same tag name
373
374 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
375 - SSL setup for monitor box, and related new config variables
376 - new conf_file for /etc/planetlab/extensions
377 - various tweaks in db-config internals, about initscripts among others
378 - also more messages defined in the db
379
380 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
381 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
382
383 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
384 - bugfix in db-config, tag 4.3-19 would not fly
385
386 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
387 - Refactored db-config into snippets in db-config.d/.
388
389 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
390 - oops, tag 4.3-17 was broken and would not work
391
392 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
393 - bugfix - escape sequences inserted in xml configs
394
395 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
396 - Handle db-config.d files properly.
397
398 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
399 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
400 - than the log file
401 - - Fix db-config to be a bit more cautious when
402 - /etc/planetlab/db-config.d doesn''t exist
403 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
404 - .orig files.
405 - - Refactor generic plc-config-tty code into plc_config.py.
406 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
407 - and the list of validated variables and the corresponding
408 - validator() function. This refactoring lets one reuse plc_config.py
409 - as a generic cmdline configuration tool for highly customer MyPLC
410 - like software.
411
412 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
413 - update PCU Type descriptions.
414 - updates to init scripts
415
416 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
417 - requires monitor-pcucontrol so register-wizard can work
418
419 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
420 - cleaned up plc-config-tty, no more need to configure plc-devel
421
422 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
423 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
424
425 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
426 - fix issue in db-config that prevented correct operation
427
428 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
429 - remove support for chroot-based packaging - no crond nor syslog step anymore
430 - plc init script now named plc.init instead of former guest.init
431
432 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
433 - add Monitor to docs build
434
435 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
436 - plc_config.py and plc-config-tty: generalized to work for more diverse
437 - MyPLC configurations.
438 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
439 - deployments and increase the memory limits in php.ini
440 - plc.d/crond: add --full option to vacuumdb
441
442 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
443 - avoid generating ssl certificates for disabled services among www api boot
444
445 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
446 - cleaned up old entries in db-config
447 - mtail more robust
448
449 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
450 - php include path tweaked for plekit includes
451 - reviewed myplc (fka native) packaging dependencies
452 - renumbered 4.3
453
454 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
455 - rename myplc into myplc-chroot and myplc-native into myplc
456 - new settings (shortname & hrn_root) for local peer
457
458 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
459 - First iteration of new data model
460 - Bunch of various fixes
461
462 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
463 - Removed proper ops from planetflow slice.
464
465 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
466 - myplc-native requires myplc-docs
467 - fixed doc build by locating locally installed DTDs at build-time
468
469 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
470 - turn myplc-docs off for now
471
472 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
473 - figures in doc package
474
475 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
476 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
477 - chroot packaging does not have docs anymore
478 - 'cvs' and 'dev' not required from myplc-native anymore
479 - cosmetic change in kml output
480
481 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
482 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
483 - gethostbyname uses python rather than perl (hope this shrinks deps) 
484 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
485 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
486 - make sync now works towards vserver-based myplc only 
487
488 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
489
490 - added vsys 'pfmount' script to the default netflow slice attributes.
491
492
493 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
494 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
495 - to new bootcd packaging
496
497 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
498 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
499
500 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
501 - packaging of mplc-release in myplc-native
502 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
503 - resolv file in /etc/resolv.conf, not plc_resolv.conf
504 - improved sirius script
505 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
506 - expires more properly set 
507
508 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
509
510
511 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
512 - renew_reminder script moved to support-scripts/
513 - gen-aliases script added in support-scripts/
514 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
515 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
516 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
517 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
518 - new setting 'Mom list address' for sending emails to a separate destination
519 - starts rsyslogd/syslogd as appropriate
520 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
521 - convenience generation of yum.conf in resulting image based on build/mirroring
522
523 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
524 - refresh-peer.py removed (duplicate with PLCAPI)
525 - plc.d/ scripts cleaned up
526 - sirius initscript updated
527 - slice auto renewal fixed
528
529 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
530 - initial build.
531
532 %define module_current_branch 4.3