Merge commit 'origin/master'
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.0
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: bzip2
29 Requires: tar 
30 Requires: less
31 Requires: sendmail
32 Requires: sendmail-cf
33 Requires: openssl
34 Requires: expect
35 Requires: php-pgsql
36 Requires: curl
37 Requires: rsync
38 Requires: python-devel
39 Requires: yum
40 Requires: PyXML
41 Requires: createrepo
42 Requires: cpio
43 Requires: wget
44 Requires: php
45 Requires: openssh
46 Requires: dnsmasq
47 Requires: diffutils
48 Requires: gzip
49 Requires: vim-minimal
50 Requires: findutils
51 Requires: xmlsec1
52 Requires: xmlsec1-openssl
53 Requires: ed
54 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
55 Requires: cronie
56 %else
57 Requires: vixie-cron
58 %endif
59 # planetlab stuff
60 Requires: bootmanager
61 Requires: bootcd-%{nodefamily}
62 Requires: bootcd-initscripts
63 Requires: PLCWWW
64 Requires: www-register-wizard
65 Requires: nodeconfig
66 Requires: nodeyum
67 Requires: PLCAPI
68 Requires: bootstrapfs-%{nodefamily}
69 Requires: myplc-docs
70 Requires: myplc-release
71 Requires: myplc-config
72
73 %define debug_package %{nil}
74
75 %description
76 MyPLC is a complete PlanetLab Central (PLC) portable installation
77 contained within a chroot jail. The default installation consists of a
78 web server, an XML-RPC API server, a boot server, and a database
79 server: the core components of PLC. The installation may be customized
80 through a graphical interface. All PLC services are started up and
81 shut down through a single System V init script installed in the host
82 system.
83
84 ####################### myplc-config
85
86 %package config
87
88 Summary: PlanetLab Central (PLC) configuration python module
89 Group: Applications/Systems
90 Requires: python
91
92 %description config
93 This package provides the Python module to configure MyPLC.
94
95
96 %prep
97 %setup -q
98
99 %build
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 # Install configuration scripts
105 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
106 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
107 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
108
109 echo "* Installing scripts in /usr/bin"
110 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
111 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
112 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
113
114 # Install initscript 
115 echo "* Installing plc initscript"
116 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
117
118 # Install initscripts
119 echo "* Installing plc.d initscripts"
120 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
121 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
122
123 # Install db-config.d files
124 echo "* Installing db-config.d files"
125 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
126 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
127 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
128
129 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
130 echo "* Installing scripts in /etc/support-scripts"
131 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
132 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
133 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
134
135 # copy initscripts to etc/plc_sliceinitscripts
136 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
137 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
138 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
139
140 # Install configuration file
141 echo "* myplc: Installing configuration file"
142 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
143 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
144     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
145 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
146
147 echo "* Installing bashrc convenience"
148 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
149
150 # yumgroups.xml and yum repo : let noderepo handle that
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %pre
156 if [ -x %{_sysconfdir}/init.d/plc ] ; then
157     %{_sysconfdir}/init.d/plc stop
158 fi
159
160 # Old versions of myplc used to ship with a bootstrapped database and
161 # /etc/planetlab directory. Including generated files in the manifest
162 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
163 # names from one RPM build to another, it would be rpmsaved and thus
164 # effectively deleted. Now we do not include these files in the
165 # manifest. However, to avoid deleting these files in the process of
166 # upgrading from one of these old versions of myplc, we must back up
167 # the database and /etc/planetlab and restore them after the old
168 # version has been uninstalled in %triggerpostun (also in %post, in
169 # case we are force upgrading to the same version).
170 #
171 # This code can be removed once all myplc-0.4-1 installations have
172 # been upgraded to at least myplc-0.4-2.
173
174 # 0 = install, 1 = upgrade
175 if [ $1 -gt 0 ] ; then
176     for dir in /var/lib/pgsql/data /etc/planetlab ; do
177         if [ -d $dir ] ; then
178             echo "Preserving $dir"
179             mkdir -p $dir.rpmsave
180             tar -C $dir -cpf - . | \
181                tar -C $dir.rpmsave -xpf -
182
183             # Except for the default configuration file and DTD, which
184             # really should be considered for upgrade.
185             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
186         fi
187     done
188 fi
189
190 %post
191 if [ -x /sbin/chkconfig ] ; then
192     /sbin/chkconfig --add plc
193     /sbin/chkconfig plc on
194 fi
195
196 %triggerpostun -- %{name}
197 # 0 = erase, 1 = upgrade
198 if [ $1 -gt 0 ] ; then
199     for dir in /var/lib/pgsql/data /etc/planetlab ; do
200         if [ -d $dir.rpmsave -a -d $dir ] ; then
201             echo "Merging $dir"
202             if tar -C $dir.rpmsave -cpf - . | \
203                tar -C $dir -xpf - ; then
204                 rm -rf $dir.rpmsave
205             fi
206         fi
207     done
208 fi    
209
210 %preun
211 # 0 = erase, 1 = upgrade
212 if [ $1 -eq 0 ] ; then
213     %{_sysconfdir}/init.d/plc stop
214     if [ -x /sbin/chkconfig ] ; then
215         /sbin/chkconfig plc off
216         /sbin/chkconfig --del plc
217     fi
218 fi
219
220 %files
221 %defattr(-,root,root,-)
222 # Host startup script and configuration file
223 /etc/init.d/plc
224 /etc/plc.d
225 /etc/planetlab
226 /etc/plc_sliceinitscripts
227 /etc/support-scripts
228 /usr/share/myplc/bashrc
229 # keep a detailed list, to avoid duplicate of plc-config,
230 # that belongs to the myplc-config rpm
231 /usr/bin/plc-config-tty
232 /usr/bin/db-config
233 /usr/bin/dns-config
234 /usr/bin/refresh-peer.py*
235 /usr/bin/partial-repo.sh
236 /usr/bin/mtail.py*
237 /usr/bin/plc-map.py*
238 /usr/bin/plc-kml.py*
239 /usr/bin/clean-empty-dirs.py*
240 /usr/bin/plc-check-ssl-peering.py*
241 /usr/bin/plc-orphan-accounts.py*
242 /usr/bin/spot-aliens.py*
243 /usr/bin/spot-dup-accounts.sh
244
245 %files config
246 %defattr(-,root,root,-)
247 /usr/bin/plc-config
248 %{python_sitearch}/plc_config.py*
249
250
251 %changelog
252 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
253 - fixed changelog, no change from 5.0-16
254
255 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
256 - requires ed for the plc.d/packages step
257 - sirius initscript to handle stop and restart
258
259 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
260 - ignore steps in db-config.d if they have a '.' or '~' in their name
261
262 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
263 - can redo myplc-docs without the doc for monitor
264
265 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
266 - no semantic change - just fixed specfile for git URL
267
268 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
269 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
270
271 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
272 - add missing files to rpm package
273
274 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
275 - mtail.py -s for SFA
276 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
277
278 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
279 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
280
281 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
282 - plc-config-tty now has a validator on booleans
283 - e.g. entering 'True' now is rejected rather than silently recording 'false'
284
285 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
286 - disable mod_wsgi
287
288 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
289 - module name changes
290 - start wsgi support
291
292 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
293 - new setting PLC_RESERVATION_GRANULARITY
294
295 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
296 - * partial-repo.sh script
297 - * preserve key along with certificates
298
299 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
300 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
301
302 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
303 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
304 - new OMF category in the config
305 - create the drl system slice
306
307 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
308 - first working version of 5.0:
309 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
310 - nodefamily is 3-fold with pldistro-fcdistro-arch
311 - new PLC_FLAVOUR config category
312 - reviewed module layout
313 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
314
315 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
316 - support for fedora 12
317 - new package myplc-config for use by sfa
318 - drupal user registration turned off
319
320 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
321 - - fix to make sure when API, BOOT, MONITOR are on the same
322 - machine as WWW that the SSL key,cert for WWW takes precedence.
323 - - Do proper setup for SSL CA certficate to be used as the server
324 - chain.
325
326 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
327 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
328
329 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
330 - depend on pcucontrol
331
332 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
333 - * validate input according to type in plc_config
334 - * added the _genicw system slice
335 - * add tag types for sites and persons
336 - * add new tags for nodes and slices for exemption from myops
337
338 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
339 - turn off drupal on a box that acts as BOOT server but not as WWW server
340 - cleanup some obsolete code for old chroot-jail packaging in the process
341 - new bootcd-kernel script for keeping bootcd variants up2date
342
343 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
344 - Make the /etc/hosts manipulation optional.
345
346 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
347 - Fix SetRole.
348
349 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
350 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
351 - into the DB.
352 - - Added the root ssh key handling support back into plc.d/ssh and the
353 - default xml file.  This should be identical to the way it was in
354 - rc12.
355 - - Added support in the db-config.d/01-init script to register the root
356 - ssh public key with the default administrator.  In this way the root
357 - ssh key will make it into the root account on the nodes by means of
358 - NodeManager's specialaccounts plugin.
359
360 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
361 - db-config ignores sliver tags
362 - sirius's db-config script renamed (was sirious)
363
364 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
365 - fix for silverauth - missing tag types now created at plc startup time
366
367 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
368 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
369
370 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
371 - companion to NM's specialaccounts plugin
372 - do not generate /etc/planetlab/root_ssh_key* anymore
373 - remove related config. variables and conf_files
374
375 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
376 - clarified description text to refer only to plcrt and not other optional
377 - packages.
378
379 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
380 - fixed a bug setting slice multiple attributes with the same tag name
381
382 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
383 - SSL setup for monitor box, and related new config variables
384 - new conf_file for /etc/planetlab/extensions
385 - various tweaks in db-config internals, about initscripts among others
386 - also more messages defined in the db
387
388 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
389 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
390
391 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
392 - bugfix in db-config, tag 4.3-19 would not fly
393
394 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
395 - Refactored db-config into snippets in db-config.d/.
396
397 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
398 - oops, tag 4.3-17 was broken and would not work
399
400 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
401 - bugfix - escape sequences inserted in xml configs
402
403 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
404 - Handle db-config.d files properly.
405
406 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
407 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
408 - than the log file
409 - - Fix db-config to be a bit more cautious when
410 - /etc/planetlab/db-config.d doesn''t exist
411 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
412 - .orig files.
413 - - Refactor generic plc-config-tty code into plc_config.py.
414 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
415 - and the list of validated variables and the corresponding
416 - validator() function. This refactoring lets one reuse plc_config.py
417 - as a generic cmdline configuration tool for highly customer MyPLC
418 - like software.
419
420 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
421 - update PCU Type descriptions.
422 - updates to init scripts
423
424 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
425 - requires monitor-pcucontrol so register-wizard can work
426
427 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
428 - cleaned up plc-config-tty, no more need to configure plc-devel
429
430 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
431 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
432
433 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
434 - fix issue in db-config that prevented correct operation
435
436 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
437 - remove support for chroot-based packaging - no crond nor syslog step anymore
438 - plc init script now named plc.init instead of former guest.init
439
440 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
441 - add Monitor to docs build
442
443 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
444 - plc_config.py and plc-config-tty: generalized to work for more diverse
445 - MyPLC configurations.
446 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
447 - deployments and increase the memory limits in php.ini
448 - plc.d/crond: add --full option to vacuumdb
449
450 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
451 - avoid generating ssl certificates for disabled services among www api boot
452
453 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
454 - cleaned up old entries in db-config
455 - mtail more robust
456
457 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
458 - php include path tweaked for plekit includes
459 - reviewed myplc (fka native) packaging dependencies
460 - renumbered 4.3
461
462 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
463 - rename myplc into myplc-chroot and myplc-native into myplc
464 - new settings (shortname & hrn_root) for local peer
465
466 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
467 - First iteration of new data model
468 - Bunch of various fixes
469
470 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
471 - Removed proper ops from planetflow slice.
472
473 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
474 - myplc-native requires myplc-docs
475 - fixed doc build by locating locally installed DTDs at build-time
476
477 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
478 - turn myplc-docs off for now
479
480 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
481 - figures in doc package
482
483 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
484 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
485 - chroot packaging does not have docs anymore
486 - 'cvs' and 'dev' not required from myplc-native anymore
487 - cosmetic change in kml output
488
489 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
490 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
491 - gethostbyname uses python rather than perl (hope this shrinks deps) 
492 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
493 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
494 - make sync now works towards vserver-based myplc only 
495
496 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
497
498 - added vsys 'pfmount' script to the default netflow slice attributes.
499
500
501 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
502 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
503 - to new bootcd packaging
504
505 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
506 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
507
508 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
509 - packaging of mplc-release in myplc-native
510 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
511 - resolv file in /etc/resolv.conf, not plc_resolv.conf
512 - improved sirius script
513 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
514 - expires more properly set 
515
516 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
517
518
519 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
520 - renew_reminder script moved to support-scripts/
521 - gen-aliases script added in support-scripts/
522 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
523 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
524 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
525 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
526 - new setting 'Mom list address' for sending emails to a separate destination
527 - starts rsyslogd/syslogd as appropriate
528 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
529 - convenience generation of yum.conf in resulting image based on build/mirroring
530
531 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
532 - refresh-peer.py removed (duplicate with PLCAPI)
533 - plc.d/ scripts cleaned up
534 - sirius initscript updated
535 - slice auto renewal fixed
536
537 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
538 - initial build.
539
540 %define module_current_branch 4.3