have turned off post-commit temporarily, just checking if that makes any difference
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 31
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) Portable Installation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: bzip2
29 Requires: tar 
30 Requires: less
31 Requires: sendmail
32 Requires: sendmail-cf
33 Requires: openssl
34 Requires: expect
35 Requires: php-pgsql
36 Requires: curl
37 Requires: rsync
38 Requires: python-devel
39 Requires: vixie-cron
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 # planetlab stuff
55 Requires: bootmanager
56 Requires: bootcd-%{pldistro}-%{_arch}
57 Requires: PLCWWW
58 Requires: www-register-wizard
59 Requires: nodeconfig
60 Requires: PLCAPI
61 Requires: monitor-pcucontrol
62 Requires: bootstrapfs-%{pldistro}-%{_arch}
63 Requires: myplc-docs
64 Requires: myplc-release
65
66 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
67 %if "%{pldistro}" == "onelab"
68 Requires: dummynet_image
69 %endif
70
71 %define debug_package %{nil}
72
73 %description
74 MyPLC is a complete PlanetLab Central (PLC) portable installation
75 contained within a chroot jail. The default installation consists of a
76 web server, an XML-RPC API server, a boot server, and a database
77 server: the core components of PLC. The installation may be customized
78 through a graphical interface. All PLC services are started up and
79 shut down through a single System V init script installed in the host
80 system.
81
82 %prep
83 %setup -q
84
85 %build
86
87 %install
88 pushd MyPLC
89 rm -rf $RPM_BUILD_ROOT
90 ./build.sh %{pldistro} $RPM_BUILD_ROOT
91 popd
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 # If run under sudo
97 if [ -n "$SUDO_USER" ] ; then
98     # Allow user to delete the build directory
99     chown -h -R $SUDO_USER .
100     # Some temporary cdroot files like /var/empty/sshd and
101     # /usr/bin/sudo get created with non-readable permissions.
102     find . -not -perm +0600 -exec chmod u+rw {} \;
103     # Allow user to delete the built RPM(s)
104     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
105 fi
106
107 %pre
108 if [ -x %{_sysconfdir}/init.d/plc ] ; then
109     %{_sysconfdir}/init.d/plc stop
110 fi
111
112 # Old versions of myplc used to ship with a bootstrapped database and
113 # /etc/planetlab directory. Including generated files in the manifest
114 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
115 # names from one RPM build to another, it would be rpmsaved and thus
116 # effectively deleted. Now we do not include these files in the
117 # manifest. However, to avoid deleting these files in the process of
118 # upgrading from one of these old versions of myplc, we must back up
119 # the database and /etc/planetlab and restore them after the old
120 # version has been uninstalled in %triggerpostun (also in %post, in
121 # case we are force upgrading to the same version).
122 #
123 # This code can be removed once all myplc-0.4-1 installations have
124 # been upgraded to at least myplc-0.4-2.
125
126 # 0 = install, 1 = upgrade
127 if [ $1 -gt 0 ] ; then
128     for dir in /var/lib/pgsql/data /etc/planetlab ; do
129         if [ -d $dir ] ; then
130             echo "Preserving $dir"
131             mkdir -p $dir.rpmsave
132             tar -C $dir -cpf - . | \
133                tar -C $dir.rpmsave -xpf -
134
135             # Except for the default configuration file and DTD, which
136             # really should be considered for upgrade.
137             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
138         fi
139     done
140 fi
141
142 %post
143 if [ -x /sbin/chkconfig ] ; then
144     /sbin/chkconfig --add plc
145     /sbin/chkconfig plc on
146 fi
147 pushd /usr/share/myplc &> /dev/null
148 python plc_config.py build
149 python plc_config.py install
150 popd &> /dev/null
151
152 %triggerpostun -- %{name}
153 # 0 = erase, 1 = upgrade
154 if [ $1 -gt 0 ] ; then
155     for dir in /var/lib/pgsql/data /etc/planetlab ; do
156         if [ -d $dir.rpmsave -a -d $dir ] ; then
157             echo "Merging $dir"
158             if tar -C $dir.rpmsave -cpf - . | \
159                tar -C $dir -xpf - ; then
160                 rm -rf $dir.rpmsave
161             fi
162         fi
163     done
164 fi    
165
166 %preun
167 # 0 = erase, 1 = upgrade
168 if [ $1 -eq 0 ] ; then
169     %{_sysconfdir}/init.d/plc stop
170     if [ -x /sbin/chkconfig ] ; then
171         /sbin/chkconfig plc off
172         /sbin/chkconfig --del plc
173     fi
174 fi
175
176 %files
177 %defattr(-,root,root,-)
178 # Host startup script and configuration file
179 /etc/init.d/plc
180 /etc/plc.d
181 /etc/planetlab
182 /etc/plc_sliceinitscripts/sirius
183 /etc/support-scripts/gen_aliases.py*
184 /etc/support-scripts/renew_reminder.py*
185 /etc/support-scripts/renew_reminder_logrotate
186 /usr/bin/plc-config
187 /usr/bin/plc-config-tty
188 /usr/bin/db-config
189 /usr/bin/dns-config
190 /usr/bin/plc-map.py*
191 /usr/bin/plc-kml.py*
192 /usr/bin/refresh-peer.py*
193 /usr/bin/clean-empty-dirs.py*
194 /usr/bin/mtail.py*
195 /usr/bin/plc-check-ssl-peering.py*
196 /usr/bin/plc-orphan-accounts.py*
197 /usr/share/myplc
198
199 %changelog
200 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
201 - Make the /etc/hosts manipulation optional.
202
203 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
204 - Fix SetRole.
205
206 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
207 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
208 - into the DB.
209 - - Added the root ssh key handling support back into plc.d/ssh and the
210 - default xml file.  This should be identical to the way it was in
211 - rc12.
212 - - Added support in the db-config.d/01-init script to register the root
213 - ssh public key with the default administrator.  In this way the root
214 - ssh key will make it into the root account on the nodes by means of
215 - NodeManager's specialaccounts plugin.
216
217 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
218 - db-config ignores sliver tags
219 - sirius's db-config script renamed (was sirious)
220
221 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
222 - fix for silverauth - missing tag types now created at plc startup time
223
224 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
225 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
226
227 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
228 - companion to NM's specialaccounts plugin
229 - do not generate /etc/planetlab/root_ssh_key* anymore
230 - remove related config. variables and conf_files
231
232 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
233 - clarified description text to refer only to plcrt and not other optional
234 - packages.
235
236 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
237 - fixed a bug setting slice multiple attributes with the same tag name
238
239 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
240 - SSL setup for monitor box, and related new config variables
241 - new conf_file for /etc/planetlab/extensions
242 - various tweaks in db-config internals, about initscripts among others
243 - also more messages defined in the db
244
245 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
246 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
247
248 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
249 - bugfix in db-config, tag 4.3-19 would not fly
250
251 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
252 - Refactored db-config into snippets in db-config.d/.
253
254 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
255 - oops, tag 4.3-17 was broken and would not work
256
257 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
258 - bugfix - escape sequences inserted in xml configs
259
260 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
261 - Handle db-config.d files properly.
262
263 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
264 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
265 - than the log file
266 - - Fix db-config to be a bit more cautious when
267 - /etc/planetlab/db-config.d doesn't exist
268 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
269 - .orig files.
270 - - Refactor generic plc-config-tty code into plc_config.py.
271 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
272 - and the list of validated variables and the corresponding
273 - validator() function. This refactoring lets one reuse plc_config.py
274 - as a generic cmdline configuration tool for highly customer MyPLC
275 - like software.
276
277 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
278 - update PCU Type descriptions.
279 - updates to init scripts
280
281 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
282 - requires monitor-pcucontrol so register-wizard can work
283
284 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
285 - cleaned up plc-config-tty, no more need to configure plc-devel
286
287 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
288 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
289
290 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
291 - fix issue in db-config that prevented correct operation
292
293 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
294 - remove support for chroot-based packaging - no crond nor syslog step anymore
295 - plc init script now named plc.init instead of former guest.init
296
297 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
298 - add Monitor to docs build
299
300 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
301 - plc_config.py and plc-config-tty: generalized to work for more diverse
302 - MyPLC configurations.
303 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
304 - deployments and increase the memory limits in php.ini
305 - plc.d/crond: add --full option to vacuumdb
306
307 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
308 - avoid generating ssl certificates for disabled services among www api boot
309
310 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
311 - cleaned up old entries in db-config
312 - mtail more robust
313
314 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
315 - php include path tweaked for plekit includes
316 - reviewed myplc (fka native) packaging dependencies
317 - renumbered 4.3
318
319 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
320 - rename myplc into myplc-chroot and myplc-native into myplc
321 - new settings (shortname & hrn_root) for local peer
322
323 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
324 - First iteration of new data model
325 - Bunch of various fixes
326
327 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
328 - Removed proper ops from planetflow slice.
329
330 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
331 - myplc-native requires myplc-docs
332 - fixed doc build by locating locally installed DTDs at build-time
333
334 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
335 - turn myplc-docs off for now
336
337 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
338 - figures in doc package
339
340 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
341 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
342 - chroot packaging does not have docs anymore
343 - 'cvs' and 'dev' not required from myplc-native anymore
344 - cosmetic change in kml output
345
346 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
347 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
348 - gethostbyname uses python rather than perl (hope this shrinks deps) 
349 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
350 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
351 - make sync now works towards vserver-based myplc only 
352
353 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
354
355 - added vsys 'pfmount' script to the default netflow slice attributes.
356
357
358 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
359 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
360 - to new bootcd packaging
361
362 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
363 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
364
365 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
366 - packaging of mplc-release in myplc-native
367 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
368 - resolv file in /etc/resolv.conf, not plc_resolv.conf
369 - improved sirius script
370 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
371 - expires more properly set 
372
373 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
374
375
376 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
377 - renew_reminder script moved to support-scripts/
378 - gen-aliases script added in support-scripts/
379 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
380 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
381 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
382 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
383 - new setting 'Mom list address' for sending emails to a separate destination
384 - starts rsyslogd/syslogd as appropriate
385 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
386 - convenience generation of yum.conf in resulting image based on build/mirroring
387
388 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
389 - refresh-peer.py removed (duplicate with PLCAPI)
390 - plc.d/ scripts cleaned up
391 - sirius initscript updated
392 - slice auto renewal fixed
393
394 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
395 - initial build.
396
397 %define module_current_branch 4.2