myplc startup now always regenerates configuration at least once
[myplc.git] / myplc.spec
1 Vendor: PlanetLab
2 Packager: PlanetLab Central <support@planet-lab.org>
3 Distribution: PlanetLab 4.0
4 URL: http://cvs.planet-lab.org/cvs/myplc
5
6 Summary: PlanetLab Central (PLC) Portable Installation
7 Name: myplc
8 Version: 0.5
9 Release: 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 License: PlanetLab
11 Group: Applications/Systems
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15 %define debug_package %{nil}
16
17 %description
18 MyPLC is a complete PlanetLab Central (PLC) portable installation
19 contained within a chroot jail. The default installation consists of a
20 web server, an XML-RPC API server, a boot server, and a database
21 server: the core components of PLC. The installation may be customized
22 through a graphical interface. All PLC services are started up and
23 shut down through a single System V init script installed in the host
24 system.
25
26 %package devel
27 Summary: PlanetLab Central (PLC) Development Environment
28 Group: Development/Tools
29 AutoReqProv: no
30
31 %description devel
32 This package install a complete PlanetLab development environment
33 contained within a chroot jail. The default installation consists of a
34 local CVS repository bootstrapped with a snapshot of all PlanetLab
35 source code, and all the tools necessary to compile it.
36
37 %prep
38 %setup -q
39
40 %build
41 pushd myplc
42 ./build_devel.sh %{?cvstag:-t %{cvstag}}
43 ./build.sh %{?cvstag:-t %{cvstag}}
44 popd
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 pushd myplc
50
51 #
52 # myplc
53 #
54
55 # Install host startup script and configuration file
56 install -D -m 755 host.init $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/plc
57 install -D -m 644 plc.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/plc
58
59 # Create convenient symlink
60 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}
61 ln -sf /plc/data/etc/planetlab $RPM_BUILD_ROOT/%{_sysconfdir}/planetlab
62
63 # Install root filesystem
64 install -d -m 755 $RPM_BUILD_ROOT/plc/root
65 install -D -m 644 root.img $RPM_BUILD_ROOT/plc/root.img
66
67 # Install data directory
68 find data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
69
70 #
71 # myplc-devel
72 #
73
74 # Install host startup script and configuration file
75 install -D -m 755 host.init $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/plc-devel
76 install -D -m 644 plc-devel.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/plc-devel
77
78 # Install root filesystem
79 install -d -m 755 $RPM_BUILD_ROOT/plc/devel/root
80 install -D -m 644 devel/root.img $RPM_BUILD_ROOT/plc/devel/root.img
81
82 # Install data directory
83 find devel/data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
84
85 # Make sure /cvs is never upgraded once installed by giving it a
86 # unique name. A hard-linked copy is made in %post.
87 mv $RPM_BUILD_ROOT/plc/devel/data/{cvs,cvs-%{version}-%{release}}
88
89 popd
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 # If run under sudo
95 if [ -n "$SUDO_USER" ] ; then
96     # Allow user to delete the build directory
97     chown -R $SUDO_USER .
98     # Some temporary cdroot files like /var/empty/sshd and
99     # /usr/bin/sudo get created with non-readable permissions.
100     find . -not -perm +0600 -exec chmod u+rw {} \;
101     # Allow user to delete the built RPM(s)
102     chown -R $SUDO_USER %{_rpmdir}/%{_arch}
103 fi
104
105 %pre
106 if [ -x %{_sysconfdir}/init.d/plc ] ; then
107     %{_sysconfdir}/init.d/plc stop
108 fi
109
110 # Old versions of myplc used to ship with a bootstrapped database and
111 # /etc/planetlab directory. Including generated files in the manifest
112 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
113 # names from one RPM build to another, it would be rpmsaved and thus
114 # effectively deleted. Now we do not include these files in the
115 # manifest. However, to avoid deleting these files in the process of
116 # upgrading from one of these old versions of myplc, we must back up
117 # the database and /etc/planetlab and restore them after the old
118 # version has been uninstalled in %triggerpostun (also in %post, in
119 # case we are force upgrading to the same version).
120 #
121 # This code can be removed once all myplc-0.4-1 installations have
122 # been upgraded to at least myplc-0.4-2.
123
124 # 0 = install, 1 = upgrade
125 if [ $1 -gt 0 ] ; then
126     for dir in /var/lib/pgsql/data /etc/planetlab ; do
127         if [ -d /plc/data/$dir ] ; then
128             echo "Preserving /plc/data/$dir"
129             mkdir -p /plc/data/$dir.rpmsave
130             tar -C /plc/data/$dir -cpf - . | \
131                tar -C /plc/data/$dir.rpmsave -xpf -
132
133             # Except for the default configuration file and DTD, which
134             # really should be considered for upgrade.
135             rm -f /plc/data/$dir.rpmsave/{default_config.xml,plc_config.dtd}
136         fi
137     done
138 fi
139
140 %post
141 if [ -x /sbin/chkconfig ] ; then
142     /sbin/chkconfig --add plc
143     /sbin/chkconfig plc on
144 fi
145
146 %triggerpostun -- %{name}
147 # 0 = erase, 1 = upgrade
148 if [ $1 -gt 0 ] ; then
149     for dir in /var/lib/pgsql/data /etc/planetlab ; do
150         if [ -d /plc/data/$dir.rpmsave -a -d /plc/data/$dir ] ; then
151             echo "Merging /plc/data/$dir"
152             if tar -C /plc/data/$dir.rpmsave -cpf - . | \
153                tar -C /plc/data/$dir -xpf - ; then
154                 rm -rf /plc/data/$dir.rpmsave
155             fi
156         fi
157     done
158 fi    
159
160 %preun
161 # 0 = erase, 1 = upgrade
162 if [ $1 -eq 0 ] ; then
163     %{_sysconfdir}/init.d/plc stop
164     if [ -x /sbin/chkconfig ] ; then
165         /sbin/chkconfig plc off
166         /sbin/chkconfig --del plc
167     fi
168 fi
169
170 %pre devel
171 if [ -x %{_sysconfdir}/init.d/plc-devel ] ; then
172     %{_sysconfdir}/init.d/plc-devel stop
173 fi
174
175 %post devel
176 if [ -x /sbin/chkconfig ] ; then
177     /sbin/chkconfig --add plc-devel
178     /sbin/chkconfig plc-devel on
179 fi
180
181 # If /cvs does not already exist, make a hard-linked copy of this
182 # version's /cvs repository.
183 if [ ! -d /plc/devel/data/cvs ] ; then
184     cp -rl /plc/devel/data/{cvs-%{version}-%{release},cvs}
185 fi
186
187 %preun devel
188 # 0 = erase, 1 = upgrade
189 if [ $1 -eq 0 ] ; then
190     %{_sysconfdir}/init.d/plc-devel stop
191     if [ -x /sbin/chkconfig ] ; then
192         /sbin/chkconfig plc-devel off
193         /sbin/chkconfig --del plc-devel
194     fi
195 fi
196
197 %files
198 %defattr(-,root,root,-)
199 # Host startup script and configuration file
200 %{_sysconfdir}/init.d/plc
201 %{_sysconfdir}/sysconfig/plc
202
203 # Symlink to /etc/planetlab within data directory
204 %{_sysconfdir}/planetlab
205
206 # Root filesystem
207 /plc/root.img
208 /plc/root
209
210 # Data directory
211 %dir /plc/data
212 %config(noreplace) /plc/data/*
213
214 %files devel
215 %defattr(-,root,root,-)
216 # Host startup script and configuration file
217 %{_sysconfdir}/init.d/plc-devel
218 %{_sysconfdir}/sysconfig/plc-devel
219
220 # Root filesystem
221 /plc/devel/root.img
222 /plc/devel/root
223
224 # Data directory
225 %dir /plc/devel/data
226 %config(noreplace) /plc/devel/data/*
227
228 %changelog
229 * Thu Jul 13 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-2, 0.5-2
230 - MyPLC 0.4 RC2.
231 - Fix many spec files (License replaces Copyright).
232 - Fix kernel build under gcc32 (module verification bug).
233 - Fix vnet build under gcc32
234 - Fix PlanetFlow. MySQL RPM postinstall script no longer starts the
235   server. Also, get hostnames list from PLC_WWW_HOST, not
236   www.planet-lab.org.
237 - Fix pl_mom/bwmon to use cached values if NM is unresponsive
238 - Fix pl_mom/swapmon reset logic to avoid endless loops
239 - Remove ksymoops, add kernel-smp to standard PlanetLab package group
240 - Add kernel-smp boot support to bootmanager
241 - Add badblock search support to bootmanager
242 - Build development environment (myplc-devel). Add support for
243   building myplc itself inside myplc-devel.
244 - Move step-specific initialization to appropriate plc.d scripts
245 - Fix postgresql startup failure when bootstrapping
246 - Allow CA to be configured for each SSL certificate set. Stop doing
247   root CA stuff, this is outside the scope of MyPLC. MyPLC now only
248   generates self-signed certificates, but supports replacement of the
249   self-signed certificates with real certifcates signed by another CA,
250   as long as the CA is specified.
251 - Self-sign the MA/SA SSL certificate (and by extension, the MA/SA API
252   certificate).
253 - pl_mom: Workarounds for when NM queries time out.
254 - plc_api: Honor PLC_MAIL_ENABLED.
255
256 * Wed Jul  6 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-1, 0.5-1
257 - First stable release of MyPLC 0.4 RC1.
258
259 * Wed Apr  5 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.2-1
260 - Basic functionality complete. Consolidate into a single package
261   installed in /plc.
262
263 * Fri Mar 17 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.1-1
264 - Initial build.
265