Setting tag myplc-5.0-12
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 %define url $URL$
4
5 %define name myplc
6 %define version 5.0
7 %define taglevel 12
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
11
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 License: PlanetLab
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %(echo %{url} | cut -d ' ' -f 2)
24
25 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
26
27 ####################### myplc
28 Summary: PlanetLab Central (PLC) Portable Installation
29 Group: Applications/Systems
30
31 # as much as possible, requires should go in the subpackages specfile
32 Requires: bzip2
33 Requires: tar 
34 Requires: less
35 Requires: sendmail
36 Requires: sendmail-cf
37 Requires: openssl
38 Requires: expect
39 Requires: php-pgsql
40 Requires: curl
41 Requires: rsync
42 Requires: python-devel
43 Requires: yum
44 Requires: PyXML
45 Requires: createrepo
46 Requires: cpio
47 Requires: wget
48 Requires: php
49 Requires: openssh
50 Requires: dnsmasq
51 Requires: diffutils
52 Requires: gzip
53 Requires: vim-minimal
54 Requires: findutils
55 Requires: xmlsec1
56 Requires: xmlsec1-openssl
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
58 Requires: cronie
59 %else
60 Requires: vixie-cron
61 %endif
62 # planetlab stuff
63 Requires: bootmanager
64 Requires: bootcd-%{nodefamily}
65 Requires: bootcd-initscripts
66 Requires: PLCWWW
67 Requires: www-register-wizard
68 Requires: nodeconfig
69 Requires: nodeyum
70 Requires: PLCAPI
71 Requires: bootstrapfs-%{nodefamily}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 %define debug_package %{nil}
77
78 %description
79 MyPLC is a complete PlanetLab Central (PLC) portable installation
80 contained within a chroot jail. The default installation consists of a
81 web server, an XML-RPC API server, a boot server, and a database
82 server: the core components of PLC. The installation may be customized
83 through a graphical interface. All PLC services are started up and
84 shut down through a single System V init script installed in the host
85 system.
86
87 ####################### myplc-config
88
89 %package config
90
91 Summary: PlanetLab Central (PLC) configuration python module
92 Group: Applications/Systems
93 Requires: python
94
95 %description config
96 This package provides the Python module to configure MyPLC.
97
98
99 %prep
100 %setup -q
101
102 %build
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 # Install configuration scripts
108 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
109 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
110 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
111
112 echo "* Installing scripts in /usr/bin"
113 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
114 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
115 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
116
117 # Install initscript 
118 echo "* Installing plc initscript"
119 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
120
121 # Install initscripts
122 echo "* Installing plc.d initscripts"
123 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
124 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
125
126 # Install db-config.d files
127 echo "* Installing db-config.d files"
128 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
129 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
130 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
131
132 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
133 echo "* Installing scripts in /etc/support-scripts"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
135 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
136 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
137
138 # copy initscripts to etc/plc_sliceinitscripts
139 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
140 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
141 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
142
143 # Install configuration file
144 echo "* myplc: Installing configuration file"
145 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
146 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
147     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
148 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
149
150 echo "* Installing bashrc convenience"
151 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
152
153 # yumgroups.xml and yum repo : let noderepo handle that
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %pre
159 if [ -x %{_sysconfdir}/init.d/plc ] ; then
160     %{_sysconfdir}/init.d/plc stop
161 fi
162
163 # Old versions of myplc used to ship with a bootstrapped database and
164 # /etc/planetlab directory. Including generated files in the manifest
165 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
166 # names from one RPM build to another, it would be rpmsaved and thus
167 # effectively deleted. Now we do not include these files in the
168 # manifest. However, to avoid deleting these files in the process of
169 # upgrading from one of these old versions of myplc, we must back up
170 # the database and /etc/planetlab and restore them after the old
171 # version has been uninstalled in %triggerpostun (also in %post, in
172 # case we are force upgrading to the same version).
173 #
174 # This code can be removed once all myplc-0.4-1 installations have
175 # been upgraded to at least myplc-0.4-2.
176
177 # 0 = install, 1 = upgrade
178 if [ $1 -gt 0 ] ; then
179     for dir in /var/lib/pgsql/data /etc/planetlab ; do
180         if [ -d $dir ] ; then
181             echo "Preserving $dir"
182             mkdir -p $dir.rpmsave
183             tar -C $dir -cpf - . | \
184                tar -C $dir.rpmsave -xpf -
185
186             # Except for the default configuration file and DTD, which
187             # really should be considered for upgrade.
188             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
189         fi
190     done
191 fi
192
193 %post
194 if [ -x /sbin/chkconfig ] ; then
195     /sbin/chkconfig --add plc
196     /sbin/chkconfig plc on
197 fi
198
199 %triggerpostun -- %{name}
200 # 0 = erase, 1 = upgrade
201 if [ $1 -gt 0 ] ; then
202     for dir in /var/lib/pgsql/data /etc/planetlab ; do
203         if [ -d $dir.rpmsave -a -d $dir ] ; then
204             echo "Merging $dir"
205             if tar -C $dir.rpmsave -cpf - . | \
206                tar -C $dir -xpf - ; then
207                 rm -rf $dir.rpmsave
208             fi
209         fi
210     done
211 fi    
212
213 %preun
214 # 0 = erase, 1 = upgrade
215 if [ $1 -eq 0 ] ; then
216     %{_sysconfdir}/init.d/plc stop
217     if [ -x /sbin/chkconfig ] ; then
218         /sbin/chkconfig plc off
219         /sbin/chkconfig --del plc
220     fi
221 fi
222
223 %files
224 %defattr(-,root,root,-)
225 # Host startup script and configuration file
226 /etc/init.d/plc
227 /etc/plc.d
228 /etc/planetlab
229 /etc/plc_sliceinitscripts
230 /etc/support-scripts
231 /usr/share/myplc/bashrc
232 # keep a detailed list, to avoid duplicate of plc-config,
233 # that belongs to the myplc-config rpm
234 /usr/bin/plc-config-tty
235 /usr/bin/db-config
236 /usr/bin/dns-config
237 /usr/bin/refresh-peer.py*
238 /usr/bin/partial-repo.sh
239 /usr/bin/mtail.py*
240 /usr/bin/plc-map.py*
241 /usr/bin/plc-kml.py*
242 /usr/bin/clean-empty-dirs.py*
243 /usr/bin/plc-check-ssl-peering.py*
244 /usr/bin/plc-orphan-accounts.py*
245 /usr/bin/spot-aliens.py*
246 /usr/bin/spot-dup-accounts.sh
247
248 %files config
249 %defattr(-,root,root,-)
250 /usr/bin/plc-config
251 %{python_sitearch}/plc_config.py*
252
253
254 %changelog
255 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
256 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
257
258 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
259 - add missing files to rpm package
260
261 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
262 - mtail.py -s for SFA
263 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
264
265 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
266 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
267
268 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
269 - plc-config-tty now has a validator on booleans
270 - e.g. entering 'True' now is rejected rather than silently recording 'false'
271
272 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
273 - disable mod_wsgi
274
275 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
276 - module name changes
277 - start wsgi support
278
279 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
280 - new setting PLC_RESERVATION_GRANULARITY
281
282 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
283 - * partial-repo.sh script
284 - * preserve key along with certificates
285
286 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
287 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
288
289 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
290 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
291 - new OMF category in the config
292 - create the drl system slice
293
294 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
295 - first working version of 5.0:
296 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
297 - nodefamily is 3-fold with pldistro-fcdistro-arch
298 - new PLC_FLAVOUR config category
299 - reviewed module layout
300 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
301
302 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
303 - support for fedora 12
304 - new package myplc-config for use by sfa
305 - drupal user registration turned off
306
307 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
308 - - fix to make sure when API, BOOT, MONITOR are on the same
309 - machine as WWW that the SSL key,cert for WWW takes precedence.
310 - - Do proper setup for SSL CA certficate to be used as the server
311 - chain.
312
313 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
314 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
315
316 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
317 - depend on pcucontrol
318
319 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
320 - * validate input according to type in plc_config
321 - * added the _genicw system slice
322 - * add tag types for sites and persons
323 - * add new tags for nodes and slices for exemption from myops
324
325 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
326 - turn off drupal on a box that acts as BOOT server but not as WWW server
327 - cleanup some obsolete code for old chroot-jail packaging in the process
328 - new bootcd-kernel script for keeping bootcd variants up2date
329
330 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
331 - Make the /etc/hosts manipulation optional.
332
333 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
334 - Fix SetRole.
335
336 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
337 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
338 - into the DB.
339 - - Added the root ssh key handling support back into plc.d/ssh and the
340 - default xml file.  This should be identical to the way it was in
341 - rc12.
342 - - Added support in the db-config.d/01-init script to register the root
343 - ssh public key with the default administrator.  In this way the root
344 - ssh key will make it into the root account on the nodes by means of
345 - NodeManager's specialaccounts plugin.
346
347 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
348 - db-config ignores sliver tags
349 - sirius's db-config script renamed (was sirious)
350
351 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
352 - fix for silverauth - missing tag types now created at plc startup time
353
354 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
355 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
356
357 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
358 - companion to NM's specialaccounts plugin
359 - do not generate /etc/planetlab/root_ssh_key* anymore
360 - remove related config. variables and conf_files
361
362 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
363 - clarified description text to refer only to plcrt and not other optional
364 - packages.
365
366 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
367 - fixed a bug setting slice multiple attributes with the same tag name
368
369 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
370 - SSL setup for monitor box, and related new config variables
371 - new conf_file for /etc/planetlab/extensions
372 - various tweaks in db-config internals, about initscripts among others
373 - also more messages defined in the db
374
375 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
376 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
377
378 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
379 - bugfix in db-config, tag 4.3-19 would not fly
380
381 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
382 - Refactored db-config into snippets in db-config.d/.
383
384 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
385 - oops, tag 4.3-17 was broken and would not work
386
387 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
388 - bugfix - escape sequences inserted in xml configs
389
390 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
391 - Handle db-config.d files properly.
392
393 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
394 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
395 - than the log file
396 - - Fix db-config to be a bit more cautious when
397 - /etc/planetlab/db-config.d doesn''t exist
398 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
399 - .orig files.
400 - - Refactor generic plc-config-tty code into plc_config.py.
401 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
402 - and the list of validated variables and the corresponding
403 - validator() function. This refactoring lets one reuse plc_config.py
404 - as a generic cmdline configuration tool for highly customer MyPLC
405 - like software.
406
407 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
408 - update PCU Type descriptions.
409 - updates to init scripts
410
411 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
412 - requires monitor-pcucontrol so register-wizard can work
413
414 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
415 - cleaned up plc-config-tty, no more need to configure plc-devel
416
417 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
418 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
419
420 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
421 - fix issue in db-config that prevented correct operation
422
423 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
424 - remove support for chroot-based packaging - no crond nor syslog step anymore
425 - plc init script now named plc.init instead of former guest.init
426
427 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
428 - add Monitor to docs build
429
430 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
431 - plc_config.py and plc-config-tty: generalized to work for more diverse
432 - MyPLC configurations.
433 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
434 - deployments and increase the memory limits in php.ini
435 - plc.d/crond: add --full option to vacuumdb
436
437 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
438 - avoid generating ssl certificates for disabled services among www api boot
439
440 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
441 - cleaned up old entries in db-config
442 - mtail more robust
443
444 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
445 - php include path tweaked for plekit includes
446 - reviewed myplc (fka native) packaging dependencies
447 - renumbered 4.3
448
449 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
450 - rename myplc into myplc-chroot and myplc-native into myplc
451 - new settings (shortname & hrn_root) for local peer
452
453 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
454 - First iteration of new data model
455 - Bunch of various fixes
456
457 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
458 - Removed proper ops from planetflow slice.
459
460 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
461 - myplc-native requires myplc-docs
462 - fixed doc build by locating locally installed DTDs at build-time
463
464 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
465 - turn myplc-docs off for now
466
467 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
468 - figures in doc package
469
470 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
471 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
472 - chroot packaging does not have docs anymore
473 - 'cvs' and 'dev' not required from myplc-native anymore
474 - cosmetic change in kml output
475
476 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
477 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
478 - gethostbyname uses python rather than perl (hope this shrinks deps) 
479 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
480 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
481 - make sync now works towards vserver-based myplc only 
482
483 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
484
485 - added vsys 'pfmount' script to the default netflow slice attributes.
486
487
488 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
489 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
490 - to new bootcd packaging
491
492 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
493 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
494
495 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
496 - packaging of mplc-release in myplc-native
497 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
498 - resolv file in /etc/resolv.conf, not plc_resolv.conf
499 - improved sirius script
500 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
501 - expires more properly set 
502
503 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
504
505
506 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
507 - renew_reminder script moved to support-scripts/
508 - gen-aliases script added in support-scripts/
509 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
510 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
511 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
512 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
513 - new setting 'Mom list address' for sending emails to a separate destination
514 - starts rsyslogd/syslogd as appropriate
515 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
516 - convenience generation of yum.conf in resulting image based on build/mirroring
517
518 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
519 - refresh-peer.py removed (duplicate with PLCAPI)
520 - plc.d/ scripts cleaned up
521 - sirius initscript updated
522 - slice auto renewal fixed
523
524 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
525 - initial build.
526
527 %define module_current_branch 4.3