Branch 5.0 for module MyPLC created (as new trunk) from tag MyPLC-4.3-37
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 5.0
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: bootcd-initscripts
67 Requires: PLCWWW
68 Requires: www-register-wizard
69 Requires: nodeconfig
70 Requires: PLCAPI
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 %define debug_package %{nil}
77
78 %description
79 MyPLC is a complete PlanetLab Central (PLC) portable installation
80 contained within a chroot jail. The default installation consists of a
81 web server, an XML-RPC API server, a boot server, and a database
82 server: the core components of PLC. The installation may be customized
83 through a graphical interface. All PLC services are started up and
84 shut down through a single System V init script installed in the host
85 system.
86
87 ####################### myplc-config
88
89 %package config
90
91 Summary: PlanetLab Central (PLC) configuration python module
92 Group: Applications/Systems
93 Requires: python
94
95 %description config
96 This package provides the Python module to configure MyPLC.
97
98
99 %prep
100 %setup -q
101
102 %build
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 # Install configuration scripts
108 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
109 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
110 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
111
112 echo "* Installing scripts in /usr/bin"
113 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
114 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
115 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
116
117 # Install initscript 
118 echo "* Installing plc initscript"
119 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
120
121 # Install initscripts
122 echo "* Installing plc.d initscripts"
123 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
124 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
125
126 # Install db-config.d files
127 echo "* Installing db-config.d files"
128 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
129 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
130 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
131
132 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
133 echo "* Installing scripts in /etc/support-scripts"
134 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
135 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
136 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
137
138 # copy initscripts to etc/plc_sliceinitscripts
139 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
140 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
141 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
142
143 # Install configuration file
144 echo "* myplc: Installing configuration file"
145 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
146 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{fcdistro},g" -e "s,@ARCH@,%{arch},g" \
147     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
148 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
149
150 echo "* Installing bashrc convenience"
151 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
152
153 # yumgroups.xml and yum repo : let noderepo handle that
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %pre
159 if [ -x %{_sysconfdir}/init.d/plc ] ; then
160     %{_sysconfdir}/init.d/plc stop
161 fi
162
163 # Old versions of myplc used to ship with a bootstrapped database and
164 # /etc/planetlab directory. Including generated files in the manifest
165 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
166 # names from one RPM build to another, it would be rpmsaved and thus
167 # effectively deleted. Now we do not include these files in the
168 # manifest. However, to avoid deleting these files in the process of
169 # upgrading from one of these old versions of myplc, we must back up
170 # the database and /etc/planetlab and restore them after the old
171 # version has been uninstalled in %triggerpostun (also in %post, in
172 # case we are force upgrading to the same version).
173 #
174 # This code can be removed once all myplc-0.4-1 installations have
175 # been upgraded to at least myplc-0.4-2.
176
177 # 0 = install, 1 = upgrade
178 if [ $1 -gt 0 ] ; then
179     for dir in /var/lib/pgsql/data /etc/planetlab ; do
180         if [ -d $dir ] ; then
181             echo "Preserving $dir"
182             mkdir -p $dir.rpmsave
183             tar -C $dir -cpf - . | \
184                tar -C $dir.rpmsave -xpf -
185
186             # Except for the default configuration file and DTD, which
187             # really should be considered for upgrade.
188             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
189         fi
190     done
191 fi
192
193 %post
194 if [ -x /sbin/chkconfig ] ; then
195     /sbin/chkconfig --add plc
196     /sbin/chkconfig plc on
197 fi
198
199 %triggerpostun -- %{name}
200 # 0 = erase, 1 = upgrade
201 if [ $1 -gt 0 ] ; then
202     for dir in /var/lib/pgsql/data /etc/planetlab ; do
203         if [ -d $dir.rpmsave -a -d $dir ] ; then
204             echo "Merging $dir"
205             if tar -C $dir.rpmsave -cpf - . | \
206                tar -C $dir -xpf - ; then
207                 rm -rf $dir.rpmsave
208             fi
209         fi
210     done
211 fi    
212
213 %preun
214 # 0 = erase, 1 = upgrade
215 if [ $1 -eq 0 ] ; then
216     %{_sysconfdir}/init.d/plc stop
217     if [ -x /sbin/chkconfig ] ; then
218         /sbin/chkconfig plc off
219         /sbin/chkconfig --del plc
220     fi
221 fi
222
223 %files
224 %defattr(-,root,root,-)
225 # Host startup script and configuration file
226 /etc/init.d/plc
227 /etc/plc.d
228 /etc/planetlab
229 /etc/plc_sliceinitscripts
230 /etc/support-scripts
231 /usr/bin/
232 /usr/share/myplc/bashrc
233
234 %files config
235 %defattr(-,root,root,-)
236 /usr/bin/plc-config
237 %{python_sitearch}/plc_config.py*
238
239
240 %changelog
241 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
242 - support for fedora 12
243 - new package myplc-config for use by sfa
244 - drupal user registration turned off
245
246 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
247 - - fix to make sure when API, BOOT, MONITOR are on the same
248 - machine as WWW that the SSL key,cert for WWW takes precedence.
249 - - Do proper setup for SSL CA certficate to be used as the server
250 - chain.
251
252 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
253 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
254
255 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
256 - depend on pcucontrol
257
258 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
259 - * validate input according to type in plc_config
260 - * added the _genicw system slice
261 - * add tag types for sites and persons
262 - * add new tags for nodes and slices for exemption from myops
263
264 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
265 - turn off drupal on a box that acts as BOOT server but not as WWW server
266 - cleanup some obsolete code for old chroot-jail packaging in the process
267 - new bootcd-kernel script for keeping bootcd variants up2date
268
269 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
270 - Make the /etc/hosts manipulation optional.
271
272 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
273 - Fix SetRole.
274
275 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
276 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
277 - into the DB.
278 - - Added the root ssh key handling support back into plc.d/ssh and the
279 - default xml file.  This should be identical to the way it was in
280 - rc12.
281 - - Added support in the db-config.d/01-init script to register the root
282 - ssh public key with the default administrator.  In this way the root
283 - ssh key will make it into the root account on the nodes by means of
284 - NodeManager's specialaccounts plugin.
285
286 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
287 - db-config ignores sliver tags
288 - sirius's db-config script renamed (was sirious)
289
290 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
291 - fix for silverauth - missing tag types now created at plc startup time
292
293 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
294 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
295
296 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
297 - companion to NM's specialaccounts plugin
298 - do not generate /etc/planetlab/root_ssh_key* anymore
299 - remove related config. variables and conf_files
300
301 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
302 - clarified description text to refer only to plcrt and not other optional
303 - packages.
304
305 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
306 - fixed a bug setting slice multiple attributes with the same tag name
307
308 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
309 - SSL setup for monitor box, and related new config variables
310 - new conf_file for /etc/planetlab/extensions
311 - various tweaks in db-config internals, about initscripts among others
312 - also more messages defined in the db
313
314 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
315 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
316
317 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
318 - bugfix in db-config, tag 4.3-19 would not fly
319
320 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
321 - Refactored db-config into snippets in db-config.d/.
322
323 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
324 - oops, tag 4.3-17 was broken and would not work
325
326 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
327 - bugfix - escape sequences inserted in xml configs
328
329 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
330 - Handle db-config.d files properly.
331
332 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
333 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
334 - than the log file
335 - - Fix db-config to be a bit more cautious when
336 - /etc/planetlab/db-config.d doesn''t exist
337 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
338 - .orig files.
339 - - Refactor generic plc-config-tty code into plc_config.py.
340 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
341 - and the list of validated variables and the corresponding
342 - validator() function. This refactoring lets one reuse plc_config.py
343 - as a generic cmdline configuration tool for highly customer MyPLC
344 - like software.
345
346 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
347 - update PCU Type descriptions.
348 - updates to init scripts
349
350 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
351 - requires monitor-pcucontrol so register-wizard can work
352
353 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
354 - cleaned up plc-config-tty, no more need to configure plc-devel
355
356 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
357 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
358
359 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
360 - fix issue in db-config that prevented correct operation
361
362 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
363 - remove support for chroot-based packaging - no crond nor syslog step anymore
364 - plc init script now named plc.init instead of former guest.init
365
366 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
367 - add Monitor to docs build
368
369 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
370 - plc_config.py and plc-config-tty: generalized to work for more diverse
371 - MyPLC configurations.
372 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
373 - deployments and increase the memory limits in php.ini
374 - plc.d/crond: add --full option to vacuumdb
375
376 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
377 - avoid generating ssl certificates for disabled services among www api boot
378
379 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
380 - cleaned up old entries in db-config
381 - mtail more robust
382
383 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
384 - php include path tweaked for plekit includes
385 - reviewed myplc (fka native) packaging dependencies
386 - renumbered 4.3
387
388 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
389 - rename myplc into myplc-chroot and myplc-native into myplc
390 - new settings (shortname & hrn_root) for local peer
391
392 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
393 - First iteration of new data model
394 - Bunch of various fixes
395
396 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
397 - Removed proper ops from planetflow slice.
398
399 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
400 - myplc-native requires myplc-docs
401 - fixed doc build by locating locally installed DTDs at build-time
402
403 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
404 - turn myplc-docs off for now
405
406 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
407 - figures in doc package
408
409 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
410 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
411 - chroot packaging does not have docs anymore
412 - 'cvs' and 'dev' not required from myplc-native anymore
413 - cosmetic change in kml output
414
415 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
416 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
417 - gethostbyname uses python rather than perl (hope this shrinks deps) 
418 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
419 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
420 - make sync now works towards vserver-based myplc only 
421
422 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
423
424 - added vsys 'pfmount' script to the default netflow slice attributes.
425
426
427 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
428 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
429 - to new bootcd packaging
430
431 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
432 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
433
434 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
435 - packaging of mplc-release in myplc-native
436 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
437 - resolv file in /etc/resolv.conf, not plc_resolv.conf
438 - improved sirius script
439 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
440 - expires more properly set 
441
442 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
443
444
445 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
446 - renew_reminder script moved to support-scripts/
447 - gen-aliases script added in support-scripts/
448 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
449 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
450 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
451 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
452 - new setting 'Mom list address' for sending emails to a separate destination
453 - starts rsyslogd/syslogd as appropriate
454 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
455 - convenience generation of yum.conf in resulting image based on build/mirroring
456
457 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
458 - refresh-peer.py removed (duplicate with PLCAPI)
459 - plc.d/ scripts cleaned up
460 - sirius initscript updated
461 - slice auto renewal fixed
462
463 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
464 - initial build.
465
466 %define module_current_branch 4.3