Setting tag MyPLC-4.3-34
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 34
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) Portable Installation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: bzip2
29 Requires: tar 
30 Requires: less
31 Requires: sendmail
32 Requires: sendmail-cf
33 Requires: openssl
34 Requires: expect
35 Requires: php-pgsql
36 Requires: curl
37 Requires: rsync
38 Requires: python-devel
39 Requires: vixie-cron
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 # planetlab stuff
55 Requires: bootmanager
56 Requires: bootcd-%{pldistro}-%{_arch}
57 Requires: PLCWWW
58 Requires: www-register-wizard
59 Requires: nodeconfig
60 Requires: PLCAPI
61 Requires: pcucontrol
62 Requires: bootstrapfs-%{pldistro}-%{_arch}
63 Requires: myplc-docs
64 Requires: myplc-release
65
66 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
67 %if "%{pldistro}" == "onelab"
68 Requires: dummynet_image
69 %endif
70
71 %define debug_package %{nil}
72
73 %description
74 MyPLC is a complete PlanetLab Central (PLC) portable installation
75 contained within a chroot jail. The default installation consists of a
76 web server, an XML-RPC API server, a boot server, and a database
77 server: the core components of PLC. The installation may be customized
78 through a graphical interface. All PLC services are started up and
79 shut down through a single System V init script installed in the host
80 system.
81
82 %prep
83 %setup -q
84
85 %build
86
87 %install
88 pushd MyPLC
89 rm -rf $RPM_BUILD_ROOT
90 ./build.sh %{pldistro} $RPM_BUILD_ROOT
91 popd
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 # If run under sudo
97 if [ -n "$SUDO_USER" ] ; then
98     # Allow user to delete the build directory
99     chown -h -R $SUDO_USER .
100     # Some temporary cdroot files like /var/empty/sshd and
101     # /usr/bin/sudo get created with non-readable permissions.
102     find . -not -perm +0600 -exec chmod u+rw {} \;
103     # Allow user to delete the built RPM(s)
104     [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
105 fi
106
107 %pre
108 if [ -x %{_sysconfdir}/init.d/plc ] ; then
109     %{_sysconfdir}/init.d/plc stop
110 fi
111
112 # Old versions of myplc used to ship with a bootstrapped database and
113 # /etc/planetlab directory. Including generated files in the manifest
114 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
115 # names from one RPM build to another, it would be rpmsaved and thus
116 # effectively deleted. Now we do not include these files in the
117 # manifest. However, to avoid deleting these files in the process of
118 # upgrading from one of these old versions of myplc, we must back up
119 # the database and /etc/planetlab and restore them after the old
120 # version has been uninstalled in %triggerpostun (also in %post, in
121 # case we are force upgrading to the same version).
122 #
123 # This code can be removed once all myplc-0.4-1 installations have
124 # been upgraded to at least myplc-0.4-2.
125
126 # 0 = install, 1 = upgrade
127 if [ $1 -gt 0 ] ; then
128     for dir in /var/lib/pgsql/data /etc/planetlab ; do
129         if [ -d $dir ] ; then
130             echo "Preserving $dir"
131             mkdir -p $dir.rpmsave
132             tar -C $dir -cpf - . | \
133                tar -C $dir.rpmsave -xpf -
134
135             # Except for the default configuration file and DTD, which
136             # really should be considered for upgrade.
137             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
138         fi
139     done
140 fi
141
142 %post
143 if [ -x /sbin/chkconfig ] ; then
144     /sbin/chkconfig --add plc
145     /sbin/chkconfig plc on
146 fi
147 pushd /usr/share/myplc &> /dev/null
148 python plc_config.py build
149 python plc_config.py install
150 popd &> /dev/null
151
152 %triggerpostun -- %{name}
153 # 0 = erase, 1 = upgrade
154 if [ $1 -gt 0 ] ; then
155     for dir in /var/lib/pgsql/data /etc/planetlab ; do
156         if [ -d $dir.rpmsave -a -d $dir ] ; then
157             echo "Merging $dir"
158             if tar -C $dir.rpmsave -cpf - . | \
159                tar -C $dir -xpf - ; then
160                 rm -rf $dir.rpmsave
161             fi
162         fi
163     done
164 fi    
165
166 %preun
167 # 0 = erase, 1 = upgrade
168 if [ $1 -eq 0 ] ; then
169     %{_sysconfdir}/init.d/plc stop
170     if [ -x /sbin/chkconfig ] ; then
171         /sbin/chkconfig plc off
172         /sbin/chkconfig --del plc
173     fi
174 fi
175
176 %files
177 %defattr(-,root,root,-)
178 # Host startup script and configuration file
179 /etc/init.d/plc
180 /etc/plc.d
181 /etc/planetlab
182 /etc/plc_sliceinitscripts/sirius
183 /etc/support-scripts/gen_aliases.py*
184 /etc/support-scripts/renew_reminder.py*
185 /etc/support-scripts/renew_reminder_logrotate
186 /usr/bin/plc-config
187 /usr/bin/plc-config-tty
188 /usr/bin/db-config
189 /usr/bin/dns-config
190 /usr/bin/plc-map.py*
191 /usr/bin/plc-kml.py*
192 /usr/bin/refresh-peer.py*
193 /usr/bin/clean-empty-dirs.py*
194 /usr/bin/mtail.py*
195 /usr/bin/plc-check-ssl-peering.py*
196 /usr/bin/plc-orphan-accounts.py*
197 /usr/share/myplc
198
199 %changelog
200 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
201 - depend on pcucontrol
202
203 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
204 - * validate input according to type in plc_config
205 - * added the _genicw system slice
206 - * add tag types for sites and persons
207 - * add new tags for nodes and slices for exemption from myops
208
209 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
210 - turn off drupal on a box that acts as BOOT server but not as WWW server
211 - cleanup some obsolete code for old chroot-jail packaging in the process
212 - new bootcd-kernel script for keeping bootcd variants up2date
213
214 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
215 - Make the /etc/hosts manipulation optional.
216
217 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
218 - Fix SetRole.
219
220 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
221 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
222 - into the DB.
223 - - Added the root ssh key handling support back into plc.d/ssh and the
224 - default xml file.  This should be identical to the way it was in
225 - rc12.
226 - - Added support in the db-config.d/01-init script to register the root
227 - ssh public key with the default administrator.  In this way the root
228 - ssh key will make it into the root account on the nodes by means of
229 - NodeManager's specialaccounts plugin.
230
231 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
232 - db-config ignores sliver tags
233 - sirius's db-config script renamed (was sirious)
234
235 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
236 - fix for silverauth - missing tag types now created at plc startup time
237
238 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
239 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
240
241 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
242 - companion to NM's specialaccounts plugin
243 - do not generate /etc/planetlab/root_ssh_key* anymore
244 - remove related config. variables and conf_files
245
246 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
247 - clarified description text to refer only to plcrt and not other optional
248 - packages.
249
250 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
251 - fixed a bug setting slice multiple attributes with the same tag name
252
253 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
254 - SSL setup for monitor box, and related new config variables
255 - new conf_file for /etc/planetlab/extensions
256 - various tweaks in db-config internals, about initscripts among others
257 - also more messages defined in the db
258
259 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
260 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
261
262 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
263 - bugfix in db-config, tag 4.3-19 would not fly
264
265 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
266 - Refactored db-config into snippets in db-config.d/.
267
268 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
269 - oops, tag 4.3-17 was broken and would not work
270
271 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
272 - bugfix - escape sequences inserted in xml configs
273
274 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
275 - Handle db-config.d files properly.
276
277 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
278 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
279 - than the log file
280 - - Fix db-config to be a bit more cautious when
281 - /etc/planetlab/db-config.d doesn't exist
282 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
283 - .orig files.
284 - - Refactor generic plc-config-tty code into plc_config.py.
285 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
286 - and the list of validated variables and the corresponding
287 - validator() function. This refactoring lets one reuse plc_config.py
288 - as a generic cmdline configuration tool for highly customer MyPLC
289 - like software.
290
291 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
292 - update PCU Type descriptions.
293 - updates to init scripts
294
295 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
296 - requires monitor-pcucontrol so register-wizard can work
297
298 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
299 - cleaned up plc-config-tty, no more need to configure plc-devel
300
301 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
302 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
303
304 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
305 - fix issue in db-config that prevented correct operation
306
307 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
308 - remove support for chroot-based packaging - no crond nor syslog step anymore
309 - plc init script now named plc.init instead of former guest.init
310
311 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
312 - add Monitor to docs build
313
314 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
315 - plc_config.py and plc-config-tty: generalized to work for more diverse
316 - MyPLC configurations.
317 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
318 - deployments and increase the memory limits in php.ini
319 - plc.d/crond: add --full option to vacuumdb
320
321 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
322 - avoid generating ssl certificates for disabled services among www api boot
323
324 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
325 - cleaned up old entries in db-config
326 - mtail more robust
327
328 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
329 - php include path tweaked for plekit includes
330 - reviewed myplc (fka native) packaging dependencies
331 - renumbered 4.3
332
333 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
334 - rename myplc into myplc-chroot and myplc-native into myplc
335 - new settings (shortname & hrn_root) for local peer
336
337 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
338 - First iteration of new data model
339 - Bunch of various fixes
340
341 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
342 - Removed proper ops from planetflow slice.
343
344 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
345 - myplc-native requires myplc-docs
346 - fixed doc build by locating locally installed DTDs at build-time
347
348 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
349 - turn myplc-docs off for now
350
351 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
352 - figures in doc package
353
354 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
355 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
356 - chroot packaging does not have docs anymore
357 - 'cvs' and 'dev' not required from myplc-native anymore
358 - cosmetic change in kml output
359
360 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
361 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
362 - gethostbyname uses python rather than perl (hope this shrinks deps) 
363 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
364 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
365 - make sync now works towards vserver-based myplc only 
366
367 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
368
369 - added vsys 'pfmount' script to the default netflow slice attributes.
370
371
372 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
373 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
374 - to new bootcd packaging
375
376 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
377 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
378
379 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
380 - packaging of mplc-release in myplc-native
381 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
382 - resolv file in /etc/resolv.conf, not plc_resolv.conf
383 - improved sirius script
384 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
385 - expires more properly set 
386
387 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
388
389
390 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
391 - renew_reminder script moved to support-scripts/
392 - gen-aliases script added in support-scripts/
393 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
394 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
395 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
396 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
397 - new setting 'Mom list address' for sending emails to a separate destination
398 - starts rsyslogd/syslogd as appropriate
399 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
400 - convenience generation of yum.conf in resulting image based on build/mirroring
401
402 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
403 - refresh-peer.py removed (duplicate with PLCAPI)
404 - plc.d/ scripts cleaned up
405 - sirius initscript updated
406 - slice auto renewal fixed
407
408 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
409 - initial build.
410
411 %define module_current_branch 4.2