move the 'Requires: pcucontrol' from myplc to PLCAPI, as it's needed by RebootNodeWithPCU
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 37
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: bootcd-initscripts
67 Requires: PLCWWW
68 Requires: www-register-wizard
69 Requires: nodeconfig
70 Requires: PLCAPI
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
72 Requires: myplc-docs
73 Requires: myplc-release
74 Requires: myplc-config
75
76 %define debug_package %{nil}
77
78 %description
79 MyPLC is a complete PlanetLab Central (PLC) portable installation
80 contained within a chroot jail. The default installation consists of a
81 web server, an XML-RPC API server, a boot server, and a database
82 server: the core components of PLC. The installation may be customized
83 through a graphical interface. All PLC services are started up and
84 shut down through a single System V init script installed in the host
85 system.
86
87 ####################### myplc-config
88
89 %package config
90
91 Summary: PlanetLab Central (PLC) configuration python module
92 Group: Applications/Systems
93 Requires: python
94
95 %description config
96 This package provides the Python module to configure MyPLC.
97
98
99 %prep
100 %setup -q
101
102 %build
103
104 %install
105 pushd MyPLC
106 rm -rf $RPM_BUILD_ROOT
107 ./build.sh %{pldistro} $RPM_BUILD_ROOT
108 popd
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %pre
114 if [ -x %{_sysconfdir}/init.d/plc ] ; then
115     %{_sysconfdir}/init.d/plc stop
116 fi
117
118 # Old versions of myplc used to ship with a bootstrapped database and
119 # /etc/planetlab directory. Including generated files in the manifest
120 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
121 # names from one RPM build to another, it would be rpmsaved and thus
122 # effectively deleted. Now we do not include these files in the
123 # manifest. However, to avoid deleting these files in the process of
124 # upgrading from one of these old versions of myplc, we must back up
125 # the database and /etc/planetlab and restore them after the old
126 # version has been uninstalled in %triggerpostun (also in %post, in
127 # case we are force upgrading to the same version).
128 #
129 # This code can be removed once all myplc-0.4-1 installations have
130 # been upgraded to at least myplc-0.4-2.
131
132 # 0 = install, 1 = upgrade
133 if [ $1 -gt 0 ] ; then
134     for dir in /var/lib/pgsql/data /etc/planetlab ; do
135         if [ -d $dir ] ; then
136             echo "Preserving $dir"
137             mkdir -p $dir.rpmsave
138             tar -C $dir -cpf - . | \
139                tar -C $dir.rpmsave -xpf -
140
141             # Except for the default configuration file and DTD, which
142             # really should be considered for upgrade.
143             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
144         fi
145     done
146 fi
147
148 %post
149 if [ -x /sbin/chkconfig ] ; then
150     /sbin/chkconfig --add plc
151     /sbin/chkconfig plc on
152 fi
153
154 %triggerpostun -- %{name}
155 # 0 = erase, 1 = upgrade
156 if [ $1 -gt 0 ] ; then
157     for dir in /var/lib/pgsql/data /etc/planetlab ; do
158         if [ -d $dir.rpmsave -a -d $dir ] ; then
159             echo "Merging $dir"
160             if tar -C $dir.rpmsave -cpf - . | \
161                tar -C $dir -xpf - ; then
162                 rm -rf $dir.rpmsave
163             fi
164         fi
165     done
166 fi    
167
168 %preun
169 # 0 = erase, 1 = upgrade
170 if [ $1 -eq 0 ] ; then
171     %{_sysconfdir}/init.d/plc stop
172     if [ -x /sbin/chkconfig ] ; then
173         /sbin/chkconfig plc off
174         /sbin/chkconfig --del plc
175     fi
176 fi
177
178 %files
179 %defattr(-,root,root,-)
180 # Host startup script and configuration file
181 /etc/init.d/plc
182 /etc/plc.d
183 /etc/planetlab
184 /etc/plc_sliceinitscripts/sirius
185 /etc/support-scripts/gen_aliases.py*
186 /etc/support-scripts/renew_reminder.py*
187 /etc/support-scripts/renew_reminder_logrotate
188 /usr/bin/plc-config-tty
189 /usr/bin/db-config
190 /usr/bin/dns-config
191 /usr/bin/plc-map.py*
192 /usr/bin/plc-kml.py*
193 /usr/bin/refresh-peer.py*
194 /usr/bin/clean-empty-dirs.py*
195 /usr/bin/mtail.py*
196 /usr/bin/plc-check-ssl-peering.py*
197 /usr/bin/plc-orphan-accounts.py*
198 /usr/share/myplc/bashrc
199
200 %files config
201 %defattr(-,root,root,-)
202 /usr/bin/plc-config
203 %{python_sitearch}/plc_config.py*
204
205
206 %changelog
207 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
208 - support for fedora 12
209 - new package myplc-config for use by sfa
210 - drupal user registration turned off
211
212 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
213 - - fix to make sure when API, BOOT, MONITOR are on the same
214 - machine as WWW that the SSL key,cert for WWW takes precedence.
215 - - Do proper setup for SSL CA certficate to be used as the server
216 - chain.
217
218 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
219 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
220
221 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
222 - depend on pcucontrol
223
224 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
225 - * validate input according to type in plc_config
226 - * added the _genicw system slice
227 - * add tag types for sites and persons
228 - * add new tags for nodes and slices for exemption from myops
229
230 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
231 - turn off drupal on a box that acts as BOOT server but not as WWW server
232 - cleanup some obsolete code for old chroot-jail packaging in the process
233 - new bootcd-kernel script for keeping bootcd variants up2date
234
235 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
236 - Make the /etc/hosts manipulation optional.
237
238 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
239 - Fix SetRole.
240
241 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
242 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
243 - into the DB.
244 - - Added the root ssh key handling support back into plc.d/ssh and the
245 - default xml file.  This should be identical to the way it was in
246 - rc12.
247 - - Added support in the db-config.d/01-init script to register the root
248 - ssh public key with the default administrator.  In this way the root
249 - ssh key will make it into the root account on the nodes by means of
250 - NodeManager's specialaccounts plugin.
251
252 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
253 - db-config ignores sliver tags
254 - sirius's db-config script renamed (was sirious)
255
256 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
257 - fix for silverauth - missing tag types now created at plc startup time
258
259 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
260 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
261
262 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
263 - companion to NM's specialaccounts plugin
264 - do not generate /etc/planetlab/root_ssh_key* anymore
265 - remove related config. variables and conf_files
266
267 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
268 - clarified description text to refer only to plcrt and not other optional
269 - packages.
270
271 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
272 - fixed a bug setting slice multiple attributes with the same tag name
273
274 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
275 - SSL setup for monitor box, and related new config variables
276 - new conf_file for /etc/planetlab/extensions
277 - various tweaks in db-config internals, about initscripts among others
278 - also more messages defined in the db
279
280 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
281 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
282
283 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
284 - bugfix in db-config, tag 4.3-19 would not fly
285
286 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
287 - Refactored db-config into snippets in db-config.d/.
288
289 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
290 - oops, tag 4.3-17 was broken and would not work
291
292 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
293 - bugfix - escape sequences inserted in xml configs
294
295 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
296 - Handle db-config.d files properly.
297
298 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
299 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
300 - than the log file
301 - - Fix db-config to be a bit more cautious when
302 - /etc/planetlab/db-config.d doesn't exist
303 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
304 - .orig files.
305 - - Refactor generic plc-config-tty code into plc_config.py.
306 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
307 - and the list of validated variables and the corresponding
308 - validator() function. This refactoring lets one reuse plc_config.py
309 - as a generic cmdline configuration tool for highly customer MyPLC
310 - like software.
311
312 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
313 - update PCU Type descriptions.
314 - updates to init scripts
315
316 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
317 - requires monitor-pcucontrol so register-wizard can work
318
319 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
320 - cleaned up plc-config-tty, no more need to configure plc-devel
321
322 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
323 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
324
325 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
326 - fix issue in db-config that prevented correct operation
327
328 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
329 - remove support for chroot-based packaging - no crond nor syslog step anymore
330 - plc init script now named plc.init instead of former guest.init
331
332 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
333 - add Monitor to docs build
334
335 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
336 - plc_config.py and plc-config-tty: generalized to work for more diverse
337 - MyPLC configurations.
338 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
339 - deployments and increase the memory limits in php.ini
340 - plc.d/crond: add --full option to vacuumdb
341
342 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
343 - avoid generating ssl certificates for disabled services among www api boot
344
345 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
346 - cleaned up old entries in db-config
347 - mtail more robust
348
349 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
350 - php include path tweaked for plekit includes
351 - reviewed myplc (fka native) packaging dependencies
352 - renumbered 4.3
353
354 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
355 - rename myplc into myplc-chroot and myplc-native into myplc
356 - new settings (shortname & hrn_root) for local peer
357
358 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
359 - First iteration of new data model
360 - Bunch of various fixes
361
362 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
363 - Removed proper ops from planetflow slice.
364
365 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
366 - myplc-native requires myplc-docs
367 - fixed doc build by locating locally installed DTDs at build-time
368
369 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
370 - turn myplc-docs off for now
371
372 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
373 - figures in doc package
374
375 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
376 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
377 - chroot packaging does not have docs anymore
378 - 'cvs' and 'dev' not required from myplc-native anymore
379 - cosmetic change in kml output
380
381 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
382 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
383 - gethostbyname uses python rather than perl (hope this shrinks deps) 
384 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
385 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
386 - make sync now works towards vserver-based myplc only 
387
388 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
389
390 - added vsys 'pfmount' script to the default netflow slice attributes.
391
392
393 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
394 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
395 - to new bootcd packaging
396
397 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
398 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
399
400 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
401 - packaging of mplc-release in myplc-native
402 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
403 - resolv file in /etc/resolv.conf, not plc_resolv.conf
404 - improved sirius script
405 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
406 - expires more properly set 
407
408 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
409
410
411 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
412 - renew_reminder script moved to support-scripts/
413 - gen-aliases script added in support-scripts/
414 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
415 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
416 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
417 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
418 - new setting 'Mom list address' for sending emails to a separate destination
419 - starts rsyslogd/syslogd as appropriate
420 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
421 - convenience generation of yum.conf in resulting image based on build/mirroring
422
423 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
424 - refresh-peer.py removed (duplicate with PLCAPI)
425 - plc.d/ scripts cleaned up
426 - sirius initscript updated
427 - slice auto renewal fixed
428
429 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
430 - initial build.
431
432 %define module_current_branch 4.2