Merge branch 'master' of ssh://git.onelab.eu/git/myplc
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.0
3 %define taglevel 18
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
56 Requires: cronie
57 %else
58 Requires: vixie-cron
59 %endif
60 # planetlab stuff
61 Requires: bootmanager
62 Requires: bootcd-%{nodefamily}
63 Requires: bootcd-initscripts
64 Requires: PLCWWW
65 Requires: www-register-wizard
66 Requires: nodeconfig
67 Requires: nodeyum
68 Requires: PLCAPI
69 Requires: bootstrapfs-%{nodefamily}
70 Requires: myplc-docs
71 Requires: myplc-release
72 Requires: myplc-config
73
74 %define debug_package %{nil}
75
76 %description 
77 MyPLC is a complete PlanetLab Central (PLC) portable installation.
78 The default installation consists of a web server, an XML-RPC API
79 server, a boot server, and a database server: the core components of
80 PLC. The installation may be customized through a graphical
81 interface. All PLC services are started up and shut down through a
82 single System V init script.
83
84 ####################### myplc-config
85
86 %package config
87
88 Summary: PlanetLab Central (PLC) configuration python module
89 Group: Applications/Systems
90 Requires: python
91
92 %description config
93 This package provides the Python module to configure MyPLC.
94
95
96 %prep
97 %setup -q
98
99 %build
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 # Install configuration scripts
105 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
106 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
107 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
108
109 echo "* Installing scripts in /usr/bin"
110 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
111 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
112 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
113
114 # Install initscript 
115 echo "* Installing plc initscript"
116 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
117
118 # Install initscripts
119 echo "* Installing plc.d initscripts"
120 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
121 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
122
123 # Install db-config.d files
124 echo "* Installing db-config.d files"
125 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
126 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
127 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
128
129 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
130 echo "* Installing scripts in /etc/support-scripts"
131 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
132 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
133 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
134
135 # copy initscripts to etc/plc_sliceinitscripts
136 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
137 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
138 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
139
140 # Install configuration file
141 echo "* myplc: Installing configuration file"
142 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
143 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
144     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
145 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
146
147 echo "* Installing bashrc convenience"
148 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
149
150 # yumgroups.xml and yum repo : let noderepo handle that
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %pre
156 if [ -x %{_sysconfdir}/init.d/plc ] ; then
157     %{_sysconfdir}/init.d/plc stop
158 fi
159
160 # Old versions of myplc used to ship with a bootstrapped database and
161 # /etc/planetlab directory. Including generated files in the manifest
162 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
163 # names from one RPM build to another, it would be rpmsaved and thus
164 # effectively deleted. Now we do not include these files in the
165 # manifest. However, to avoid deleting these files in the process of
166 # upgrading from one of these old versions of myplc, we must back up
167 # the database and /etc/planetlab and restore them after the old
168 # version has been uninstalled in %triggerpostun (also in %post, in
169 # case we are force upgrading to the same version).
170 #
171 # This code can be removed once all myplc-0.4-1 installations have
172 # been upgraded to at least myplc-0.4-2.
173
174 # 0 = install, 1 = upgrade
175 if [ $1 -gt 0 ] ; then
176     for dir in /var/lib/pgsql/data /etc/planetlab ; do
177         if [ -d $dir ] ; then
178             echo "Preserving $dir"
179             mkdir -p $dir.rpmsave
180             tar -C $dir -cpf - . | \
181                tar -C $dir.rpmsave -xpf -
182
183             # Except for the default configuration file and DTD, which
184             # really should be considered for upgrade.
185             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
186         fi
187     done
188 fi
189
190 %post
191 if [ -x /sbin/chkconfig ] ; then
192     /sbin/chkconfig --add plc
193     /sbin/chkconfig plc on
194 fi
195
196 %triggerpostun -- %{name}
197 # 0 = erase, 1 = upgrade
198 if [ $1 -gt 0 ] ; then
199     for dir in /var/lib/pgsql/data /etc/planetlab ; do
200         if [ -d $dir.rpmsave -a -d $dir ] ; then
201             echo "Merging $dir"
202             if tar -C $dir.rpmsave -cpf - . | \
203                tar -C $dir -xpf - ; then
204                 rm -rf $dir.rpmsave
205             fi
206         fi
207     done
208 fi    
209
210 %preun
211 # 0 = erase, 1 = upgrade
212 if [ $1 -eq 0 ] ; then
213     %{_sysconfdir}/init.d/plc stop
214     if [ -x /sbin/chkconfig ] ; then
215         /sbin/chkconfig plc off
216         /sbin/chkconfig --del plc
217     fi
218 fi
219
220 %files
221 %defattr(-,root,root,-)
222 # Host startup script and configuration file
223 /etc/init.d/plc
224 /etc/plc.d
225 /etc/planetlab
226 /etc/plc_sliceinitscripts
227 /etc/support-scripts
228 /usr/share/myplc/bashrc
229 # keep a detailed list, to avoid duplicate of plc-config,
230 # that belongs to the myplc-config rpm
231 /usr/bin/plc-config-tty
232 /usr/bin/db-config
233 /usr/bin/dns-config
234 /usr/bin/refresh-peer.py*
235 /usr/bin/mtail.py*
236 /usr/bin/plc-map.py*
237 /usr/bin/plc-kml.py*
238 /usr/bin/clean-empty-dirs.py*
239 /usr/bin/plc-check-ssl-peering.py*
240 /usr/bin/plc-orphan-accounts.py*
241 /usr/bin/spot-aliens.py*
242 /usr/bin/spot-dup-accounts.sh
243
244 %files config
245 %defattr(-,root,root,-)
246 /usr/bin/plc-config
247 %{python_sitearch}/plc_config.py*
248
249
250 %changelog
251 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
252 - new settings for myslice (comon&tophat) and monitor (db)
253 - removed mentions of chroot in description
254 - can redo myplc-docs on broken f12-latex
255 - set short_open_tag in php.ini
256 - fixes in gen-sites-xml (is that still used ?)
257 - partial-repo.sh has moved to 'build' where it more belongs
258 - tweaks in convenience tool 'mtail'
259
260 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
261 - fixed changelog, no change from 5.0-16
262
263 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
264 - requires ed for the plc.d/packages step
265 - sirius initscript to handle stop and restart
266
267 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
268 - ignore steps in db-config.d if they have a '.' or '~' in their name
269
270 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
271 - can redo myplc-docs without the doc for monitor
272
273 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
274 - no semantic change - just fixed specfile for git URL
275
276 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
277 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
278
279 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
280 - add missing files to rpm package
281
282 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
283 - mtail.py -s for SFA
284 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
285
286 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
287 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
288
289 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
290 - plc-config-tty now has a validator on booleans
291 - e.g. entering 'True' now is rejected rather than silently recording 'false'
292
293 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
294 - disable mod_wsgi
295
296 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
297 - module name changes
298 - start wsgi support
299
300 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
301 - new setting PLC_RESERVATION_GRANULARITY
302
303 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
304 - * partial-repo.sh script
305 - * preserve key along with certificates
306
307 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
308 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
309
310 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
311 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
312 - new OMF category in the config
313 - create the drl system slice
314
315 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
316 - first working version of 5.0:
317 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
318 - nodefamily is 3-fold with pldistro-fcdistro-arch
319 - new PLC_FLAVOUR config category
320 - reviewed module layout
321 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
322
323 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
324 - support for fedora 12
325 - new package myplc-config for use by sfa
326 - drupal user registration turned off
327
328 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
329 - - fix to make sure when API, BOOT, MONITOR are on the same
330 - machine as WWW that the SSL key,cert for WWW takes precedence.
331 - - Do proper setup for SSL CA certficate to be used as the server
332 - chain.
333
334 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
335 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
336
337 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
338 - depend on pcucontrol
339
340 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
341 - * validate input according to type in plc_config
342 - * added the _genicw system slice
343 - * add tag types for sites and persons
344 - * add new tags for nodes and slices for exemption from myops
345
346 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
347 - turn off drupal on a box that acts as BOOT server but not as WWW server
348 - cleanup some obsolete code for old chroot-jail packaging in the process
349 - new bootcd-kernel script for keeping bootcd variants up2date
350
351 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
352 - Make the /etc/hosts manipulation optional.
353
354 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
355 - Fix SetRole.
356
357 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
358 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
359 - into the DB.
360 - - Added the root ssh key handling support back into plc.d/ssh and the
361 - default xml file.  This should be identical to the way it was in
362 - rc12.
363 - - Added support in the db-config.d/01-init script to register the root
364 - ssh public key with the default administrator.  In this way the root
365 - ssh key will make it into the root account on the nodes by means of
366 - NodeManager's specialaccounts plugin.
367
368 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
369 - db-config ignores sliver tags
370 - sirius's db-config script renamed (was sirious)
371
372 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
373 - fix for silverauth - missing tag types now created at plc startup time
374
375 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
376 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
377
378 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
379 - companion to NM's specialaccounts plugin
380 - do not generate /etc/planetlab/root_ssh_key* anymore
381 - remove related config. variables and conf_files
382
383 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
384 - clarified description text to refer only to plcrt and not other optional
385 - packages.
386
387 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
388 - fixed a bug setting slice multiple attributes with the same tag name
389
390 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
391 - SSL setup for monitor box, and related new config variables
392 - new conf_file for /etc/planetlab/extensions
393 - various tweaks in db-config internals, about initscripts among others
394 - also more messages defined in the db
395
396 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
397 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
398
399 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
400 - bugfix in db-config, tag 4.3-19 would not fly
401
402 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
403 - Refactored db-config into snippets in db-config.d/.
404
405 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
406 - oops, tag 4.3-17 was broken and would not work
407
408 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
409 - bugfix - escape sequences inserted in xml configs
410
411 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
412 - Handle db-config.d files properly.
413
414 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
415 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
416 - than the log file
417 - - Fix db-config to be a bit more cautious when
418 - /etc/planetlab/db-config.d doesn''t exist
419 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
420 - .orig files.
421 - - Refactor generic plc-config-tty code into plc_config.py.
422 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
423 - and the list of validated variables and the corresponding
424 - validator() function. This refactoring lets one reuse plc_config.py
425 - as a generic cmdline configuration tool for highly customer MyPLC
426 - like software.
427
428 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
429 - update PCU Type descriptions.
430 - updates to init scripts
431
432 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
433 - requires monitor-pcucontrol so register-wizard can work
434
435 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
436 - cleaned up plc-config-tty, no more need to configure plc-devel
437
438 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
439 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
440
441 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
442 - fix issue in db-config that prevented correct operation
443
444 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
445 - remove support for chroot-based packaging - no crond nor syslog step anymore
446 - plc init script now named plc.init instead of former guest.init
447
448 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
449 - add Monitor to docs build
450
451 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
452 - plc_config.py and plc-config-tty: generalized to work for more diverse
453 - MyPLC configurations.
454 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
455 - deployments and increase the memory limits in php.ini
456 - plc.d/crond: add --full option to vacuumdb
457
458 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
459 - avoid generating ssl certificates for disabled services among www api boot
460
461 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
462 - cleaned up old entries in db-config
463 - mtail more robust
464
465 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
466 - php include path tweaked for plekit includes
467 - reviewed myplc (fka native) packaging dependencies
468 - renumbered 4.3
469
470 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
471 - rename myplc into myplc-chroot and myplc-native into myplc
472 - new settings (shortname & hrn_root) for local peer
473
474 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
475 - First iteration of new data model
476 - Bunch of various fixes
477
478 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
479 - Removed proper ops from planetflow slice.
480
481 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
482 - myplc-native requires myplc-docs
483 - fixed doc build by locating locally installed DTDs at build-time
484
485 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
486 - turn myplc-docs off for now
487
488 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
489 - figures in doc package
490
491 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
492 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
493 - chroot packaging does not have docs anymore
494 - 'cvs' and 'dev' not required from myplc-native anymore
495 - cosmetic change in kml output
496
497 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
498 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
499 - gethostbyname uses python rather than perl (hope this shrinks deps) 
500 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
501 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
502 - make sync now works towards vserver-based myplc only 
503
504 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
505
506 - added vsys 'pfmount' script to the default netflow slice attributes.
507
508
509 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
510 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
511 - to new bootcd packaging
512
513 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
514 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
515
516 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
517 - packaging of mplc-release in myplc-native
518 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
519 - resolv file in /etc/resolv.conf, not plc_resolv.conf
520 - improved sirius script
521 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
522 - expires more properly set 
523
524 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
525
526
527 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
528 - renew_reminder script moved to support-scripts/
529 - gen-aliases script added in support-scripts/
530 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
531 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
532 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
533 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
534 - new setting 'Mom list address' for sending emails to a separate destination
535 - starts rsyslogd/syslogd as appropriate
536 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
537 - convenience generation of yum.conf in resulting image based on build/mirroring
538
539 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
540 - refresh-peer.py removed (duplicate with PLCAPI)
541 - plc.d/ scripts cleaned up
542 - sirius initscript updated
543 - slice auto renewal fixed
544
545 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
546 - initial build.
547
548 %define module_current_branch 4.3