moving the plc.d scripts for bootcd where they belong
[myplc.git] / myplc.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc
7 %define version 4.3
8 %define taglevel 37
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26
27
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
31
32 # as much as possible, requires should go in the subpackages specfile
33 Requires: bzip2
34 Requires: tar 
35 Requires: less
36 Requires: sendmail
37 Requires: sendmail-cf
38 Requires: openssl
39 Requires: expect
40 Requires: php-pgsql
41 Requires: curl
42 Requires: rsync
43 Requires: python-devel
44 Requires: yum
45 Requires: PyXML
46 Requires: createrepo
47 Requires: cpio
48 Requires: wget
49 Requires: php
50 Requires: openssh
51 Requires: dnsmasq
52 Requires: diffutils
53 Requires: gzip
54 Requires: vim-minimal
55 Requires: findutils
56 Requires: xmlsec1
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
59 Requires: cronie
60 %else
61 Requires: vixie-cron
62 %endif
63 # planetlab stuff
64 Requires: bootmanager
65 Requires: bootcd-%{pldistro}-%{_arch}
66 Requires: bootcd-initscripts
67 Requires: PLCWWW
68 Requires: www-register-wizard
69 Requires: nodeconfig
70 Requires: PLCAPI
71 Requires: pcucontrol
72 Requires: bootstrapfs-%{pldistro}-%{_arch}
73 Requires: myplc-docs
74 Requires: myplc-release
75 Requires: myplc-config
76
77 %define debug_package %{nil}
78
79 %description
80 MyPLC is a complete PlanetLab Central (PLC) portable installation
81 contained within a chroot jail. The default installation consists of a
82 web server, an XML-RPC API server, a boot server, and a database
83 server: the core components of PLC. The installation may be customized
84 through a graphical interface. All PLC services are started up and
85 shut down through a single System V init script installed in the host
86 system.
87
88 ####################### myplc-config
89
90 %package config
91
92 Summary: PlanetLab Central (PLC) configuration python module
93 Group: Applications/Systems
94 Requires: python
95
96 %description config
97 This package provides the Python module to configure MyPLC.
98
99
100 %prep
101 %setup -q
102
103 %build
104
105 %install
106 pushd MyPLC
107 rm -rf $RPM_BUILD_ROOT
108 ./build.sh %{pldistro} $RPM_BUILD_ROOT
109 popd
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %pre
115 if [ -x %{_sysconfdir}/init.d/plc ] ; then
116     %{_sysconfdir}/init.d/plc stop
117 fi
118
119 # Old versions of myplc used to ship with a bootstrapped database and
120 # /etc/planetlab directory. Including generated files in the manifest
121 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
122 # names from one RPM build to another, it would be rpmsaved and thus
123 # effectively deleted. Now we do not include these files in the
124 # manifest. However, to avoid deleting these files in the process of
125 # upgrading from one of these old versions of myplc, we must back up
126 # the database and /etc/planetlab and restore them after the old
127 # version has been uninstalled in %triggerpostun (also in %post, in
128 # case we are force upgrading to the same version).
129 #
130 # This code can be removed once all myplc-0.4-1 installations have
131 # been upgraded to at least myplc-0.4-2.
132
133 # 0 = install, 1 = upgrade
134 if [ $1 -gt 0 ] ; then
135     for dir in /var/lib/pgsql/data /etc/planetlab ; do
136         if [ -d $dir ] ; then
137             echo "Preserving $dir"
138             mkdir -p $dir.rpmsave
139             tar -C $dir -cpf - . | \
140                tar -C $dir.rpmsave -xpf -
141
142             # Except for the default configuration file and DTD, which
143             # really should be considered for upgrade.
144             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
145         fi
146     done
147 fi
148
149 %post
150 if [ -x /sbin/chkconfig ] ; then
151     /sbin/chkconfig --add plc
152     /sbin/chkconfig plc on
153 fi
154
155 %triggerpostun -- %{name}
156 # 0 = erase, 1 = upgrade
157 if [ $1 -gt 0 ] ; then
158     for dir in /var/lib/pgsql/data /etc/planetlab ; do
159         if [ -d $dir.rpmsave -a -d $dir ] ; then
160             echo "Merging $dir"
161             if tar -C $dir.rpmsave -cpf - . | \
162                tar -C $dir -xpf - ; then
163                 rm -rf $dir.rpmsave
164             fi
165         fi
166     done
167 fi    
168
169 %preun
170 # 0 = erase, 1 = upgrade
171 if [ $1 -eq 0 ] ; then
172     %{_sysconfdir}/init.d/plc stop
173     if [ -x /sbin/chkconfig ] ; then
174         /sbin/chkconfig plc off
175         /sbin/chkconfig --del plc
176     fi
177 fi
178
179 %files
180 %defattr(-,root,root,-)
181 # Host startup script and configuration file
182 /etc/init.d/plc
183 /etc/plc.d
184 /etc/planetlab
185 /etc/plc_sliceinitscripts/sirius
186 /etc/support-scripts/gen_aliases.py*
187 /etc/support-scripts/renew_reminder.py*
188 /etc/support-scripts/renew_reminder_logrotate
189 /usr/bin/plc-config-tty
190 /usr/bin/db-config
191 /usr/bin/dns-config
192 /usr/bin/plc-map.py*
193 /usr/bin/plc-kml.py*
194 /usr/bin/refresh-peer.py*
195 /usr/bin/clean-empty-dirs.py*
196 /usr/bin/mtail.py*
197 /usr/bin/plc-check-ssl-peering.py*
198 /usr/bin/plc-orphan-accounts.py*
199 /usr/share/myplc/bashrc
200
201 %files config
202 %defattr(-,root,root,-)
203 /usr/bin/plc-config
204 %{python_sitearch}/plc_config.py*
205
206
207 %changelog
208 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
209 - support for fedora 12
210 - new package myplc-config for use by sfa
211 - drupal user registration turned off
212
213 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
214 - - fix to make sure when API, BOOT, MONITOR are on the same
215 - machine as WWW that the SSL key,cert for WWW takes precedence.
216 - - Do proper setup for SSL CA certficate to be used as the server
217 - chain.
218
219 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
220 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
221
222 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
223 - depend on pcucontrol
224
225 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
226 - * validate input according to type in plc_config
227 - * added the _genicw system slice
228 - * add tag types for sites and persons
229 - * add new tags for nodes and slices for exemption from myops
230
231 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
232 - turn off drupal on a box that acts as BOOT server but not as WWW server
233 - cleanup some obsolete code for old chroot-jail packaging in the process
234 - new bootcd-kernel script for keeping bootcd variants up2date
235
236 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
237 - Make the /etc/hosts manipulation optional.
238
239 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
240 - Fix SetRole.
241
242 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
243 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
244 - into the DB.
245 - - Added the root ssh key handling support back into plc.d/ssh and the
246 - default xml file.  This should be identical to the way it was in
247 - rc12.
248 - - Added support in the db-config.d/01-init script to register the root
249 - ssh public key with the default administrator.  In this way the root
250 - ssh key will make it into the root account on the nodes by means of
251 - NodeManager's specialaccounts plugin.
252
253 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
254 - db-config ignores sliver tags
255 - sirius's db-config script renamed (was sirious)
256
257 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
258 - fix for silverauth - missing tag types now created at plc startup time
259
260 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
261 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
262
263 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
264 - companion to NM's specialaccounts plugin
265 - do not generate /etc/planetlab/root_ssh_key* anymore
266 - remove related config. variables and conf_files
267
268 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
269 - clarified description text to refer only to plcrt and not other optional
270 - packages.
271
272 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
273 - fixed a bug setting slice multiple attributes with the same tag name
274
275 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
276 - SSL setup for monitor box, and related new config variables
277 - new conf_file for /etc/planetlab/extensions
278 - various tweaks in db-config internals, about initscripts among others
279 - also more messages defined in the db
280
281 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
282 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
283
284 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
285 - bugfix in db-config, tag 4.3-19 would not fly
286
287 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
288 - Refactored db-config into snippets in db-config.d/.
289
290 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
291 - oops, tag 4.3-17 was broken and would not work
292
293 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
294 - bugfix - escape sequences inserted in xml configs
295
296 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
297 - Handle db-config.d files properly.
298
299 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
300 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
301 - than the log file
302 - - Fix db-config to be a bit more cautious when
303 - /etc/planetlab/db-config.d doesn't exist
304 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
305 - .orig files.
306 - - Refactor generic plc-config-tty code into plc_config.py.
307 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
308 - and the list of validated variables and the corresponding
309 - validator() function. This refactoring lets one reuse plc_config.py
310 - as a generic cmdline configuration tool for highly customer MyPLC
311 - like software.
312
313 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
314 - update PCU Type descriptions.
315 - updates to init scripts
316
317 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
318 - requires monitor-pcucontrol so register-wizard can work
319
320 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
321 - cleaned up plc-config-tty, no more need to configure plc-devel
322
323 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
324 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
325
326 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
327 - fix issue in db-config that prevented correct operation
328
329 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
330 - remove support for chroot-based packaging - no crond nor syslog step anymore
331 - plc init script now named plc.init instead of former guest.init
332
333 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
334 - add Monitor to docs build
335
336 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
337 - plc_config.py and plc-config-tty: generalized to work for more diverse
338 - MyPLC configurations.
339 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
340 - deployments and increase the memory limits in php.ini
341 - plc.d/crond: add --full option to vacuumdb
342
343 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
344 - avoid generating ssl certificates for disabled services among www api boot
345
346 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
347 - cleaned up old entries in db-config
348 - mtail more robust
349
350 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
351 - php include path tweaked for plekit includes
352 - reviewed myplc (fka native) packaging dependencies
353 - renumbered 4.3
354
355 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
356 - rename myplc into myplc-chroot and myplc-native into myplc
357 - new settings (shortname & hrn_root) for local peer
358
359 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
360 - First iteration of new data model
361 - Bunch of various fixes
362
363 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
364 - Removed proper ops from planetflow slice.
365
366 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
367 - myplc-native requires myplc-docs
368 - fixed doc build by locating locally installed DTDs at build-time
369
370 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
371 - turn myplc-docs off for now
372
373 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
374 - figures in doc package
375
376 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
377 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
378 - chroot packaging does not have docs anymore
379 - 'cvs' and 'dev' not required from myplc-native anymore
380 - cosmetic change in kml output
381
382 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
383 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
384 - gethostbyname uses python rather than perl (hope this shrinks deps) 
385 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
386 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
387 - make sync now works towards vserver-based myplc only 
388
389 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
390
391 - added vsys 'pfmount' script to the default netflow slice attributes.
392
393
394 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
395 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
396 - to new bootcd packaging
397
398 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
399 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
400
401 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
402 - packaging of mplc-release in myplc-native
403 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
404 - resolv file in /etc/resolv.conf, not plc_resolv.conf
405 - improved sirius script
406 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
407 - expires more properly set 
408
409 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
410
411
412 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
413 - renew_reminder script moved to support-scripts/
414 - gen-aliases script added in support-scripts/
415 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
416 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
417 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
418 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
419 - new setting 'Mom list address' for sending emails to a separate destination
420 - starts rsyslogd/syslogd as appropriate
421 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
422 - convenience generation of yum.conf in resulting image based on build/mirroring
423
424 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
425 - refresh-peer.py removed (duplicate with PLCAPI)
426 - plc.d/ scripts cleaned up
427 - sirius initscript updated
428 - slice auto renewal fixed
429
430 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
431 - initial build.
432
433 %define module_current_branch 4.2