scaffolding multi-fcdistro yum config
[nodeimage.git] / bootstrapfs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define extensionfamily %{distroname}-%{_arch}
8
9 %define name bootstrapfs-%{nodefamily}
10 %define version 2.0
11 %define taglevel 2
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 Requires: tar, gnupg, sharutils, bzip2
34
35 # 5.0 now has 3-fold nodefamily
36 %define obsolete_nodefamily %{pldistro}-%{_arch}
37 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
38
39 AutoReqProv: no
40 %define debug_package %{nil}
41
42 %description
43
44 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
45 BootManager to instantiate a node with a new filesystem.
46
47 %package plain
48 Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
49 Group: System Environment/Base
50 %description plain
51 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
52
53 %package -n nodeyum
54 Summary: the MyPLC-side utilities for tweaking nodes yum configs
55 Group: System Environment/Base
56 %description -n nodeyum 
57 Utility scripts for configuring node updates. This package is designed
58 for the MyPLC side.
59
60 %prep
61 %setup -q
62
63 %build
64
65 ############################## node-side
66 pushd BootstrapFS
67 ./build.sh %{pldistro} 
68 popd
69
70 ############################## server-side
71 pushd BootstrapFS/nodeconfig/yum
72 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
73 for fcdistro in $(ls); do
74     [ -d $fcdistro ] || continue
75     # get kexcludes for that distro
76     KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
77     pushd $fcdistro/yum.myplc.d
78     echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
79     for filein in $(find . -name '*.in') ; do
80         file=$(echo $filein | sed -e "s,\.in$,,")
81         sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
82     done
83     rm -f stock.repo
84     cat *.repo > stock.repo
85     popd
86 done
87 popd
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 ############################## node-side
93 pushd BootstrapFS
94 #arch=$(uname -i)
95
96 install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
97         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
98 install -D -m 644 bootstrapfs-%{nodefamily}.tar \
99         $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
100
101 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
102     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
103     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
104                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
105     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
106                 $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
107 done
108 popd
109
110 ############################## server-side
111 # xxx unfinished business here
112 # xxx in a multi-flavour myplc, we should ship for all fcdistros
113 # and let the php scripts do the right thing
114 pushd BootstrapFS
115 echo "* Installing MyPLC-side nodes yum config utilities"
116 echo "* Multi-fcdistro yum stuff"
117 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
118 rsync -av ./nodeconfig/yum/                                                 $RPM_BUILD_ROOT/var/www/html/yum/
119 echo "* Legacy (single fcdistro) yum stuff"
120 # expose (fixed) myplc.repo.php as                                          https://<plc>/yum.legacy/myplc.repo.php
121 install -D -m 644 ./nodeconfig/yum/myplc.repo.php                           $RPM_BUILD_ROOT/var/www/html/yum.legacy/myplc.repo.php
122 # expose the fcdistro-dependant yum.conf as                                 https://<plc>/yum.legacy/yum.conf
123 install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.conf                   $RPM_BUILD_ROOT/var/www/html/yum.legacy/yum.conf
124 # expose the (fcdistro-dependant) stock.repo as                             https://<plc>/yum.legacy/stock.repo
125 install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.myplc.d/stock.repo     $RPM_BUILD_ROOT/var/www/html/yum.legacy/stock.repo
126
127 # Install initscripts
128 echo "* Installing plc.d initscripts"
129 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
130 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
131
132 echo "* Installing db-config.d files"
133 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
134 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
135 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
136 popd
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141
142 %files
143 %defattr(-,root,root,-)
144 /var/www/html/boot/bootstrapfs*.tar.bz2
145
146 %files plain
147 %defattr(-,root,root,-)
148 /var/www/html/boot/bootstrapfs*.tar
149
150 %files -n nodeyum
151 %defattr(-,root,root,-)
152 /var/www/html/yum
153 /etc/planetlab/db-config.d
154 /etc/plc.d
155
156 %changelog
157 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
158 - new slicerepo package for exposing stuff to slivers
159
160 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
161 - first working version of 5.0:
162 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
163 - nodefailiy is 3-fold with pldistro-fcdistro-arch
164 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
165
166 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
167 - for building on fedora12
168
169 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
170 - cosmetic change in message at build-time
171
172 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
173 - can use groups in the pkgs file with +++ for space
174
175 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
176 - bugfix for when a .post script is not needed
177
178 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
179 - search post-install scripts (.post) in path (distro, then planetlab)
180 - mostly useful for externally-defined pldistros
181
182 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
183 - fix build bug when dealing with extensions
184
185 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
186 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
187
188 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
189 - cosmetic changes in build: displays duration, and shows up in summary
190
191 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
192 - Do not overwrite yumgroups.xml upon updates of noderepo
193
194 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
195 - uses the right yum.conf when building images
196
197 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
198 - rpm release tag does not need pldistro as it is already part of the rpm name
199
200 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
201 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
202 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
203
204 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
205 - search more carefully for alternate pkgs files
206 - handling of sysconfig/crontab and creation of site_admin reviewed
207 - (this tag is set with module-tag.py)
208
209 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
210 - Initial build.
211
212 %define module_current_branch 1.0