add a config_file to have /etc/dnf/dnf.conf point at /etc/yum.myplc.d as /etc/yum...
[nodeimage.git] / nodeimage.spec
1 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
2 %define extensionfamily %{distroname}-%{_arch}
3
4 %define name nodeimage-%{nodefamily}
5 %define version 5.2
6 %define taglevel 4
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # we don't really need the standard postinstall process from rpm that
13 # strips files and byte-compiles python files. all files in this
14 # package are comming from other rpm files and they've already went
15 # through this post install processing. - baris
16 %define __os_install_post %{nil}
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Summary: The PlanetLab nodeimage filesystems for %{nodefamily}
24 Name: %{name}
25 Version: %{version}
26 Release: %{release}
27 License: BSD
28 Group: System Environment/Base
29 Source0: %{name}-%{version}.tar.gz
30 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31 # other archs must be able to install this
32 BuildArch: noarch
33
34 Requires: tar, gnupg, sharutils, bzip2
35 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
36 Requires: ed
37
38 # 5.1 now uses new name nodeimage
39 Obsoletes: bootstrapfs-%{nodefamily}
40 # 5.0 now has 3-fold nodefamily
41 %define obsolete_nodefamily %{pldistro}-%{_arch}
42 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
43
44 AutoReqProv: no
45 %define debug_package %{nil}
46
47 %description
48
49 The PlanetLab nodeimage filesystem is downloaded by the
50 BootManager to reinstall a node with a new filesystem.
51
52 %package plain
53 Summary: The (uncompressed) PlanetLab nodeimage filesystem for %{nodefamily}
54 Group: System Environment/Base
55 %description plain
56 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
57
58 %package -n nodeyum
59 Summary: the MyPLC-side utilities for tweaking nodes yum configs
60 Group: System Environment/Base
61 %description -n nodeyum 
62 Utility scripts for configuring node updates. This package is designed
63 for the MyPLC side.
64
65 %prep
66 %setup -q
67
68 %build
69
70 ############################## node-side
71 pushd nodeimage
72 ./build.sh %{pldistro} 
73 for tar in *.tar *.tar.bz2; do 
74     start=$(date +%H-%M-%S)
75     sha1sum $tar > $tar.sha1sum
76     chmod 444 $tar.sha1sum
77     end=$(date +%H-%M-%S)
78     echo "* Computed SHA1 checksum for $tar ($start .. $end) "
79 done
80 popd
81
82 ############################## server-side
83 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
84 pushd nodeimage/nodeconfig/yum
85 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
86 for fcdistro in $(ls); do
87     [ -d $fcdistro ] || continue
88     # get packages to exclude on nodes for that fcdistro/pldistro
89     NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro %{pldistro})"
90     pushd $fcdistro/yum.myplc.d
91     echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
92     for filein in $(find . -name '*.in') ; do
93         file=$(echo $filein | sed -e "s,\.in$,,")
94         sed -e "s,@NODEYUMEXCLUDE@,$NODEYUMEXCLUDE,g" $filein > $file
95     done
96     rm -f stock.repo
97     cat *.repo > stock.repo
98     popd
99 done
100 popd
101
102 echo "* nodeconfig/yum done $(date +%H-%M-%S)"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 ############################## node-side
108 pushd nodeimage
109 for out in *.tar *.tar.bz2 ; do
110     echo "* Installing $out"
111     install -D -m 644 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
112 done
113 for out in *.sha1sum; do
114     echo "* Installing $out"
115     install -D -m 444 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
116 done
117 popd
118
119 ############################## server-side
120 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
121 pushd nodeimage
122 echo "* Installing MyPLC-side nodes yum config utilities (support for multi-fcdistro)"
123 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
124 rsync -av ./nodeconfig/yum/     $RPM_BUILD_ROOT/var/www/html/yum/
125
126 # Install initscripts
127 echo "* Installing plc.d initscripts"
128 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
129 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
130
131 echo "* Installing db-config.d files"
132 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
133 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
134 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
135 popd
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140
141 %files
142 %defattr(-,root,root,-)
143 /var/www/html/boot/bootstrapfs*.tar.bz2
144 /var/www/html/boot/bootstrapfs*.tar.bz2.sha1sum
145
146 %files plain
147 %defattr(-,root,root,-)
148 /var/www/html/boot/bootstrapfs*.tar
149 /var/www/html/boot/bootstrapfs*.tar.sha1sum
150
151 %files -n nodeyum
152 %defattr(-,root,root,-)
153 /var/www/html/yum
154 /etc/planetlab/db-config.d
155 /etc/plc.d
156
157 %changelog
158 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
159 - minor change; start plc packages only at run-time, not build-time
160 - only available on systems that have systemctl
161
162 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
163 - template for f20 yum config
164
165 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
166 - more timestamps during build
167
168 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
169 - add support for f18 yum config
170
171 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
172
173 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
174 - fix /etc/plc.d/packages for empty install dirs
175
176 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
177 - exclude slice repos when running plc.d/packages start
178
179 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
180 - renamed as nodeimage - works on both mainline and lxc
181
182 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
183 - changes needed for build with yumexcludes defined in a separate pkgs file
184
185 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
186 - plc.d/packages: rewrote comments about some corner cases where it fails
187 - plc.d/packages: marginally more robust
188
189 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
190 - minor tweak in plc.d/packages
191
192 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
193 - sl6 templates
194
195 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
196 - bugfix for multi-flavour deployments
197
198 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
199 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
200
201 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
202 - no semantic change - attempt to speed up build
203
204 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
205 - yum repo template for f14 nodes
206 - tweaks the way /etc/plc.d/packages works
207
208 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
209 - add sha1sum
210 - module name changes
211
212 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
213 - support different flavours of vservers on nodes
214
215 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
216 - fix unmatched $ in URL svn keywords
217
218 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
219 - choice between various pldistros is not made at build time, but at run time
220 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
221 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
222 - the https method does not work on fedora 12, and GPG is used below anyway
223
224 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
225 - new slicerepo package for exposing stuff to slivers
226
227 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
228 - first working version of 5.0:
229 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
230 - nodefailiy is 3-fold with pldistro-fcdistro-arch
231 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
232
233 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
234 - for building on fedora12
235
236 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
237 - cosmetic change in message at build-time
238
239 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
240 - can use groups in the pkgs file with +++ for space
241
242 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
243 - bugfix for when a .post script is not needed
244
245 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
246 - search post-install scripts (.post) in path (distro, then planetlab)
247 - mostly useful for externally-defined pldistros
248
249 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
250 - fix build bug when dealing with extensions
251
252 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
253 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
254
255 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
256 - cosmetic changes in build: displays duration, and shows up in summary
257
258 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
259 - Do not overwrite yumgroups.xml upon updates of noderepo
260
261 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
262 - uses the right yum.conf when building images
263
264 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
265 - rpm release tag does not need pldistro as it is already part of the rpm name
266
267 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
268 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
269 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
270
271 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
272 - search more carefully for alternate pkgs files
273 - handling of sysconfig/crontab and creation of site_admin reviewed
274 - (this tag is set with module-tag.py)
275
276 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
277 - Initial build.
278
279 %define module_current_branch 1.0