Setup and teardown NAT interfaces automatically
[nodemanager-topo.git] / NodeManager-topo.spec
1 %define url $URL$
2
3 Name:           NodeManager-topo
4 Version:        0.2
5 Release:        2
6 Summary:        Plugin supporting creating a default virtual topology.
7
8 Group:          System Environment/Daemons
9 License:        PlanetLab
10 URL:            %(echo %{url} | cut -d ' ' -f 2)
11 Source0:        topo.py
12 Source1:        setup-egre-link
13 Source2:        teardown-egre-link
14 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15 BuildArch:      noarch
16
17 BuildRequires:  python, python-devel
18 Requires:       NodeManager >= 1.7
19
20 %description
21 This package provides a plugin for NodeManager implementing
22 support for the topo_rspec slice attribute.
23
24 %prep
25
26
27 %build
28
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -p -D -m755 %{SOURCE0} \
33         $RPM_BUILD_ROOT%{_datadir}/NodeManager/plugins/topo.py
34 install -p -D -m755 %{SOURCE1} \
35         $RPM_BUILD_ROOT%{_datadir}/vini/setup-egre-link
36 install -p -D -m755 %{SOURCE2} \
37         $RPM_BUILD_ROOT%{_datadir}/vini/teardown-egre-link
38
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post
44 /sbin/service nm restart
45
46 %files
47 %defattr(-,root,root,-)
48 %{_datadir}/NodeManager/plugins/topo.py*
49 %{_datadir}/vini/*-egre-link
50
51
52 %changelog