satisfy FC6 rpm requirements for python files
[nodeupdate.git] / NodeUpdate.spec
1 %define name NodeUpdate
2 %define version 0.4
3 %define release 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
4
5 Vendor: PlanetLab
6 Packager: PlanetLab Central <support@planet-lab.org>
7 Distribution: PlanetLab 3.0
8 URL: http://cvs.planet-lab.org/cvs/NodeUpdate
9
10 Summary: PlanetLab service to periodically update node RPMS
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
15 License: GPL
16 Group: System Environment/Base
17 Source: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}root
19 Requires: vixie-cron, logrotate
20
21 %description
22 PlanetLab service to periodically update node RPMS
23
24 %prep
25
26 %setup
27
28 %build
29
30
31 %install
32 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/local/planetlab/bin/NodeUpdate.py
33 install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
34
35 %clean
36 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
37
38 %files
39 %defattr(-,root,root)
40 %attr(0755,root,root) /usr/local/planetlab/bin/NodeUpdate.py*
41 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
42
43 %pre
44
45 %post
46 /usr/local/planetlab/bin/NodeUpdate.py updatecron
47
48 %preun
49 if [ "$1" = 0 ]; then
50         /usr/local/planetlab/bin/NodeUpdate.py removecron
51 fi
52
53
54 %postun
55
56
57 %changelog
58 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
59 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
60 - cron job now runs once a day instead of once an hour
61
62 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
63 - added better support for different groups
64 - added support for deleting rpms
65
66 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
67 - updated for new build process
68
69 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
70 - new yum option for ssl cert dir used
71 - added noreboot option which ignores the reboot flag
72   (useful during install and/or boot time)
73
74 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
75 - Initial build.
76