Setting tag nodeupdate-0.5-10
[nodeupdate.git] / NodeUpdate.spec
1 %define name NodeUpdate
2 %define version 0.5
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: PlanetLab service to periodically update node RPMS
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
17 License: GPL
18 Group: System Environment/Base
19 Source: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}root
21 Requires: vixie-cron, logrotate
22
23 %description
24 PlanetLab service to periodically update node RPMS
25
26 %prep
27
28 %setup
29
30 %build
31
32
33 %install
34 echo "* Installing NodeUpdate node-side files"
35 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
36 install -D -m 644 logrotate/NodeUpdate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
37
38 %clean
39 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(-,root,root)
43 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
44 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
45
46 %post
47 /usr/bin/NodeUpdate.py updatecron
48
49 %preun
50 if [ "$1" = 0 ]; then
51     /usr/bin/NodeUpdate.py removecron
52 fi
53
54 %changelog
55 * Mon May 06 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-10
56 - bugfix in nodeupdate.RemoveRPMS, NodeUpdate.py bails out if rpms can't be removed
57
58 * Fri Jul 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-9
59 - support /etc/planetlab/NodeUpdate.packages and /etc/planetlab/crucial-rpm-list
60 - delete exceptions from delete-rpm-list individually
61
62 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-8
63 - has a builtin list of packages to update individually (NodeManager for now)
64 - plus an optional set that is read from /etc/planetlab/NodeUpdate.packages
65
66 * Wed Jul 14 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodeupdate-0.5-7
67 - Use groupinstall to get new group members.
68
69 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-6
70 - new module layout - no functional change
71
72 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
73 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups
74
75 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-4
76 - invokes 'yum clean all' before updates
77 - as it is more reliable, although suboptimal
78
79 * Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
80 - more verbose : invoke yum with --verbose, and print timestamps
81
82 * Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
83 - Rebuild RPM Database nightly to avoid corruption
84 - Move working directory from /usr/local to /usr/bin
85
86 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
87 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
88 - cron job now runs once a day instead of once an hour
89
90 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
91 - added better support for different groups
92 - added support for deleting rpms
93
94 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
95 - updated for new build process
96
97 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
98 - new yum option for ssl cert dir used
99 - added noreboot option which ignores the reboot flag
100   (useful during install and/or boot time)
101
102 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
103 - Initial build.
104