add yum clean all to the routine of NodeUpdate
[nodeupdate.git] / NodeUpdate.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name NodeUpdate
7 %define version 0.5
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: PlanetLab service to periodically update node RPMS
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
22 License: GPL
23 Group: System Environment/Base
24 Source: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}root
26 Requires: vixie-cron, logrotate
27
28 %description
29 PlanetLab service to periodically update node RPMS
30
31 %prep
32
33 %setup
34
35 %build
36
37
38 %install
39 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
40 install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
41
42 %clean
43 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root)
47 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
48 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
49
50 %pre
51
52 %post
53 /usr/bin/NodeUpdate.py updatecron
54
55 %preun
56 if [ "$1" = 0 ]; then
57         /usr/bin/NodeUpdate.py removecron
58 fi
59
60
61 %postun
62
63
64 %changelog
65 * Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
66 - more verbose : invoke yum with --verbose, and print timestamps
67
68 * Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
69 - Rebuild RPM Database nightly to avoid corruption
70 - Move working directory from /usr/local to /usr/bin
71
72 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
73 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
74 - cron job now runs once a day instead of once an hour
75
76 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
77 - added better support for different groups
78 - added support for deleting rpms
79
80 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
81 - updated for new build process
82
83 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
84 - new yum option for ssl cert dir used
85 - added noreboot option which ignores the reboot flag
86   (useful during install and/or boot time)
87
88 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
89 - Initial build.
90