Setting tag NodeUpdate-0.5-6
[nodeupdate.git] / NodeUpdate.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name NodeUpdate
7 %define version 0.5
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: PlanetLab service to periodically update node RPMS
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
22 License: GPL
23 Group: System Environment/Base
24 Source: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}root
26 Requires: vixie-cron, logrotate
27
28 %description
29 PlanetLab service to periodically update node RPMS
30
31 %prep
32
33 %setup
34
35 %build
36
37
38 %install
39 echo "* Installing NodeUpdate node-side files"
40 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
41 install -D -m 644 logrotate/NodeUpdate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
42
43 %clean
44 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(-,root,root)
48 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
49 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
50
51 %post
52 /usr/bin/NodeUpdate.py updatecron
53
54 %preun
55 if [ "$1" = 0 ]; then
56     /usr/bin/NodeUpdate.py removecron
57 fi
58
59 %changelog
60 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-6
61 - new module layout - no functional change
62
63 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
64 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups
65
66 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-4
67 - invokes 'yum clean all' before updates
68 - as it is more reliable, although suboptimal
69
70 * Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
71 - more verbose : invoke yum with --verbose, and print timestamps
72
73 * Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
74 - Rebuild RPM Database nightly to avoid corruption
75 - Move working directory from /usr/local to /usr/bin
76
77 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
78 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
79 - cron job now runs once a day instead of once an hour
80
81 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
82 - added better support for different groups
83 - added support for deleting rpms
84
85 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
86 - updated for new build process
87
88 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
89 - new yum option for ssl cert dir used
90 - added noreboot option which ignores the reboot flag
91   (useful during install and/or boot time)
92
93 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
94 - Initial build.
95