Setting tag NodeUpdate-0.5-5
[nodeupdate.git] / NodeUpdate.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name NodeUpdate
7 %define version 0.5
8 %define taglevel 5
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: PlanetLab service to periodically update node RPMS
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
22 License: GPL
23 Group: System Environment/Base
24 Source: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}root
26 Requires: vixie-cron, logrotate
27
28 %description
29 PlanetLab service to periodically update node RPMS
30
31 %prep
32
33 %setup
34
35 %build
36
37
38 %install
39 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
40 install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
41
42 %clean
43 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root)
47 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
48 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
49
50 %pre
51
52 %post
53 /usr/bin/NodeUpdate.py updatecron
54
55 %preun
56 if [ "$1" = 0 ]; then
57         /usr/bin/NodeUpdate.py removecron
58 fi
59
60
61 %postun
62
63
64 %changelog
65 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
66 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups
67
68 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-4
69 - invokes 'yum clean all' before updates
70 - as it is more reliable, although suboptimal
71
72 * Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
73 - more verbose : invoke yum with --verbose, and print timestamps
74
75 * Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
76 - Rebuild RPM Database nightly to avoid corruption
77 - Move working directory from /usr/local to /usr/bin
78
79 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
80 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
81 - cron job now runs once a day instead of once an hour
82
83 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
84 - added better support for different groups
85 - added support for deleting rpms
86
87 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
88 - updated for new build process
89
90 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
91 - new yum option for ssl cert dir used
92 - added noreboot option which ignores the reboot flag
93   (useful during install and/or boot time)
94
95 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
96 - Initial build.
97