fixed and moved the server-side yum scripts, from nodeconfig/yum to BootstrapFS/nodec...
[nodeupdate.git] / NodeUpdate.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name NodeUpdate
7 %define version 0.5
8 %define taglevel 5
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: PlanetLab service to periodically update node RPMS
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
22 License: GPL
23 Group: System Environment/Base
24 Source: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}root
26 Requires: vixie-cron, logrotate
27
28 %description
29 PlanetLab service to periodically update node RPMS
30
31 %prep
32
33 %setup
34
35 %build
36
37
38 %install
39 echo "* Installing NodeUpdate node-side files"
40 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
41 install -D -m 644 logrotate/NodeUpdate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
42
43 %clean
44 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(-,root,root)
48 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
49 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
50
51 %post
52 /usr/bin/NodeUpdate.py updatecron
53
54 %preun
55 if [ "$1" = 0 ]; then
56     /usr/bin/NodeUpdate.py removecron
57 fi
58
59 %changelog
60 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
61 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups
62
63 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-4
64 - invokes 'yum clean all' before updates
65 - as it is more reliable, although suboptimal
66
67 * Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
68 - more verbose : invoke yum with --verbose, and print timestamps
69
70 * Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
71 - Rebuild RPM Database nightly to avoid corruption
72 - Move working directory from /usr/local to /usr/bin
73
74 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
75 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
76 - cron job now runs once a day instead of once an hour
77
78 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
79 - added better support for different groups
80 - added support for deleting rpms
81
82 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
83 - updated for new build process
84
85 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
86 - new yum option for ssl cert dir used
87 - added noreboot option which ignores the reboot flag
88   (useful during install and/or boot time)
89
90 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
91 - Initial build.
92