Setting tag nodeupdate-1.0-0
[nodeupdate.git] / NodeUpdate.spec
1 %define name NodeUpdate
2 %define version 1.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: PlanetLab service to periodically update node RPMS
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
17 License: GPL
18 Group: System Environment/Base
19 Source: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}root
21 Requires: cronie, logrotate
22
23 %description
24 PlanetLab service to periodically update node RPMS
25
26 %prep
27
28 %setup
29
30 %build
31
32
33 %install
34 echo "* Installing NodeUpdate node-side files"
35 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
36 install -D -m 644 logrotate/NodeUpdate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
37
38 %clean
39 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(-,root,root)
43 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
44 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
45
46 %post
47 /usr/bin/NodeUpdate.py updatecron
48
49 %preun
50 if [ "$1" = 0 ]; then
51     /usr/bin/NodeUpdate.py removecron
52 fi
53
54 %changelog
55 * Mon Jan 07 2019 Thierry <Parmentelat> - nodeupdate-1.0-0
56 - ported to python3 + pep8
57
58 * Sun Jan 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-14
59 - more robust nodeupdate (again) on dnf-based nodes
60
61 * Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-13
62 - dnf-based nodes (f22/f23) need to call dnf group upgrade
63 - and not yum groupinstall; with this patch, slice images
64 - will now make it smoothly to the node
65
66 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-12
67 - crucial nodemanager packages were not using new naming convention
68
69 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-11
70 - reflect a name change for NodeManager that becomes nodemanager as part of crucial packages
71
72 * Mon May 06 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-10
73 - bugfix in nodeupdate.RemoveRPMS, NodeUpdate.py bails out if rpms can't be removed
74
75 * Fri Jul 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-9
76 - support /etc/planetlab/NodeUpdate.packages and /etc/planetlab/crucial-rpm-list
77 - delete exceptions from delete-rpm-list individually
78
79 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-8
80 - has a builtin list of packages to update individually (NodeManager for now)
81 - plus an optional set that is read from /etc/planetlab/NodeUpdate.packages
82
83 * Wed Jul 14 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodeupdate-0.5-7
84 - Use groupinstall to get new group members.
85
86 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-6
87 - new module layout - no functional change
88
89 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
90 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups
91
92 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-4
93 - invokes 'yum clean all' before updates
94 - as it is more reliable, although suboptimal
95
96 * Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
97 - more verbose : invoke yum with --verbose, and print timestamps
98
99 * Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
100 - Rebuild RPM Database nightly to avoid corruption
101 - Move working directory from /usr/local to /usr/bin
102
103 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
104 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
105 - cron job now runs once a day instead of once an hour
106
107 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
108 - added better support for different groups
109 - added support for deleting rpms
110
111 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
112 - updated for new build process
113
114 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
115 - new yum option for ssl cert dir used
116 - added noreboot option which ignores the reboot flag
117   (useful during install and/or boot time)
118
119 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
120 - Initial build.
121