bump release number
[nodeupdate.git] / NodeUpdate.spec
1 %define name NodeUpdate
2 %define version 0.4
3 %define release 2.planetlab%{?date:.%{date}}
4
5 Vendor: PlanetLab
6 Packager: PlanetLab Central <support@planet-lab.org>
7 Distribution: PlanetLab 3.0
8 URL: http://cvs.planet-lab.org/cvs/NodeUpdate
9
10 Summary: PlanetLab service to periodically update node RPMS
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
15 Copyright: GPL
16 Group: System Environment/Base
17 Source: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}root
19 Requires: vixie-cron
20
21 %description
22 PlanetLab service to periodically update node RPMS
23
24 %prep
25
26 %setup
27
28 %build
29
30
31 %install
32 mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
33 cp NodeUpdate.py $RPM_BUILD_ROOT/usr/local/planetlab/bin/
34
35 %clean
36 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
37
38 %files
39 %defattr(-,root,root)
40 %attr(0755,root,root) /usr/local/planetlab/bin/NodeUpdate.py
41
42 %pre
43
44 %post
45 if [ "$1" = 1 ]; then
46         /usr/local/planetlab/bin/NodeUpdate.py updatecron
47 fi
48
49
50 %preun
51 if [ "$1" = 0 ]; then
52         /usr/local/planetlab/bin/NodeUpdate.py removecron
53 fi
54
55
56 %postun
57
58
59 %changelog
60 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
61 - added better support for different groups
62 - added support for deleting rpms
63
64 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
65 - updated for new build process
66
67 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
68 - new yum option for ssl cert dir used
69 - added noreboot option which ignores the reboot flag
70   (useful during install and/or boot time)
71
72 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
73 - Initial build.
74