- cron package is usually named vixie-cron
[nodeupdate.git] / NodeUpdate.spec
1 %define name NodeUpdate
2 %define version 0.3
3 %define release 1.planetlab%{?date:.%{date}}
4
5 Summary: PlanetLab service to periodically update node RPMS
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
10 Copyright: GPL
11 URL: http://www.planet-lab.org
12 Group: System Environment/Base
13 Source: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}root
15 Requires: vixie-cron
16
17 %description
18 PlanetLab service to periodically update node RPMS
19
20 %prep
21
22 %setup
23
24 %build
25
26
27 %install
28 mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
29 cp NodeUpdate.py $RPM_BUILD_ROOT/usr/local/planetlab/bin/
30
31 %clean
32 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
33
34 %files
35 %defattr(-,root,root)
36 %attr(0755,root,root) /usr/local/planetlab/bin/NodeUpdate.py
37
38 %pre
39
40 %post
41 if [ "$1" = 1 ]; then
42         /usr/local/planetlab/bin/NodeUpdate.py updatecron
43 fi
44
45
46 %preun
47 if [ "$1" = 0 ]; then
48         /usr/local/planetlab/bin/NodeUpdate.py removecron
49 fi
50
51
52 %postun
53
54
55 %changelog
56 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
57 - added better support for different groups
58 - added support for deleting rpms
59
60 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
61 - updated for new build process
62
63 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
64 - new yum option for ssl cert dir used
65 - added noreboot option which ignores the reboot flag
66   (useful during install and/or boot time)
67
68 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
69 - Initial build.
70