change release numbers to <release>.planetlab[.<date>] for consistency
[nodeupdate.git] / NodeUpdate.spec
1 %define name NodeUpdate
2 %define version 0.2
3 %define release 3.planetlab%{?date:.%{date}}
4
5 Summary: PlanetLab service to periodically update node RPMS
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
10 Copyright: GPL
11 URL: http://www.planet-lab.org
12 Group: System Environment/Base
13 Source: %{name}-%{version}.tar.gz
14 BuildRoot: /tmp/%{name}-%{version}-root
15
16 %description
17 PlanetLab service to periodically update node RPMS
18
19 %prep
20
21 %setup
22
23 %build
24
25
26 %install
27 mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
28 cp NodeUpdate.py $RPM_BUILD_ROOT/usr/local/planetlab/bin/
29
30 %clean
31
32 %files
33 %defattr(-,root,root)
34 %attr(0755,root,root) /usr/local/planetlab/bin/NodeUpdate.py
35
36 %pre
37
38 %post
39 if [ "$1" = 1 ]; then
40         /usr/local/planetlab/bin/NodeUpdate.py updatecron
41 fi
42
43
44 %preun
45 if [ "$1" = 0 ]; then
46         /usr/local/planetlab/bin/NodeUpdate.py removecron
47 fi
48
49
50 %postun
51
52
53 %changelog
54 * Mon Apr 12 2004 Aaron K <alk@cs.princeton.edu>
55 - updated for new build process
56
57 * Mon Feb  2 2004 Aaron K <alk@cs.princeton.edu>
58 - new yum option for ssl cert dir used
59 - added noreboot option which ignores the reboot flag
60   (useful during install and/or boot time)
61
62 * Tue Oct 28 2003 Aaron K <Aaron.L.Klingaman@intel.com>
63 - Initial build.
64