Setting tag pcucontrol-1.0-4
[pcucontrol.git] / pcucontrol.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/pcucontrol/trunk/pcucontrol.spec $
6
7 %define name pcucontrol
8 %define version 1.0
9 %define taglevel 4
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Requires: python
28 Requires: OpenIPMI-tools
29 Obsoletes: monitor-pcucontrol
30
31 Summary: pcu controls for monitor and plcapi
32 Group: Applications/System
33
34 %description
35 both monitor and the plcapi use a set of common commands to reboot machines
36 using their external or internal pcus.  this package is a library of several
37 supported models.
38
39 %prep
40 %setup -q
41
42 %build
43 # NOTE: the build uses g++ cmdamt/
44 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
45 cd pcucontrol/models/intelamt
46 export TMPDIR=$PWD/tmp
47 make
48 cd ..
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
53 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root)
60 %{python_sitearch}
61
62
63 %changelog
64 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-4
65 - * add ipmi trasport type.
66
67 * Mon May 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-3
68 - remove unused import (that causes deprecated warnings in plcsh)
69
70 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pcucontrol-1.0-2
71 - tweak for DRAC - protect against spaces in password
72
73 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-1
74 - * pcucontrol obsoletes monitor-pcucontrol
75 - * use bash built-in instead of which to locate ssh
76 - * racadm fix for DRAC.
77
78 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr>
79 - initial package