fix URL in specfile - rm svn-keywords
[pcucontrol.git] / pcucontrol.spec
1 %define name pcucontrol
2 %define version 1.0
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Source0: %{name}-%{version}.tar.bz2
12 License: GPL
13 Group: Applications/System
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Requires: python
22 Requires: OpenIPMI-tools
23 Obsoletes: monitor-pcucontrol
24
25 Summary: pcu controls for monitor and plcapi
26 Group: Applications/System
27
28 %description
29 both monitor and the plcapi use a set of common commands to reboot machines
30 using their external or internal pcus.  this package is a library of several
31 supported models.
32
33 %prep
34 %setup -q
35
36 %build
37 # NOTE: the build uses g++ cmdamt/
38 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
39 cd pcucontrol/models/intelamt
40 export TMPDIR=$PWD/tmp
41 mkdir -p $TMPDIR
42 make
43 cd ..
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
48 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(-,root,root)
55 %{python_sitearch}
56
57
58 %changelog
59 * Fri Dec 03 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-9
60 - fix build for f14
61
62 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-8
63 - fix build issue
64
65 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-7
66 - fixes for HPiLO
67
68 * Fri Jun 18 2010 s s <soltesz@cs.princeton.edu> - pcucontrol-1.0-6
69 - adding a testrun parameter to the api
70
71 * Fri May 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-5
72 - ePowerSwitchOld fix
73
74 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-4
75 - * add ipmi trasport type.
76
77 * Mon May 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-3
78 - remove unused import (that causes deprecated warnings in plcsh)
79
80 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pcucontrol-1.0-2
81 - tweak for DRAC - protect against spaces in password
82
83 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-1
84 - * pcucontrol obsoletes monitor-pcucontrol
85 - * use bash built-in instead of which to locate ssh
86 - * racadm fix for DRAC.
87
88 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr>
89 - initial package