taglevel 0
[pcucontrol.git] / pcucontrol.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/pcucontrol/trunk/pcucontrol.spec $
6
7 %define name pcucontrol
8 %define version 1.0
9 %define taglevel 0
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Requires: python
28
29 Summary: pcu controls for monitor and plcapi
30 Group: Applications/System
31
32 %description
33 both monitor and the plcapi use a set of common commands to reboot machines
34 using their external or internal pcus.  this package is a library of several
35 supported models.
36
37 %prep
38 %setup -q
39
40 %build
41 # NOTE: the build uses g++ cmdamt/
42 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
43 cd pcucontrol/models/intelamt
44 export TMPDIR=$PWD/tmp
45 make
46 cd ..
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
51 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(-,root,root)
58 %{python_sitearch}
59
60
61 %changelog
62 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr>
63 - initial package