remove support for SSL on f27 because of openssl-1.1 - see specfile
[pcucontrol.git] / pcucontrol.spec
1 %define name pcucontrol
2 %define version 1.0
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Source0: %{name}-%{version}.tar.bz2
12 License: GPL
13 Group: Applications/System
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Requires: python
22 Requires: OpenIPMI-tools
23 Obsoletes: monitor-pcucontrol
24
25 Summary: pcu controls for monitor and plcapi
26 Group: Applications/System
27
28 %description
29 both monitor and the plcapi use a set of common commands to reboot machines
30 using their external or internal pcus.  this package is a library of several
31 supported models.
32
33 %prep
34 %setup -q
35
36 #################### Important note
37 # starting with fedora27, fedora comes with openssl-11.0g
38 # and in this version 
39 # X509_EXTENSION {aka struct X509_extension_st}
40 # has become opaque
41 # this is mentioned here
42 # https://github.com/openssl/openssl/issues/2239
43 # see https://wiki.openssl.org/index.php/OpenSSL_1.1.0_Changes#Compatibility_Layer
44
45 # so we turn off support for SSL starting with fedora27
46 # this is in pcucontrol/models/intelamt/Makefile - see FCDISTRO
47
48 %build
49 # NOTE: the build uses g++ cmdamt/
50 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
51 cd pcucontrol/models/intelamt
52 export TMPDIR=$PWD/tmp
53 mkdir -p $TMPDIR
54 make FCDISTRO=%{fcdistro}
55 cd ..
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
60 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(-,root,root)
67 %{python_sitearch}
68
69
70 %changelog
71 * Mon Jun 25 2012 Stephen Soltesz <soltesz@cs.princeton.edu> - pcucontrol-1.0-13
72 - remove many unnecessary debugging print statement.
73 - move APC & DRAC to expect scripts.  Much greater control.
74
75 * Wed Aug 31 2011 Stephen Soltesz <soltesz@cs.princeton.edu> - pcucontrol-1.0-12
76 - Fixed DRAC regular expression for ssh, and added IP address for external
77 - command.
78
79 * Wed Jun 08 2011 s s <soltesz@cs.princeton.edu> - pcucontrol-1.0-11
80 - Updated HPiLO, DRAC with expect scripts.
81 - Updated other models to use subprocess module in favor of os.popen*
82
83 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pcucontrol-1.0-10
84 - no semantic change - just fixed specfile for git URL
85
86 * Fri Dec 03 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-9
87 - fix build for f14
88
89 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-8
90 - fix build issue
91
92 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-7
93 - fixes for HPiLO
94
95 * Fri Jun 18 2010 s s <soltesz@cs.princeton.edu> - pcucontrol-1.0-6
96 - adding a testrun parameter to the api
97
98 * Fri May 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-5
99 - ePowerSwitchOld fix
100
101 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-4
102 - * add ipmi trasport type.
103
104 * Mon May 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-3
105 - remove unused import (that causes deprecated warnings in plcsh)
106
107 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pcucontrol-1.0-2
108 - tweak for DRAC - protect against spaces in password
109
110 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-1
111 - * pcucontrol obsoletes monitor-pcucontrol
112 - * use bash built-in instead of which to locate ssh
113 - * racadm fix for DRAC.
114
115 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr>
116 - initial package