Setting tag pcucontrol-1.0-1
[pcucontrol.git] / pcucontrol.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/pcucontrol/trunk/pcucontrol.spec $
6
7 %define name pcucontrol
8 %define version 1.0
9 %define taglevel 1
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Requires: python
28 Obsoletes: monitor-pcucontrol
29
30 Summary: pcu controls for monitor and plcapi
31 Group: Applications/System
32
33 %description
34 both monitor and the plcapi use a set of common commands to reboot machines
35 using their external or internal pcus.  this package is a library of several
36 supported models.
37
38 %prep
39 %setup -q
40
41 %build
42 # NOTE: the build uses g++ cmdamt/
43 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
44 cd pcucontrol/models/intelamt
45 export TMPDIR=$PWD/tmp
46 make
47 cd ..
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
52 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(-,root,root)
59 %{python_sitearch}
60
61
62 %changelog
63 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-1
64 - * pcucontrol obsoletes monitor-pcucontrol
65 - * use bash built-in instead of which to locate ssh
66 - * racadm fix for DRAC.
67
68 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr>
69 - initial package