fixes in the specfile for f31 that has python3 as its unqualified python
[pcucontrol.git] / pcucontrol.spec
1 %define name pcucontrol
2 %define version 1.0
3 %define taglevel 14
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 # Turn off the brp-python-bytecompile automagic
9 # this is required for fedora31 that has moved to python3 as a default
10 %global _python_bytecompile_extra 0
11
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 Source0: %{name}-%{version}.tar.bz2
16 License: GPL
17 Group: Applications/System
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %{SCMURL}
24
25 Requires: python
26 Requires: OpenIPMI-tools
27 #Obsoletes: monitor-pcucontrol
28
29 Summary: pcu controls for monitor and plcapi
30 Group: Applications/System
31
32 %description
33 both monitor and the plcapi use a set of common commands to reboot machines
34 using their external or internal pcus.  this package is a library of several
35 supported models.
36
37 %prep
38 %setup -q
39
40 #################### Important note
41 # starting with fedora27, fedora comes with openssl-11.0g
42 # and in this version 
43 # X509_EXTENSION {aka struct X509_extension_st}
44 # has become opaque
45 # this is mentioned here
46 # https://github.com/openssl/openssl/issues/2239
47 # see https://wiki.openssl.org/index.php/OpenSSL_1.1.0_Changes#Compatibility_Layer
48
49 # so we turn off support for SSL starting with fedora27
50 # this is in pcucontrol/models/intelamt/Makefile - see FCDISTRO
51
52 %build
53 # NOTE: the build uses g++ cmdamt/
54 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
55 cd pcucontrol/models/intelamt
56 export TMPDIR=$PWD/tmp
57 mkdir -p $TMPDIR
58 make FCDISTRO=%{fcdistro}
59 cd ..
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
64 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(-,root,root)
71 %{python_sitearch}
72
73
74 %changelog
75 * Mon Jan 07 2019 Thierry <Parmentelat> - pcucontrol-1.0-14
76 - for building on fedora27; had to drop support for openssl, see specfile for details
77
78 * Mon Jun 25 2012 Stephen Soltesz <soltesz@cs.princeton.edu> - pcucontrol-1.0-13
79 - remove many unnecessary debugging print statement.
80 - move APC & DRAC to expect scripts.  Much greater control.
81
82 * Wed Aug 31 2011 Stephen Soltesz <soltesz@cs.princeton.edu> - pcucontrol-1.0-12
83 - Fixed DRAC regular expression for ssh, and added IP address for external
84 - command.
85
86 * Wed Jun 08 2011 s s <soltesz@cs.princeton.edu> - pcucontrol-1.0-11
87 - Updated HPiLO, DRAC with expect scripts.
88 - Updated other models to use subprocess module in favor of os.popen*
89
90 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pcucontrol-1.0-10
91 - no semantic change - just fixed specfile for git URL
92
93 * Fri Dec 03 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-9
94 - fix build for f14
95
96 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-8
97 - fix build issue
98
99 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-7
100 - fixes for HPiLO
101
102 * Fri Jun 18 2010 s s <soltesz@cs.princeton.edu> - pcucontrol-1.0-6
103 - adding a testrun parameter to the api
104
105 * Fri May 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-5
106 - ePowerSwitchOld fix
107
108 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-4
109 - * add ipmi trasport type.
110
111 * Mon May 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-3
112 - remove unused import (that causes deprecated warnings in plcsh)
113
114 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pcucontrol-1.0-2
115 - tweak for DRAC - protect against spaces in password
116
117 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - pcucontrol-1.0-1
118 - * pcucontrol obsoletes monitor-pcucontrol
119 - * use bash built-in instead of which to locate ssh
120 - * racadm fix for DRAC.
121
122 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr>
123 - initial package